Jump to content
henri

OSC-Affiliate

Recommended Posts

Yes, I installed it and it is VERY easy. The only trick was figuring out which file to put the terms in, it is affiliate info, instead of affiliate terms.

 

And now for my question, would it be very difficult to make it so that there could be different commission rates for different products/categories? I am setting my site up as a pseudo mall and would like to offer higher commissions on certain products and lower on others because of the profit margin, this could be done by store/category (each top category will be a "store". I would also like to have a check box system to have the affilitiates choose the program they want to participate in, but I can live without that if necessary.

 

I want to thank you for a WONDERFUL contribution, it made the decision between shopping cart systems for me :D


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Does anyone know why I am getting this error ? I am trying to go into my Admin page - cheers, Adam.

 

Warning: open_basedir restriction in effect. File is in wrong directory in /home/httpd/vhosts/allstarsmemorabilia.com.au/httpdocs/shop/admin/includes/application_top.php on line 263

 

Warning: open_basedir restriction in effect. File is in wrong directory in /home/httpd/vhosts/allstarsmemorabilia.com.au/httpdocs/shop/admin/includes/application_top.php on line 263

 

Fatal error: Failed opening required 'includes/affiliate_application_top.php' (include_path='.:/php/includes:/usr/share/php') in /home/httpd/vhosts/allstarsmemorabilia.com.au/httpdocs/shop/admin/includes/application_top.php on line 263

Share this post


Link to post
Share on other sites

@loxly: Yes difficult ;) Not planned for the future

 

@bomber:Hmm, if you used:

require('includes/affiliate_application_top.php');

then try:

require(DIR_WS_INCLUDES . 'affiliate_application_top.php');

or look at the top at the file whats there standing when requiring configure.php

And check if the file is in the right directory

Share this post


Link to post
Share on other sites

This Affiliate Program could be the greatest contribution to OSC yet!!!!

 

 

 

Install went correctly. Links to banners work. Images don't display. Any ideas?


"Aliiiiive, it's alive, it's ALIIIIIIIIIIIIIVE!!!"

Share this post


Link to post
Share on other sites
Install went correctly. Links to banners work. Images don't display. Any ideas?

 

Try changing

define ('AFFILIATE_KIND_OF_BANNERS','2');

to 1

in affiliate_configuration.php.

Then you should see where it tries to get the images from.

Perhaps it helps

Share this post


Link to post
Share on other sites

the images now display. Any ideas how to get the banner count to work? Everything else works great.


"Aliiiiive, it's alive, it's ALIIIIIIIIIIIIIVE!!!"

Share this post


Link to post
Share on other sites

No, without seeing it and some testing not.

You can contact me: henri@in-solution.de

Share this post


Link to post
Share on other sites

First of all, great module! Many thanks, a lot of hard work must of gone into this!

 

Just a quick Q, sorry if i am being stupid,

 

I plan to run billing on 28th of each month, print the invoices and change the status to paid. However, the commision in the affiliate summery page still shows up as the total they have earned. I would like it to show just thier account balance (ie what they have not yet been paid) for example if a customer has earned ?20 in commision, then at the end of the month when billing is done, that ?20 balance would be set to ?0.

 

I have tested it and it only displays total earnings, not current earnings.

Share this post


Link to post
Share on other sites

Install went correctly. Links to banners work. Images don't display. Any ideas?

 

Try changing

define ('AFFILIATE_KIND_OF_BANNERS','2');

to 1

in affiliate_configuration.php.

Then you should see where it tries to get the images from.

Perhaps it helps

 

I did this and the banners now display, but don't get counted. :(

 

So they are in the correct location. Is it a bug that setting "2" isn't working or have I done something incorrectly?

 

Other than that this is an AWESOME contribution!!!!!!

 

Debbie


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

If you use AFFILIATE_KIND_OF_BANNERS=2 the banners are showed via affiliate_show_banner.php. This file counts the views.

Before showing it checks if the banner exists.

I.E.

  $pic=DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG. DIR_WS_IMAGES . $banner;



 // Some configurations need '/'

 if (!is_file($pic)) $pic=DIR_FS_DOCUMENT_ROOT . '/'.  DIR_WS_IMAGES . $banner;

 

 // Show Banner only if it exists:

 if (is_file($pic)) {

Perhaps something here goes wrong.

What can you do:

Get the Link to the picture and open it in a new Browserwindow.

-> if you get an error (don't belive this) it could help.

Insert echo $pic; before the is_file function. Then reload the browserwindow.

Now you should see the absolute URL to the Banner. Perhaps you see something wrong.

 

or

Contact me, and let me have a look.

 

And i wanna try to optimise this file and/or add an iframe method.

Share this post


Link to post
Share on other sites

Case solved :)

Path error in configure.php gave an wrong path to the pic...

Share this post


Link to post
Share on other sites

Install went correctly. Links to banners work. Images don't display. Any ideas?

 

Try changing

define ('AFFILIATE_KIND_OF_BANNERS','2');

to 1

in affiliate_configuration.php.

Then you should see where it tries to get the images from.

Perhaps it helps

 

I'm having the same problem as this. When i change define ('AFFILIATE_KIND_OF_BANNERS','2'); to 1 the image location ends at /images/ without putting the actual image in there. Banner images (ones i upload) work fine with the 1 but not 2, its when people attempt to make their own links that with 1 set the images location ends .../catalog/images/ with no image!!!

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites

Works great for me. The only thing I though was would it not be better if this quantity would be inside the product_info? The only reason for that is, sometimes people will not realize that they can click on the product to see the picture since it asks them to choose the quantity right away.

Share this post


Link to post
Share on other sites
I'm having the same problem as this. When i change define ('AFFILIATE_KIND_OF_BANNERS','2'); to 1 the image location ends at /images/ without putting the actual image in there. Banner images (ones i upload) work fine with the 1 but not 2, its when people attempt to make their own links that with 1 set the images location ends .../catalog/images/ with no image!!!

 

Any help would be appreciated.

 

Ok, some as above, If you want contact me (henri@in-solution.de) then i take a look.

In CVS there is a new affiliate_show_banner and affiliate_configure which has a debug modus. Perhaps you can try this.

Share this post


Link to post
Share on other sites
Is there a final virsion of this contribution?

 

Thanks

Is there a final of OSC? If you want to see a 1.0, wait untill we release the next 6 releases. Or should we make a faste jump... :)

Share this post


Link to post
Share on other sites

Henri,

Here is a question in the admin in Affiliate Clickthroughs I already have 24 pages worth of clicks is there any way to remove those without it affecting the click count or something else?

I'm not sure if I want to have 100 pages of this stuff in my DB at the end of the this month :wink:

Share this post


Link to post
Share on other sites

As I recall deleting of all entries in affiliate_clickthroughs should do it.

But this will crash the stats...

hmm perhaps we should think about an solution here, sometimes....

Share this post


Link to post
Share on other sites
How can you set the pay per click amount?

Thanks

No pay per click yet. Look in the thread why...

Share this post


Link to post
Share on other sites
And i wanna try to optimise this file and/or add an iframe method.

 

I would prefer to stay away from iframe if you can, too many browsers don't support it. Or offer it as an option. Allposters.com has iframe links, but they post a text link for browsers that don't support iframes.

 

Debbie


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

I the files and this and followed the directions, this is what I get now. I had version .2 installed first and then copied this one over.

 

Fatal error: Cannot redeclare _sess_open() (previously declared in /home/virtual/site82/fst/var/www/html/catalog/includes/functions/sessions.php:18) in /home/virtual/site82/fst/var/www/html/catalog/includes/functions/sessions.php on line 18

 

Your help is greatly appreciated.

Share this post


Link to post
Share on other sites

Oops, forgot to tell you the error is when I try to sign-up a new affiliate - everything else seems to work fine with existing affiliates.

 

Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×