Jump to content
henri

OSC-Affiliate

Recommended Posts

Hello,

 

Can anyone provide an example of a store that is using this contribution?  It would be helpful to see what it looks like installed.  Also, has anyone installed it on a version of the Shoppe Enhancement Controller?  This looks very interesting - congratulations and thank you to all who have worked so hard.  Best,

 

sorry, now with quote.

see https://secure.optimizekit.com


Keesjan

Share this post


Link to post
Share on other sites

 

:blink:

Can anyone tell me what is missing that gives me this result for a category banner:

 

<a href="http://mytestsite.com/FILENAME_CATEGORIES_INFO?ref=5&cPath=34&affiliate_banner_id=1" target="_blank">Artist Crafted</a>

 

 

I'm obviously missing the definition for FILENAME_CATEGORIES_INFO. At least I think :-" it's obvious! Where is this supposed to be defined and what is it set to?

Thanks!!

Share this post


Link to post
Share on other sites

HI Greg, in oscAffiliate integration with PayPal IPN that you have directed me to:

 

 

QUOTE

-------------------------------

//in paypal/application_top.php

-------------------------------

AFTER (approx line 93):

//$shipping = unserialize($orders_session['shipping']);

 

ADD:

  $affiliate_ref = $orders_session['affiliate_id'];

  $affiliate_clickthroughs_id = $orders_session['affiliate_clickthroughs_id'];

  $affiliate_clientdate = $orders_session['affiliate_date'];

  $affiliate_clientbrowser = $orders_session['affiliate_browser'];

  $affiliate_clientip = $orders_session['affiliate_ipaddress'];

 

 

I would assume it is paypal/application_top.php.inc file ?

 

this file does not have

//$shipping = unserialize($orders_session['shipping']); line or anything that looks like that?

 

what to do?

 

PS. i have posted this question in PayPal Ipn support also - when you reply I will copy the answer to wherever it would be missing - it kinda belongs in both topics...

Share this post


Link to post
Share on other sites

if anyone has a solution, workaround or advice on OSC-Afilliate working with Paypal_IPN, please post.

 

The misc file in version 2.6a of paypal_ipn refers to file and lines that don't exist.

 

Any help would be greatly appriciated.

Share this post


Link to post
Share on other sites
:blink:

Can anyone tell me what is missing that gives me this result for a category banner:

 

<a href="http://mytestsite.com/FILENAME_CATEGORIES_INFO?ref=5&cPath=34&affiliate_banner_id=1" target="_blank">Artist Crafted</a>

I'm obviously missing the definition for FILENAME_CATEGORIES_INFO. At least I think  :-"  it's obvious!  Where is this supposed to be defined and what is it set to?

Thanks!!

 

Anyone?? :huh:

Share this post


Link to post
Share on other sites
if you have a look at v2.6a in the misc directory you'll see a file with info on howto integrate, it should work with intuition, eg. paypal/checkout_process.php is paypal/catalog/checkout_process.inc.php

 

There are also some sql alterations to be performed as specified in the above mentioned file.

 

The only revision that needs to be made is for the edit for catalog/includes/affiliates_application_top.php, you need to also insert:

 

&& $affiliates_id !=0

 

after where it says tep_not_null($affiliates_id)

 

eg:

 

tep_not_null($affiliates_id)  && $affiliates_id !=0

 

hey i cant find this tep_not_null($affiliates_id) in this file affiliates_application_top.php

 

every thing is working fine but it doesnt record the sales made through paypal.

can any one please help me out

 

thankx

Share this post


Link to post
Share on other sites

Users using the Mozilla Firefox browser can't create an affiliate account. When registering, the user gets the congratulations screen and the welcome email but the affiliate account doesn't really get created.

Would someone know how to fix this?

 

Thanks!

Share this post


Link to post
Share on other sites

I originally posted this on the B2B support thread but it makes more sense here.

 

I have installed B2B over osc Affiliate. Everything works fine with B2B but I'm getting display_price() errors all over the affiliate summary pages.

 

e.g. Warning: Missing argument 3 for display_price()

 

I realise B2B has changed the display_price() function:

- 4 input variables rather than the existing three, where the first is the product ID.

 

My question!

 

Should I just create another function for all affiliate calls only e.g. display_price_affiliate(), using the original display_price() functionality (pre-B2B) or will that bugger up the affiliate calculations when discounts are in place?

 

I hope that makes sense and thanks in advance.

Simon

Share this post


Link to post
Share on other sites
I originally posted this on the B2B support thread but it makes more sense here.

 

I have installed B2B over osc Affiliate. Everything works fine with B2B but I'm getting display_price() errors all over the affiliate summary pages.

 

e.g. Warning: Missing argument 3 for display_price()

 

I realise B2B has changed the display_price() function:

- 4 input variables rather than the existing three, where the first is the product ID.

 

My question!

 

Should I just create another function for all affiliate calls only e.g. display_price_affiliate(), using the original display_price() functionality (pre-B2B) or will that bugger up the affiliate calculations when discounts are in place?

 

I hope that makes sense and thanks in advance.

Simon

 

I've tried it and it seems to work fine.

 

Only applicable if you have TotalB2B and osc affiliates installed.

 

In catalog/includes/classes/currencies.php

 

create a new function display_affiliates_price() with the original functionality like so:

 

//fix for conflict between osc affiliates contribution and totalB2B contribution
function display_affiliates_price($products_price, $products_tax, $quantity = 1) {
     return $this->format(tep_add_tax($products_price, $products_tax) * $quantity);
   }

 

 

Then find every call to display_price() in affiliate code - catalog ONLY

don't change admin code

 

replace:

display_price

 

with:

display_affiliates_price

 

and that's it.

 

I hope that helps.

Simon

Share this post


Link to post
Share on other sites

So yesterday evening I installed the osC Affiliate contribution - despite having to wade through lots of packages to find the October 13th starting point, everything went pretty smoothly. B)

 

I created a few affiliates and modified some of my ppc advertising to include the ?ref= in the url so I could track their hits and hopefully their conversion rates.

 

This morning I got a sale :D from someone coming through one of the ppc advertisers but the sale didn't get recorded. :o I started doing my usual "ok, where did I screw up this time" :o forensic work and in looking at my server logs, I saw this:

 

xxx.xxx.xxx.xxx - - [08/Nov/2004:08:16:14 -0600] "GET /login.php HTTP/1.1" 200 19775 "http://www.atomicvideoranch.com/shopping

_cart.php?ref=1&affiliate_banner_id=4" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; AT&T CSM7.0; .NET CLR 1.0.3705; .N

ET CLR 1.1.4322)"

xxx.xxx.xxx.xxx - - [08/Nov/2004:08:16:14 -0600] "GET /stylesheet.css HTTP/1.1" 200 6267 "https://www.atomicvideoranch.com/log

in.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; AT&T CSM7.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"

 

It looks like the ref= portion of the url got lost :'( when they switched to the secure site for the checkout process - or was it lost as a result of the login script?

 

Either way, until I get this figured out, I can't roll out the affiliate program - I don't want to have to parse server logs to find out what I owe to whom. :-"

 

Any help anyone can offer would be MUCH appreciated!

 

Thanks,

Al

abunch@atomicvideoranch.com


Boycott shampoo, demand real poo instead.

Share this post


Link to post
Share on other sites

Hello I just installed this mod on my test site and I'm getting a.

 

1044 - Access denied for user: 'xxxxxxxx@localhost' to database 'xxxx'

 

LOCK TABLES affiliate_affiliate WRITE

 

[TEP STOP]

 

 

error when I try to create an affiliate account. Any ideas on why this is happening? My other create user account works fine so I know my paths are setup correct in configuration....

 

Thanks!

Edited by homewetbar

Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

Nevermind found the solution elsewhere. Here it is if you have the same problem:

 

From:pfaustino

My hosting company recently upgraded mysql and deemed that this was a security issue and therefore revoked this privilege to all users. Rather than allowing the privileges described in the previous posts, they have asked us to comment out the code that locks the table.

 

That seems to work BUT I don't know if it has any repercussions yet.

 

Here's how to do it. Under /includes/functions/affiliate_functions.php, locate

 

tep_db_query("LOCK TABLES " . TABLE_AFFILIATE . " WRITE");

 

and comment it out

 

// tep_db_query("LOCK TABLES " . TABLE_AFFILIATE . " WRITE");

 

Let me know if I missed anything. There are some UNLOCK codes in this same file but I did not touch them.


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites
So yesterday evening I installed the osC Affiliate contribution - despite having to wade through lots of packages to find the October 13th starting point, everything went pretty smoothly. B)

 

I created a few affiliates and modified some of my ppc advertising to include the ?ref= in the url so I could track their hits and hopefully their conversion rates.

 

This morning I got a sale  :D  from someone coming through one of the ppc advertisers but the sale didn't get recorded. :o  I started doing my usual "ok, where did I screw up this time"  :o  forensic work and in looking at my server logs, I saw this:

 

xxx.xxx.xxx.xxx - - [08/Nov/2004:08:16:14 -0600] "GET /login.php HTTP/1.1" 200 19775 "http://www.atomicvideoranch.com/shopping

_cart.php?ref=1&affiliate_banner_id=4" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; AT&T CSM7.0; .NET CLR 1.0.3705; .N

ET CLR 1.1.4322)"

xxx.xxx.xxx.xxx - - [08/Nov/2004:08:16:14 -0600] "GET /stylesheet.css HTTP/1.1" 200 6267 "https://www.atomicvideoranch.com/log

in.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; AT&T CSM7.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"

 

It looks like the ref= portion of the url got lost  :'(  when they switched to the secure site for the checkout process - or was it lost as a result of the login script?

 

Either way, until I get this figured out, I can't roll out the affiliate program - I don't want to have to parse server logs to find out what I owe to whom.  :-"

 

Any help anyone can offer would be MUCH appreciated!

 

Thanks,

Al

abunch@atomicvideoranch.com

 

I'm having the exact same problem and I use paypal IPN additionally but I have added

include(DIR_WS_INCLUDES . 'affiliate_checkout_process.php');

 

in my checkout_process.inc.php for paypal so the problem lies in the seperate secure server I think??? Any ideas on how to fix this?


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

Hi!

 

My OSCAffiliate works great .. but i have one question.

 

PAYMENTS

 

Ok .. got billed affiliates ... on my test affiliate i received email my payment is added now to the question .. how will i know when to bill comission to affiliate .. under Payments everything is still blank .. i have set treshold to 1 and days before billing to 1 .. but still my test affiliate account has exceeded amount for payout but i still can't see "invoice" for this affiliate

 

sorry for my bad english :(

Share this post


Link to post
Share on other sites
Hi!

 

My OSCAffiliate works great .. but i have one question.

 

PAYMENTS

 

Ok .. got billed affiliates ... on my test affiliate i received email my payment is added now to the question .. how will i know when to bill comission to affiliate .. under Payments everything is still blank .. i have set treshold to 1 and days before billing to 1 .. but still my test affiliate account has exceeded amount for payout but i still can't see "invoice" for this affiliate

 

sorry for my bad english :(

 

 

is there any documentation on Payment in Affiliate?

Share this post


Link to post
Share on other sites

Hi

I am looking for some help with a feature of oscaffiliate

I would love to add an extra field to the table that records affiliate sales - I would like to add a 'clickref' where the affiliate can set this value to anything (to help them track what link has been clicked)

Anyone done this already.

It shouldn't be too difficult but I dont want to reinvent the wheel.

If not all I really need to know is....

 

What file is the affiliate cookie set.

What file is the sql for the affiliate sale tracking

Which table is the affiliate sale tracking in.

 

Thanks for your time

 

Brian

Share this post


Link to post
Share on other sites

i guess noone is answering here .. i wonder what's teh use of making so complicated script .. and then noone is ready to help?

Share this post


Link to post
Share on other sites

have looked at a lot of posts didn't find the answer to this. sorry if it is a repetition.

 

in my affiliate admin under summary (and sales report alike) i get this:

 

Impressions: [?] n/a Visits: [?] 0

Transactions: [?] 0 Conversion: [?] n/a

Sales Amount: [?] TEXT_PRICE_IS_ZERO Sales Average: [?] TEXT_PRICE_IS_ZERO

Clickthrough Rate: [?] TEXT_PRICE_IS_ZERO Pay Per Sale Rate: [?] TEXT_PRICE_IS_ZERO

Commission Rate: [?] 5.00% Commission: [?] TEXT_PRICE_IS_ZERO

 

where can i find the and fix the TEXT_PRICE_IS_ZERO ?


Did you try? Did you fail? No matter! Try again. Fail again! But fail better!

Share this post


Link to post
Share on other sites

does this contribution offer capability to pay a flat rate commision in $ (not %) for a sale and as the sales level increases the commision paid is increased as a result. for instance consider a commision structure like below:

 

____sale_________commission per product sold__

 

1-49 -> $ 10

50- 100 -> $ 20

 

is it aslo possible to have a combination of % and $ commision structure?

how about automatic upgrade for high performing affiliates? such that if they generate over a certain level of sales per month (set by the administrator) their accont is upgraed to give them a higher percentage of commission as an incentive.

 

cheers


Did you try? Did you fail? No matter! Try again. Fail again! But fail better!

Share this post


Link to post
Share on other sites

hey Mibble,

 

i'm using v2.02. i noticed people talking about v2.6a and 2.8!!!!!! but sounds like there was a mixup! what's the latest version and where can i get it if the problem is that of an earlier version!

 

i should that i have not modified anything in the oscaffiliate fies, and don't thing there's a conflict w/ other contributons!

 

but i'm not an expert. please help

 

cheers.


Did you try? Did you fail? No matter! Try again. Fail again! But fail better!

Share this post


Link to post
Share on other sites

hmm .. what about to build a link for all products from category

 

I.E.

 

Category

- Item 1 (5.600 USD)

- Item 2 (4.600 USD)

- Item 3 (100 USD)

- Item 4 (400 USD)

 

 

is this possible?

Share this post


Link to post
Share on other sites

Hey all,

 

this seems like a wierd question but I have built a high traffic affiliate a complete storefront using my database and images but the affiliates store front is located in a different folder.

 

Ie. www.mystore.com/myshop/index.php

and www.mystore.com/affilaitesshop/index.php

 

It is working great when the affiliate sends people to his store using his affiliate link but what i would like to do is make it so every visitor that comes to this store without the referal code will get this affiliates ref ID attached and thus any purchases through this store will get commision.

 

I could use a redirect from /affiliateshop/index.php to include his ref ID but would rather hard code this into the store.

 

Any ideas on how I can do this?

Thanks..

 

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×