Jump to content
henri

OSC-Affiliate

Recommended Posts

Hi folks.

 

Well, I've installed this Contrib for the third time now.

 

(I deleted it twice before because it wouldn't generate user IDs.)

 

 

This time, it DOES generate the IDs.

 

 

 

 

OK, this time, there aren't any sales or clicks being recorded.

 

 

I created a dummy affiliate account and, using the affiliate links , I have made three test purchases....all different products.

 

But only ONE is recorded in the stats.

But only as a CLICK, ....NOT as a sale. :(

 

In my store Admin, I have these settings:

 

Billing Time: 0

Order Min Status 0

 

 

Why isn't it recording any clicks or sales????

 

Any ideas?

i have this same problem -

 

 

any ideas how to fix it?

Share this post


Link to post
Share on other sites

Ok i now have it installed and working great, but for the life of me i cannot figure out where to edit the affiliate faqs. I tried a few different ways with no luck.

Share this post


Link to post
Share on other sites

You'll find the affiliaste faq text in

 

catalog/includes/languages/english/affiliate_faq.php

Share this post


Link to post
Share on other sites

Hi all:

 

My affiliate program runs for months. All good but... Since middle of May,

the Affiliate program stopped counting clickthrough and sales... :huh: Is it because DB full? (record 23,406 clickthroughs already)

or?

I didn't find any articles talk about this. I really need it to fix and keep running again...

Even if the problem is not because the full of DB, how to clean the DB record about the clickthrough data? I didn't find the function and it's already showes 1,171 pages of click through data... :(

Share this post


Link to post
Share on other sites

Hi - Great contrib!

 

I operate a multi-languages site, and I was wondering...

 

I want to have some banners in English, with the link pointing to the English version of the site; and some banners in French, pointing to the French version of the site.

 

Is this possible?

 

Thanks a bunch.

Share this post


Link to post
Share on other sites

DECOUPLING OSCAffiliate from ORDER tables

 

Hi all,

 

I have a unique problem. I want to use the OSCaffiliate mod but i use another application to delete orders when they are processed externally. I am wondering if there is a way to .. or what i would need to do to decouple the affiliate tracking from the order tables so that when the orders were deleted OSCaffiliate will still count the order as "delivered" . Thanks!

 

rw

Share this post


Link to post
Share on other sites

I need some help - I realize this is sorta not the right thread but not having much luck with IPN thread.

 

I have installed the new PayPal IPN 2.3 and trying to get affiliate to process with PayPal.

 

If you think you can help here is where I am at:

 

http://forums.oscommerce.com/index.php?sho...ndpost&p=383141

 

Chris


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

was wondering if anyone got a parse error in their header when installing this? i think it's my header tags controller that is conflicting. I also have the sts add-on installed any help would be great. thanks in advance!

 

M

Share this post


Link to post
Share on other sites

Well, now i really need to get this sorteted out, before i get in to deep with this contribution! :rolleyes:

 

I downloaded:

http://www.oscommerce.com/community/contri...earch,affiliate

 

And as usuall before installing stuff like this i read the "READ ME" files!

Yes it's tru, i do read em (from time to time)

 

Well, my reading pointed me here, and to a sourgeforge site:!

http://sourceforge.net/projects/oscaffiliate/

 

And since i enjoy reading forums (not) i found this thread; Is 0.3 greater then 2.0a???, the aswer there was that the version found at this sourceforge site was the on to use since the files here no longer is maintained!

 

Is this true, or is these two contributions not related?

 

/me very confused!


----===~~oOo~~===----

// Bjarne Varoystrand aka Black Skorpio

Do to others what you want them to do to you

- �� Lek och Lust F�r Vuxna

Share this post


Link to post
Share on other sites

Wonderful contribution, works perfectly. Just one suggestion.

It may have been mentioned here but there are a lot of pages.

 

Affiliate TEXT LINKS are just based on the banners, and produce codes like

 

<a href="http://yoursite/catalog/index.php?ref=2&affiliate_banner_id=1" target="_blank">468x60 Banner</a>

 

Not a very good TEXT LINK :(

 

Is there a way to fix or improve upon this?

 

TIA

Share this post


Link to post
Share on other sites
G'day Mates,

 

does anyone have any idea how do i setup a email notifiucation for new affliate partner ?

 

I got all the time the prob that signed new partners wrote me a mail because i didn't notice that they are waiting for unlock her account.

 

B)

Share this post


Link to post
Share on other sites

Hello,

I have an question:

in the database in the tabel affiliate_affiliate i found the fields affiliate_lft and affiliate_rgt and affiliate_root.

For as far i can see the affiliate_root is the field where i can see what the sponsor is of the affiliate, but wherefor are the other 2 fields?

 

And is it posible to see in the admin of the shop an family tree so i can see witch affiliate is an sponsor of an other affiliate.

The same thing for the affiliates, is it posible that they can see how many partners they have under them?

 

Regards

 

Dani?l

Share this post


Link to post
Share on other sites
in the database in the tabel affiliate_affiliate i found the fields affiliate_lft and affiliate_rgt and affiliate_root.

Search google for nested sets Tutorials.

 

family tree

Yes is possible, must only be implemented....

Share this post


Link to post
Share on other sites

Hi

 

I am using osC Affiliate v 2.00 with OsCommerce 2.2-MS2. Everything is working perfectly.

 

But I am confuse with payment calculation. From where I (as an admin) can add "pay per click" rate? Number of clicks are calculated correctly but my affiliate members ( me also......) are unable to know how much they earn from "pay per click".

 

I think this problem is also same for "sale". "sales report" and "clickthrough report" always showing me zero amount.

 

Have to configure someting from admin section?

Share this post


Link to post
Share on other sites

I've got a quick question on this mod. I've got it running but when I make a test sale I get this under:

 

Afiliates / Sales

 

When the screen shows it says "Deleted (Admin)" under Status.

 

I don't know why its defaulting on this value. Can anyone help me with this?


I need to read the rules more often...

Share this post


Link to post
Share on other sites

Hi There

 

I've just installed the OSCommerce Affiliate v2.03 for the Admin side only cause I want to look at it first. However, when I go to login to Admin I am presented with the following error.

 

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /hsphere/local/home/encorep/encoreproductions.co.uk/admin/includes/functions/database.php:13) in /hsphere/local/home/encorep/encoreproductions.co.uk/admin/includes/functions/database.php on line 13

 

If you can help me solve this, I will be very grateful.

 

Many thanks

 

David James

Share this post


Link to post
Share on other sites
Fatal error: Cannot redeclare tep_db_connect() (previously declared in /hsphere/local/home/encorep/encoreproductions.co.uk/admin/includes/functions/database.php:13) in /hsphere/local/home/encorep/encoreproductions.co.uk/admin/includes/functions/database.php on line 13

:rolleyes: Don't worry solved it. Did'nt see it at first but after a long coffee and ciggy I spotted my stupid mistake. :blink:

Share this post


Link to post
Share on other sites
I've got a quick question on this mod. I've got it running but when I make a test sale I get this under:

 

Afiliates / Sales

 

When the screen shows it says "Deleted (Admin)" under Status.

 

I don't know why its defaulting on this value. Can anyone help me with this?

Check the changes you made to checkout_process.php in catalog. I had the smae problem and found I added the information in the wrong place. The bit your suppose to put it before is right at the bottom near line 240ish

 

HTH

 

Iklekid

Share this post


Link to post
Share on other sites

Hi guys,

 

Is there a way to convert an affiliate's earnings into store credit that is automatically deductable when they shop at my store?

Share this post


Link to post
Share on other sites

Yes, I installed that credit class and gift voucher module already - the latest release.

Share this post


Link to post
Share on other sites

Hi everyone.

 

I'm having problem installing affiliate v2.03! The admin section works fine. all problems are in my main page of the website. There are two problems... here are the errors I'm getting:

 

Error #1:

 

Fatal error: Call to undefined function: tep_session_register() in c:\SP\artwww\health\shops\includes\affiliate_application_top.php on line 106

 

which pertains to the following codes:

 

   tep_session_register('affiliate_ref');
  tep_session_register('affiliate_clickthroughs_id');

none of the main page shows up because of this!! except the error message writing...

Now, if I commented out these two lines, then main page shows up in messed up way and gives the following error at the affiliate box in left side:

 

Error #2:

 

Fatal error: Call to undefined function: tep_session_is_registered() in c:\SP\artwww\health\shops\includes\boxes\affiliate.php on line 26

 

which pertains to the following code:

 

   if (tep_session_is_registered('affiliate_id')) {

 

guys, it's now 9:45pm of Boston, USA time, I'll stay online and awake until someone please help me in this. It's really important that I get this error fixed and get the side back working and add more functions :D

 

Thanks very much for your support!

Share this post


Link to post
Share on other sites

could someone please be kind enough to help me fix the above problems I have with installation? I would greatly appreciate it. I have unfortunately not heard from anyone in the past 2 days.....

 

thanks.

Share this post


Link to post
Share on other sites

could someone be kind enough to help me fix the above errors? i'd appreciate your help.

Unfortunately, I haven't heard from anyone since past 2 days!

thanks very much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×