Jump to content
henri

OSC-Affiliate

Recommended Posts

ups i saw:

 

INSERT INTO affiliate_payment_status (affiliate_payment_status_id, affiliate_language_id, affiliate_payment_status_name) VALUES("0", "2", "schwebend");

INSERT INTO affiliate_payment_status (affiliate_payment_status_id, affiliate_language_id, affiliate_payment_status_name) VALUES("1", "2", "zahlend");

Share this post


Link to post
Share on other sites

Hello,

Thanx for this great contribution.

I only have one problem: the start billing function is not working :-(

 

The orders are 30 days old and the must be 5 days old, the status of the orders is 3 and they must be 1 (set for testing, and also tested it on status 3) the affiliate has earnd 500.00 euro and that must be 50 euro so all of this is good.

When i now press the start billing button on the payment page i get the following message:

 

Your Affiliates have been sucessfully billed

 

But there are stil 0 payments....... :blink:

 

What can be wron?

 

Hope someone can help me.

 

Kind regards

 

Dani?l

Share this post


Link to post
Share on other sites

IF YOU#RE USING THE GERMAN LANGUAGE PACK ADD THIS IN YOUR SQL AFFILIATES_PAYMENTS_STATUS

 

INSERT INTO affiliate_payment_status (affiliate_payment_status_id, affiliate_language_id, affiliate_payment_status_name) VALUES("0", "2", "schwebend");

INSERT INTO affiliate_payment_status (affiliate_payment_status_id, affiliate_language_id, affiliate_payment_status_name) VALUES("1", "2", "zahlend");

Share this post


Link to post
Share on other sites

Hi,

Thanx for the reply, but i'm not sure...

i'm using the german language, but i have just copy the english files to the german language, i still have to do that database upgrade?

And i'm also using the dutch language, do i have to do another database upgrade than?

 

Dani?l

Share this post


Link to post
Share on other sites

oke, i have find out what to do after looking into the database, i have also made an database entry for the dutch language and now it is working

 

Thanx

 

Dani?l

Share this post


Link to post
Share on other sites

Hello,

I have another quistion and that is the following:

I'm using the affiliate tier and i have 3 levels in that.

I want the following: i want to have 3 kinds of tiers

tier 1 is 3 levels and as following -> level 1 = 20% / level 2 =5% and level 3 = 1%

tier 2 is 3 levels and as following -> level 1 =5% / level 2 = 15% and level 3 = 5%

tier 3 is 5 levels and as following -> level 1 =5% / level 2 = ..... and so on

this is just an example.

Standard an new affiliate has to be assignt to tier 1 but i want the posibility to assign an affiliate to another tier, this is becouse i also can get some affiliates that not use the program to sell the products but know a lot of posible affiliates that want to use my affiliate program.

Is this somehowe posible?

I also want to pay for someone who can make this with custom programming (there is already been custom programming to the affiliate program).

Hope someone can help me with this.

Regards

 

Dani?l

Share this post


Link to post
Share on other sites
Hi,

Thanx for the reply, but i'm not sure...

i'm using the german language, but i have just copy the english files to the german language, i still have to do that database upgrade?

And i'm also using the dutch language, do i have to do another database upgrade than?

 

Dani?l

this will just add the german language ... got the same prob mate

Share this post


Link to post
Share on other sites

hi, i have found out how to solve this when you use another language.

 

INSERT INTO affiliate_payment_status (affiliate_payment_status_id, affiliate_language_id, affiliate_payment_status_name) VALUES("0", "2", "schwebend");
INSERT INTO affiliate_payment_status (affiliate_payment_status_id, affiliate_language_id, affiliate_payment_status_name) VALUES("1", "2", "zahlend");

 

the 2 is for the language, i'm also using dutch, and that was the 4 language, so i replaced the to in above code with 4 and put that in the database and it is working now.

 

So just look what your language number si and place that on the place of the 2 .

 

Dani?l

Share this post


Link to post
Share on other sites

Hi folks.

 

Well, I've installed this Contrib for the third time now.

 

(I deleted it twice before because it wouldn't generate user IDs.)

 

 

This time, it DOES generate the IDs.

 

 

 

 

OK, this time, there aren't any sales or clicks being recorded.

 

 

I created a dummy affiliate account and, using the affiliate links , I have made three test purchases....all different products.

 

But only ONE is recorded in the stats.

But only as a CLICK, ....NOT as a sale. :(

 

In my store Admin, I have these settings:

 

Billing Time: 0

Order Min Status 0

 

 

Why isn't it recording any clicks or sales????

 

Any ideas?

Share this post


Link to post
Share on other sites

I have installed the affliate addon and most of it looks good except whenever you try to save anything in the admin or the affiliates area i get the error message

Cannot modify header information - headers already sent by (output started at advertising/catalog/includes/application_top.php:512) in advertising/catalog/includes/functions/general.php on line 29

 

It still save's everything if you hit the back button, but i would like to fix this before going live.

 

;)

Share this post


Link to post
Share on other sites

I have everything running except for one problem. I am not recording any sales. I do record clicks and everything else is working. When I look at the database there are no recorded in the table. I have set the billing time to zero, went through and marked the order as delivered. Still no record of a sale. Anyone have any ideas?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

OK, I've got mine working, but I have another little problem.

 

I tested out the START BILLING function.

 

It bills the affiliate ok, but it ADDS TAX to the payment.

 

 

 

How do I stop it adding tax?????? :blink:

Share this post


Link to post
Share on other sites

I have isolated my problem, it is that the following statement is not testing as true:

 

if ($HTTP_SESSION_VARS['affiliate_ref']) {

 

I have a newer version of osCommerce and have experienced some incompatibilities in the past. Does anyone know if the $HTTP_SESSION_VARS is not supported in newer or future versions of either osCommerce or PHP/SQL?

 

Is there an alternative IF statement I can use? I'm not a programmer, so your help is appriciated. Thanks!

Share this post


Link to post
Share on other sites

I just can't figure out why osAffiliate is ADDING TAX to mty affiliate payouts.

 

 

I haven't got ANY tax settings set up on my store.

 

:blink:

Share this post


Link to post
Share on other sites

Mikey,

 

I don't know if this has anything to do with your tax problem but take a look at the admin\includes\affiliate_configure.php. There is a line which says

define ('AFFILIATE_TAX_ID','1'); // Tax Rates used for billing the affiliates

 

I don't quite understand what this does, so it may not have anything to do with your tax charging problem...

Share this post


Link to post
Share on other sites

Just a small question: is there a way to put banners on another server as the one where the as commerce site is (bandwith problems)?

 

Thanks!

Share this post


Link to post
Share on other sites

Does anyone know what the database field "affiliate_clickthroughs_id" is being used for? It is zero for all of my records of sales. I can't find where it is assigned a value and what it would be used for.

Share this post


Link to post
Share on other sites

Isn't the affiliate clickthroughs ID for recording which banners are being clicked?

 

Just a guess.

 

 

 

By the way......what you said earlier about affiliate configure.

 

I've now changed it to:

 

define ('AFFILIATE_TAX_ID','');

 

 

Hopefully that'll sort it out.

 

 

 

Mind you, I can't for the life of me guess why tax would be ADDED to affiliate commissions.

 

:ph34r:

Share this post


Link to post
Share on other sites

someone could answer please (my bandwith is realy suffering because of this!):

 

<quote>Just a small question: is there a way to put banners on another server as the one where the as commerce site is (bandwith problems)?

 

Thanks!</quote>

Share this post


Link to post
Share on other sites

No.

 

They have to be in your osCommerce images folder.

 

;)

Share this post


Link to post
Share on other sites

Why don't you move your osCommerce store to a server with better bandwidth?

 

After all, you'll need extra bandwidth as your store grows.

 

:unsure:

Share this post


Link to post
Share on other sites

Well, because I have some webspace with my internet provider for free and no limit on the bandwith but no php either... So I would like to put my banners there!

 

I will just ask my affiliates to change the link manualy!

 

Thanks anyway!

 

And if someone can find a way, it would be great (even if the number of showed banners doesn't appear!)

Share this post


Link to post
Share on other sites
I have installed the affliate addon and most of it looks good except whenever you try to save anything in the admin or the affiliates area i get the error message
Cannot modify header information - headers already sent by (output started at advertising/catalog/includes/application_top.php:512) in advertising/catalog/includes/functions/general.php on line 29

 

It still save's everything if you hit the back button, but i would like to fix this before going live.

 

;)

Please tell me can anyone give me any ideas on fixing this, i really need to get the store running, and cant do it till it is fixed.

Share this post


Link to post
Share on other sites

dedj,

 

according to the results I found from using the search function (located on the top right of the page), it usually means you have extra spaces or other white spaces after a closing ?> in one of your files. Take a look and try to find it and remove them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×