Jump to content
henri

OSC-Affiliate

Recommended Posts

About the password issue i posted the solution here some times...

 

This runtime error might be a javascript error, try to rempove onSubmit="return check_form();

Share this post


Link to post
Share on other sites

Tried removing just that and it caused an error.

 

This is the code

<td width="100%" valign="top"><?php echo tep_draw_form('affiliate_signup', tep_href_link(FILENAME_AFFILIATE_SIGNUP, '', 'SSL'), 'post', 'onSubmit="return check_form();"') . tep_draw_hidden_field('action', 'process'); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

 

How should it be?

 

All help is appreciated

Share this post


Link to post
Share on other sites
Henri' date='

 

The Affiliate Program works great but I am having problem with "Forgotten Password Feature"

 

The new password which it generates does not work.

 

Is there a fix for this.

 

 

 

 

There is a typo error in the affiliate_password_forgotten.php file

 

At Line 27:

 

$crpted_password = tep_encrypt_password($newpass);

 

Replace with :

 

$crypted_password = tep_encrypt_password($newpass);

 

 

You can find it here:

http://cvs.sourceforge.net/cgi-bin/viewcvs...f?r1=1.6&r2=1.7

Share this post


Link to post
Share on other sites

wow, this is a huge thread...

 

My apologies if I missed the answer somewhere within these pages but i am currious what version should I install?

 

I downloaded the zip for 1.01 dated 2003-03-02 but also see many other zips..

 

another question just before I start to install this.. Do i need to insert my new tables manually?

 

Thanks in advance.. Mikey

Share this post


Link to post
Share on other sites

Ok, nevermind.. LOL..

 

I actually did it and its working amazing... I guess everyday You lean something new..

 

I have been looking for an affiliate program as good as this for months and never even knew this contribution was here until today...

 

I do have another question that someone may be able to help me with. My old affiliate program had the affiliate id as retailer and not a number. I have tons of affiliates and want to make a smooth transition to this new affiliate program. Is there a way to customize this script to have the linking code changed from

 

http://mysite.com/video/product_info.php?ref=1&products_id=63&affiliate_banner_id=3

 

http://mysite.com/video/product_info.php?retailer=companyname&products_id=63&affiliate_banner_id=3

 

 

wow, this is a huge thread...

 

My apologies if I missed the answer somewhere within these pages but i am currious what version should I install?

 

I downloaded the zip for 1.01 dated 2003-03-02 but also see many other zips..  

 

another question just before I start to install this.. Do i need to insert my new tables manually?  

 

Thanks in advance.. Mikey

Share this post


Link to post
Share on other sites

With some (easy) changes to the code and database it should be possible;

Share this post


Link to post
Share on other sites

i tried skimming through the 45 pages in order to find an answer to this question but couldnt, so I am asking it now...

 

my OSCAffiliates is installed into Ians 5 loaded package and I got it working almost perfectly...

 

but

 

when i make a test purchase with the PayPal IPN my affiliate account is not credited for that purchase.... but it is if i use COD...

 

it seems as though the customer MUST reach the final "success" page before any orders are credited toward the affiliate...

 

is it possible to credit the affiliate even if the customer doesnt hit the "continue" button on the PayPal site? because a lot of people close their browser after making a payment on the paypal site and dont hit "continue", which leads them back to my site's sucess page...

 

is there any other way to solve this problem or has it been mentioned elsewhere?

 

thanks

Share this post


Link to post
Share on other sites

The affilate is cleared at the checkout_process page.

If he doesn'T come back from paypal you don't have a order, cause the checkout is called from paypal.

Share this post


Link to post
Share on other sites

Henri

 

Can you add a functionality regarding signing up for an Affiliate.

 

When a New Affiliate Signs up, the store owner or the email provided in the Admin Section should get an email confirming a new affiliate signup.

Share this post


Link to post
Share on other sites

ok...i just created a new PayPal account and tested a $3.50 purchase...

and nothing was recorded in my affiliates account.... but I got an email from PayPal and my test PayPal account was credited $3.50...

Item #9 - Notification of Payment Received

But no earnings recorded in the affiliate's area...

I even completed the transaction fully, returning me to my OSC site and showing me that ckeck box asking if I wanted to be updated in the future about that product... my cart was also cleared...

 

for some reason my affiliate program doesnt record any PayPal transactions... but i know it works because everything is recorded when I make a purchase using COD...

 

i did a complete checkout with the same item, clicked from the same link, but using the COD payment method and everything was recorded without a hitch...

 

what am i missing?

thanks again...

Share this post


Link to post
Share on other sites

ok...i just created a new PayPal account and tested a $3.50 purchase...

and nothing was recorded in my affiliates account.... but I got an email from PayPal and my test PayPal account was credited $3.50...

Item #9 - Notification of Payment Received

But no earnings recorded in the affiliate's area...

I even completed the transaction fully, returning me to my OSC site and showing me that ckeck box asking if I wanted to be updated in the future about that product... my cart was also cleared...

 

for some reason my affiliate program doesnt record any PayPal transactions... but i know it works because everything is recorded when I make a purchase using COD...

 

i did a complete checkout with the same item, clicked from the same link, but using the COD payment method and everything was recorded without a hitch...

 

what am i missing?

thanks again...

Share this post


Link to post
Share on other sites

I hope someone will be able to help me.

 

I set up the oscaffiliate and it looks great.

the problem im having is that after the customer is logged in he is redirected to the affiliate summery page and he is now on ssl mode (I use shared ssl) but when I click on the banners button it takes to a non ssl page and it doesn?t recognize the logged in customer any more and because of that it redirects it to the login page.

The problem is in switching between ssl page and a nonssl page.

 

Any one has an idea how to solve that?

I actually turned all the pages on the oscaffiliate to ssl pages and it works ok as long as I don?t leave the oscaffiliate files.

 

I hope I was clear. :oops:

 

Thank you,

Felix.

Share this post


Link to post
Share on other sites

Hi,

 

Can someone point me to which affilate contribution I should download. Can someone post the link here, so I can grab it, Because there are soo many contribution of afficliae i don't know which one is which, and can someone repack it and put in allt he fixes. I believe this thread is too long for anyone to read in what is going on here and what to fix. I"m a litle bit confusse in readinnng all this

 

Someone please be kind enough to repack this and send it to the contriub or put up a link where we can download the updated affilate.

 

Thnk YOU so much

Share this post


Link to post
Share on other sites

ok.... i figured out why PayPal IPN wasnt working with this great mod...

 

here's what you need to do...

 

If you are using Ian's loaded snapshot 5 or the PayPal IPN contribution,

 

open catalog/checkout_paypalipn.php

 

FIND

// unregister session variables used during checkout

 

 

ADD BEFORE

  // Include OSC-AFFILIATE 

 require(DIR_WS_INCLUDES . 'affiliate_checkout_process.php');

 

save and upload....

Share this post


Link to post
Share on other sites

Is this possible? Our store practices in the past have been to give affiliates their all sales from click-throughs, plus a bonus from their customer whether they came through the affiliate link or direct to our store. I have managed it in the past with a scary set of SQL scripts in another commerce package. Does OsC_Affiliate have a way to assign customers permanently to an affiliate?

Not implemented yet. But should be possible.

add a field to the customer table where the ref is stored.

On Account creation the ref is stored there

When he logs in the ref is taken and registerred into the sseion

 

Nearly 2 months later, and I have finally made the modifications to assign customers permanently to an affiliate. :roll:

 

First off, I added the field "customers_affiliate_ref" to the customers table.

ALTER TABLE `customers` ADD `customers_affiliate_ref` INT( 11 );

This adds a field for us to store the affiliate ID permanently in the customer record.

 

In catalog/login.php around line 25, the query needs to be changed from

    $check_customer_query = tep_db_query("select customers_id, customers_firstname, customers_password, customers_email_address, customers_default_address_id from " . TABLE_CUSTOMERS . " where customers_email_address = '" . tep_db_input($email_address) . "'");

To

    $check_customer_query = tep_db_query("select customers_id, customers_firstname, customers_password, customers_email_address, customers_default_address_id, customers_affiliate_ref from " . TABLE_CUSTOMERS . " where customers_email_address = '" . tep_db_input($email_address) . "'");

 

And after the following line (line 50)

tep_session_register('customer_zone_id');

Add

if ($check_customer['customers_affiliate_ref']) {

         $affiliate_ref = $check_customer['customers_affiliate_ref'];

         tep_session_register('affiliate_ref');

       }

This will retrieve the affiliate ID and set the session variable, if the customer is assigned to an affiliate.

 

In catalog/create_account_process.php around line 266 find

if (ACCOUNT_DOB == 'true') $sql_data_array['customers_dob'] = tep_date_raw($dob);

And add the following line of code

if ($HTTP_SESSION_VARS['affiliate_ref']) $sql_data_array['customers_affiliate_ref'] = $HTTP_SESSION_VARS['affiliate_ref'];

This will retrieve any affiliate ID and assign it to the customer upon account creation.


jackhandy - http://jackhandy.com

Share this post


Link to post
Share on other sites

Hi Guys,

 

I'm sure this is simple! I've uploaded and configured the affiliate system, and it seems to work OK except for the code generator part. When ever I try to get the affiliate link code it comes up blank. :shock:

 

Any help would be appreciated.

 

Many thanks in advance

 

Norman.

 

PS OSC Rocks!

Share this post


Link to post
Share on other sites

I installed this and the "banners" addon a couple of days ago, and for the most part it works fine but I'm having a couple of problems with it.

 

First, I can't seem to change the affiliate payment amount. When I edit an affiliate account from the admin panel, it saves the changes there, but doesn't change what's displayed in the affiliates list or in the invididual affiliate's account. It always says 10%, and nothing I do changes it. I assume this is because something is supposed to be writable that isn't, but the installation instructions didn't say anything about what the permissions should be.

 

Next, it doesn't send e-mails after an affiliate registers. It says there will be one sent within the hour, but it isn't. When I go to the contact page in the admin center, the e-mail address that shows up in the 'from' field is "affiliate@localhost.com" instead of my address. It's certainly not a big issue, but I'm concerned that it's just a symptom of something bigger.

 

And finally....the "build a link" code generator doesn't work. It directs to a page with empty text boxes. Once again I assume something should be writable that isn't, but I don't know what.

 

Can anyone help me figure out what I did wrong or what needs tweaked?

Share this post


Link to post
Share on other sites

I found and fixed most of my problems, but still can't get the code generator to work for the "build a link" section.

 

Also, when I make a product link, it puts it into the banners section...and I have no idea how to move it to the product links page?

 

I'd appreciate any help any of you can give me!

 

Thanks :D

Share this post


Link to post
Share on other sites

Julie

 

Have you tried my Banner Centre addon for the affiliate system? or are you just having difficulties with the standard build a link module?

Share this post


Link to post
Share on other sites

HI,

 

From my site I have the problem that no code is generated in the box to paste.

 

As you may have guessed I'm new to PHP, but learning quickly!

 

Thanks

Norman

Share this post


Link to post
Share on other sites
Nearly 2 months later, and I have finally made the modifications to assign customers permanently to an affiliate. :roll:

 

Thats a very neat solution and you save me 2 months of effort! Many thanks :D


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

Yes, and Yes Snowman. I installed oscafilliate vs 1.01 from sourceforge, and played with it a little bit. Everything seemed to work on the customer end except the e-mail and the included "build-a-link" code generator.

 

Then, I installed the oscaffiliate banners 1.0 ...but "build a link" still didn't work. Also, it puts all the product banners I make in the admin panel into the "banner links" section, and I'd like to move them to the "product links" section so I can post some standard size .gif banners in the 'banner links' section.

 

I found the other problems, but am not understanding why it doesn't generate the code. When I view the source, it's just an empty box -it doesn't even have an " " in it. So, it's trying to do something....

 

BTW, the code generator for the text links seems to work fine. I've only tested it once, but it did make the code without any problems.

 

I appreciate your trying to help me, as I'm brand new to php, and am not learning it quickly!

Share this post


Link to post
Share on other sites

I installed oscaffiliate on my late may snapshot (may 31'st I belive?) The install when fine and I even thought the addin was running fine, but when I'm logged in as an affiliate, the payment report, clickthrough report and sales report links return an error "1064 - You have an error in your SQL syntax near ') as total ' at line 1

 

select count() as total

 

[TEP STOP]"

 

Is this due to an incompatible version of oscommerce? Any help would be appreciated. Thanks

Share this post


Link to post
Share on other sites

Julie

 

I'll look back thru the code and see if i can find a cause.

 

Tony

 

The sql error has me stumped, its not related to the affiliate code as i have suddenly started gettign the same error in several other mods under a new CVS snapshot of MS2.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×