Jump to content
henri

OSC-Affiliate

Recommended Posts

Fatal error: Failed opening required 'includes/languages/affiliate_.php' (include_path='.:') in /usr/local/psa/home/vhosts/xlandia.com/httpdocs/tienda/admin/includes/affiliate_application_top.php on line 56

Did you put the include of affiliate_application_top.php at the end of application_top.php?

includes/languages/affiliate_.php

means that no language is defined (and so the rest of your admin shouldn't work either without the affiliate if it's proparly installed.

Share this post


Link to post
Share on other sites

I have found that if I type the following url directly,

http://mydomain.com/catalog/affiliate_show_banner.php

The following errors will occurr. How to avoid these error.

This is not good for security.

 

Notice: Undefined index: ref in C:webcomcatalogaffiliate_show_banner.php on line 90

 

Notice: Undefined index: ref in C:webcomcatalogaffiliate_show_banner.php on line 91

 

Notice: Undefined index: affiliate_banner_id in C:webcomcatalogaffiliate_show_banner.php on line 93

 

Notice: Undefined index: affiliate_banner_id in C:webcomcatalogaffiliate_show_banner.php on line 94

 

Notice: Undefined index: affiliate_pbanner_id in C:webcomcatalogaffiliate_show_banner.php on line 95

 

Notice: Undefined index: affiliate_pbanner_id in C:webcomcatalogaffiliate_show_banner.php on line 96

 

Notice: Undefined variable: banner_id in C:webcomcatalogaffiliate_show_banner.php on line 101

 

Notice: Undefined variable: prod_banner_id in C:webcomcatalogaffiliate_show_banner.php on line 110

Share this post


Link to post
Share on other sites

define('AFFILIATE_KIND_OF_BANNERS','2'); // 1 Direct Link to Banner ; no counting of how much banners are shown

// 2 Banners are shown with affiliate_show_banner.php; bannerviews are counted (recommended)

 

I also find that if Affiliate_kind_of_banners set to 2, it can't display the banner. If I set it to 1, it can display the banner.

 

How to fix this problem!?

Share this post


Link to post
Share on other sites

I don't have these warnings ;)

but try changing

if ($HTTP_GET_VARS['ref'])

 

to

if (isset($HTTP_GET_VARS['ref']))

 

were thes errors happen.

Share this post


Link to post
Share on other sites
I also find that if Affiliate_kind_of_banners set to 2, it can't display the banner. If I set it to 1, it can display the banner.

How to fix this problem!?

 

read the fq and aktivate the debugmode to check for errors (andf lok through this thread)

Share this post


Link to post
Share on other sites
I don't have these warnings ;)  

but try changing

 if ($HTTP_GET_VARS['ref'])  

 

to  

 if (isset($HTTP_GET_VARS['ref']))

 

were thes errors happen.

 

:D

Thank you! This works!

Because I am using Win2000 Server. I know that it is Linux server, there is no error!

Thank you!

Share this post


Link to post
Share on other sites

Yes, I have put everything and reviewed several times to it :roll:

 

 

 

Fatal error: Failed opening required 'includes/languages/affiliate_.php' (include_path='.:') in /usr/local/psa/home/vhosts/xlandia.com/httpdocs/tienda/admin/includes/affiliate_application_top.php on line 56

Did you put the include of affiliate_application_top.php at the end of application_top.php?

includes/languages/affiliate_.php

means that no language is defined (and so the rest of your admin shouldn't work either without the affiliate if it's proparly installed.

Share this post


Link to post
Share on other sites

Henri, you're a star. This is the best mod I have seen for a long time and certainly one that will come in handy.

 

Question though. I have made a few purchases and completed the transactions (like the product has been shipped) but nothing shows in the SALES figures. I see click-thru totals but no sales.

 

If I use the banner to point to catalog/default.php, the affiliate code is there until I click a link at which point is goes away. Is this still registering the purchase against the affiliate?

 

Should the affiliate ID stay in the address bar at all times?

 

Any ideas what could be causing this? Thanks.

 

Eddy

Share this post


Link to post
Share on other sites

@HaggisBoy Seems that you have forgotten the change the checkout_process

 

@redlo the variable $language is normally set in application_top.php and is needed by affiliate_application_top.php

 

You can set it manually at the strt of affiliate_application_top so it should work. But something is wrong in your installation!

Share this post


Link to post
Share on other sites

Yes But, it is not rare that it does so much in "admin" as in "catalog" and before everything worked correctly and already there are many changes , I do not believe that this is normal. Question: It is possible that he is because I have desabilitado ingles and German?

 

@HaggisBoy Seems that you have forgotten the change the checkout_process

 

@redlo the variable $language is normally set in application_top.php and is needed by affiliate_application_top.php

 

You can set it manually at the strt of affiliate_application_top so it should work. But something is wrong in your installation!

Share this post


Link to post
Share on other sites

Could be,

but:

application_top (about Line 263)

 

// include the language translations

require(DIR_WS_LANGUAGES . $language . '.php')

 

affiliate_application_top (Line 55)

// include the language translations

require(DIR_WS_LANGUAGES . 'affiliate_' . $language . '.php');

$languge is empty -> affiliate_.php which can't be found

 

If everything is installed correctly and your admin works without the affiliate (which i don't belive) than something must unset the variable $language after the requirel in line 263.

But this is not intended and not the affiliate.

Share this post


Link to post
Share on other sites

Hiya All!

 

I installed this mod with no probs atall!!

 

However, It is ver confusiong for the customer!

 

Is there any way for an existing customer to interigete their standard account with their affiliate account?

 

Then, when a customer loggs in, both accounts log in, and when customer logs out, both accounts log out... Just a thought... Well its what I want to achive...

 

Warren

Share this post


Link to post
Share on other sites

hummm... interesting... there is only one site that I shop at and am affiliate for, and I don't shop and check affilate stats at the same time. So this is something that I have not thought of. If they use the same information to sign up for an affiliate account they acually should be logged in as both at the same time I would think....


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Warning: copy(x:/xxxx/images/testbanner.jpg) [function.copy]: failed to create stream: Permission denied in x:xxxxadminaffiliate_banners.php on line 71

 

Warning: Cannot modify header information - headers already sent by (output started at x:xxxxadminaffiliate_banners.php:71) in x:xxxxadminincludesfunctionsgeneral.php on line 18

 

win2k IIS5.0 Isapi dll no cgi

 

any help is most welcome !

 

also getting and error on the sign up form when I hit the continue button

(affiliate_signup.php) this is the page i get the error on

 

error message as follows .

 

A run time error has occured

line 215

Error object expected

Share this post


Link to post
Share on other sites

<td width="100%" valign="top"><form name="affiliate_signup" action="https://www.overdog.com/affiliate_signup.php" method="post" onSubmit="return check_form();"><input type="hidden" name="action" value="process"><table border="0" width="100%" cellspacing="0" cellpadding="0">

Share this post


Link to post
Share on other sites
Is there any way for an existing customer to interigete their standard account with their affiliate account?

A way there is;)

You must add all fields which are availible for the affiliates to the customers table, then adjust the table name of the affiliates to the customer table (affiliate_application_top) and fix all errors which are coming.

Share this post


Link to post
Share on other sites
Warning: copy(x:/xxxx/images/testbanner.jpg) [function.copy]: failed to create stream: Permission denied in x:xxxxadminaffiliate_banners.php on line 71

 

Is the bannermanager of OSC working?

Then use instead of the copy() tep_copy_uploaded_file();

Please give feedback if this works.

also getting and error on the sign up form when I hit the continue button

(affiliate_signup.php) this is the page i get the error on

error message as follows .

 

A run time error has occured

line 215

Error object expected

 

remove the onSubmit="return check_form();"

there's no formchecking yet :oops:

Share this post


Link to post
Share on other sites

Yes the banner manger is working . Are saying for me to upload my banners using the banner manager ?

 

 

thanks your contrib looks very good just a few tweaks to get it going ..

Share this post


Link to post
Share on other sites
Yes the banner manger is working . Are saying for me to upload my banners using the banner manager ?

 

 

thanks your contrib looks very good just a few tweaks to get it going ..

No the bannermanger uses tep_copy_uploaded() file the affiliate copy()

adjust the function to tep_copy.. and than it should work. (If i've time i'll do it too for the cvs)

Share this post


Link to post
Share on other sites

I read an earlier post from this thread about the errors listed below running OSC on WIn2k IIS 5.1 SP3 and that's what I am running on so I tried to see if I would get that same error's and I did :( I tried the fix but no workie for me I think I may have done it worng so If anyone can post the code for the fix that would be very nice !

 

Find in affiliate_show_banner.php ( what goes here)

 

Replace with (what goes here )

 

Thanks !

 

 

Notice: Undefined index: ref in x:xxxxaffiliate_show_banner.php on line 91

 

Notice: Undefined index: affiliate_banner_id in x:xxxxxaffiliate_show_banner.php on line 93

 

Notice: Undefined index: affiliate_banner_id in x:xxxxaffiliate_show_banner.php on line 94

 

Notice: Undefined index: affiliate_pbanner_id in x:xxxxxaffiliate_show_banner.php on line 95

 

Notice: Undefined index: affiliate_pbanner_id in x:xxxxxaffiliate_show_banner.php on line 96

 

Notice: Undefined variable: banner_id in x:xxxxxaffiliate_show_banner.php on line 101

 

Notice: Undefined variable: prod_banner_id in x:xxxxxxaffiliate_show_banner.php on line 110

Share this post


Link to post
Share on other sites

One thing i have noticed is that the banners can chew up a lot of bandwith if youre not carefull.

 

I have an affiliate who is on a huge site which is getting hundreds of thousands of hits per month and since he joined my bandwith has jumped by 5Gb.

 

Im wonderign how the BW can get pulled back down...ie compression or similar.

 

Any suggestions?

Share this post


Link to post
Share on other sites

Notice: Use of undefined constant STORE_DB_TRANSACTIONS - assumed 'STORE_DB_TRANSACTIONS' in x:xxxxxincludesfunctionsdatabase.php on line 40

 

Notice: Use of undefined constant STORE_DB_TRANSACTIONS - assumed 'STORE_DB_TRANSACTIONS' in x:xxxxxincludesfunctionsdatabase.php on line 46

 

 

debug info

 

 

Check the pathes! (catalog/includes/configure.php)

absolute path to picture: D:/Overdog/images/testbanner.jpg

build with: DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG . DIR_WS_IMAGES . $banner

DIR_FS_DOCUMENT_ROOT x:/xxxx

DIR_WS_CATALOG /

DIR_WS_IMAGES images/

$banner testbanner.jpg

SQL-Query used: select affiliate_banners_image, affiliate_products_id from affiliate_banners where affiliate_banners_id = '15' and affiliate_status = 1

Try to find error:

SQL-Query: Got Result

Locating Pic x:/xxxx/images/testbanner.jpg

success

Share this post


Link to post
Share on other sites

@Overdog I don't now the combination of IIS with PHP but i would suggest to set the error handling less strict in php (ask your server provider). Notices shouldn't be displayed normaly. Only in developing enviroment (but which i seem noone does)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×