Jump to content
henri

OSC-Affiliate

Recommended Posts

Do you have an approximate date when you will be releasing a Affiliate Contribution at the MS1 level?

 

TY

Theo


Share your knowlege and you learn even more !

Share this post


Link to post
Share on other sites

Hi,

 

I have just installed oscommerce for the first time today. So I am just getting used to how everthing works.

 

I installed the osCommerce 2.2 Milestone 1 release and added oscAffiliate contribution (oscaffiliate_vs_0.4.zip)

 

I got an sql error (dupplicate key) checkout_process.php after one affiliate sales had been created.

 

I noticed $insert_id was not set to the orders_id before affiliate_checkout_process.php is included in checkout_process.php

 

I moved the include to line 100 after $insert_id is set

-------

$insert_id = tep_db_insert_id();

 

// Include OSC-AFFILIATE

require(DIR_WS_INCLUDES . 'affiliate_checkout_process.php');

-------

 

And now works great.

 

Thanks,

 

Adrian.

Share this post


Link to post
Share on other sites

anyone?

 

>i had the affiliate working great, but now when i create an account at >affiliate_signup.php i get redirected to another blank affiliate_signup.php >page. no message, and no account created. anyone have any ideas?

 

we were going to annouce the affiliate program today. :(

Share this post


Link to post
Share on other sites
hello all,

 

i had the affiliate working great, but now when i create an account at affiliate_signup.php i get redirected to another blank affiliate_signup.php page. no message, and no account created. anyone have any ideas?

 

thanks for the great module.

 

sorry that last one copied weird.

Share this post


Link to post
Share on other sites
Do you have an approximate date when you will be releasing a Affiliate Contribution at the MS1 level?  

 

TY  

Theo

 

Theo, you read my mind!

 

Henri, Steve? Any timeframe? Not pushing, just planning!

 

:)


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

It is not settiing the cookie. After clicking on a banner I can not see a cookie set by the affiliate script.

 

Where can I set this? I have already set the duratioin of the cookie.

Share this post


Link to post
Share on other sites
anyone?

>i had the affiliate working great, but now when i create an account at >affiliate_signup.php i get redirected to another blank affiliate_signup.php >page. no message, and no account created. anyone have any ideas?

(

Sorry not without seeing it...

Share this post


Link to post
Share on other sites
Henri, Steve? Any timeframe? Not pushing, just planning!

:)

If everything wents well and no issues come up within some hours (10-48)

Share this post


Link to post
Share on other sites

Yeehaaa! I can make all my udates at the same time. Line up those files and make changes :)


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
anyone?

>i had the affiliate working great, but now when i create an account at >affiliate_signup.php i get redirected to another blank affiliate_signup.php >page. no message, and no account created. anyone have any ideas?

 

i found this only happens when i am not logged in as a customer. do you have to create a customer account and log into it first?

 

you can check it out here. www.paintballgear.ca/catalog

Share this post


Link to post
Share on other sites

@envy2000 Normally it shouldn't happen. Perhaps it'S a problem with search engine save URL's

I test it here.

 

@Hunter I just tested the cookies. It worked.

Clicked a banner, closed the browser, reopened it went to the shop and made an order. -> registed for the affiliate

Share this post


Link to post
Share on other sites

@envy2000: Just tried it with search engine save URLs no problem happend.

 

to all: Thomas want's to look over the files and my changes one more time and than we will release it.

Everyone who can't wait-> cvs

Share this post


Link to post
Share on other sites
not sure what you mean? search engine save url's?

In the Admin you activate the search engine safe urls

This makes urls like: affiliate_signup.php/action/login/?sessid=....

 

Perhaps this makes the problem, but i don't know it for sure, without deeper investigation.

Share this post


Link to post
Share on other sites

@envy2000

Hmm, then i should need a closer look.

But for that i need access (via ftp, and perhaps phpmyadmin) to try some things...

-> henri@in-solution.de

 

Version 1.0 is shortly delayed until thomas finds the time to look after the latest changes (but i fixed some more bugs, today :) )

Share this post


Link to post
Share on other sites

Aw shucks, I was hoping this was "the announcement" :)

 

Waiting with bated breath...


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

hi henri (and steve),

 

sourceforge lists the following information

 

oscaffiliate oscaffiliate_vs_0.4.zip January 22, 2003

 

 

i've been meaning to install this ... but, always haven't gotten around to for want of waiting until a newer version is released ...

 

can you personally say if anytime in the near future (1-2week timeframe) if a version newer/higher than the above listed is going to be out?

 

thanks.

 

 

*** and can anyone comment on the CVS usage .. never used it before.

but, say if i installed the oscaffiliate and made some modifications to it, how easy/workable is it to use the CVS to update newer code (from henri/steve's?) directly into my own files?

Share this post


Link to post
Share on other sites

After a lot of work the new release is out:

https://sourceforge.net/projects/oscaffiliate/

http://www.oscommerce.com/community/contributions,158

 

VS 1.0 (for MS1)

 

- it's most likely 100% codingstyle compatible to Milestone 1

- should work with older Snashots

- a lot of bugfixes

- introduced taxes for the affiliate provisions

- changed the affiliate_signup Page (catalog-part) to match OSC-Standard

- added possibility to pay the affiliates by bank, check, paypal (setable in Admin)

- moved some variables to admin

- ... (and i forget to update the changelog file...)

 

There is an update.txt file in which (i hope all) the database changes are listed. To update execute them via phpmyadmin.

 

Special thx to Thomas Pl?nkers from the developer team who looked over the whole code.

 

If you like it, you find a way to DONATE :wink: at the end of the Readme's

 

P.S. :

 

Steve alternative Banner handling didn't find it's way to this release (had no time to look at it yet) and i'm still planning on rewriting the banner manager.

But he told me he will adjust the files for this release, so you can download it soon i think (there is no change in the database).

 

Have Fun

Henri

Share this post


Link to post
Share on other sites

And for those with older Snapshots:

When you use it, you now have a "breadcrumb-class" for newer contributions

Share this post


Link to post
Share on other sites

Yippee! Can't wait to see it :-) Paypal as a payment option is wonderful.

 

Debbie


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Quite awesome!!! Can't wait to try this out in it's entirety!

 

I just gotta say... for younger programs out there, it's good to donate something now, then donate BIGGER when your program grows. :) After all, something like groundbreak runs over $200, and outside services like Commission Junction run over $6000 in startup fees, then 20% off the top. So a solution pre-integrated with oSc is a fine, fine deal that should be compensated for by everyone using it somehow.

 

Now, I do have a question... When I go to the login -- affiliate_affiliate.php, it uses the secure URL. However, unlike login.php, this page displays the non-SSL version of images, so the browser blows warning.

 

How do we go about fixing this?

 

Otherwise, looks great so far! Again, can't wait to put this through it's paces! :)

Share this post


Link to post
Share on other sites
Now, I do have a question... When I go to the login -- affiliate_affiliate.php, it uses the secure URL. However, unlike login.php, this page displays the non-SSL version of images, so the browser blows warning.  

How do we go about fixing this?

:oops: my fault:

look at includes/affiliate_application_top (bottom), i forget a '!' (and SSL was only tested with new Snapshots)

 

// Compatibility to older Snapshots

 

// set the type of request (secure or not)

if (!isset($request_type)) $request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

Share this post


Link to post
Share on other sites

Great thing, I installed it and it worked very well. I have one small problem:

 

If I use build a link and use the ID for example "28" I get this in the output window:

 

-----------------------------------------------

<a href="https://ssl.kundenserver.de/ssl.klosterbrauerei.net/webshop/catalog/product_info.php?ref=1&products_id=28&affiliate_banner_id=1" target="_blank"><img src="https://ssl.kundenserver.de/ssl.klosterbrauerei.net/webshop/catalog/images/" border="0"></a>

-------------------------------------

 

The image is missing :-(

 

The image is on:

https://ssl.kundenserver.de/ssl.klosterbrau...images/bock.gif

 

 

config:

--------------------------------------------------

 

 

define('AFFILIATE_KIND_OF_BANNERS','1');

 

define('AFFILIATE_SHOW_BANNERS_DEBUG', 'true');

define('AFFILIATE_SHOW_BANNERS_DEFAULT_PIC', 'http://www.klosterbrauerei.com/webshop/catalog/images/banners/oscommerce.gif');

 

--------------------------------------------

 

The banner feature is working I can see a banner.

 

What is still wrong?

 

Best regards

 

Stefan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×