Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
zamir

PayPal Website Payments Pro (UK) Direct Payments probs

Recommended Posts

Please Help

 

 

I have installed the following contribution http://addons.oscommerce.com/info/5660 on my website www.esleds.com but get the following errors

 

Error: All payment information fields are required.

 

I have also done a fresh installation of oscommerce m2.2

 

 

 

Please help

Share this post


Link to post
Share on other sites
Error: All payment information fields are required.

try to fulfil all the fields


Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Share this post


Link to post
Share on other sites

Thanks for replying

 

 

Just looked at my server details

 

PHP version 4.4.7

MySQL version 4.1.22-standard

 

and yes ive tried filling in all the details no luck

Share this post


Link to post
Share on other sites

Please try v1.1 of the module and set the Card Acceptance Page parameter to Checkout Payment. This is a requirement for 2.2MS2 stores where only 2.2RC1/RC2 stores have the option of either Checkout Payment or Checkout Confirmation pages.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

i'm having the same trouble and have card acceptance page on "payment" and have filled in all fields (i'm using a maestro card to test which doesn't have a start date and i've filled in all fields..

 

edit1: i've just tried your code changes in your link above, and it's not giving me that error now :)

 

 

edit2: it still gives me that same error now, but it doesn't show it until i try and get past the checkout confirmation page.

Edited by kev@num

Share this post


Link to post
Share on other sites

Hi,

 

I’m also trying to use this payment method but I get a different error

“Error: A general problem has occurred with the transaction. Please try again.“

 

Can someone help please?

 

Many thanks

Share this post


Link to post
Share on other sites

I have the "All payment information fields are required." error but had an interesting one too, in the admin/modules/payment/PP UK Direct payment, the field for Checkout Payment was not working, looked at the script and it's not defined in the install - should it come from somewhere else ?? think I may have missed something.

 

to correct the problem I ran this SQL query.

 

INSERT INTO configuration( configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added )

VALUES (

'Card Acceptance Page parameter:', 'MODULE_PAYMENT_PAYPAL_UK_DIRECT_CARD_INPUT_PAGE', '', 'Card Acceptance Page parameter', '6', '20', now( )

);

 

Still have the "All payment information fields are required." error but at least the admin menu works now.

 

Will keep digging..

 

Paul

Edited by Courty

Share this post


Link to post
Share on other sites
have you set the "Card Acceptance Page" parameter to "Confirmation" in admin?

 

Thanks,

 

John.

 

Hi Guys,

 

I added the fix Harold mentioned for catalog/checkout_confirmation.php and now it looks better.

I set the Card Acceptance Page to Confirmation and now I get

"Error - Payment module configuration error. Please verify the login credentials." Checked the PayPal account and my Website Payments Pro account is "Application Pending" so I assume its working, just awaiting the account to be switched on.

 

I'll let you know what happens once the account is working.

 

For Info, I'm running a custom osCommerce 2.2-MS2 with all the patches as recommended by PayPal with the latest version of the UK Pro Payment Module files.

 

Thanks All,

 

Regards

 

Paul

Share this post


Link to post
Share on other sites
have you set the "Card Acceptance Page" parameter to "Confirmation" in admin?

 

Thanks,

 

John.

 

I don’t have the option in the admin panel to set "Card Acceptance Page" parameter to “Confirmation" ; I’m using the current oscommerce-2.2rc2a release. The card acceptance automatically appears on "Confirmation"!

 

 

*I have a feeling my problem may be linked to API. Can someone give me steps on how to install the API or where exactly to store it within the catalog please?

 

Many thanks

psg

Edited by psg

Share this post


Link to post
Share on other sites
I don’t have the option in the admin panel to set "Card Acceptance Page" parameter to “Confirmation" ; I’m using the current oscommerce-2.2rc2a release. The card acceptance automatically appears on "Confirmation"!

 

 

*I have a feeling my problem may be linked to API. Can someone give me steps on how to install the API or where exactly to store it within the catalog please?

 

Many thanks

psg

 

What version Website Payments Pro UK Module are you running?

 

Check here for latest version http://addons.oscommerce.com/service/paypal

 

John.

Share this post


Link to post
Share on other sites
What version Website Payments Pro UK Module are you running?

 

Check here for latest version http://addons.oscommerce.com/service/paypal

 

John.

 

Thanks John,

 

I'm now using the latest version from the above link and I have the option to change "Card Acceptance Page" parameters. :)

 

 

I downloaded the API certificate file: cert_key_pem.txt from PayPal.

 

Where do I upload (which directory) the "cert_key_pem.txt” ? I couldn't find anything in the contribution documentation!

 

Many thanks,

 

psg

Edited by psg

Share this post


Link to post
Share on other sites

PayPal_JohnF / Guys,

 

I'm sure I'm not being daft but I'm still having a few issues..

 

We got our PP-Pro account sorted and i signed in and went to the pro section, I went to the 'Request API Credentials' section and set up a user and then I went to the Grant API Permission and set the permissions. this is where it started going wrong :rolleyes:

 

When I went to the shop/admin and looked to enter the details, I appear to be short on fields to get the info in. the Credentials section gave me a username, password and a signature but the PayPal Direct Payment UK module only has spaces for Username and Password, what am I supposed to do with the signature ?

 

In the US module you can load a API cert, should I be using this module even though I'm a UK shop with a UK PP account ??

 

I have tried the new username and pasword, the old username and password and both give the same error Error: Payment module configuration error. Please verify the login credentials.

 

Has anyone got a step by step idiots guide to setting up PP Pro direct UK and Express UK or could anyone give me a run down of what goes in which field ?

 

Many Thanks

 

Paul

Share this post


Link to post
Share on other sites

Hi Guys,

 

Got it working.. :)

 

You need to use the Your unique Merchant Login from your Pro account acceptance mail as the Vendor AND User entries and the password is the Second password you used when upgrading from a normal paypal account to a Pro account (not your normal PayPal password).

 

In conclusion, use the 1.1 version of the Direct Payment module, do the update mentioned above to the code if your version of OSC needs it and follow the above for username and password...

 

 

Many Thanks for a great contrib...

 

Regards

 

Paul

Share this post


Link to post
Share on other sites
Guest

When I try to install the PP Direct mod, I click on the Install button in admin and it does NOTHING.

It won't work. All other modules install fine.

 

 

Therefore I now have the PP Express module, but wjen I test it, I get:

 

"Error: Payment module configuration error. Please verify the login credentials"

 

 

Can someone PLEEEEEEEEEEEEEEEEEEASE tell me what I'm supposed to put in usename, password and vendor. :(

Share this post


Link to post
Share on other sites

Hi

 

Can someone please advise on how to send Paypal pro the customer billing address?

 

I am using Version 1.0 of paypal pro uk direct that came with oscommerce rs2 1 and then value of the order gets sent to paypal but not the billing address.

 

Which module actually send the billing address?

 

OR

 

Do I need to code this functionality myself?

 

Thnaks

 

B


Whats the point of a signature?

Share this post


Link to post
Share on other sites
Please Help

 

 

I have installed the following contribution http://addons.oscommerce.com/info/5660 on my website www.esleds.com but get the following errors

 

Error: All payment information fields are required.

 

I have also done a fresh installation of oscommerce m2.2

 

 

 

Please help

 

Hi, i have the same issue.. when i use Card Acceptance Page on Confirmation it gives out the error above.. and when i put on Payment it does nothing.. it bounce back to the page to fill out the card details again without any error..

order is not processed on paypal or osc.

 

i tried to establish API on my paypal account.. but there is no option of API REQUEST under account information.

please i need help asap

thanks alot

bye


outside links are not allowed in signatures

Share this post


Link to post
Share on other sites

What should be used in the vendor field:

 

- your email

or

- API Username: xxx_api1.yyy.com

 

?

 

Can anyone make a screenshot of correct settings of the paypal module?

Edited by Pay

Share this post


Link to post
Share on other sites

Hi all,

 

Has anyone found a solutions to these errors? I've read every post I can find but am still getting the "Error: All payment information fields are required." error with the direct module and the "Error: Payment module configuration error. Please verify the login credentials." with the express module. I'm at a loss at what to do next.

 

The step-by-step guide on the paypal website is so straightforward I can't see how I can possibly have the wrong login details so what's causing the error?

 

Any help would be greatly appreciated.

 

Thanks,

Helen

Share this post


Link to post
Share on other sites

Hi Guys,

 

Got it working.. :)

 

You need to use the Your unique Merchant Login from your Pro account acceptance mail as the Vendor AND User entries and the password is the Second password you used when upgrading from a normal paypal account to a Pro account (not your normal PayPal password).

 

In conclusion, use the 1.1 version of the Direct Payment module, do the update mentioned above to the code if your version of OSC needs it and follow the above for username and password...

 

 

Many Thanks for a great contrib...

 

Regards

 

Paul

 

 

Hi there, I have the same issue but still cant figure out what login details to use,kindly provide an clear straight forward example of where to get the details to fill in, I really would appreciate some help.

Thanks

Share this post


Link to post
Share on other sites

Too long I have struggled with this issue, then finally found it. I felt so stupid, that a simple thing caused me 2 full-days of suffering.

So, when I took a look at the source code of checkout_confirmation.php, I found out that The form (which sends params to paypal) is actually empty! No fields in it. The I digged-in the code, I found (Around line 372), that Form is being opened AND closed right away, after populating form-fields. SO I cut the first part of the form (which creates the form. the second part closes the form) and placed it before the form - fields (around line No 305). That's it! It works fine for me. Here is the first part of the code, which I moved:

<START COPY>

 

 

<?php

if (isset($$payment->form_action_url)) {

$form_action_url = $$payment->form_action_url;

} else {

$form_action_url = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL');

}

 

echo tep_draw_form('checkout_confirmation', $form_action_url, 'post');

?>

 

 

<END COPY>

If you need more help, contact me through this forum or by email; ironheat at gmail dot com

 

Good Luck

Edited by ironheat

Share this post


Link to post
Share on other sites

Ironheat,

 

1 post and you’re a genius! I have been searching for days to try and figure this out.

 

Thanks,

 

Scott

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×