Jump to content
Sign in to follow this  
luckyno

[Contribution] All In One FCK WYSIWYG Editor

Recommended Posts

mmmm... WHERE DO YOU HAVE YOUR ADMIN DIRECTORY????

 

Go in you admin directory ---> tools---> Backups and you will see it. It is very simple!

 

You will see your absolute path, then you remove directories until your root, and you add /userfiles/ than you put it in the config file of FCK.

My Admin Directory is directly below my catalog directory, I think this is the standard setup for OsCommerce.

Share this post


Link to post
Share on other sites

"and

 

catalog/userfiles/

 

2. Change read and write permissions to 777 for:

 

catalog/userfiles/

catalog/userfiles/file

catalog/userfiles/media

catalog/userfiles/image

catalog/userfiles/flash"

 

 

I don't have a catalog/userfiles/ already installed in oscommerce OR nor is the folder in the zip file for this contribution..... can someone tell me where it is??

Share this post


Link to post
Share on other sites
"and

 

catalog/userfiles/

 

2. Change read and write permissions to 777 for:

 

catalog/userfiles/

catalog/userfiles/file

catalog/userfiles/media

catalog/userfiles/image

catalog/userfiles/flash"

I don't have a catalog/userfiles/ already installed in oscommerce OR nor is the folder in the zip file for this contribution..... can someone tell me where it is??

 

The files are all in the zip file, you simply upload them.

 

Let me know if you get it working, I still can't save anything.

Share this post


Link to post
Share on other sites
can some one confirm it all works ? reading mixed comments here.

 

also what is information form?

 

For me it works perfectly.

 

Information_form is a file for Information Pages Unlimited Contribution.


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites
Hi There,

 

thanks for the cont...

 

Does it work with v2.2 rc 2 ?

 

TIA - Dave Porter

 

I haven't tried with RC2. I really don't know.


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites
Hi. Is this mod compatible with newsletter_product ?

 

Thanks ...

 

I haven't tryed it until now. Perhaps during next 2 weeks. If you try it, let me know.


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites

Hi everyone,

 

Just advising that I have just installed this with no problems at all with 2.2 RC1 ( so I'm guessing RC2 will be fine ! )

 

Took around 20 minutes....

 

Thanks for the contribution...

 

Dave Porter

Share this post


Link to post
Share on other sites
Hi everyone,

 

Just advising that I have just installed this with no problems at all with 2.2 RC1 ( so I'm guessing RC2 will be fine ! )

 

Took around 20 minutes....

 

Thanks for the contribution...

 

Dave Porter

 

thank you for yuor message! I'm happy to see that it works as said :)

 

Another user tested it with RC2 and he said it worked.

 

You can now find the contribution here: http://addons.oscommerce.com/info/5679

 

I removed some languages from the package to make it smaller, you can easily find them on: fckeditor.net


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites

Hi

 

I tested it (together with newsletter_product)

 

But I got an error when I'm trying to send an email :

 

Fatal error: Call to undefined method: newsletter_products->send_fckeditor() in /home/httpd/vhosts/www.mt-performances.com/web/catalog/admin/newsletters.php on line 481

 

Has anybody an idea ?

Share this post


Link to post
Share on other sites

Hi there.

This contrib really looks like what I am looking for. However, after numerous attempts I almost give up. I keep getting this error:

Warning: require(fckeditor/fckeditor.php) [<function.require>]: failed to open stream: No such file or directory 
in /[snip]/includes/functions/html_output.php on line 12

Fatal error: require() [<function.require>]: Failed opening required 'fckeditor/fckeditor.php' (include_path='.:/usr/share/php:/usr/share/pear') 
in [snip]/includes/functions/html_output.php on line 12

 

It's the line 12 in html_output.php as you can see. According to contrib you should add

require(''fckeditor/fckeditor.php'');

 

And as it does not work like that, I have tried adding /admin/, I have removed one ' , I have cried out loud whilst doing and several other things.

 

Can someone just tell me the correct line?

 

Thanks


Green as green can be - but the grass is always greener somewhere.

Share this post


Link to post
Share on other sites
Hi there.

This contrib really looks like what I am looking for. However, after numerous attempts I almost give up. I keep getting this error:

Warning: require(fckeditor/fckeditor.php) [<function.require>]: failed to open stream: No such file or directory 
in /[snip]/includes/functions/html_output.php on line 12

Fatal error: require() [<function.require>]: Failed opening required 'fckeditor/fckeditor.php' (include_path='.:/usr/share/php:/usr/share/pear') 
in [snip]/includes/functions/html_output.php on line 12

 

It's the line 12 in html_output.php as you can see. According to contrib you should add

require(''fckeditor/fckeditor.php'');

 

And as it does not work like that, I have tried adding /admin/, I have removed one ' , I have cried out loud whilst doing and several other things.

 

Can someone just tell me the correct line?

 

Thanks

 

My html_output file starts like this:

 

<?php

/*

$Id: html_output.php,v 1.29 2003/06/25 20:32:44 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

////

require("fckeditor/fckeditor.php");

 

You can try to re-upload the fckeditor.php file too.


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites
My html_output file starts like this:

 

<?php

/*

$Id: html_output.php,v 1.29 2003/06/25 20:32:44 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

////

require("fckeditor/fckeditor.php");

 

You can try to re-upload the fckeditor.php file too.

 

Hi there...

I think you should modify the file ./admin/includes/functions/html_output.php

and NOT

./includes/functions/html_output.php

 

This last was one doesn't need the "require FCKeditor" !

Edited by actarus1011

Share this post


Link to post
Share on other sites

Thanks - it works.

I really do not know what I did. However, the path was correct: I did edit the correct html_output.php file - so that was not it.

All I did, was copy the text require(''... etc again, and suddenly it worked.

 

Probably the server just had to sleep on it.


Green as green can be - but the grass is always greener somewhere.

Share this post


Link to post
Share on other sites
Thanks - it works.

I really do not know what I did. However, the path was correct: I did edit the correct html_output.php file - so that was not it.

All I did, was copy the text require(''... etc again, and suddenly it worked.

 

Probably the server just had to sleep on it.

 

perfect! I'm happy to hear this. I corrected install instructions 3-4 times from other contributions and now i start seeing that 20-30 people are using my contrib. I'm happy.


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites

Oh, yes, it works. I will test the newsletter-part also...

 

Now, since this is sort of your baby, maybe you could tell me in plain English what I should put in the

$Config['UserFilesPath'] = '/userfiles/';
and a few lines down:
$Config['UserFilesAbsolutePath'] = '/YOUR/ABSOLUTE/PATH/OF/THE/USERFILES/DIRECTORY/';

 

I just dont get it right. (And I see that someone else had the same problem, but the answer there did not help me).

I have a directory structure where 'admin' is at same level as 'userfiles'. And the "absolute-path" does not ring any bells. All over OSC and in contribs people keep refering to 'catalog' which I havent got, and it always confuses me. Is my absolute path in this case not just '/userfiles/' - or do I need any kind of root or http or ./ in front of that?


Green as green can be - but the grass is always greener somewhere.

Share this post


Link to post
Share on other sites
Oh, yes, it works. I will test the newsletter-part also...

 

Now, since this is sort of your baby, maybe you could tell me in plain English what I should put in the

$Config['UserFilesPath'] = '/userfiles/';
and a few lines down:
$Config['UserFilesAbsolutePath'] = '/YOUR/ABSOLUTE/PATH/OF/THE/USERFILES/DIRECTORY/';

 

I just dont get it right. (And I see that someone else had the same problem, but the answer there did not help me).

I have a directory structure where 'admin' is at same level as 'userfiles'. And the "absolute-path" does not ring any bells. All over OSC and in contribs people keep refering to 'catalog' which I havent got, and it always confuses me. Is my absolute path in this case not just '/userfiles/' - or do I need any kind of root or http or ./ in front of that?

 

you can check your absolute path in admin, under http://www.yoursite.com/catalog/admin/back...ected_box=tools

 

In this page you can find the absolute path of your backups directory, something like:

 

/var/www/vhosts/yoursite.com/httpdocs/catalog/admin/backups/

 

or

 

/var/www/vhosts/yoursite.com/httpdocs/admin/backups/

 

just copy it and change the final directory to be the userfiles directory.... something like:

 

/var/www/vhosts/yoursite.com/httpdocs/userfiles/


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites

I have a problem after installing this contribution. When editing products in admin I just get a blank area where the description should be.

 

When looking at the html code (view source in browser) I see this:

 

   <iframe id="products_description[4]___Frame" src="fckeditor/editor/fckeditor.html?InstanceName=products_description[4]&Toolbar=Default" width="600" height="300" frameborder="0" scrolling="no"></iframe>

 

As you can see, the codes are converted like the &amp in the example above. Anybode now why?

 

Everything in the product description itself is also converted.

Share this post


Link to post
Share on other sites
Oh, yes, it works. I will test the newsletter-part also...

 

Now, since this is sort of your baby, maybe you could tell me in plain English what I should put in the

$Config['UserFilesPath'] = '/userfiles/';
and a few lines down:
$Config['UserFilesAbsolutePath'] = '/YOUR/ABSOLUTE/PATH/OF/THE/USERFILES/DIRECTORY/';

 

I just dont get it right. (And I see that someone else had the same problem, but the answer there did not help me).

I have a directory structure where 'admin' is at same level as 'userfiles'. And the "absolute-path" does not ring any bells. All over OSC and in contribs people keep refering to 'catalog' which I havent got, and it always confuses me. Is my absolute path in this case not just '/userfiles/' - or do I need any kind of root or http or ./ in front of that?

 

Did you get this working, I still can't get it to work. Out of interest do you also have HTC installed? I know others have got it to work, I must be doing something wrong.

 

Thanks

Share this post


Link to post
Share on other sites
Did you get this working, I still can't get it to work. Out of interest do you also have HTC installed? I know others have got it to work, I must be doing something wrong.

 

Thanks

 

I finally got this working - it was a server problem, so anyone else that hits th problems I did check with your hosting company!!!

 

It was worth persevering as It's a great contribution!

 

 

One question. I want to add some more pages, such as a home page which can use this editor to manage content. Can I do that?

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites

This is still not working for me. I followed everything correctly. The box just does not appear. Here is the page source in firefox

 

td class="main" valign="top">Products Description:</td>

<td><table border="0" cellspacing="0" cellpadding="0">

<tr>

 

<td class="main" valign="top"><img src="/includes/languages/english/images/icon.gif" border="0" alt="English" title=" English "> </td>

<td class="main"><div><input type="hidden" id="products_description[1]" name="products_description[1]" value="Pr

 

 

that is what i see when i look at categories.php where is input type hidden coming from?


********************************************************

Deep Link Bidding PR 4 Directory

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×