Jump to content
Sign in to follow this  
notubes_pete

UPS XML

Recommended Posts

i just got errors reading

This module supports only xpci version 1.0001 of the UPS Rates Interface. Please contact the webmaster for additional assistance.

If you prefer to use ups as your shipping method, please contact NoTubes.com via

 

i have not changed anything on my end. Did ups change something for the new year?

Share this post


Link to post
Share on other sites
i just got errors reading

This module supports only xpci version 1.0001 of the UPS Rates Interface. Please contact the webmaster for additional assistance.

If you prefer to use ups as your shipping method, please contact NoTubes.com via

 

i have not changed anything on my end. Did ups change something for the new year?

The contribution thread is somewhere else....

 

The time and transit uses 1.0002 but the newer modules don't look for the version because the differences are very minor. Rates and Services on the test server still uses 1.0001 but the production server is down and triggers this xpci version error. The actual message was:

<HTML>
<HEAD>
<TITLE>Weblogic Bridge Message
</TITLE>
</HEAD>
<BODY>
<H2>Failure of server APACHE bridge:</H2><P>
<hr>No backend server available for connection: timed out after 10 seconds or idempotent set to OFF.
<hr><BR><B>Build date/time:</B> <I>Dec  4 2006 15:11:28</I>
<P><HR><B>Change Number:</B> <I>871803</I>
</BODY>
</HTML>

Nothing we can do really.

Share this post


Link to post
Share on other sites
i just got errors reading

This module supports only xpci version 1.0001 of the UPS Rates Interface. Please contact the webmaster for additional assistance.

If you prefer to use ups as your shipping method, please contact NoTubes.com via

 

i have not changed anything on my end. Did ups change something for the new year?

 

I have the same problem. Not getting any prices for shipping UPS. Nothing was changed at my end. Hope there is someone who can HELP.

Thanks


Production:
osCommerce V. 2.3.4BS
VPS Box

Share this post


Link to post
Share on other sites
Hope there is someone who can HELP.

Hello..... it's a problem on the UPS side. Call them or use the test server (don't know how accurate their rates are).

Share this post


Link to post
Share on other sites

I'm running version 1.2.4 of the module, and I found that just changing a variable in catalog/includes/modules/shipping/upsxml.php resolved my problem.

 

It's line 75 in my file, and reads as follows:

 

$this->xpci_version = '1.0001';

 

Changing that to this:

 

$this->xpci_version = '1.0002';

 

solved the problem for me. I can't claim that this will work for everyone or that it is the proper way to address this issue, but it got us back up and running and able to take orders. If anyone else understands the issue better, I'd like to hear about it, but hopefully this change can be a band-aid for those whose sites aren't functioning right now.

Share this post


Link to post
Share on other sites

It appears to have fixed itself about an hour ago for me. Did not make any modificatons on my end.


Production:
osCommerce V. 2.3.4BS
VPS Box

Share this post


Link to post
Share on other sites

FYI - got this email from UPS since I was bitching about negotiated rates not working:

 

[ ... ]UPS had a major enterprise release

over the holiday weekend which affected the availability of the ABR

component. We believe the problems you encountered this weekend are due

to the downtime experienced by ABR. Additionally, we have also

experienced some intermittent issues concerning ABR today. This is

currently being investigated. [ ... ]


Even at a Mensa convention someone is the dumbest person in the room.

Share this post


Link to post
Share on other sites

I didn't check how long this post has been dead, -but I cannot seem to shake this problem for 4 days of work. i've poured through every single page of the articles, i've tried all the fixes, i've triple checked my installation procedure, using 1.3.5, and osC rc2a. and i did make some modifications to some of the files, which i've restored.

 

i simply cannot get rid of this "This module supports only xpci version 1.0001 of the UPS Rates Interface. Please contact the webmaster for additional assistance.

If you prefer to use UPS as your shipping method, please contact ____________ via Email."

 

it is nuts, i can see many people writing about other issues, but it does not matter what i do, every single time i enter the checkout, this error occurs.

 

any ideas? any theories?? i'll take anything.

 

thanks in advance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×