Jump to content
Latest News: (loading..)
Sign in to follow this  
GLWalker

ASN Forum for osCommerce

Recommended Posts

ASN Forum for osCommerce is so far the best "simple" forum addon I have found. Many thanks to the MasterGiGi and all others who have worked on this mod . Hopefully we can advance this script little by little, as it looks to be a very promising piece of code. As time permits I shall be cleaning it up to better match osC code and style.

My first step has been to create a customer moderator addon.

The contribution may be found here:

http://addons.oscommerce.com/info/4832


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

Hi,

 

I know that the code is not perfect but this was only fast mod to fit original ASN Forum for osc needs.

Recently I've worked a little bit on the script and made some improvements:

+ added forum categories

+ clean up of admin scripts (replacement of the mysql_fetch_row - use of this function isn't comfortable >_< )

+ some register_globals fixes (now it should work with registers_globals off)

+ ultimate seo integration

To do:

+ there are plenty places wher sql queries should be reduced

+ admin for forum categories

 

I'll relase new version very soon... Stay tuned

Share this post


Link to post
Share on other sites

A few things Ive done that may help others out.

Disable having to login to the forum admin when your already in your admin:

Open admin/asnf_admin.php

find and comment out on line 28:

require_once("asnf_auth.php");

You can then delete asnf_auth.php

Thats it!

In your catalog files find all instances of asnf_header.php and asnf_footer.php,

Comment them out and then delete the asnf_header.php and asnf_footer.php files.

 

Thats it for now. More to come..........


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

Hello :'( wanted to ask something about this forum because if not written anything in the mail gives me the sieguiente error:

 

Fatal error: Call to a member function on a non-object in C: \ Program Files \ Apache Group \ Apache2 \ htdocs \ jos \ includes \ header.php on line 51

 

Greetings and good contribution this :-)

Share this post


Link to post
Share on other sites

I have tried to remove mail but does not work either by removing the function

function check_email($email) {

if(!ereg("([[:alnum:]\.\-]+)(\@[[:alnum:]\.\-]+\.+)", $email)) {

error("Invalid email address!");

}

}

 

in catalog/includes/asnf_lib.php

 

I am going crazy please help :'( :'(

Share this post


Link to post
Share on other sites

I also installed asnf_v7 which includes a search engine, but it does have a problem if a user has loaded the shopping cart and then direje forum and use the search button loses section was empty cart and but when I use the arrow back Browser retrieves the cart ...

Not that happens maybe this evil the links or not if they can give me an idea ... Very useful to have a search in the forum but if we can not solve what losing sections I am with the previous version the only problem is that it gives me the error mistake to explain above ...

Share this post


Link to post
Share on other sites
I also installed asnf_v7 which includes a search engine, but it does have a problem if a user has loaded the shopping cart and then direje forum and use the search button loses section was empty cart and but when I use the arrow back Browser retrieves the cart ...

Not that happens maybe this evil the links or not if they can give me an idea ... Very useful to have a search in the forum but if we can not solve what losing sections I am with the previous version the only problem is that it gives me the error mistake to explain above ...

 

 

I just checked on mine, and did not have a problem with loosing the cart. I added product to the cart, then went to the forum, did a forum search, went to the search results, then even did a new search from the results page. The cart never lost its content. What do you have your admin/configuration/sessions set as? I keep everything false except for prevent spider sessions.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
Hello :'( wanted to ask something about this forum because if not written anything in the mail gives me the sieguiente error:

 

Fatal error: Call to a member function on a non-object in C: \ Program Files \ Apache Group \ Apache2 \ htdocs \ jos \ includes \ header.php on line 51

 

Greetings and good contribution this :-)

 

 

That seems to happen when you try to add a reply or post without putting in your email.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
I have tried to remove mail but does not work either by removing the function

function check_email($email) {

if(!ereg("([[:alnum:]\.\-]+)(\@[[:alnum:]\.\-]+\.+)", $email)) {

error("Invalid email address!");

}

}

 

in catalog/includes/asnf_lib.php

 

I am going crazy please help :'( :'(

 

I havent been able to look into it yet, but you would have to remove the code calling to the function in the asnf_viewtopic.php, asnf_index.php, asnf_newtopic.php. Otherwise it will just look for the function.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
Hi,

 

I know that the code is not perfect but this was only fast mod to fit original ASN Forum for osc needs.

Recently I've worked a little bit on the script and made some improvements:

+ added forum categories

+ clean up of admin scripts (replacement of the mysql_fetch_row - use of this function isn't comfortable >_< )

+ some register_globals fixes (now it should work with registers_globals off)

+ ultimate seo integration

To do:

+ there are plenty places wher sql queries should be reduced

+ admin for forum categories

 

I'll relase new version very soon... Stay tuned

 

 

Great News. I had recently rearranged the code that looks in the database in the catalog files, and changed all the style definitions to use standard osc stylesheet. But then somehow it hit my delete folder and is now gone.

I'll will wait for your next version and then redo the styles to match.

Excellent work so far.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

Leaflet with a way to validate the form of mail, my idea is that if the user does not put him email apareca an error message like this "field of mail must contain an e-mail!" Or something so, it would be good to find a way to validate all fields ... To prevent another this

 

wanted to ask something about this forum because if not written anything in the mail gives me the sieguiente error:

 

Fatal error: Call to a member function on a non-object in C: \ Program Files \ Apache Group \ Apache2 \ htdocs \ jos \ includes \ header.php on line 51

:'( :'(

 

The configuration is my admin

 

Session Directory /tmp

Force Cookie Use False

Check SSL Session ID False

Check User Agent False

Check IP Address False

Prevent Spider Sessions True

Recreate Session False

 

 

I ralizando the testing forum localhost, however continues to lose the contents of the cart whenever a search in the forum, I do not understand that evil, it is as if the link button estubiera look bad but not with the solution ... I :'(

Share this post


Link to post
Share on other sites

Hi,

Hope someone can help me,

 

on my form_index ,I get the message "1146 - Table 'db.table_asnforum_post' doesn't exist

 

SELECT post_id FROM TABLE_ASNFORUM_POST

 

[TEP STOP]"

 

I did check my database, and ,asnforum_post,asnforum_postext,asnforum_smile,asnforum_topic,

is in the db with the tables, in admin side, the data seems o.k, when i log in I do see the John, my first topic

 

Got any ideas for me.

Thanks

Share this post


Link to post
Share on other sites
ASN Forum for osCommerce is so far the best "simple" forum addon I have found. Many thanks to the MasterGiGi and all others who have worked on this mod . Hopefully we can advance this script little by little, as it looks to be a very promising piece of code. As time permits I shall be cleaning it up to better match osC code and style.

My first step has been to create a customer moderator addon.

The contribution may be found here:

http://addons.oscommerce.com/info/4832

 

 

I get this error when I try to post a reply

Fatal error: Call to a member function on a non-object in /path_to/includes/header.php on line 51

 

 

Can any one help?

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites
I get this error when I try to post a reply

Fatal error: Call to a member function on a non-object in /path_to/includes/header.php on line 51

Can any one help?

Did you add your email into the form feild?

Edited by Jan Zonjee

Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
Did you add your email into the form feild?

 

 

definitely looks like a bad path, the href is not going to the right URL

Share this post


Link to post
Share on other sites

I am in my shop and have added some topics I go to view them and I get this

error

Forum	  Forum
1054 - Unknown column '707_781_782' in 'where clause'

SELECT * FROM asnforum_topic WHERE topic_id=707_781_782

[TEP STOP]

 

and the topic id in the database is 192

193

194

 

I don't know where to looks for this error

thank you in advance

noppie


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

Great contribution!

 

Everything works fine, BUT it's not possible for me to click on a topic to read the rest of the thread in the forum. Works fine in the admin section...

 

Any Ideas?

Share this post


Link to post
Share on other sites

HELP ME Please,

 

Hello, I m in big trouble to add forum to my oscommerce site.

I found AsnForum, and dowloaded last version (v7)from system but, there is no install of this forum. And I tried to follow what is wrtten in "readme.txt doc. I put all doc of forum under my www but, it doesnt work. When I write the path, it shows me this error:

 

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in C:\Program Files\EasyPHP 2.0b1\www\cityguideOS\osc\forum\asnf_index.php on line 25

 

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.;C:/Program Files/EasyPHP 2.0b1\php5\pear\') in C:\Program Files\EasyPHP 2.0b1\www\cityguideOS\osc\forum\asnf_index.php on line 25

 

Can anyone describe what is the mistake? or directly can anyone describe how you put the forum to your web site. I m very needy. I m waiting for your helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×