Jump to content
Sign in to follow this  
djruffle

oscThumb blank page problem think its html_output.php

Recommended Posts

Hi

 

If anyone could help with this it would be great.

 

I have installed oscThumb and then when I went to my catalog root with a blank page.

 

It doesn't matter if I turn the contribution on or off it still shows blank.

 

As I was i restoring the files from the backup i noticed it started to work again when i copied html_output.php back.

 

So i am guessing that it has something to do with the tep_image function. the code is below:

 

Is there something I am missing here? Can anyone shed any light on why it might be giving me a blank page?

 

I cant seem to see anything wrong with the new function.

 

 

////
// The HTML image wrapper function
 function tep_image_original($src, $alt = '', $width = '', $height = '', $parameters = '') {
if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) {
  return false;
}


// START oscThumb
// If you want to call the original function, you can call tep_image_original or call this one with $original=true.
function tep_image($src, $alt = '', $width = '', $height = '', $params = '', $original = false, $thumbnail_type = 0) {
 global $oscthumb;

 // We are asked to return the result of the original function
 if ($original || $oscthumb->enabled==false) {
return tep_image_original ($src, $alt, $width, $height, $params);
 }

$oscthumb->set_type ($src, $width, $height, $thumbnail_type); // Detect the type of image we are currently processing
if ($oscthumb->set_size ($src, $width, $height)==false) return false; // Choose the displayed width and height of the image, and if display something
$image = $oscthumb->process($src); // Returns the beginning of the image tag, like <img src="oscthumb.php?src=... or <img src="images/logo.gif"

 // Add remaining image parameters if they exist
 if ($width) { 
$image .= ' w="' . tep_output_string($width) . '"'; 
 } 

 if ($height) { 
$image .= ' h="' . tep_output_string($height) . '"'; 
 }	 

 if (tep_not_null($params)) $image .= ' ' . $params;

 $image .= ' border="0" alt="' . tep_output_string($alt) . '"';

 if (tep_not_null($alt)) {
$image .= ' title="' . tep_output_string($alt) . '"';
 }


 $image .= '>';   
 return $image; 
}
// END oscThumb

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×