Jump to content
Sign in to follow this  
sharmainfoway

Paging in Ultimate URL doesnt work

Recommended Posts

Hi

I have integrated store with oscommerce and Ultimate SEO contribution by chemo.

I have used the latest version of SEO contribution.

Everything works perfect except the paging.

If th product page has more products, it shows page links at the bottom

see here http://www.theramedic.co.uk/rise-recline-chairs-c-29.html

Try to click on Page links or next page link at the bottom, it just refreshes the page but never goes to other page.

Please help.


Thanks

Mahendra Sharma

Sharma Infoway

Share this post


Link to post
Share on other sites

The solution is in this topic: http://forums.oscommerce.com/index.php?sho...999&st=1480

 

The file is... uhm... seo.class.php ?

 

Is necessary to modify only one line: "return $current_page" to "return $return"

 

This is the explanation:

 

Well I don't know much about php but when I changed line 1073 from return current page to return return the same as the other lines below everything seems to be working.Maybe somebody knows if this will mess something else up.
line : 1064 to1073

function requested_page() 
{ 
$protocol = ((int) $_SERVER['SERVER_PORT'] === 443)? 'https://' : 'http://'; 
$current_page = $protocol . $_SERVER['HTTP_HOST'] . ((!empty($_SERVER['REQUEST_URI']))? $_SERVER['REQUEST_URI'] : ''); 
$current_page = substr($current_page, strlen(HTTP_SERVER));
if (($pos = strpos($current_page, "?osCsid")) !== FALSE)
$current_page = substr($current_page, 0, $pos).'<br>'; 
if ($current_page[0] == "/")
$current_page = substr($current_page, 1); 

Changed commented out // return $current_page; 

Now 
return $return;

 

Enjoy.

Share this post


Link to post
Share on other sites
The solution is in this topic: http://forums.oscommerce.com/index.php?sho...999&st=1480

 

The file is... uhm... seo.class.php ?

 

Is necessary to modify only one line: "return $current_page" to "return $return"

 

This is the explanation:

 

Well I don't know much about php but when I changed line 1073 from return current page to return return the same as the other lines below everything seems to be working.Maybe somebody knows if this will mess something else up.
line : 1064 to1073

function requested_page() 
{ 
$protocol = ((int) $_SERVER['SERVER_PORT'] === 443)? 'https://' : 'http://'; 
$current_page = $protocol . $_SERVER['HTTP_HOST'] . ((!empty($_SERVER['REQUEST_URI']))? $_SERVER['REQUEST_URI'] : ''); 
$current_page = substr($current_page, strlen(HTTP_SERVER));
if (($pos = strpos($current_page, "?osCsid")) !== FALSE)
$current_page = substr($current_page, 0, $pos).'<br>'; 
if ($current_page[0] == "/")
$current_page = substr($current_page, 1); 

Changed commented out // return $current_page; 

Now 
return $return;

 

Enjoy.

 

 

Thanks buddy, the solution rocks. Thanks a lot.


Thanks

Mahendra Sharma

Sharma Infoway

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×