Jump to content
Sign in to follow this  
adgrafics

[Contribution] FAQ system v.1.0

Recommended Posts

FAQ system v.1.0

11/29/2002 - zz_FAQ_SYSTEM v.1.0.zip (2.2-CVS) Author: adgrafics

http://www.oscommerce.com/downloads.php/co...ntributions,740

 

FAQ system can

1.Multilanguage automatically

2.Create questons and answer

3. Edit Faq

4.Delete Faq

5.Activation / DeActivation the Faq

6.Change Queue

7.View All or to chosen language FAQ (only Admin area)

8.Determination of amount of rarefying symbols for Question

Note: for default MaxLen = 512 in file zz_faq_form.php var

9.Counter Faq gross amount for chosen language and all

10. Grafical and html possibilities

end more...

Screen here http://khm.biz -->OSC zz_applications

thanks

Share this post


Link to post
Share on other sites

I have installed the FAQ system. I have encountered some problems, but most has been solved. Except the following:

 

- My admin works only in English, but I have a multilingual site (English, Dutch, French and German). How do I create FAQ for different languages from the english admin(I only see the english FAQ)?

 

- A lot of images/buttons don't show up in de admin:

in FAQ manager:

Edit FAQ

Delete FAQ

Add new FAQ

 

FAQ view:

Add new FAQ

 

FAQ ALL view:

Add new FAQ

 

Hope you can help me out on this one,

 

Geert-Jan Leerentveld

Share this post


Link to post
Share on other sites

for v.1.0 Change language:

Administration-->change language-->faq manager --):

 

I do a new version v.1.1. See please screen http://khm.biz -->zz_applications Corrected mistakes to desksides. There be straight changing language. However, I have problem with JavaScrip (counter) in file zz_faq_form.php

Who that can help to correct counterScript mistake?

thanks

Share this post


Link to post
Share on other sites

works great... :)

 

just need to rename in admin the include application_top to include zz_application_top and same for configure to zz_configure to have according name file

 

and in catalog i have copied language file zz_english.php that are missing in zip files from the admin part (i think even mpty files should be used but does not matter to use admin files as is..))

 

should be nice to update faq form in admin to work as catalog with all the avalaible translation to be entered in same page

Share this post


Link to post
Share on other sites

After I followed the instructions, I encountered this error:

 

Fatal Error: Failed opening required 'DIR_WS_LOCAL_LANGUAGESzz_.php' (include_path='')

in /catalog/includes/local/zz_application_top.php on line 3 :?

 

 

What can be the problem?

 

Stonez

Share this post


Link to post
Share on other sites

just read my answer in post before i've add same problem

Share this post


Link to post
Share on other sites

adgrafics wrote

 

I do a new version v.1.1.

 

Where to download updated files to select languages ?

Share this post


Link to post
Share on other sites

I spent all night trying to fix the problems...failed.

I would have to wait for the V1.1 come out.

Thanks!

 

Stonez

Share this post


Link to post
Share on other sites

Victor,

 

I just installed your FAQ System and every thing is working.

 

It would be very helpful to be able to group the FAQ. This way I could have a FAQ for the company, and for individual products.

 

Can you give me some direction for the modifications that would be necessary.

 

Thanks,

Doug

Share this post


Link to post
Share on other sites

Hi

What FAQ are you using? I have installed the zz_FAQ_SYSTEM_VER1.0 but I can only make it work in the admin module. To me it looks like there are no boxes for the catalog part.

 

Regards

 

Jes

Share this post


Link to post
Share on other sites

From the readme.txt file:

 

Note:catalog/includes/boxes/information.php - insertt line from information.php

Share this post


Link to post
Share on other sites

there is no boxes for the catalog part

you must just add the link in an existing box

Share this post


Link to post
Share on other sites

Hi... great contrib! Thanks!

 

When this is updated, how about an option to have an infobox that randomly rotates FAQ questions?

 

so you'd have something like

 

-------------------------

:: FAQ

 

8. What's a widget do?

 

This is the first X chars of the answer ... [click here

to read the full answer]

 

Click here for the Full FAQ

--------------------------------

 

It'd help to suck people into reading the faq questions and answers, to entice them to educate themselves.

Share this post


Link to post
Share on other sites

just reread install file

you have to add the link in an existing box...

Share this post


Link to post
Share on other sites

Great contribution. I got everything installed, though I had to change some references:

================================

ADMIN AREA

configure.php

// include local zz_configure.php

 require('includes/local/zz_configure.php');

--------------------------------------------------------------

application_top.php

// include local zz_application_top.php

 require('includes/local/[b]zz_[/b]application_top.php');

-------------------------------------------------------------

column_left.php

// include local zz_column_left.php

 require('includes/local/[b]zz_[/b]column_left.php');

--------------------------------------------------------------



CATALOG AREA

configure.php

// include local zz_configure.php

 require('includes/local/zz_configure.php');

-------------------------------------------------------------

application_top.php

// include local zz_application_top.php

 require('includes/local/[b]zz_[/b]application_top.php');

===============================

 

Thanks again.

 

GDW[/b][/code]

Share this post


Link to post
Share on other sites

How can we insert a GOTO TOP link in this great FAQ scripts ?

 

I have a long FAQ and it would help if people could click a link (under each answer) to go back to top.

 

Thanks !!


http://www.burnproofusa.com

Your Safety is our Hotspot!

Share this post


Link to post
Share on other sites

never mind found a solution already ...

 

added "<a name="TOP"> </a> next to <head> in zz_faq.php

 

and added "<br><b><a href="zz_faq.php#TOP">TOP</b></a> on the bottom of every answer :-)


http://www.burnproofusa.com

Your Safety is our Hotspot!

Share this post


Link to post
Share on other sites

Hello I have some trouble to install zz_faq

 

I rename in admin the include application_top to include zz_application_top and same for configure to zz_configure to have according name file

 

I do the same change like :arrow: gdfwilliams

 

but I have this error in catalog :

 

Fatal error: Failed opening required 'includes/local/languages/zz_.php' (include_path='.;E:conceptionEasyPHPphppear') in e:conceptioneasyphpwwwtestsitecatalogincludeslocalzz_application_top.php on line 3

 

zz_application_top.php on line 3 : require(DIR_WS_LOCAL_LANGUAGES . zz_ .$language . '.php');

 

and this error for admin :

Fatal error: Failed opening required 'includes/local/languages/zz_.php' (include_path='.;E:conceptionEasyPHPphppear') in e:conceptioneasyphpwwwtestsiteadminincludeslocalzz_application_top.php on line 7

 

zz_application_top.php on line 7 : require(DIR_WS_LOCAL_LANGUAGES . zz_ .$language . '.php');

 

I need help, thx :? :?:

Share this post


Link to post
Share on other sites

Is there somewhere where I can see this script in action?

 

Thanks,

Mattice


"Politics is the art of preventing people from taking part in affairs which properly concern them"

Share this post


Link to post
Share on other sites

in my demo page

 

 

working great but would like to find v2 somewhere :)

 

seems victor does not repply :(

Share this post


Link to post
Share on other sites

Why are files going into the local directory?

 

I'm lost ... :wink:


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

yes this is a strange install... but working

 

maybe victor had some interrest to make this way

Share this post


Link to post
Share on other sites
but I have this error in catalog :

 

Quote:

Fatal error: Failed opening required 'includes/local/languages/zz_.php' (include_path='.;E:conceptionEasyPHPphppear') in e:conceptioneasyphpwwwtestsitecatalogincludeslocalzz_application_top.php on line 3

 

 

zz_application_top.php on line 3 : require(DIR_WS_LOCAL_LANGUAGES . zz_ .$language . '.php');

 

just reread my first post in the thread

you have to create a dummy zz_'language'.php file or copy the language files from admin in catalog part

Share this post


Link to post
Share on other sites

I need to build a faq system for a client.

 

I installed this mod but ... I'm not sure if this is the way to go for me. It works for me but ... hmmm ... I'd like categories and what not.

 

I wonder if I might not just be better off with hacking my NewsDesk mod a bit to create faqs also/instead.

 

Any comments from anybody out there that uses this contrib? I would love to hear your praises and complaints.


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×