Jump to content
Sign in to follow this  
ckyshop.co.uk

New Google Sitemap Generator

Recommended Posts

I have copied the 2 files into the /Catalog/ . I notified Google sitemap and they said there in an Error.

Can you help me.

What do i have to do next?

Share this post


Link to post
Share on other sites
I have copied the 2 files into the /Catalog/ . I notified Google sitemap and they said there in an Error.

Can you help me.

What do i have to do next?

 

Can you elaborate on the error please?


Thanks for any help/comments.

 

Regards,

 

Lewis Hill

Share this post


Link to post
Share on other sites
Can you elaborate on the error please?

 

I've deleted the error form the sitemap, but I've done it again, so I will be able to send it later

Share this post


Link to post
Share on other sites

This is the error:

 

Sitemap Type Submitted Last Downloaded Sitemap Status URLs submitted

googleSitemapProducts.php Code Search 9 hours ago 9 hours ago Errors –

 

 

This Sitemap has the following errors.

Errors

General HTTP error: 404 not found

We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit. [?]

Share this post


Link to post
Share on other sites
This is the error:

 

Sitemap Type Submitted Last Downloaded Sitemap Status URLs submitted

googleSitemapProducts.php Code Search 9 hours ago 9 hours ago Errors –

This Sitemap has the following errors.

Errors

General HTTP error: 404 not found

We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit. [?]

 

Please post the location for the sitemaps you have input to the Google Webmaster/Sitemaps account.


Thanks for any help/comments.

 

Regards,

 

Lewis Hill

Share this post


Link to post
Share on other sites

I get the following error after telling Google where the files are located:

 

"Unsupported file format

Your Sitemap does not appear to be in a supported format. Please ensure it meets our Sitemap guidelines and resubmit."

 

Any ideas?

Share this post


Link to post
Share on other sites
I get the following error after telling Google where the files are located:

 

"Unsupported file format

Your Sitemap does not appear to be in a supported format. Please ensure it meets our Sitemap guidelines and resubmit."

 

Any ideas?

 

Please confirm you are selecting 'General Sitemap' under 'Sitemaps' > 'Add sitemap' and then inputting 'googleSitemapCategories.php' and likewise for xx...products.php.

 

You need to input both files separately as two different sitemaps.

 

HTH.


Thanks for any help/comments.

 

Regards,

 

Lewis Hill

Share this post


Link to post
Share on other sites
Please confirm you are selecting 'General Sitemap' under 'Sitemaps' > 'Add sitemap' and then inputting 'googleSitemapCategories.php' and likewise for xx...products.php.

 

You need to input both files separately as two different sitemaps.

 

HTH.

 

 

Yes, I did that. Inputted both files seperately and that is the error I received.

Share this post


Link to post
Share on other sites
Please confirm you are selecting 'General Sitemap' under 'Sitemaps' > 'Add sitemap' and then inputting 'googleSitemapCategories.php' and likewise for xx...products.php.

 

You need to input both files separately as two different sitemaps.

 

HTH.

 

It worked.Thanks a lot

Share this post


Link to post
Share on other sites

I am not sure I get it. This is an old contribution, why re-upload it? I have done a compare with the one I already have installed and it is exactly the same, I do not see the point on re-uploading it again months or years later, labeling it "new", and opening a new suport thread.


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites
I am not sure I get it. This is an old contribution, why re-upload it? I have done a compare with the one I already have installed and it is exactly the same, I do not see the point on re-uploading it again months or years later, labeling it "new", and opening a new suport thread.

 

I thought it was a new contribution. I looked but obviously could not find it. I'm sorry for inconveniencing you.


Thanks for any help/comments.

 

Regards,

 

Lewis Hill

Share this post


Link to post
Share on other sites

I have a warning in google sitemaps (categories and products) folder saying "Sitemap begins with a space". They have added sitemaps but recommended to fix it to be with a standard XML.

I didn't find any spaces here

echo '<?xml version="1.0" encoding="UTF-8"?>' . "\n";

Thank you for answers.

Share this post


Link to post
Share on other sites

I also am getting this error message when viewing the page directly:

 

The XML page cannot be displayed 
Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later. 


--------------------------------------------------------------------------------

Required white space was missing. Error processing resource 'http://www.torostam.com/googleSitemapProducts.php'. Line 1, P...

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">


 

Any ideas as to what might cause this?

 

 

-Jim

Share this post


Link to post
Share on other sites

I started using this contribution about a week ago. It was easy, fast and has worked with zero errors to date. Google found it within seconds after I notified them in the add sitemap section of my account there. They have been hitting it plenty ever since. My vote is 3 cheers for this contribution!!!!!

 

I have a question however... what can I do about adding a sitemap for everyone else? For instance, I have noticed ShopWiki pounding my site to death and seems completely blind. I would like something to help them find their way and for all other search engines that would benefit from a sitemap. It appears that other engines/bots do not or will not read this type?

 

I would appreciate any advice you can give.

 

Iceman B)

Share this post


Link to post
Share on other sites

I have OSC 2.2 RC1.

I uploaded these two file in to root folder, then added in to Google Webmaster Tools and 5 minutes after Google take it, without any problem my sitemap :)

 

It works perfect with my 2.2 RC1

Share this post


Link to post
Share on other sites
e encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit. [?]

 

Had the same problem i just uploaded the files ran them in browser and then download the XML file that was generated

to my computer .

Then uploaded the file to the web site and changed the name so i will be without .php in it

XXX.xml only then added a site map in google from the XML file and it worked

:thumbsup:

Share this post


Link to post
Share on other sites

I installed Google Sitemap Generator yesterday and all is OK so far.

However it can be enhanced, a third sitemap showing manufacturers,

I've already written one and have it installed.

To help with search enging optimization the url's generated could have some

meaningful text added such as &title=product%20name

Share this post


Link to post
Share on other sites

Before submitting them to Google, run them yourself in your browser. If an error occurs, open up the files and delete or comment out the line where it includes application_bottom.php, and it will then work

Share this post


Link to post
Share on other sites

Hi,

 

I have a problem with implementing this contrib:

 

I have a 301 redirect for my index.htm in my root directory which points to www.myshop.com/catalog/default.php. So when one uses www.myshop.com it goes to this address.

 

When I now copy those 2 contrib-files to the root directory (public_html in my case) Google can NOT find them. But when I copy them to the catalog-directory Google says that I have to create a new site in webmaster tools which is www.myshop.com/catalog/. When I do this and copy the files to this directory Google says "We can't currently access your home page because of an HTTP error (403)."

 

Any ideas how I can get this working?

 

Thanks.

 

Albert

Share this post


Link to post
Share on other sites

The instructions tells you to install both files in your root directory. I know root directory is the top folder. But does that go if your address is as follows?

 

http://brs-giftsgop.com/oscommerce2/catalog/index.php

 

So is this the correct method:

 

http://brs-giftsgop.com/googleSitemapCategories.php

http://brs-giftsgop.com/googleSitemapProducts.php

 

or:

 

http://brs-giftsgop.com/oscommerce2/google...pCategories.php

http://brs-giftsgop.com/oscommerce2/google...mapProducts.php

 

Also, in a way, I believe robots.txt works hand in hand. I am guessing. I have two robots.txt files. They are in the following dir.

 

brs-giftshop.com/robots.txt

 

and

 

brs-giftshop.com/oscommerce2/catalog/robots.txt

 

Is this correct or not?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi,

 

I installed this contrib and submitted to google on 23feb08 without any probs.

 

today I get this warning in google webmaster tools:

 

URLs not followed

When we tested a sample of the URLs from your Sitemap, we found that some URLs were not accessible to Googlebot because they contained too many redirects. Please change the URLs in your Sitemap that redirect and replace them with the destination URL (the redirect target). All valid URLs will still be submitted.

 

HTTP Error:

URL:

Found: 301 (Moved permanently) Help

 

http://www.mydomain.com/files-filing-stora...es-c-8_157.html

Feb 25, 2008

 

Any ideas what I should do now? any help would be much appreciated as I'm new to this...

Share this post


Link to post
Share on other sites
Hi,

 

I installed this contrib and submitted to google on 23feb08 without any probs.

 

today I get this warning in google webmaster tools:

 

URLs not followed

When we tested a sample of the URLs from your Sitemap, we found that some URLs were not accessible to Googlebot because they contained too many redirects. Please change the URLs in your Sitemap that redirect and replace them with the destination URL (the redirect target). All valid URLs will still be submitted.

 

HTTP Error:

URL:

Found: 301 (Moved permanently) Help

 

http://www.mydomain.com/files-filing-stora...es-c-8_157.html

Feb 25, 2008

 

Any ideas what I should do now? any help would be much appreciated as I'm new to this...

 

LOL, just worked it out.

 

I had changed a categories name without reseting the URL cache, hence too many redirects as the page being redirected to was then redirecting to the new category name :)

 

So hopefully this will fix it up

Share this post


Link to post
Share on other sites

Hi,

 

I have a problem for this good contribuation.

I have installed STS. Before all work fine, now I have this errors:

 

- For googleSitemapCategories.php

<font color="#000000"><b>1064 - You have an error in your SQL syntax; check the manual that corresponds to your ...

 

- For googleSitemapArticles.php

              articles_date_added DESC<br><br><small><font color="#ff0000">[TEP STOP]</font>&l...

 

etc. Only googleSitemapreview.php work fine.

 

Anyone can help me?

 

Thanks,

Fabio

Edited by sakkiotto

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×