Jump to content
chris23

[contribution] Tracking Module

Recommended Posts

Hi Chris,

 

Royal mail's change has broken the URL's again :(

 

Thanks for the update working fine on CRE Loaded, just wanted to bring something to your attention though, the international Signed for do not seem to work, I was looking at teh URLs and noticed the following:

 

International:

http://postcode.royalmail.com/portal/rm/tr...equestid=112464

 

1st Class/Special:

http://postcode.royalmail.com/portal/rm/tr...equestid=112559

 

Its the Keyname that changes 3H versus 3A

 

I will PM you an example International Sign-For Tracking number to test with, it and when you have the time for it :)

 

Let me know if I can help you in anyway.

 

This is nothing to do with the URL changes. The International page return contains invalid HTML which chokes the script.

A fix for this is here - post #148:

 

I should have added this to the last updated module but forgot. Sorry!


Please use forum for support rather than PM - PMs unrelated to my contributions will be ignored.

Google Site Search is your friend

My contributions: Tracking Module | PDF Customer Invoice | Subcategory textboxes

Share this post


Link to post
Share on other sites
This is nothing to do with the URL changes. The International page return contains invalid HTML which chokes the script.

A fix for this is here - post #148:

 

I should have added this to the last updated module but forgot. Sorry!

 

Excellent, thanks for that :)

Share this post


Link to post
Share on other sites
-right. the massege occures when i try to add the ID on admin/orders.php

 

- 1. Yes i think so. If i write the tracking number in the database, there is no tracking information...

- 2. For sure not.

 

thanks

rolf

 

Rolf,

Could you please PM me with one of the new tracking IDs so I can come up with a new regexp?

Thanks,

Chris

Edited by chris23

Please use forum for support rather than PM - PMs unrelated to my contributions will be ignored.

Google Site Search is your friend

My contributions: Tracking Module | PDF Customer Invoice | Subcategory textboxes

Share this post


Link to post
Share on other sites

Hi there,

 

You done an excellent job in providing support for this module. I was wondering if you could please kindly help me as I have installed the modules 3-4 times already and still get the same error message in the admin orderes panel:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/***/public_html/shop/includes/languages/english/tracking_module.php:52) in /home/***/public_html/shop/admin/includes/functions/general.php on line 22

 

Could you please kindly point me in the right direction please?

 

Thanks

 

Best Regards,

 

Jonathan

 

www.justek.com.au

Share this post


Link to post
Share on other sites
Hi there,

 

You done an excellent job in providing support for this module. I was wondering if you could please kindly help me as I have installed the modules 3-4 times already and still get the same error message in the admin orderes panel:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/***/public_html/shop/includes/languages/english/tracking_module.php:52) in /home/***/public_html/shop/admin/includes/functions/general.php on line 22

 

Could you please kindly point me in the right direction please?

 

Thanks

 

Best Regards,

 

Jonathan

 

www.justek.com.au

 

Jonathan,

This is caused by an extra whitespace character after the closing ?> php tag in includes/languages/english/tracking_module.php

This is a common problem - edit the file above and make sure there are no characters, spaces or newlines after the closing ?>


Please use forum for support rather than PM - PMs unrelated to my contributions will be ignored.

Google Site Search is your friend

My contributions: Tracking Module | PDF Customer Invoice | Subcategory textboxes

Share this post


Link to post
Share on other sites
Jonathan,

This is caused by an extra whitespace character after the closing ?> php tag in includes/languages/english/tracking_module.php

This is a common problem - edit the file above and make sure there are no characters, spaces or newlines after the closing ?>

 

Hi Chris23,

 

Thanks alot for the solution! it worked!!! I have spent working on this module from 1am straight through to 11am! (while working on other modules too of course)

and now on the 24th you have helped me work this out and I can now enjoy Christmas without having to worry that there's some glitch in the system!

 

Merry Christmas and a Happy new Year!

 

Best Regards,

 

Jonathan

Share this post


Link to post
Share on other sites

Hello,

 

I have a problem, I tried to change the Swisspost tracking GET url. Wanted to try the changes, but i got the error message that the tracking id is incorrect. I undo the changes on the Swisspost tracking GET url. Now i can't any tracking ids anymore: although correct i get the error message. Any help please? thanks alot

Share this post


Link to post
Share on other sites
Hello,

 

I have a problem, I tried to change the Swisspost tracking GET url. Wanted to try the changes, but i got the error message that the tracking id is incorrect. I undo the changes on the Swisspost tracking GET url. Now i can't any tracking ids anymore: although correct i get the error message. Any help please? thanks alot

 

 

O.k found solution for this bug: deinstalled, updated status on a order. reinstalled and entered tracking id. now reworking ;)

Share this post


Link to post
Share on other sites

Swisspost v1.1 is online. Thanks Chris for your work.

 

If someone could translate the modul to french/italian, please mail me...

 

have a nice weekend.

Share this post


Link to post
Share on other sites

Hi Chris,

 

This is a life and labour saving contribution for us! I think you might have already dealt with this issue before but from what I can work out it was resolved over PM. back in 2007, so I hope you can help and remember what you did.

 

I am having a problem, saving tracking numbers into the db, I have checked the installation 3 times now and added both TNT and RM modules. niether enter data. I have also used the orders page as included in the download and still it does not enter.

 

I am running curl libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

 

I have a very heavily modified version of OsCommerce, with Protx and PayPal on the orders.php page we did try to install google checkout but we don't run it.

 

When I enter data into the db tracking field e.g 1234568|tt the script works fine untill I click on the number to track where upon I get the message

 

Error calling tracking script. Please try later.

 

Having looked into this, I changed

 

 $path = empty($admin) ? "" :
            "../";
           $wait = TRACKING_AJAX_WAIT;

to

 

   $path = empty($admin) ? "" :
		DIR_WS_CATALOG;
		$wait = TRACKING_AJAX_WAIT;

 

In the tracking_module.php

 

Sadly no change.

 

I have tried running the debug script you posted a while back but could not get a result.

 

I read further back I might need to change general.php?

 

If you could help me or if you know the answer I would be so grateful!

 

Thanks very much

 

Peter

Edited by Zebrabanana

Thanking God for a beautiful day??

Share this post


Link to post
Share on other sites

Hey all.. Great contribution this Chris, we have been running this faultlessly for the past year - all has been well..

 

We have just changed our servers from a Linux shared to a Windows dedicated and the MYSQL database has also changed servers to the new host but has seen an upgrade from PHP4.8* over to PHP5

 

Everything worked fine after CURL was installed on the Windows server, but what we didnt realise was when we put the new server live, come to update customer orders with the new tracking information as normal and nothing is displayed next to the order coments box on the right regardless of the tracking number entered being correct.

 

Is there something we need to be changing for this to work so we can enter all customer tracking codes again ? Really stuck on this one now :blink:

 

Thanks in advance

Share this post


Link to post
Share on other sites
Hi Chris,

 

This is a life and labour saving contribution for us! I think you might have already dealt with this issue before but from what I can work out it was resolved over PM. back in 2007, so I hope you can help and remember what you did.

 

I am having a problem, saving tracking numbers into the db, I have checked the installation 3 times now and added both TNT and RM modules. niether enter data. I have also used the orders page as included in the download and still it does not enter.

 

I am running curl libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

 

I have a very heavily modified version of OsCommerce, with Protx and PayPal on the orders.php page we did try to install google checkout but we don't run it.

 

When I enter data into the db tracking field e.g 1234568|tt the script works fine untill I click on the number to track where upon I get the message

 

Error calling tracking script. Please try later.

 

Having looked into this, I changed

 

 $path = empty($admin) ? "" :
            "../";
           $wait = TRACKING_AJAX_WAIT;

to

 

   $path = empty($admin) ? "" :
		DIR_WS_CATALOG;
		$wait = TRACKING_AJAX_WAIT;

 

In the tracking_module.php

 

Sadly no change.

 

I have tried running the debug script you posted a while back but could not get a result.

 

I read further back I might need to change general.php?

 

If you could help me or if you know the answer I would be so grateful!

 

Thanks very much

 

Peter

 

Hey

has anyone got any ideas about this ?

 

Thanks

 

Peter


Thanking God for a beautiful day??

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed this module and think its fantastic I've got royal mail and interparcel working. I tried installing the DHL module, however as I use a 3rd party (parcel2go) to book the collections, I don't have an account and couldn't get the included module to work. Has any one got a DHL module that i can input 2characters and 16 number indents into? can the existing module be easily moded?

 

heres hoping!!!

Share this post


Link to post
Share on other sites
Hi there, I am creating a tacking module for FEDEX and have got the following problems / errors:

 

 

On account_history_info.php

 

and

 

On /admin/orders.php

  • The order has an Tracking ID which I added in admin.
  • My fedex mod has been installed
  • Add tracking ID / ref to an order works fine!

I see its not getting the two digit reference (FX in this case).

 

I have gone through the instructions several times, but not found anything missing.

 

Can anyone help pin point the problem and suggest a fix.

 

Thanks,

 

Gareth

 

how to fix similar problem? I am trying to develop module for your contribution.


Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Share this post


Link to post
Share on other sites
how to fix similar problem? I am trying to develop module for your contribution.

 

fixed, don't worry.


Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Share this post


Link to post
Share on other sites

The fedex tracking module has the problem. I got this message when input the real Fedex Tracking ID;

 

"The Federal Express ID you have supplied is not valid. Please check and try again. The required format is 2 letters, 6 digits eg AB123456. Do not use spaces."

 

The Fedex tracking ID supposed have 12 digits and with no letters include...

 

Trying to find out the solutions

Share this post


Link to post
Share on other sites

Hi

 

Has anybody had problems with the Interlink Express tracking module. I have it working fine but the output seems to ignore the tracking_div class so the output is ugly. Can't seem to get it to output correctly. I have the new Royal Mail track and trace module installed and outputting correctly so I don't think its my install. Any help or fix most appreciated.

 

Great contrib on the whole.

Share this post


Link to post
Share on other sites

hello to all,

 

I have a problem with this module and I dry, so I hope I have a little help

 

when I click the tracking number, I have this

 

 

 

Error: Unable to connect to server - please try again later.

 

[x] Close

 

 

 

in local installation, this worked very well, but more about the online site

 

Can this book come from? or other parameters?

 

Thank you for your help because I was really dry

 

switzzie

Share this post


Link to post
Share on other sites

Hi, I have some problem with the Posten Norge module.

 

All seems fine, ID's are listed in order history and admin panel. But when I click on the ID, there's no output. Only the Close button. I get no error, and I've tried debugging. But still no output.

 

Any ideas?

 

regards,

jonarvid

Share this post


Link to post
Share on other sites

Also tried running the np_tracking.php directly. Screen is blank. And when I try to view pagesource, it's blank too!

 

Seem like np_tracking.php can't grab data from TRACKING_GET_URL_NP and $_GET['tracking_id'].

Also tried installing module for swisspost

Same problem when running sp_tracking.php

 

 

Could it be something not supported by server?

Server running:

PHP Version 4.4.7

CURL support enabled

CURL Information libcurl/7.15.3 OpenSSL/0.9.6b zlib/1.2.3

Edited by jonarvid

Share this post


Link to post
Share on other sites
Also tried running the np_tracking.php directly. Screen is blank. And when I try to view pagesource, it's blank too!

 

Seem like np_tracking.php can't grab data from TRACKING_GET_URL_NP and $_GET['tracking_id'].

Also tried installing module for swisspost

Same problem when running sp_tracking.php

 

 

Could it be something not supported by server?

Server running:

PHP Version 4.4.7

CURL support enabled

CURL Information libcurl/7.15.3 OpenSSL/0.9.6b zlib/1.2.3

Got it working. Was some faulty code in np_tracking.php.

Share this post


Link to post
Share on other sites
Got it working. Was some faulty code in np_tracking.php.

 

Hi Jon, I have the same errors cant connect to server, although it's business post tracking can you tell me what code you found was wrong in your fix please

Share this post


Link to post
Share on other sites

Further to my post above I've now installed Royal Mail (1.4) aswell as Business Post (1). everything works on both contributions except for the track id in both admin and account history. after trying for a minute or so we get

 

Error: Unable to connect to server - please try again later.

 

The customer email works fine as does the link to the courier.

 

Hope someone can point me in the right direction.

 

cheers

Share this post


Link to post
Share on other sites

Hi Guys

 

I downloaded both the DHL tracking modules, however it appears that they will not work with uk tracking numbers (which come in the following format: JD0002297176187364).

 

These tracking numbers can be used at the following page:

http://track.dhl.co.uk/tracking/

 

You just have to enter the code in the 'from ident code' box, and then hit 'submit'.

I have started messing about with the 'DHL without account' module to try and make it work for UK users. First I changed the tracking number validation regexp so that it will accept the format of uk tracking numbers. I also changed the DHL Tracking Get URL to "http://track.dhl.co.uk/tracking/", however I do not get any tracking info when I click on the tracking number. Obviously there are more changes that need to be made to get this working properly. If anyone could be of assistance it would be greatly appreciated.

 

I don't know if this is any help but I discovered that you can get info in xml format by including the tracking number in the URL:

http://track.dhl.co.uk/tracking/wrd/run/wt...dGB&date%3d

 

Cheers,

Nick

Share this post


Link to post
Share on other sites

Hello @all,

 

i have the same problem with the tracking number DHL.

The tracking number from DHL are new. They have change the system so the right number begins with JDD or JD or what else.

The next, i have only 16 characters without any point or space.

 

Is it possible to modify the module for dhl?

 

Many thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×