Jump to content
rigadin2

[Contribution] oscThumb

Recommended Posts

There not errors, they're notices, its due to the old version of php on your server.

 

in includes/applicaion_top.php

 

replace@

 

error_reporting(E_ALL);

 

 

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);

 

've made the changes you did not say fix

site adress error page

 

http://www.akbanagold.com.tr

 

and Simple Multiple Images error product

http://www.akbanagold.com.tr/crm/product_info.php?products_id=83

Edited by tubisan

Share this post


Link to post
Share on other sites

Hello,

 

First off the contri works really well, there is one issue I have using this in combination with embedded content (youtube).

 

The popups don't pop over the youtube content but under it, which looks a bit odd, I don't know whether there is a fix but it would be greatly appreciated.

 

 

Example

Share this post


Link to post
Share on other sites

Hello,

 

First off the contri works really well, there is one issue I have using this in combination with embedded content (youtube).

 

The popups don't pop over the youtube content but under it, which looks a bit odd, I don't know whether there is a fix but it would be greatly appreciated.

 

 

Example

 

 

Looks fine to me in ie7, but you post in wrong thread, please post in multi image thread detailed in doc.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

I have reason to NOT want the cache in the /catalog/ filespace. Anyone know if it will break oscThumb if I move it somewhere else, provided it is accessible and writable by the web server process?

Because of the way Site Monitor indexes the exclude list of directories, and that phpThumb creates directories on the fly, the two do not work well with each other. Site Monitor will not work with phpThumb. So, I moved the phpThumb cache directory out of the catalog filespace and phpThumb quickly died. It appears that the path to the cache directory is hard coded so that it must be in the catalog path. So, I changed the phpThumb config file to allow the configuration parameter to be an absolute path, and moved the cache to a better location. All is working well, so far. I'll know more tomorrow.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

Ok, all is well after 24 hours so i will share this simple edit.

 

If you have oscThumb and Site Monitor both installed, and Site Monitor gives you multiple errors that all point to a phpthumb cache file error it is due to the way Site Monitor indexes the files combined with oscThumb's dynamic creation of directories. Entering the oscThumb Cache directory in Site Monitor exclude list does not stop the errors. The fix is to move your phpThumb cache directory out of the osCommerce directory structure.

 

If you have osCommerce in your document root then this will not work for you. It must be in a directory not monitored by Site Monitor.

 

Go to your Administration Panel, Configuration, My Store, oscThumb, and turn off oscThumb.

Use your cPanel or any other method you are comfortable with, and move your cache directory to a directory not in your store path. Note the path to it for later use. If your store is at /catalog/ you can move it to / or to /other_directory/cache/ or /other_directory/phpThumb/cache/ or whatever you want, as long as it is not in /catalog/*

 

In your /catalog/phpThumb/phpThumb.config.php file find this set of lines.

 

// * Cache directory configuration (choose only one of these - leave the other lines commented-out):
// Note: this directory must be writable (usually chmod 777 is neccesary) for caching to work.
// If the directory is not writable no error will be generated but caching will be disabled.
//$PHPTHUMB_CONFIG['cache_directory'] = dirname(__FILE__).'/cache/';                            // set the cache directory relative to the phpThumb() installation
$PHPTHUMB_CONFIG['cache_directory'] = $PHPTHUMB_CONFIG['document_root'].CFG_TN_CACHE_DIRECTORY; // oscThumb: set the cache directory to an absolute directory for all source images
//$PHPTHUMB_CONFIG['cache_directory'] = './cache/';                                           // set the cache directory relative to the source image - must start with '.' (will not work to cache URL- or database-sourced images, please use an absolute directory name)
//$PHPTHUMB_CONFIG['cache_directory'] = null;                                                 // disable thumbnail caching (not recommended)
//if (strtoupper(substr(PHP_OS, 0, 3)) == 'WIN') {
//	$PHPTHUMB_CONFIG['cache_directory'] = dirname(__FILE__).'/cache/'; // set the cache directory to an absolute directory for all source images
//} else {
//	$PHPTHUMB_CONFIG['cache_directory'] = '/tmp/persistent/phpthumb/cache/';
//}

 

Only one of the lines is NOT commented out. Comment out that line by adding // in front of the line, and add a line to the end of it all so that it all looks like this.

// * Cache directory configuration (choose only one of these - leave the other lines commented-out):
// Note: this directory must be writable (usually chmod 777 is neccesary) for caching to work.
// If the directory is not writable no error will be generated but caching will be disabled.
//$PHPTHUMB_CONFIG['cache_directory'] = dirname(__FILE__).'/cache/';                            // set the cache directory relative to the phpThumb() installation
// $PHPTHUMB_CONFIG['cache_directory'] = $PHPTHUMB_CONFIG['document_root'].CFG_TN_CACHE_DIRECTORY; // oscThumb: set the cache directory to an absolute directory for all source images
//$PHPTHUMB_CONFIG['cache_directory'] = './cache/';                                           // set the cache directory relative to the source image - must start with '.' (will not work to cache URL- or database-sourced images, please use an absolute directory name)
//$PHPTHUMB_CONFIG['cache_directory'] = null;                                                 // disable thumbnail caching (not recommended)
//if (strtoupper(substr(PHP_OS, 0, 3)) == 'WIN') {
//	$PHPTHUMB_CONFIG['cache_directory'] = dirname(__FILE__).'/cache/'; // set the cache directory to an absolute directory for all source images
//} else {
//	$PHPTHUMB_CONFIG['cache_directory'] = '/tmp/persistent/phpthumb/cache/';
//}
$PHPTHUMB_CONFIG['cache_directory'] = CFG_TN_CACHE_DIRECTORY; // oscThumb: set the cache directory to an absolute directory for all source images

Now go to your Administration panel,Configuration,My Store,oscThumb, select the Thumbnail Cache Directory. This directory path will now be absolute if it starts with a / and relative to the httpd base if it does not. Set it to the absolute path to where you moved your cache directory above. use your cPanel to determine the path.

Then turn oscThumb master switch back on.

 

For security create an .htaccess in the new cache directory that has the following contents.

<Files *.php>
Order Deny,Allow
Deny from all
</Files>

 

Site Monitor will now no longer report any errors in phpThumb/cache/ files.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

Howdy, I have just installed oscThumb, but the text size of the font for the water mark does not appear to be listening to the setting in "text water mark size" I have changed it to 120 and my water marked text is still the same size

 

So I then said I will solve it and use tiled and a water mark method but this is not doing what I thought it would do and that is write my text over the image multiple times.

 

What I want to achieve is either my water mark text repeated multiple times over the image or just one larger one going from bottom left to top right

 

I am fairly new at all this so all help would be good, Also I should add I have installed "Simple Multi Image Add-on (Un-Limited) with FancyBox Popups" http://addons.oscommerce.com/info/7008

Share this post


Link to post
Share on other sites

I should have also mentioned that I can't see what turning on "Encrypt Image Filenames" does and this does not appear to be working either - not that I know what it does look like when it is working

Share this post


Link to post
Share on other sites

Howdy, I have just installed oscThumb, but the text size of the font for the water mark does not appear to be listening to the setting in "text water mark size" I have changed it to 120 and my water marked text is still the same size

 

Try changing it to 10.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

nah still did not change anything so are you saying smaller number is larger text size?

Text Watermark Size 10

Share this post


Link to post
Share on other sites

Hi :)

I've installed this contrib and it is really good but I have some problems:

 

1) I cannot change the watermark font in the popup images, when I try to change it just clicking on edit it gives me this error: "Fatal error: Call to undefined function tep_cfg_pull_down_installed_fonts() in C:\Inetpub\vhosts\...\mydomain\httpdocs\osc2\admin\configuration.php(125) : eval()'d code on line 1"

 

2) It does not print the watermark in the images, I settled it up with a simple text without changing any other thing but it does not appear, maybe it is related to the font error???

 

3) When I try to change the watermark position, just clicking on edit, it gives me this error: "Fatal error: Call to undefined function tep_cfg_pull_down_watermark_alignment() in C:\Inetpub\vhosts\....\mydomain\httpdocs\osc2\admin\configuration.php(125) : eval()'d code on line 1"

 

Thank you in advance for your help :)

 

Simone

Share this post


Link to post
Share on other sites

Hi :)

I've installed this contrib and it is really good but I have some problems:

 

1) I cannot change the watermark font in the popup images, when I try to change it just clicking on edit it gives me this error: "Fatal error: Call to undefined function tep_cfg_pull_down_installed_fonts() in C:\Inetpub\vhosts\...\mydomain\httpdocs\osc2\admin\configuration.php(125) : eval()'d code on line 1"

 

2) It does not print the watermark in the images, I settled it up with a simple text without changing any other thing but it does not appear, maybe it is related to the font error???

 

3) When I try to change the watermark position, just clicking on edit, it gives me this error: "Fatal error: Call to undefined function tep_cfg_pull_down_watermark_alignment() in C:\Inetpub\vhosts\....\mydomain\httpdocs\osc2\admin\configuration.php(125) : eval()'d code on line 1"

 

Thank you in advance for your help :)

 

Simone

Share this post


Link to post
Share on other sites

Hi,

 

OscThumb installed just fine. However, my images look grainy. I have the image qualities in admin set good but still grainy. Turn off contrib and images look great.

 

Is there something I need to do to get the image quality back up?

Share this post


Link to post
Share on other sites

I apologize, but I was forced to suspend the script "/home/-----/public_html/oscthumb.php" as it was causing a high load on the server, and due to the nature of the problem, I forced to take immediate action for the health of the server.

 

Unfortunately I do not have any specific recommendations for this script, however, in general, adding some sort of caching mechanism, where the script does not need to generate a new page with every request, helps to lower the over load that a script will cause. Likely the original author or support group of the software that you are using will be able to help you to understand how to add something of this nature.

 

did anybody have solution for this problem.

Share this post


Link to post
Share on other sites

I apologize, but I was forced to suspend the script "/home/-----/public_html/oscthumb.php" as it was causing a high load on the server, and due to the nature of the problem, I forced to take immediate action for the health of the server.

 

Unfortunately I do not have any specific recommendations for this script, however, in general, adding some sort of caching mechanism, where the script does not need to generate a new page with every request, helps to lower the over load that a script will cause. Likely the original author or support group of the software that you are using will be able to help you to understand how to add something of this nature.

 

did anybody have solution for this problem.

 

Actually mine has a cache folder. For example: In admin you have a setting for thumbnail cache directory and mine is phpThumb/cache/. Maybe you need to do an upgrade.

Share this post


Link to post
Share on other sites

what do you mean fan4chevy upgrade.

 

Well if you don't have a cache folder like I do, than it appears your not up to date on the mod.

Share this post


Link to post
Share on other sites

Hi,

I have installed the Simple Multiple Images with Fancy Popups (1.3.5) addon and the oscthumb (1.1.2) according with other topics both must work perfectly together, but after install both of them runing without errors, as it was mentioned in other topic (theoretically fixed in the last versions) the product_info images shows in the fancy popups doesn`t show the watermark despite activated and neither appears any file in the cache directory. Is like the oscthumb would be switched off.

I have reviewed all and suppossly it's ok, any idea? Thanks in advance

Share this post


Link to post
Share on other sites

Hi,

I just installed oscThumb and it seems to work flawlessly. "Simple Multi Image Add-on (Un-Limited) with FancyBox Popups" goes next.

Thanks for a great contribution!

Share this post


Link to post
Share on other sites

I installed the Simple Multiple Images with Fancy Popups (1.3.5) addon and the oscthumb (1.1) contributions. OscThumbs works great except I seem to be having a problem that other users seem to also be having: thumbnails occasionally do not show, instead the alt text shows. Half of the time an image will load, and then the rest of the time an image may not load. If I right click and view an image that did not show (right click on the alt text) and view image, the image will then load in the browser.

 

What would cause the thumbnails to sometimes load and sometimes not?

 

Thanks for any assistance.

Share this post


Link to post
Share on other sites

 

 

What would cause the thumbnails to sometimes load and sometimes not?

 

 

 

 

There is a bug in some versions (maybe all) of ie that can cause this witth any image, have you tried in firefox, whats your versions?


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

There is a bug in some versions (maybe all) of ie that can cause this witth any image, have you tried in firefox, whats your versions?

 

It has been happening in Firefox 3.6 and the same thing is happening(images sometimes loading)in IE 8 as well.

Share this post


Link to post
Share on other sites

I notice a small error when turning osc thumb on /off the first page load after that will show an error

 

Warning: chdir() [function.chdir]: No such file or directory (errno 2) in /home/inno/public_html/maleri/includes/classes/oscthumb.php on line 271

 

A refresh of the page will clear this error.

 

But is there a way to force reload of page or not showing this error.

Share this post


Link to post
Share on other sites

It has been happening in Firefox 3.6 and the same thing is happening(images sometimes loading)in IE 8 as well.

 

 

Then that would imply a install error on your part, go over it again, I`ve never seen that issue on a site with a valid install.

 

If you still have issues after triple checking then you must give full info, otherwise is hard to tell anything!! wink.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Having an error with osc thumbs after moving site to new server.

With osc thumbs off, everything is ok.

Turning osc thumbs on showing no images and put this into the log

[Mon Mar 15 15:10:14 2010] [notice] mod_fcgid: call /home/norgeswe/public_html/xxxxxx.com/oscthumb.php with wrapper /usr/local/cpanel/cgi-sys/php5-wrapper

 

Anyone have a clue what is making thsi error.

Running

PHP 5.2.8

Apache 2.2.11

mysql 5.0.89

Share this post


Link to post
Share on other sites

 

 

 

I would query your notice issue with your host, and check that php is compiled with GD library & what GD library options are enabled.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×