Jump to content
kymation

Request Product Reviews

Recommended Posts

i have uploaded the module, and modified all the database tables according to readme file.

but my test customer is not receving any email after test oredr i modified all details according to readme file.

One more think review_write.php is not showing any message just a balnk page.

Can anyone help...

Thanks in advance


Making ERROR is Human So Please BACKUP

Shantnu

Share this post


Link to post
Share on other sites
i have uploaded the module, and modified all the database tables according to readme file.

but my test customer is not receving any email after test oredr i modified all details according to readme file.

One more think review_write.php is not showing any message just a balnk page.

Can anyone help...

Thanks in advance

 

Hey...Moderators Please delete my previous post.

Problem Solved

It was issue of my mail server configuration.

Anyways

Thanks


Making ERROR is Human So Please BACKUP

Shantnu

Share this post


Link to post
Share on other sites

I am having the same problem as Richard a few posts back .. I followed the instructions but got this error when I tried to run the test:

 

#!/usr/local/bin/php

Fatal error: main() [function.require]: Failed opening required 'includes/functions/FILENAME_DOWNLOADS_CONTROLLER' (include_path='.:') in /var/www/vhosts/lurebeauty.com/httpdocs/includes/functions/general.php on line 1451

 

Does anyone know how to fix that? Im sort of a novice to php , sorry :( But help would be greatly appreciated :)

Share this post


Link to post
Share on other sites

I replied above as jawproducts but that is an old username with an old email address - this is my new login ...

 

I am wondering if there is an area where i was supposed to configure my path before I ran this ?

Share this post


Link to post
Share on other sites
I am having the same problem as Richard a few posts back .. I followed the instructions but got this error when I tried to run the test:

 

#!/usr/local/bin/php

Fatal error: main() [function.require]: Failed opening required 'includes/functions/FILENAME_DOWNLOADS_CONTROLLER' (include_path='.:') in /var/www/vhosts/lurebeauty.com/httpdocs/includes/functions/general.php on line 1451

 

Does anyone know how to fix that? Im sort of a novice to php , sorry :( But help would be greatly appreciated :)

And the answer is the same: This contribution does not alter catalog/includes/functions/general.php. If you've added some other contribution or made any other changes to that file, I suggest that you overwrite it with your backup copy, or a fresh copy from the osCommerce distribution. If you did add some sort of downloads controller, you missed the changes to catalog/includes/filenames.php, so fixing that would also work.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
And the answer is the same: This contribution does not alter catalog/includes/functions/general.php. If you've added some other contribution or made any other changes to that file, I suggest that you overwrite it with your backup copy, or a fresh copy from the osCommerce distribution. If you did add some sort of downloads controller, you missed the changes to catalog/includes/filenames.php, so fixing that would also work.

 

Regards

Jim

Thanks, sorry - I didn't mean to be repetitive; I know it doesn't alter that file yet i still got the error and didn't know why. sorry and thanks

Share this post


Link to post
Share on other sites

HI

 

I just get a blank page when i run the script manually. And i only recieve one email. That is the email telling me that i have used the script and that 0 emails where sent.. I've changed the "Days delay for review email" to "2" and "Review email limit" to "0"(I am using guest account so my costumers doesnt signup at my newsletter automatically...

 

Any ideas on why i dont get the email?

 

My site has no problems sending emails out...


Nem træning af lår, arme og mave?

Share this post


Link to post
Share on other sites
HI

 

I just get a blank page when i run the script manually. And i only recieve one email. That is the email telling me that i have used the script and that 0 emails where sent.. I've changed the "Days delay for review email" to "2" and "Review email limit" to "0"(I am using guest account so my costumers doesnt signup at my newsletter automatically...

 

Any ideas on why i dont get the email?

 

My site has no problems sending emails out...

Did you remove the first line of review_mail.php, the one that says

#!/usr/local/bin/php

That line should always show when you test the page manually. It should also be the only thing on the page.

 

Did you run the SQL command in the instructions? Did you create a test order per the instructions? Did you set the date of this order to at least three days ago? Did you set the orders_status of that order to 3?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I havent removed the first line of code in review_mail.php (should i do that???)

 

I have runned the SQL command, and when i look in my database the table order has a field named "reminder_sent" so everything looks fine there.. (and the line in "Configuration" exists as well)

 

I have created a test order, and set the date to 2008-01-01. And i have also set the order status to 3.

 

And the configuration:

 

Days delay for review email 2

Review email limit 0

 

 

So i really dont understand what can be wrong.....


Nem træning af lår, arme og mave?

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the great contribution, it's working very well when running the script manually.

Right now I'm trying to get the Cron working but I don't succeed yet.

 

In the email from the cron I get the following errors

 

Warning: file(review_mail.tpl): failed to open stream: No such file or directory in /home/***/domains/***.nl/public_html/automatic/review_mail.php on line 162

Warning: implode(): Bad arguments. in /home/***/domains/***.nl/public_html/automatic/review_mail.php on line 162

Warning: file(review_mail.tpl): failed to open stream: No such file or directory in /home/***/domains/***.nl/public_html/automatic/review_mail.php on line 162

Warning: implode(): Bad arguments. in /home/***/domains/***.nl/public_html/automatic/review_mail.php on line 162

 

 

Line 162 from review_mail.php:

 

$file_string = trim (implode ("", file ($text_file) ) );

 

 

 

The rel. path is set as following

$path_rel = '/home/***/domains/***.nl/public_html/';

 

The command in DirectAdmin > Cron is set to:

/usr/local/bin/php /home/***/domains/***.nl/public_html/automatic/review_mail.php

 

If anyone could please help me out here?

Thanks in advance.

Share this post


Link to post
Share on other sites
I havent removed the first line of code in review_mail.php (should i do that???)

 

I have runned the SQL command, and when i look in my database the table order has a field named "reminder_sent" so everything looks fine there.. (and the line in "Configuration" exists as well)

 

I have created a test order, and set the date to 2008-01-01. And i have also set the order status to 3.

 

And the configuration:

 

Days delay for review email 2

Review email limit 0

So i really dont understand what can be wrong.....

As I said above, the first line of review_mail.php should show when you run the script manually. Does it? Don't remove that line, you'll need it later.

 

For your test order ONLY, is the reminder_sent field in the Orders table set to 0? If not, change it.

 

That's all I can think of right now.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
<snip>

The rel. path is set as following

$path_rel = '/home/***/domains/***.nl/public_html/';

 

The command in DirectAdmin > Cron is set to:

/usr/local/bin/php /home/***/domains/***.nl/public_html/automatic/review_mail.php

 

If anyone could please help me out here?

Thanks in advance.

That relative path could be part of the problem -- it should be relative to the file location, not an absolute. Try setting it to:

  $path_rel = '../';

Also check that the review_mail.tpl file is in the folder along with the review_mail.php. Don't change the name of either of these files. And check that the files were not corrupted in the upload, or just reload them.

 

Please post again if none of that works, and I'll try to think of what else could cause this.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
As I said above, the first line of review_mail.php should show when you run the script manually. Does it? Don't remove that line, you'll need it later.

 

For your test order ONLY, is the reminder_sent field in the Orders table set to 0? If not, change it.

 

That's all I can think of right now.

 

Regards

Jim

 

The first line of review_mail.php arent showing.... Could this have something to do with it?


Nem træning af lår, arme og mave?

Share this post


Link to post
Share on other sites
The first line of review_mail.php arent showing.... Could this have something to do with it?

That could be a problem. That line is really only there to call the PHP processor when the file is run by CRON. It doesn't do anything when you're running manually.

 

Try checking the source of the manual output page. You could also add a line of text after that line and see if that shows up.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
That relative path could be part of the problem -- it should be relative to the file location, not an absolute. Try setting it to:

  $path_rel = '../';

Also check that the review_mail.tpl file is in the folder along with the review_mail.php. Don't change the name of either of these files. And check that the files were not corrupted in the upload, or just reload them.

 

Please post again if none of that works, and I'll try to think of what else could cause this.

 

Regards

Jim

 

Thanks for the reply!

 

Setting the relative path to ../ gives me the following error:

 

Warning: require(../includes/configure.php): failed to open stream: No such file or directory in /home/***/domains/***.nl/public_html/automatic/review_mail.php on line 23

Fatal error: require(): Failed opening required '../includes/configure.php' (include_path='.:/usr/local/lib/php') in /home/***/domains/***.nl/public_html/automatic/review_mail.php on line 23

 

I also tried to:

remove the first line of the script #!/usr/local/bin/php

add

chdir('/home/***/domains/***.nl/public_html/');

in the beginning of the script.

Unfortunately it didn't work out.

Share this post


Link to post
Share on other sites
Thanks for the reply!

 

Setting the relative path to ../ gives me the following error:

 

Warning: require(../includes/configure.php): failed to open stream: No such file or directory in /home/***/domains/***.nl/public_html/automatic/review_mail.php on line 23

Fatal error: require(): Failed opening required '../includes/configure.php' (include_path='.:/usr/local/lib/php') in /home/***/domains/***.nl/public_html/automatic/review_mail.php on line 23

 

I also tried to:

remove the first line of the script #!/usr/local/bin/php

add

chdir('/home/***/domains/***.nl/public_html/');

in the beginning of the script.

Unfortunately it didn't work out.

The path needs to be from the location of the review_mail.php file to the root of your osCommerce installation. I was assuming that was in /home/***/domains/***.nl/public_html/, which is apparently incorrect. You need to set that path correctly, or move the /automatic directory to the root of your osCommerce catalog.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The source code is empty. I cant see this line #!/usr/local/bin/php.

 

But if i write something as html it is shown as normal...


Nem træning af lår, arme og mave?

Share this post


Link to post
Share on other sites
The source code is empty. I cant see this line #!/usr/local/bin/php.

 

But if i write something as html it is shown as normal...

Your server may be treating that first line as a comment and not showing it. Since you can see HTML in the page, the script is running without errors. I suspect that you have no valid orders in your database that qualify for an email. Try running the test again, following the instructions in the Readme file.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
The path needs to be from the location of the review_mail.php file to the root of your osCommerce installation. I was assuming that was in /home/***/domains/***.nl/public_html/, which is apparently incorrect. You need to set that path correctly, or move the /automatic directory to the root of your osCommerce catalog.

 

Regards

Jim

 

You're assuming correctly. The folder automatic is placed in the root dir witch is /home/***/domains/***.nl/public_html/

The errors are kind of strange because the files has bin in the right location all the time. Some other cronjob has similar problems. I managed to fix that with the chdir posted earlier.

 

Do you have some other options for me? Thanks for the effort

Share this post


Link to post
Share on other sites
You're assuming correctly. The folder automatic is placed in the root dir witch is /home/***/domains/***.nl/public_html/

The errors are kind of strange because the files has bin in the right location all the time. Some other cronjob has similar problems. I managed to fix that with the chdir posted earlier.

 

Do you have some other options for me? Thanks for the effort

I was referring to the root of your osCommerce installation. I still don't know where that is, so I can't give you a path to it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
I was referring to the root of your osCommerce installation. I still don't know where that is, so I can't give you a path to it.

 

Regards

Jim

 

The root of the osCommerce installation is also /home/***/domains/***.nl/public_html/ I don't use catalog or something like that. Sorry about the confusion, I tought I made it clear in the previous post. Apperently not ;).

 

The path ../ should be correct. All files are present in the right place I've triple checked everything. When called manually the script is working fine.

Share this post


Link to post
Share on other sites
The root of the osCommerce installation is also /home/***/domains/***.nl/public_html/ I don't use catalog or something like that. Sorry about the confusion, I tought I made it clear in the previous post. Apperently not ;).

 

The path ../ should be correct. All files are present in the right place I've triple checked everything. When called manually the script is working fine.

Sorry, I misunderstood. I've seen CRON do this sort of thing before, and it's a real pain. I suspect that it's some server setting somewhere, sinc I don't have the problem on any of the machines I've installed this on.

 

Try changing everything to absolute paths. That is, change line 17 to the full path (as you had it before.) Then change line 161 to a full path, like

$text_file = '/home/***/domains/***.nl/public_html/review_mail.tpl';

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
Sorry, I misunderstood. I've seen CRON do this sort of thing before, and it's a real pain. I suspect that it's some server setting somewhere, sinc I don't have the problem on any of the machines I've installed this on.

 

Try changing everything to absolute paths. That is, change line 17 to the full path (as you had it before.) Then change line 161 to a full path, like

$text_file = '/home/***/domains/***.nl/public_html/review_mail.tpl';

Regards

Jim

 

You're the best! It's working, thanks a lot!

 

Great contribution, even better support. Thanks again.

Share this post


Link to post
Share on other sites

Great contribution, easy to install and great instructions!! I have a small problem that I am sure is easy to answer. The email sends fine but the link in the body points to the wrong location. I need it to point to https://mystore.com/catalog/product_reviews_write.php?products_id=13877 instead of https://mystore.com/product_reviews_write.p...oducts_id=13877. It is my understanding that I need to change line 17 in review_mail.php to reflect this change, but am unsure what to change it to. Could someone please advise me what it should be changed to? My suggestions below!

 

$path_rel = '../../'; or $path_rel = '/../'; or $path_rel = 'catalog/../';

 

 

I just want to correct this before I send it out to customers.

 

 

Your help is greatly appreciated!!!!

Share this post


Link to post
Share on other sites
Great contribution, easy to install and great instructions!! I have a small problem that I am sure is easy to answer. The email sends fine but the link in the body points to the wrong location. I need it to point to https://mystore.com/catalog/product_reviews_write.php?products_id=13877 instead of https://mystore.com/product_reviews_write.p...oducts_id=13877. It is my understanding that I need to change line 17 in review_mail.php to reflect this change, but am unsure what to change it to. Could someone please advise me what it should be changed to? My suggestions below!

 

$path_rel = '../../'; or $path_rel = '/../'; or $path_rel = 'catalog/../';

I just want to correct this before I send it out to customers.

Your help is greatly appreciated!!!!

$path_rel is set correctly if you are not getting any error messages when you run automatic/review_mail.php manually. From the information you gave, I don't believe that this is the problem.

 

The link to product_reviews_write.php is in the variable $link_server (see lines 57-61 of automatic/review_mail.php.) This is set by either HTTP_SERVER or HTTPS_SERVER from your catalog/includes/configure.php or catalog/includes/local/configure.php. I suspect that HTTPS_SERVER is incorrectly set. Fixing the config file settings is a pain, but you are likely to see other problems with your store if you don't get those settings right.

 

As a quick hack, you can just change line 131 to

			$products_string .= '  ' . $link_server . '/catalog/product_reviews_write.php?products_id=' . $products_array['products_id'] . "\n";

This is a poor long-term solution. It will not work if you change your store settings in the future, and will not work if you use this code on a store that is set up differently.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×