Jump to content
Sign in to follow this  
cleverflo

Paypal IPN incorrect link

Recommended Posts

Hi,

 

I have managed to install the Paypal IPN v2.3. When I tried to pay for a test order, I got the following error message:

 

The link you have used to enter the PayPal system contains an incorrectly formatted packing value.

 

How can I solve that?

 

Thanks,

 

Florence

Share this post


Link to post
Share on other sites
Hi,

 

I have managed to install the Paypal IPN v2.3. When I tried to pay for a test order, I got the following error message:

 

The link you have used to enter the PayPal system contains an incorrectly formatted packing value.

 

How can I solve that?

 

Thanks,

 

Florence

 

It's me replying to myself. It seems to be working now. I create a new item and the payment went through. Maybe the problem is with items pre-loaded with the installation. Don't know, don't care, as long as it works for my products.

Share this post


Link to post
Share on other sites
It's me replying to myself. It seems to be working now. I create a new item and the payment went through. Maybe the problem is with items pre-loaded with the installation. Don't know, don't care, as long as it works for my products.

 

Hi, I get the same error message of "The link you have used to enter the PayPal system contains an incorrectly formatted packing value", and have tried it with newly created items, but I still get the same error message back from paypal. I'm also using the new 2.3 version of the IPN. Any ideas?

 

Regards Rob.

Share this post


Link to post
Share on other sites
Hi, I get the same error message of "The link you have used to enter the PayPal system contains an incorrectly formatted packing value", and have tried it with newly created items, but I still get the same error message back from paypal. I'm also using the new 2.3 version of the IPN. Any ideas?

 

Regards Rob.

 

Hi Rob,

 

I created my new item in a new category. Maybe the links for the existing categories and items are wrong.

 

I have just tried again with one of the existing item, the keyboard and when I put it in my cart it appears in red first, then I went through the checkout and same error message appears..

 

Retried with my own item, no problem.

 

So my advice is to create a new category with your new item and try. Hope that helps.

 

Flo

Share this post


Link to post
Share on other sites

I installed 2.3 but get the same error "PayPal system contains an incorrectly formatted packing value"

 

I have 2000+ products so cant change them

 

anyone know why this happens - the devosc paypal contrib works fine but this one is much better

 

thanks

 

jody

 

Hi Rob,

 

I created my new item in a new category. Maybe the links for the existing categories and items are wrong.

 

I have just tried again with one of the existing item, the keyboard and when I put it in my cart it appears in red first, then I went through the checkout and same error message appears..

 

Retried with my own item, no problem.

 

So my advice is to create a new category with your new item and try. Hope that helps.

 

Flo

Share this post


Link to post
Share on other sites

It seems to me that the paypal error message (PayPal system contains an incorrectly formatted packing value) occurs when osCommerce sends details to paypal with one or more products in it's basket which are priced with VAT on them. But...

 

Strangely, this only happens when products that were added 'pre-PayPal IPN contribution' are being checked-out.

Even if only one of the products (pre-cont.) in the basket have VAT, the error will occur. Remove the product's VAT (from the drop-down menu) and the details are sent to PayPal without a problem.

 

I am not a coder, just a juggler so any help would be much appreciated.

 

(-_-)v

Edited by pegasus_paradox

------------------------------------------------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

I got this same problem. I tried creating a new product, and removing the TAX but still go the same problem.

 

What i was actually testing was trying to get CCGV(trad) and IPN 2.3 working together (yes i know they dont play nice but i thought there must be a way to get them to). In my case once I took away the voucher in the users order the issue went away.

 

So is it something to do with the total calculation maybe and the wrong value being generated and then passed to paypal? Certainly would be consistent with the idea that with tax on the problem can happen.

 

Any one else have any ideas. :'(

Share this post


Link to post
Share on other sites

I had the same problem when using "PayPal IPN v2.3.4.6" and the "super download store" addons (still testing if they work together without problems at all).

I could solve the problem by editing the "PayPal IPN v2.3.4.6" settings from transaction type = "aggregate" to "per item". Maybe this helps...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×