Jump to content

Archived

This topic is now archived and is closed to further replies.

di_stephano20

How to remove osCsid from url?

Recommended Posts

what is the best known contribution to remove the osCsid from an url? I am using Ultimate SEO, but my osCsid is still showing up! What do you recommend? Please post here the link to the contributions, or any code hacks that you are aware of! Thanks in advance!

Share this post


Link to post
Share on other sites
what is the best known contribution to remove the osCsid from an url? I am using Ultimate SEO, but my osCsid is still showing up! What do you recommend? Please post here the link to the contributions, or any code hacks that you are aware of! Thanks in advance!

 

 

Make your cookie paths settings in includes/configure.php correct and the oscid will only show on the first 1-2 clicks on the site.

Share this post


Link to post
Share on other sites

well i tried to do that, but it still doesn't work! here's my config file:

 

define('HTTP_SERVER', 'http://www.pravaliadecalculatoare.ro');
define('HTTPS_SERVER', 'http://www.pravaliadecalculatoare.ro');
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', '.pravaliadecalculatoare.ro');
define('HTTPS_COOKIE_DOMAIN', '.pravaliadecalculatoare.ro');
define('HTTP_COOKIE_PATH', '/cookies/');
define('HTTPS_COOKIE_PATH', '/cookies/');
define('DIR_WS_HTTP_CATALOG', '/');
define('DIR_WS_HTTPS_CATALOG', '/');
define('DIR_WS_IMAGES', '/images/');
define('DIR_WS_ICONS', '/icons/');

 

any ideas?

Share this post


Link to post
Share on other sites

change

define('HTTP_COOKIE_PATH', '/cookies/');

define('HTTPS_COOKIE_PATH', '/cookies/');

 

if your shop is is in the root

 

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

 

if your shop is in a sub folder, then the name of the folder..

 

for instance if you have your shop in the catalog folder then:

 

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

Share this post


Link to post
Share on other sites
change

if your shop is is in the root

if your shop is in a sub folder, then the name of the folder..

 

for instance if you have your shop in the catalog folder then:

 

 

I think that some shops need more than this adjustment.

 

I already installed shops with the path empty and oscid disappears in the second click.

 

But have also installed stores with the full cookie path and not solved. The OsCsid still appearing on all pages.

 

Is there any relationship with the PHP version , Mysql or something so?

 

Marvin

Share this post


Link to post
Share on other sites

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://www.futomart.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

 

 

This is what I have and osCsid is still apearing. When I put 'Force Cookies' then its ok but I cannot login or anything. I have Ultimate Seo's as well....

 

What could be the problem ?

 

Session directory is /tmp/


The creator of www.futomart.com

Share this post


Link to post
Share on other sites

change this:

 

define('HTTP_COOKIE_DOMAIN', 'http://www.futomart.com');

 

to

 

define('HTTP_COOKIE_DOMAIN', '.futomart.com');

Share this post


Link to post
Share on other sites

Hello,

 

I have read the posts and i've donned the same settings in my config file - and also it not works, the only way to remove oscsid from urls is to set from the admin force cookie use but users cannot log in.

 

define('HTTP_SERVER', 'http://www.paradisulzoo.ro'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', '.paradisulzoo.ro');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

im using SEO urls

please help me

Share this post


Link to post
Share on other sites

NoPb

 

if you have correctly setup cookie domains

 

just add this

 

define('SESSION_FORCE_COOKIE_USE', TRUE);

 

in your configure.php file

 

done

Share this post


Link to post
Share on other sites

hi there ...

 

after using the define('SESSION_FORCE_COOKIE_USE', TRUE); statement in my configuration file, it worked until I use the "Refresh" functionality of the browser.

 

After refreshing the page within the first few clicks the osCid is appearing again ... *sigh*

 

Any ideas?

 

Thanks and regards

Share this post


Link to post
Share on other sites
just add this

 

define('SESSION_FORCE_COOKIE_USE', TRUE);

 

in your configure.php file

The includes/configure.php is the wrong place to make this change. Instead, go to admin > Configuration > Sessions and set it to true there.

Always back up before making changes.

Share this post


Link to post
Share on other sites

Some essential info and why you must ensure you don`t loose osCsid http://forums.oscommerce.com/index.php?sho...c=330479&hl

 

You should'nt worry so much with the sid, ussually it will only appear on the first page browsed, just ensure your safe with search engines by turning on Prevent Spider Sessions and updateing spiders.txt


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hello,

 

I think we have all as per suggested in this thread but its still a problem... We are getting osCsid in URls. We have used,

 

  define('HTTP_SERVER', 'http://www.domainname.com');
 define('HTTPS_SERVER', 'http://www.domainname.com');
 define('ENABLE_SSL', false);
 define('HTTP_COOKIE_DOMAIN', '.domainname.com');
 define('HTTPS_COOKIE_DOMAIN', '.domainname.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');

 

We have also installed Ultimate Seo Urls 5:

 

http://addons.oscommerce.com/info/6768

 

Please help.

 

Thanks,


Hardik Vyas

HV InfoTech

Share this post


Link to post
Share on other sites

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://www.futomart.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

 

 

This is what I have and osCsid is still apearing. When I put 'Force Cookies' then its ok but I cannot login or anything. I have Ultimate Seo's as well....

 

What could be the problem ?

 

Session directory is /tmp/

 

I installed OSC on localhost and i have same with you, i tried more configure but when i log in, it redirect to cookie_usage.php although my browser is enable Cookie. Somebody can help me?

Share this post


Link to post
Share on other sites

×