Jump to content
Sign in to follow this  
wasson65

EasyPopulate 1.0 - Populate your store from Excel / csv

Recommended Posts

Sorry to post agian, but I installed 2.0 to test it and when I try to upload I get the following:

 

Warning: Unable to create '/var/www/html/catalog/temp/EP1038337199.txt': Permission denied in /var/www/html/catalog/admin/includes/functions/general.php on line 783

 

Warning: Unable to move '/tmp/phpw61ASE' to '/var/www/html/catalog/temp/EP1038337199.txt' in /var/www/html/catalog/admin/includes/functions/general.php on line 783

 

 

File uploaded.  

Temporary filename: /tmp/phpw61ASE

User filename: EP1038337199.txt

Size: 386

 

Warning: file("/var/www/html/catalog/temp/EP1038337199.txt") - No such file or directory in /var/www/html/catalog/admin/easypopulate.php on line 737

 

Warning: Invalid argument supplied for foreach() in /var/www/html/catalog/admin/easypopulate.php on line 742

| | | | | | | | | | | | | | | | |  

 

No products_model field in record or incorrect root for category. I cannot import this record!  

 

I checked line 783 to see what it looked like and I just do not quite know enough to know if that is the problem or if its something else.

 

I am thinking that I need to specify the temp directory there or something.

 

here is what the line consists of  

 

mvoe_uploaded_file($filename['temp_name'], $target);

 

The new easypopulates use a temp directory to store the excel sheets in, so it can split them if it needs to. You just need to go into the catalog folder and create a folder called "temp"


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Barry, read the post right above yours,,

 

 

 

Dreamscape, I thought that right off the bat, and put one there but that didn't help, do I have to point to that in the easypopulate.php or the general.php, or is it allready done?

 

I added temp, but I get the same thing, actually the first time the first error said no such file or directory,

 

I added a temp folder and now it says permision denied. so I chmod 666 it and nothing changed.

 

Sorry for any stupidity on my part


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

Kirk,

 

I dunno. creating the temp directory worked for me. I am developing on windowsXP though... but for development I have the permissions set to full permission on /catalog and all of its subdirectories and files.


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

hi kirk, i assume that you mean your post right above mine?

 

I don't think im breaching the 30 sec timeout as i've only got about 62 products so far in the file.

 

some of the descriptions are pretty long though.

 

cheers

barry


"A lie gets halfway around the world before the truth has a chance to get its pants on."

 

"I don't want to achieve immortality through my work; I want to achieve immortality through not dying."

Share this post


Link to post
Share on other sites

Barry,

 

I do not know if this will help but what size is the file you are trying to upload?

 

after I ripped mine into300 products each, they were around 48k each

 

dreamscape, I don't know,,I just don't know


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

ah, got it to work, I went back in and went to the properties on the temp folder and the permisions did not get set right for some reason, I just checked all of the boxes and it worked, Sorry for the hastle if any


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

cheers kirk, i dunno why i didn't do it before now but i used the split box and it worked.

 

cheers

 

barry


"A lie gets halfway around the world before the truth has a chance to get its pants on."

 

"I don't want to achieve immortality through my work; I want to achieve immortality through not dying."

Share this post


Link to post
Share on other sites
I am running W2K / Apache and it does not split the file up.. any ideas ?

 

Kim,

 

are you using the 2nd entry box in easy populate? the top one says "upload and import into easypopulate" and the 2nd one says "upload and split file"... you wannt use that one... and then you should see the message like:

 

File uploaded.

Temporary filename: C:PHPuploadtempphp333.tmp

User filename: books.txt

Size: 30470

You can download your split files in the Tools/Files under /catalog/temp/EP_Split[1-1].txt, etc....

 

those are your split files that you use to import then...


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

It says :

 

File uploaded.

Temporary filename: C:PHPuploadtempphpDE.tmp

User filename: import.txt

Size: 726875

You can download your split files in the Tools/Files under /catalog/temp/EP_Split[1-1].txt

 

It generates 1 file and does not spilt it up... :(

 

 

Kim

Share this post


Link to post
Share on other sites

there is still a problem with something somewhere,

 

there has to be a limit seting somewhere that is being missed.

 

I finally got everything set up to import with no errors.

 

I take my 15000 products and try to use the split utility and I get nothing, no error and no confirmation, just like kim and barry were getting, and Like I was getting from the get go.

 

when I cut the file to say 3000 products then I can get messages like kim is reciving, but just as she had stated,, it is not being split up.

 

so I am going to try to determine where the point is that the messages quit coming, its almost like there is so much info that it is causing a buffer problem.

 

now on the split function when you are using a file small enough to work, like kims, instead of spliting the file it is actually making a copy, I look in the temp directory and there is a test with a file size of 401233 and a ep_split1.txt with the same size.

 

I will look at it but I am by no means a programer.


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

Exactly what i see Tim.

Let me know if I can assist you anyway to solve this problem.

When you have found the fix for this one - we have a 100% fine tuned import application !!!!!!

 

You are GOD Tim :)

 

Kim

Share this post


Link to post
Share on other sites

Ok when I tried to import 12000 I recived absolutly no messages

when I droped it down to 11500I got the message that the file had been uploaded but not split.

 

Granted the processor speed, memory and so on might make a difference but I don't think so.

 

So unless you can think of something that would be causing this and fix it, I would make a note in the doc that if the file has more than 11,000 products or if the file is larger than say 1.6Mb there could be a problem and that they may have to split the file manualy a few times and then use the built in spliter when that is fixed.

 

as for the built in spliter,

 

I have no clue


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

what do you do when you hose your own database?

 

 

deleted some things through mysql because deleting them through admin timed out and left some trash behind, now when I upload a file with products, I get the category and sub cat and no product under that, although it sais that there is products there when you look at the categories.

 

:?


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites
what do you do when you hose your own database?

 

 

deleted some things through mysql because deleting them through admin timed out and left some trash behind, now when I upload a file with products, I get the category and sub cat and no product under that, although it sais that there is products there when you look at the categories.

 

:?

 

You restore the backup you made before you started.

Share this post


Link to post
Share on other sites

hehe :lol: I knew that

 

 

 

 

Just added a few products manually and it fixed the problem,, go figure,

 

but it did however scare me just enough to start backups.


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

Sorry to be offline yesterday, I was travelling to my Dad's house with my 4 kids and 2 dogs. Unfortunately, one dog was somehow misplaced at a stop on the trip. So yesterday was shot.

 

But I'm here now and will read all the posts, and get answers out as needed.

 

Tim

Share this post


Link to post
Share on other sites

For those having trouble splitting large files, keep in mind that there is a file upload size limit set by your hosting service in their php.ini file. If the file size is too big they probably won't accept it. I'll need to test to verify.

 

As to why it's not splitting, I don't know, I'll need to check and see why.

 

I'll let everyone know.

Share this post


Link to post
Share on other sites

Confirming: Split isn't splitting. Troubleshooting now.....

 

It just wouldn't be a .0 release without something wrong, right?

 

 

;-)

Tim

Share this post


Link to post
Share on other sites

I have my own server, and my php.ini is set at 120sec

and 8m However, my file is less than 4Mb. and the process time that it uses when I try to upload the file is actually less than if I were to upload a 300 product file. its like the server says ok upload the file,,, then sees what it is and says never mind thats crazy.

 

 

Also, Tim, I am not asking you to code anything else, but I would like to know what you think, about this.

15000 some odd products, 2500 pics

My images are named the same as my products, so I just made a custom format in excel to ad a .gif after each number in the image column.

 

That worked great, but now I still have about 12500 products that are looking for thier product name.gif and it is not there. Is there an easy way to create a switch somewhere in osc that says:

 

Ok look for the given image name, if it is not found, default to image_not_avalibe.gif

???

Thanks, Kirk


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

Its ok man, before long you'll be taking over Microsoft

(somebody needs to) :lol:


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites
Confirming: Split isn't splitting.  Troubleshooting now.....

 

It just wouldn't be a .0 release without something wrong, right?

 

 

;-)

Tim

 

In easypopulate, around line 775, find a line that looks like this:

 	 if (substr($line,strlen($line)-10,9) == 'EOREOR'){

 

and change it to look like this:

 	 if (substr($line,strlen($line)-7,6) == 'EOREOR'){

 

This worked for me, if someone can test, and let me know I'll release 2.1

 

 

Thanks,

Tim

Share this post


Link to post
Share on other sites
--snip--

Also this may have been addressed allready but on the pictures, is it necessary to have the extention on the end such as .jpg or .gif?

If so is there a way to merge to cells together in excell. I just have the actuall name of the picture for my product. like

9557

04732

801187

and so on, they are all gifs but I do not want to have to type .gih for 15000 products so I thought mabey I could just populate two columns, one with the picture names and the other with nothing but .gif all of the way down and then merge them together, cut the column and past it into my upload file

 

 

Kirk

 

I could set up a default setting that would add an extension to the file name if none was given. Would this help in this case?

 

Tim

Share this post


Link to post
Share on other sites

Thats up to you on the picture deal, I just did a little research and found out how to make a custom format for excel and it automaticaly added the .gif for me. problem solved

 

 

You fixed the slipt option, Just tested 4000 products and it worked fine.


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×