Jump to content
Sign in to follow this  
wasson65

EasyPopulate 1.0 - Populate your store from Excel / csv

Recommended Posts

I have never had a problem with EP creating new categories. Are you sure you have a unique product model number for each product?

 

yes, i am, it's a code used every day by pharmaceutical professionals

ex : 7784345

 

the "solution" (!!!) i use actually is uploading twice the same file : awful, isn't it !?

 

:oops:

 

charles

Share this post


Link to post
Share on other sites

my product names and descriptions do not update even when I am for sure updating the right txt file with EP. It's as if the page hasn't refreshed, or the new information is not copying over the old. can anyone help me?

 

-mark

Share this post


Link to post
Share on other sites

forgot one thing that i'm also having trouble with.

 

How do I get rid of the category pictures (which I don't have and are seen as the annoying red x box) above the items listed?

 

-mark

Share this post


Link to post
Share on other sites
forgot one thing that i'm also having trouble with.

 

How do I get rid of the category pictures (which I don't have and are seen as the annoying red x box) above the items listed?

 

-mark

 

try the search in the right top corner :twisted: or wiki.oscommerce.com

 

ANSWER is golden that way


Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Share this post


Link to post
Share on other sites

Hi druide, thanks for the tip. I looked at your site and am wondering how you were able to show your product descriptions as a bulleted list. Were you able to do that with Excel? and how did you get it to show up in a Cell? on seperate lines? I'm assuming you used Easy Populate to populate your product list.

 

-mark

Share this post


Link to post
Share on other sites

You can use html in your product descriptions, I assume that is what he did.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

one more question. I have had to change this one cart into 5 seperate carts, beacuse it was getting to bogged down with thousands of products this company wants online. So I've created the seperate carts fine, and now the question is how to link the pictures from each cart to one directory outside of the cart's directories. I've looked in the configuration.php but I do not know php well or how to change the default image paths to something outside the cart directory. thanks as always.

 

-mark

Share this post


Link to post
Share on other sites

This is a question that needs a new topic.....


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

ok, sorry about that, the new topic is called, "Help with catalog image paths"

 

-mark

Share this post


Link to post
Share on other sites

i update the price but the old price still staying the same.

 

Anyone knows why? please help

 

Thanks in Advance

Share this post


Link to post
Share on other sites

Hello, you there.

 

I am using prefixes for my database, and then Easy Populate dind't work as the tables were called DIRECTLY in most cases.

 

With a good editor and a nice search function, I replaced all the direct calls to the apropriate table-calls and now it requires the database_tables.php in the admin-dir.

(if this is not there, then you have other problems than EP, I guess)

I am pretty sure that I got all the direct calls, exept if other sql-queries than "insert", "update" and "select" are used in this script.

 

OK, I am having this file,

and I'd be glad if someone could tell me now,

 

a) wheter there are persons who are willing to test it ?

(downloading the data in such a tab-txt-file works quite well for me, but i don't know all the options

B) whether I was allowed to change this file ?

c) whether I now have to open this code to the public and how to do this.

 

(As you might guess I am completely new to Open Source; so please apologize my newbie questions)

 

CU, karlheinz Meier a.k.a. forgotten_soul

Share this post


Link to post
Share on other sites

ok i have a quick question before i download this. i have multi vendor mod in my store, will this mod create a custom field for what vendor to ship with when i download my current products or do i manually have to enter the field for this out of my database into the coding?

Share this post


Link to post
Share on other sites

I like to say thanks for this contribution first, and second, I have read the whole manual. Those things being said, I didn't have any trouble until I had to start changing the "Image" names. I am not entirely certain I have them correct or not.

 

When I reuploaded the eaypopulate.php file I am getting a parse error on line 1651, which is shown below.

 

I have MS 2.2 installed with the additional images contrib also installed. I looked at my database and took the names off the table there.

 

I need some guidance as to:

 

1. The cause of the parse error

 

2. Do I have the images named right in these places:

 

	$query .=         $v_products_image . '", "'

    	 . $v_products_additional_images_id . '", "'

    	 . $v_products_medium_images . '", "'

    	 . $v_products_popup_images . '", "'

    	 #. $v_products_subimage2 . '", "'

    	 #. $v_products_bsubimage2 . '", "'

    	 #. $v_products_subimage3 . '", "'

    	 #. $v_products_bsubimage3 . '", "'

 



------>line 1651  $query .=        "     '$v_products_model',

       '$v_products_price',

       '$v_db_status',

       CURRENT_TIMESTAMP,

       $v_date_added,

       $v_date_avail,

       '$v_tax_class_id',

       '$v_products_weight',

       '$v_products_quantity',

       '$v_manufacturer_id')

 

I didn't have the parse error before I changed the names. Thanks for your assistance & time.

Cindyd

Share this post


Link to post
Share on other sites

How do all you people make a file for upload from your list of your suppliers ? Sorry for my bad english.

I mean, I have a shop where I sell computer hardware. I have different suppliers. Some have their products and prices listed in excel files, others not they only have a web site with their prices. Is there a way I can grab these products with prices, calculate my sell price for them. And generate a file which I can use with easy populate ?

Share this post


Link to post
Share on other sites

I am receiving this error. I have no image mods running so I am commenting out the extras, if I use */ it does nothing when I upload, if I use #or // I get

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'UPDATE products SET products_price="2.00" ,products

 

UPDATE products SET products_price="2.00" ,products_image="" ,products_weight="0" ,products_tax_class_id="1" ,products_date_available= CURRENT_TIMESTAMP ,products_date_added= "2/23/2003 13:16" ,products_last_modified=CURRENT_TIMESTAMP ,products_quantity="0" ,manufacturers_id=NULL , products_status=0 WHERE (products_id = "28")UPDATE products SET products_price="2.00" ,products_image="" ,products_weight="0" ,products_tax_class_id="1" ,products_date_available= CURRENT_TIMESTAMP ,products_date_added= "2/23/2003 13:16" ,products_last_modified=CURRENT_TIMESTAMP ,products_quantity="0" ,manufacturers_id=NULL , products_status=0 WHERE (products_id = "28")

 

[TEP STOP]

 

Here is that section

 

$query = 'UPDATE products

SET

products_price="'.$v_products_price.

'" ,products_image="'.$v_products_image;

 

// unmcomment these lines if you are running the image mods

 

$query .= //. $v_products_mimage . '", "'

//. $v_products_bimage . '", "'

//. $v_products_subimage1 . '", "'

//. $v_products_bsubimage1 . '", "'

//. $v_products_subimage2 . '", "'

//. $v_products_bsubimage2 . '", "'

//. $v_products_subimage3 . '", "'

//. $v_products_bsubimage3 . '", "'

 

 

$query .= '" ,products_weight="'.$v_products_weight.

'" ,products_tax_class_id="'.$v_tax_class_id.

'" ,products_date_available= ' . $v_date_avail .

' ,products_date_added= ' . $v_date_added .

' ,products_last_modified=CURRENT_TIMESTAMP

,products_quantity="'.$v_products_quantity.

'" ,manufacturers_id='.$v_manufacturer_id.

' , products_status='.$v_db_status . '

WHERE

can anyone please help?? This is driving me nuts...

Thanks

Share this post


Link to post
Share on other sites

Do anybody know how to specify the catagory image for the number of different subcatagories in easy populate. It will automatically create however many subcatagories you want but there is no field for the catagory image, in turn after it is uploaded ther are a bunch of catagories and subcatagories without pictures.

 

Mike

Share this post


Link to post
Share on other sites

Hi

 

I am trying to install EP but get this error

 

Fatal error: Failed opening required 'includes/database_tables.php' (include_path='') in /home/sites/site1/web/catalog/admin/easypopulate.php on line 319

 

Which is refering to

 

require('includes/database_tables.php');

 

But I do not have a clue why this is not in my admin/includes or how I can get it.

 

I have Loaded 5 OSC

 

Thanks

Phil


Phil Townsend

Waterslap Farm, Airth

Falkirk Stirlingshire FK2 8QW

Share this post


Link to post
Share on other sites

Hi, I am no expert but I had the same issue. All I did was create a blank database_tables.php file and put it in there. That stopped the error. Now there may be more errors coming that I do not know about yet. but it got me past that one for now.

 

Joanna

Share this post


Link to post
Share on other sites

I do have a question about Easy Populate. I need to have the cost of the item in addition to the price in the database. Though not visible of course. is this possible for me to add without messing everything up ;) ?

 

Thanks

 

Joanna

Share this post


Link to post
Share on other sites

hi, back again. Now I'm having to update a clients cart that I worked on a few months ago. I upgraded the cart to the newest msc2.2 version. I also have downloaded the newest version of EP. When i upload the same .txt files I had done before the upload now fails with this error.

 

Warning: move_uploaded_file(/home/cbarbcon/public_html/medcart/catalog/temp/medcatalogpart1.txt): failed to open stream: No such file or directory in /home/cbarbcon/public_html/medcart/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpZEODEx' to '/home/cbarbcon/public_html/medcart/catalog/temp/medcatalogpart1.txt' in /home/cbarbcon/public_html/medcart/admin/easypopulate_functions.php on line 32

 

 

File uploaded.

Temporary filename: /tmp/phpZEODEx

User filename: medcatalogpart1.txt

Size: 1700232

 

Warning: file(/home/cbarbcon/public_html/medcart/catalog/temp/medcatalogpart1.txt): failed to open stream: No such file or directory in /home/cbarbcon/public_html/medcart/admin/easypopulate.php on line 730

 

Warning: Invalid argument supplied for foreach() in /home/cbarbcon/public_html/medcart/admin/easypopulate.php on line 748

 

 

 

 

 

of course, the first guess is chmod 777 catalog/temp dir. I have done that, in fact it had always been set to that since I last worked on it using EP. Is it because of the new versions? is there something I'm missing with these new versions?

 

-mark

Share this post


Link to post
Share on other sites
hi, back again.  Now I'm having to update a clients cart that I worked on a few months ago.  I upgraded the cart to the newest msc2.2 version.  I also have downloaded the newest version of EP.  When i upload the same .txt files I had done before the upload now fails with this error.

 

Warning: move_uploaded_file(/home/cbarbcon/public_html/medcart/catalog/temp/medcatalogpart1.txt): failed to open stream: No such file or directory in /home/cbarbcon/public_html/medcart/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpZEODEx' to '/home/cbarbcon/public_html/medcart/catalog/temp/medcatalogpart1.txt' in /home/cbarbcon/public_html/medcart/admin/easypopulate_functions.php on line 32

 

 

File uploaded.

Temporary filename: /tmp/phpZEODEx

User filename: medcatalogpart1.txt

Size: 1700232

 

Warning: file(/home/cbarbcon/public_html/medcart/catalog/temp/medcatalogpart1.txt): failed to open stream: No such file or directory in /home/cbarbcon/public_html/medcart/admin/easypopulate.php on line 730

 

Warning: Invalid argument supplied for foreach() in /home/cbarbcon/public_html/medcart/admin/easypopulate.php on line 748

 

 

 

 

 

of course, the first guess is chmod 777 catalog/temp dir.  I have done that, in fact it had always been set to that since I last worked on it using EP.  Is it because of the new versions?  is there something I'm missing with these new versions?

 

-mark

I had the same errors as you and then changed the path to the temp directory in

admin/easypopulate.php

 

to

 

$tempdir = "temp/";

$tempdir2 = "/temp/";

 

and that worked 4 me.

 

Hopes it helpes.

Share this post


Link to post
Share on other sites

Let me just take 1 second to congratulate you on creating a great contribution.... it makes life a lot easier.

 

I have an issue when you update a product, only changing the category (the imported data was incorrectly categorised). Easy populate updated the database - the product table but did not delete the existing corresponding entry in the Products_to_categories table - therefore making the product appear in both categories...... (Since there was two listings of the same product id, each with different category ids)

 

I started looking through all the listing in this forum, but couldn't find any mention of this issue, please excuse me if there is a resolution to it already, and kindly point me towards it.

 

Thanks

Francois.

Share this post


Link to post
Share on other sites

Hi Everyone,

 

Great Contribution.... Then I mucked it up somewhere. It was working fine and now it isn't. Please help me out if possible, I'm getting this error:

 

1064 - You have an error in your SQL syntax near '", "", "", "", "", "", "", " 'MAX-BLAST', '175', '1', ' at line 14

INSERT INTO products ( products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( 'bags/max-blast-s.gif',bags/max-blast-b.gif", "", "", "", "", "", "", " 'MAX-BLAST', '175', '1', CURRENT_TIMESTAMP, "0000-00-00 00:00:00", "0000-00-00 00:00:00", '', '0', '10', '11')

 

Also, I was just going to live with this, but since I'm asking the above question, I'll ask this next one also.

 

How can I set up my EZpopulate upload so that my images will show at the category level. That is when I click on a category all the images for the subcategories show up. For some reason, if I input manually it works, if I upload with EZpopulate, it doesn't.

 

Thanks for all the effort everyone puts in on this board. I'm still a newbie, but hope to be able to contribute once I get this site launched and am up the learning curve a bit.

 

Cheers,

 

Dave

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×