Jump to content
Sign in to follow this  
quicklyshop

Ebay auction manager for OSCOMMERCE

Recommended Posts

Just a note in /admin/includes/languages/english/auction_listing_item.php I would take the . out after the auction_finder.php in the URL that's sent to the customer. That . causes all kinds of problems, I receive tons of emails that people get Invalid Page errors.


Sean Hull

Share this post


Link to post
Share on other sites

Auctionblox

 

for this title fix, is there an easy way to put in the fix or do we need to send up the full mod again?

 

Regards

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites
for this title fix, is there an easy way to put in the fix or do we need to send up the full mod again?

 

Yes, simply copy the new version of /admin/auction_listing_item.php

Share this post


Link to post
Share on other sites
Ok I really got it this time. I found a little javascript that determins what kind of browser you are using and exicutes script accordingly. Check this out:

 

<script language="JavaScript" 
type="text/JavaScript">
if(navigator.appName == "Microsoft Internet Explorer") 
{
document.write("<object type='text/x-scriptlet' data='http://smittys.pointclark.net/auctions/product_info.php?products_id=28' width='100%' height='1300'></object>")
}
else
{
document.write("<object type='text/html' data='http://smittys.pointclark.net/auctions/product_info.php?products_id=28' width='100%' height='1300'></object>")
}
</script>

 

:D :D

 

Now that we got that out of the way back to php :) .....The auto email at the end of the auction.

Am I right in thinking that I'd just create an auction and instead of putting details about my product in i'd just paste the link into the screen (obviously changed with my details on)

Share this post


Link to post
Share on other sites

Fatal error: Call to undefined function: curl_init() in /home/scrapboo/public_html/catalog/admin/includes/functions/get_auction_info.php on line 65

 

My hosting tells me that curl is installed, but the above leads me to believe otherwise. Also I cant find any reference to cURL in the server info. I just installed the latest auction manager, and autoupdate.

Any thoughts?

 

thanks

gerald

Share this post


Link to post
Share on other sites

Can anyone please help. My site is down and I don't know what to do about it.

 

After uploading the Auto Update & the Auction Manager I now get this error when you click on a category or try to do a search for a product.

 

Fatal error: Cannot pass parameter 3 by reference in /home/enchant/public_html/catalog/includes/modules/product_listing.php on line 13

 

 

Thanks!

Share this post


Link to post
Share on other sites
Yes, simply copy the new version of /admin/auction_listing_item.php

Thanks Auctionblox

 

Regards

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

Hello everyone,

Let me try to answer some questions,

 

steve*** -thats right! You can just copy and past that code into ebay's item description field. The New Automated Auction Manager their will be a link to create this code for you, so all you will have to do is copy and paste.

 

gschep -You definatly have a cURL problem. Your hosting may have it but do they have the curl for php module and is it enabled? You should see something like this in server info:

 

curl

 

CURL support enabled

CURL Information libcurl 7.9.8 (OpenSSL 0.9.7a) (ipv6 enabled)

 

If you do not see something like this the module is not installed.

 

Try here for more answers

http://www.php.net/manual/en/ref.curl.php

 

http://curl.sourceforge.net/

 

Update on the Automated Auction Manager

Almost done, I have the basic structure up and running, now just the little stuff. It should be done in about a week, and it will be well worth the wait. :D :D


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

Hey Smitty1

 

Know of anyway to hid the folder and default product set up for the auto update you fixed, so that a unnamed catagory wont show up in the structure? such as when using catagory tabs?

 

greatful for any thoughts from anyone,,

 

Regards

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

Well Qwiz that has to do with the whole maping thing. If we could come up with some kind of generic product script to map it to then add this as maybe a module?

I don't think it would be to difficult to do, but my hands are tied right now. I have decided to call My Automated Auction Manager "Automated Auction Process" so it won't be confused with Auctionblox's contrib.

 

Coming very soon!

:D :D


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

Has anyone sucessfully added this contribution to their website? If someone has could you please show me a working example. And also which contribution did you use?

 

Thank you

 

Mike

Share this post


Link to post
Share on other sites

Harborsales -

 

You can see a version of the eBay Auction Sales Manager for MS2 at http://demo.auctionblox.com/oscommerce/admin

 

A Quick Start Guide on how to use it is included contribution download at:

http://www.oscommerce.com/community/contributions,1577

 

This does not include Smitty1's Auto Update contribution.

Edited by auctionblox

Share this post


Link to post
Share on other sites
Hey Smitty1

 

Know of anyway to hid the folder and default product set up for the auto update you fixed, so that a unnamed catagory wont show up in the structure? such as when using catagory tabs?

 

greatful for any thoughts from anyone,,

 

Regards

Tom

I use this contrib http://www.oscommerce.com/community/contributions,326

 

I diable the catagory, then disable the default item. I have no problems with using this.

Share this post


Link to post
Share on other sites

i noticed that when a customer checks out using ebay contribution, their info is not stored on the oscommerce's shopping cart with all the rest of the accounts. Shouldnt their be a way to pass all the customer's info into oscommerce's account manager so they can log in later and track the order?

Share this post


Link to post
Share on other sites

another problem i found is that my auction list doesnt display a price above $999. This im assuming because the number of digits cant exceed 6 (inlcuding the cents). is there a way to remove the 2 digits after the decimal to make more room for the 1000's and 10000's digit? Cents isnt so much of a significance when i reach a $1000 auction.

Edited by dimports

Share this post


Link to post
Share on other sites

i get an error when i edit and update the auction, i get this:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/designi/public_html/catalog/admin/includes/languages/english/auction_listing_item.php:55) in /home/designi/public_html/catalog/admin/includes/functions/general.php on line 18

anyone know why this is?

Share this post


Link to post
Share on other sites

when the ebay manager sends an email, it looks like the auction info is missing. Is it not yet implemented or do i have an error? The subject says "Checkout of:" with nothing after the collon. In the email body it says "Thank you for your Design Imports purchase of:" with nothing after the collon again. How does it work for everyone else.

Share this post


Link to post
Share on other sites
when the ebay manager sends an email, it looks like the auction info is missing. Is it not yet implemented or do i have an error? The subject says "Checkout of:" with nothing after the collon. In the email body it says "Thank you for your Design Imports purchase of:" with nothing after the collon again. How does it work for everyone else.

There is a new update, realeased about 3 days ago that fixes this problem.

Share this post


Link to post
Share on other sites
i noticed that when a customer checks out using ebay contribution, their info is not stored on the oscommerce's shopping cart with all the rest of the accounts. Shouldnt their be a way to pass all the customer's info into oscommerce's account manager so they can log in later and track the order?

This is a function of Purchase without an account. Re-check the install instructions with that. There is a section that mentions commenting out a big section of the anonymous accounts. If you do what it says you'll have new accounts created for everyone who checks out with the auction manager

Share this post


Link to post
Share on other sites

well noppie,

I tried the link and nothing. So I went to your admin (I hope you don't mind) to check out the scripts and see whats happening. Looks like all the scripts look ok.

The only thing is in File Manager when I went into the admin folder the link at the top looks like this:

 

/home/virtual/site37/fst/var/www/html/catalog//admin

 

Maybe there is a deeper issue than my contrib. See where the double // are, this could be a problem with the link. That could be why it can't find auction_update.php. Maybe a problem with configure.php? Anyways, your server can not find auction_update.php for some strange reason. Maybe permissions on that file? Try checking the permissions.

 

Hope that helps.


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites
well noppie,

I tried the link and nothing. So I went to your admin (I hope you don't mind) to check out the scripts and see whats happening. Looks like all the scripts look ok.

The only thing is in File Manager when I went into the admin folder the link at the top looks like this:

 

/home/virtual/site37/fst/var/www/html/catalog//admin

 

Maybe there is a deeper issue than my contrib. See where the double // are, this could be a problem with the link. That could be why it can't find auction_update.php. Maybe a problem with configure.php? Anyways, your server can not find auction_update.php for some strange reason. Maybe permissions on that file? Try checking the permissions.

 

Hope that helps.

Noppie,, Smitty1

 

I dont think its the // you noticed as when i am in my admin folder with the page file manager I too see that listed on mine and it works.

 

however,, I think you may have something with the file perm's,,, mine are set differently than Noppies,, maybe thats something she should look at ..

 

 

Regards

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

hey auctionblox, what file needed to be changed to fix the missing title bug. i dont wanna reload the entire file structure becuase my particular copy has many customizations. was the bug a fix one file or multiple files. thx as always genius. :)

Share this post


Link to post
Share on other sites
hey auctionblox, what file needed to be changed to fix the missing title bug. i dont wanna reload the entire file structure becuase my particular copy has many customizations. was the bug a fix one file or multiple files. thx as always genius. :)

dimports

I can help him out there and answer that one for ya,, he had to answer it for me a day or so ago,,

 

here is his response

 

Yes, simply copy the new version of /admin/auction_listing_item.php

 

 

Hope this helps

 

Regards

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×