Jump to content
Sign in to follow this  
quicklyshop

Ebay auction manager for OSCOMMERCE

Recommended Posts

noppie -all that update button is a link to auction_update.php. Make sure you have FILENAME_AUCTION_UPDATE listed oscommerce/admin/includes/filenames.php.

 

Do you have alot of auctions listed at ebay? This may slow the process down.

 

Hope that helps

:rolleyes:


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

i upgraded from beta 2, and now i do not see any kind of update button. I am able to manually key in to the auction_update.php any ideas? and "test product mappings" does not work. i get an errrow as it tries to point to:

 

catalog/admin/FILENAME_AUCTION_TEST_MAPPING

Share this post


Link to post
Share on other sites

Smitty

They are there. the ended one.. oh thank god..

I don't know what I did but they are there..

 

You guys are really the best.. I know I keep tellling you that. I really hopes this help us make a good wage..

 

but again it is there

 

NOPPIE


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

i fixed the test product mapping.

 

but i'm still missing the screen under admin to enter and update my ebay information

Share this post


Link to post
Share on other sites

It's really getting difficult for me to know when you guys are talking about the eBay auction manager that I contributed and the Auto Update contributed by Smitty1. (Looking back, I've given bad info on certain issues when I thought that they were related to my code.) If possible, when you post issues, can you try to determine from which contribution it originates?

 

Smitty1 - Perhaps this is because that are listed under the same contribution.

How about moving Auto Update to it's own contribution, and we can put a link to it in the description of the Ebay auction sales manager?

Share this post


Link to post
Share on other sites

Smitty

I spoke to soon..

 

My auctions are not updating..

 

This is what I did today..

i made a fresh install.

 

on my computer.. I make a copy of the ms2.2

then added the auto Update and the ebay manager and the paypalin and the purchase without an acount.. I also have gift certificats mod on there. could that have anything to do with it. I really dont' think so..

 

the auto update is my department. so when you hit the update button does it take you to a new page that says updating.... please be patient it stays there for about 5 seconds and then goes to the auction_listing.php page.

 

it is doing the samething as last night.. I see on the bottom status bar the My main page http://elle.rainbowstop.com for about 2 seconds and that is all..

 

I wait and wait and nothing else happens it doens't go into another page and ask to wait.

 

and then I check all auctions and nothing new is in there.

 

I am at my wits end I don't know what to do... my business partner is very irritated with me because i have spent so much time on here and not gotton to much on ebay..

 

Help HElp heLp

tHANK YOU

nAOMI


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

smitty, auctioblox, I think that may be wise, to seperate, but link the two contributions. Personally, I am not installing any of smitty's because I want to make sure it will be compatible with auctionblox's finished piece. Others however I know are interested in smitty's work though, but you are right, it is confusing to tell what people are talking about. Most people thing since it's all under one contribution it's all the same thing, and don't realize two diff people are responsible for them all.


Sean Hull

Share this post


Link to post
Share on other sites

auctionblox, I think you need to add a 'Not Offered' to the insurance. So when they go through checkout they don't always select the insured item, even though it's not insured. I know I'd set it to optional, it would show two things, same price one insured, one not. They'd click the insured (who wouldn't), something would happen, and I'd catch hell because they selected insurance.


Sean Hull

Share this post


Link to post
Share on other sites

I'm not sure what to tell you noppie. Try the link directly. Something like:

https://www.whatever.com/oscommerce/admin/auction_update.php

What happens? I mean this is a really basic thing, all it is, is a link to another page auction_update.php.

 

Hope this helps.

:rolleyes:

Edited by smitty1

REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

Hello Smitty

I really don't know what is going on.. sence i Just started the web site. deleted the whole thing and going to start from scratch again..

now when I up load the "10/22/2003 - Auto Update Author: Joseph Smith"

 

I did get the uploading please wait.. but nothing was loaded into the database..

 

I had the gift voucher contrib loaded on there I don't know if that is the problem.. but I am going to load it without that contrib..

 

I will keep you posted..

 

Noppie


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

noppie, as we stated, there are multiple parts. If you are trying to get to the auction_finder page, then that is a seperate contrib. As far as that particular error goes, I usually see it when I am missing something in the catalog/includes/filenames.php


Sean Hull

Share this post


Link to post
Share on other sites

auctionblox, found a small bug. When I first set up the auction, it send the email fine. But, when I edit it, and click update, and have it send the email again, then it doesn't include the Title in the message title, or in the message. It is blank. I was about to send reminders to people and I caught that.

 

Speaking of that. What about having it send reminders automatically on 3, 5 and 7 days or something. Either preset, or configurable. Also, having another verbage for the reminder. My reminder emails are a little most straightforward and firm than the initial one.


Sean Hull

Share this post


Link to post
Share on other sites

im also using STS contribution and its not working for me. im itching to use this so i was playing around with it to see why auction_finder comes blank. well i found out that not only this file comes back blank, but also the other auction files that reside in the catalog/ directory. so the ebay sale contribution is not writing anything on my catalog pages. but on the admin side it works perfectly. i even tried to write a string of words together right under the <body> section in the auction files but not even that showed up. i also tried removing the <html><header>and<body> tags from the begining since STS already puts these in the files. anybody using STS contribution and works for them?

Edited by dimports

Share this post


Link to post
Share on other sites

worldwidedvds

 

noppie, as we stated, there are multiple parts. If you are trying to get to the auction_finder page, then that is a seperate contrib.

 

I can find that page with no problem.. and I read and reread thiis forum.. I do do the research before I post.

 

 

the problem I have is i can't get the auctions to update.. or even load into the program

I can't get any auctions to import into my web site.

 

 

 

I am wondering if the curl I have which is below not working..

 

curl

CURL support enabled

CURL Information libcurl 7.9.2

 

I just don't know what to do.

Noppie

 

 

I deleted everything. and reloaded everything from scratch and still the same thing.


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

auctionblox,

Okay, I found this bit of code in the catalog/auction_checkout_process.php

  $sql_data_array = array('customers_id' => $customer_id,
                         'customers_name' => $order->customer['firstname'] . ' ' . $order->customer['lastname'],
                         'customers_company' => $order->customer['company'],
                         'customers_street_address' => $order->customer['street_address'],
                         'customers_suburb' => $order->customer['suburb'],
                         'customers_city' => $order->customer['city'],
                         'customers_postcode' => $order->customer['postcode'], 
                         'customers_state' => $order->customer['state'], 
                         'customers_country' => $order->customer['country']['title'], 
                         'customers_telephone' => $order->customer['telephone'], 
                         'customers_email_address' => $order->customer['email_address'],
                         'customers_address_format_id' => $order->customer['format_id'], 
                         'delivery_name' => $order->delivery['firstname'] . ' ' . $order->delivery['lastname'], 
                         'delivery_company' => $order->delivery['company'],
                         'delivery_street_address' => $order->delivery['street_address'], 
                         'delivery_suburb' => $order->delivery['suburb'], 
                         'delivery_city' => $order->delivery['city'], 
                         'delivery_postcode' => $order->delivery['postcode'], 
                         'delivery_state' => $order->delivery['state'], 
                         'delivery_country' => $order->delivery['country']['title'], 
                         'delivery_address_format_id' => $order->delivery['format_id'], 
                         'billing_name' => $order->billing['firstname'] . ' ' . $order->billing['lastname'], 
                         'billing_company' => $order->billing['company'],
                         'billing_street_address' => $order->billing['street_address'], 
                         'billing_suburb' => $order->billing['suburb'], 
                         'billing_city' => $order->billing['city'], 
                         'billing_postcode' => $order->billing['postcode'], 
                         'billing_state' => $order->billing['state'], 
                         'billing_country' => $order->billing['country']['title'], 
                         'billing_address_format_id' => $order->billing['format_id'], 
                         'payment_method' => $order->info['payment_method'],
                         'cc_type' => $order->info['cc_type'], 
                         'cc_owner' => $order->info['cc_owner'], 
                         'cc_number' => $order->info['cc_number'], 
                         'cc_expires' => $order->info['cc_expires'],
                         'date_purchased' => 'now()', 
                         'orders_status' => $order->info['order_status'], 
                         'currency' => $order->info['currency'], 
                         'currency_value' => $order->info['currency_value'],
             'auction_order' => 'YES');
 tep_db_perform(TABLE_ORDERS, $sql_data_array);

 

I added the bit at the end to fill in my auction_order field. I have another field in the ORDERS table called shipping_insurance. I am unsure what to check at this point to see if the insurance is included. I figure I'd add something like

if (?????? == ?????)
{ $insured = 'NO'; }
else
{ $insured = 'YES'; }

 

then toss this at the end of the above code:

'shipping_insurance' => $insured


Sean Hull

Share this post


Link to post
Share on other sites

it is me again Smitty1

 

I am testing my hosting service to see if the curl works and I put this

http://elles.rainbowstop.com/test_curl.php

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN
 "http://www.w3.org/TR/html4/loose.dtd"">
<html>
<head>
 <title></title>
 <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
 <meta name="GENERATOR" content="Quanta Plus">
</head>
<body>
<?php
<?php
$ch = curl_init();

curl_setopt ($ch, CURLOPT_URL, "http://rainbowstop.com/");
curl_setopt ($ch, CURLOPT_HEADER, 0);

curl_exec ($ch);

curl_close ($ch);
?>

 

and the same thing happen.. the page didn't show up.. so I am under the conclusion that the curl my hosting has doesn't work.. or I am doing something wrong.. I so wanted this to work.. so I though (not knowing a lot about programing but trying my best to trouble shoot)

please tell me what you think and am I on the right track????

Noppie (Naomi)

 

 

 

 

</body>

</html>[/code]


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

Hello,

 

This is my first post here.

 

I have

osCommerce 2.2MS2

Payment Without Account Contrib

eBay Auction Sales Manager for MS2

Auto Update

 

I can't seem to get $product['extTitle'] into the email subject or text line.

It worked fine when I modified this for eBay Auction sales mamager for ms2 beta 2, but when I upgraded, this field no longer worked.

 

Anybody else have this problem?

 

Thanks,

Mark

Share this post


Link to post
Share on other sites

Sorry to break this to you noppie the code above would not display anything anyways. Fist of all you need "echo" or "print" in php to display anything. Also cURL will only display the result of the action. For example you could tell cURL to goto http://rainbowstop.com/ read the page and spit out the text as a veriable like $rainbowstop_text. But cURL's best feature is it can goto a webpage fill out a form submit it and return the results. Thus, that is why I picked it for the contrib. What it does is logs in to ebay goes to the search by seller page showing email addresses spits the page back to you. The information on this page contains the following information item number, start date, end date & time, title, high bidder, and high bidders email address.

 

As far as the cURL problem maybe you can find some answers here:

 

http://www.php.net/manual/en/ref.curl.php

 

http://curl.sourceforge.net/

 

Hope this helps!

:rolleyes:


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

so Smitty!

 

My question I have is

the curl I have on the sever I use is

 

curl

CURL support enabled

CURL Information libcurl 7.9.2

 

is that the right one.. and if so I know It is something I did somewhere/

and

if not then I know I can't use it..

 

so does the lastest update you create work with the Curl I have.??

 

I just copied that to see it the curl worked..

Thank you Smitty1

 

noppie (naomi) :ph34r: :ph34r:


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

noppie It says "CURL support enabled" so it must be enabled. Try editing oscommerce/admin/includes/functions/get_auction_info.php and then find this line:

// Lines used during debug
// echo "$pre_result\n";
// echo "$pre_result2\n"; 
// echo "$URL_results\n";

and remove the // from echo "$URL_results\n";

then go back to the admin and try to update you should see a ebay webpage on top of the "Updating....Please BE Patient"

 

can you see that?

 

this is called trouble shooting.

:unsure:


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

I hope someone can help with this problem. I almost have the Ebay modle working, at last. But now I have a new error:

 

Fatal error: Cannot pass parameter 3 by reference in /home/enchant/public_html/catalog/includes/modules/product_listing.php on line 13

 

Any ideas??

 

Thanks o everyone who has helped & written this great contribution :D

 

Joanne

Share this post


Link to post
Share on other sites

All,

 

Fixed the problem with updating an auction listing blanking out the title.

 

Also, if you used a prior version and have a lot of auctions in the checked out state, but want to move them to completed in one operation, you can use the following SQL:

 

UPDATE auction_basket SET listing_status = 5 WHERE listing_status = 4 AND time_end < DATE_ADD( now( ) , interval - 5 day )

 

Essentially, this updates all auction in checked out to completed for everything older than 5 days.

 

You would not want to do this if the person has NOT checked out and paid.

 

Good luck!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×