Jump to content
Sign in to follow this  
Ajeh

[Contribution] Quantity Controller v5.0

Recommended Posts

Not a ton of changes there.

 

Mainly it adds in addition information on the display and the update to emails and orders_attributes_download for when you need to use the Update feature on Max Days and number of downloads.

 

Most of my changes are preceeded with a // BOF: WebMakers.com Added: and end with // EOF: WebMakers.com Added:

 

Beyond compare is really helpful for this stuff.

Share this post


Link to post
Share on other sites

The site that i added your mod to, mysteryiously started working after i went in and did an edit on one of the existing products, now i can add

products and pics, no problem. Hav not realy had a chance to look over all

the mods you put in, but it looks good so far. So again thanks for your work, i hope i do not break, cause i know there are other mods to add.

 

Thanks Jim

Share this post


Link to post
Share on other sites

after adding the mod

i go to create an account and when i hit continue it stops


Always open to sugestions on my site to make it better

Share this post


Link to post
Share on other sites

in the catalog when i click on the product i get

1054 - Unknown column 'p.products_bimage' in 'field list'

 

select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, p.products_bimage, p.products_subimage1, p.products_subimage2, p.products_subimage3, p.products_subimage4, p.products_subimage5, p.products_subimage6, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id, p.products_price_list, p.products_price_rebate from products p, products_description pd where p.products_id = '1' and pd.products_id = '1' and pd.language_id = '1'

 

[TEP STOP]


Always open to sugestions on my site to make it better

Share this post


Link to post
Share on other sites

Did you add all the fields specified in the readme?

 

If so, check and see if you have spaces on the field names.

Share this post


Link to post
Share on other sites

Excellent Mod, you are a genius :D

I have got a weird problem (with the site, not me personally)

I can add quantity discounts to existing products (that were in the database before I installed your mod) but when I try to add discounts to a new product it shows on the "preview" but when you click "update" it just resets all the discount values to zero.


Best wishes

Steve

Share this post


Link to post
Share on other sites

One other thing, I forgot to menion :) at the moment it is showing the discount prices before tax but the main price including tax, is it possible to show the discount prices including tax. I have an item that costs 3.06 + 17.5% tax = 3.60 it shows the main price as 3.60 but in the discount box it shows as qty 1 = 3.06?

 

http://www.livefood.co.uk/catalog/product_...&products_id=47


Best wishes

Steve

Share this post


Link to post
Share on other sites

:D to start with i really like the mod now that its installed to instructions

 

but i still have one problem

 

after instaling the mod i can no longer creat a new account

 

it lets me put in all the details for the account but when i hit continue it goes to a blank screen and stops

 

it worked before i installed the mod as i tried it

 

this mod has been intaled on a fresh snapshot from nov 19 on my test server


Always open to sugestions on my site to make it better

Share this post


Link to post
Share on other sites

I downloaded the 11/19 snapshost and was going to install it and this mod,

but i thought i would look at the mod files and the new snapshot files first.

There have been some file changes in the new snapshot, use diff to compare. I have not installed yet, and will go ahead and add changes to Lindas mod before install. I will go to my other site and check your problem, installed lindas mod on 11/01 snapshot.

Share this post


Link to post
Share on other sites

i would be greatfull if you find the problem as realy would like to use this mod on my live site :)


Always open to sugestions on my site to make it better

Share this post


Link to post
Share on other sites

I have not set up HTTPS on my site with this mod so it wont work, i will look to see what i have to do.

Jim.

 

Do you have a program to compare files, there has been changes made to the login.php file and some others since Linda made this mod. I dont know if that is the problem but, would be a place start. Some of the changes are minor.

Share this post


Link to post
Share on other sites

sorry i dont have a compare program but im going to try it on a snapshot from the 12th to see if it makes a difrence


Always open to sugestions on my site to make it better

Share this post


Link to post
Share on other sites

Here is where you can download the program, it will make all of this a lot easier. Program name CSDiff http://www.componentsoftware.com/products, There are some others,this

is just one i found. I am presuming you are using windows PC.

 

One file i found that had a lot of new changes in it was catalogincludesfunctionsgeneral.php

 

Let me know how it turns out, I just signed up for another hosting account

so will be trying to get this to work on it tommorrow.

 

Jim

Share this post


Link to post
Share on other sites

I am not having any problems with the addition of new products and discounts. Check how you added the changed in for the categories.php file.

 

I have not run into any issues on creating an account either. If you are getting a blank screen, you might check your configure.php file. Also see if your if you can place an order to see if this is a secure issue.

 

I will be releasing v5.1 which is current to Nov 19th snapshot, hopefully today or tomorrow.

 

The discounts do not show the tax prices ... I guess that would be a nice feature, eh? :shock:

 

I will see if this is something I have time to update for this release.

Share this post


Link to post
Share on other sites
The discounts do not show the tax prices ... I guess that would be a nice feature, eh? :shock:

 

I will see if this is something I have time to update for this release.

That would be absolutly fantastic if it could be done, you are a real star :D


Best wishes

Steve

Share this post


Link to post
Share on other sites
I will be releasing v5.1 which is current to Nov 19th snapshot, hopefully today or tomorrow.

 

I'm wondering if this is why I can't get the mod to work properly with my snapshot of that date...

Share this post


Link to post
Share on other sites

Can you define *can't get it working properly*?

 

That is a little vague and there are a lot of features to this.

Share this post


Link to post
Share on other sites

Hi Linda,

 

Thank you for a great contribution.

 

I just have a simple question. When I use loginbox.php I am not redirected to a secure connection and of course get the irritating browser pop up warning telling me so.

 

I've only modified/installed the files contained in this package pertaining to loginbox.php. I was using the original contribution by Aubrey until current snapshots made this obsolete. I saw you modified the code a bit to work with the latest snapshot but I'm just having a simple redirect problem. For some reason I can't figure it out myself.

 

I'd appreciate any help you might be able to offer.

 

Thanks,

 

Henry

Share this post


Link to post
Share on other sites

I have the login.php and application_top.php files modified to redirect to secure pages.

 

If you only loaded a peice, I am not sure what you would be missing off hand.

Share this post


Link to post
Share on other sites

I just figured out how to refresh out of CVS...am I gonna get killed, or what? Hopefully, this should put me right up there with hpdl, dgw, and project3000.

 

My question is, how do mods like this make it into the central CVS, or do they?

Share this post


Link to post
Share on other sites

i tried the mod on the snapshot from nov 12 and it worked fine

 

but when i put it on nov 19 snapshot i get that same blank screen when hitting continue after filling out the details for creating a account

 

:D eagerly awaiting 5.1


Always open to sugestions on my site to make it better

Share this post


Link to post
Share on other sites

I'm getting the following error when trying to create an account:

 

Fatal error: Call to undefined function: tep_rand() in catalog/includes/functions/password_funcs.php on line 50

 

I've installed a new snapshot dated 19.11.02, and then applied this contribution, so I don't know if the missing function is resulting from using this contribution or not.

 

Does anyone have this function defined somewhere, and know where it should be?

Share this post


Link to post
Share on other sites

If I am not mistaken, there was a fix added for the rand function that may be effecting you as my Quantity Controller does not contain it if any of the files are using it.

 

When I post v5.1 later today or tomorrow, that is based on snapshot 11-19

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×