Jump to content

Archived

This topic is now archived and is closed to further replies.

hauruapai

How Do I ...? All the basic install questions regularly asked...

Recommended Posts

As I said, it's the text in question is not in that file.

 

i was having the same problem...it is in the english.php not the english/index.php

Share this post


Link to post
Share on other sites
Many thanks! I was looking for this. And it did the trick. It got rid of the clip art in the headers. But didn't seem to remove it for the shopping cart clip art (below header on right side). How do I get rid of it all?

 

Thanks in advance for any help!

 

i found the easiest way was to replace the image with a blank image the same size - that way if you ever decide you want to put something there you dont have to change the code

Share this post


Link to post
Share on other sites

hi,i tried making my image same name and size and it's not working.

please help!!! :blush:

 

 

How big is the file size? If it is too big it won't load.

Also you need to save as the same file type as the original and replace it. Store logo is in images/store_logo.png

So make sure you save you logo with the exact same name, and also as a .png of otherwise the php code will not know how to find it (unless you recode the php and this is much harder!)

Share this post


Link to post
Share on other sites

hi i still need help adding my logo to the site please help i tried adding same file name etc is there anything else you can help me do?????

 

please help!!!

Share this post


Link to post
Share on other sites

is it the same FILE TYPE?? if it is not, then thats why..

 

Is your code for your header teh EXACT same as when you uploaded it from the stock install? if so, then you need to name it oscommerce.jpg

 

if you want to use a different file type, then you go to catalog/includes/header.php

 

find the code that has the store logo image in it and change it to the name that you created WITH the correct file type. Then just upload the file to the images folder and you SHOULD be all set


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites
easy but cant find: How do i change the week day name? Like "Friday" for "Sexta-Feira".

=) ty

 

are you trying to change the language?? i dont understand the Sexta-Fiera

 

Anyways, if you just want to change that text, MOST text is defined in the catalog/includes/languages/english.php


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites
hi i still need help adding my logo to the site please help i tried adding same file name etc is there anything else you can help me do?????

 

please help!!!

Check your images folder.

 

You don't have a logo.gif

 

It's named logo.gif.gif

 

logo.gif.gif 23-Jul-2008 01:37 4k

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

yes,i'm tryin to change the language but cant find the days at the english.php =|

 

---

 

to better explain, i want to change the "Tuesday, 30 July 2008" for a portuguese format that will be "Quarta-feira, 30 Julho de 2008"

I saw the edit part to change the format only (ie: 07/30/2008 for 30/07/2008); its not what i'm looking for.

Share this post


Link to post
Share on other sites

hi,thanks for the responds but i tried that already sooo manytimes and it's not working , is there anything else i can do i can't upload my logo or any header images for the category pages please help!!!

 

 

is it the same FILE TYPE?? if it is not, then thats why..

 

Is your code for your header teh EXACT same as when you uploaded it from the stock install? if so, then you need to name it oscommerce.jpg

 

if you want to use a different file type, then you go to catalog/includes/header.php

 

find the code that has the store logo image in it and change it to the name that you created WITH the correct file type. Then just upload the file to the images folder and you SHOULD be all set

Share this post


Link to post
Share on other sites

I told you in my reply what your problem was.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Hi folks,

 

I'm not really a newbie (been using OSC for some 6 years now), but I have what feels like a newbie question :blush:

 

My latest site isn't showing the subcategories, either the images or the text links.

 

I'm pretty sure I switched them off when I installed, but for the life of me, I can't remember how!!

 

basically, when the user clicks the main category, I want it to give links to the various sub-categories at the top of the page, then show the items in the main category below that.

 

URL - http://www.mustav.co.uk

OSC V2.2

 

Told you its a noob question....

 

TIA :)

Share this post


Link to post
Share on other sites
16. … Change the date format to DD/MM/YYYY?

Go to catalog/includes/languages/English.php and around line 21

 
define('DATE_FORMAT_SHORT', '%m/%d/%Y');  // this is used for strftime()

change it to

 
define('DATE_FORMAT_SHORT', '%d/%m/%Y');  // this is used for strftime()

 

Then around line 23 find this

 define('DATE_FORMAT', 'm/d/Y'); // this is used for date()

and change it to

 define('DATE_FORMAT', 'd/m/Y'); // this is used for date()

 

You also need to make the same changes in catalog/ADMIN/includes/languages/English.php

 

Hi I just changed the date format doing exactly what you suggested in all the languages pages, including portuguese.php - the one I set as default-, but is not working. It still asking the format mm/dd/yyyy. Can somebody help me to sort it?

Share this post


Link to post
Share on other sites
Hi I just changed the date format doing exactly what you suggested in all the languages pages, including portuguese.php - the one I set as default-, but is not working. It still asking the format mm/dd/yyyy. Can somebody help me to sort it?

 

update: that resolved my issue: http://addons.oscommerce.com/info/3778

Share this post


Link to post
Share on other sites

After a customer Orders something with a credit card on my site, under the customer's name there is a 'PAYMENT METHOD:' field that says Credit Card or Debit Card (Processed' But doesn't have the closing ")" after the word "(Processed" Been trying to find the file where I could correct that. Can anyone point me in the right direction? Thanks!

 

ORDERS.JPG

Share this post


Link to post
Share on other sites

Is it possible that the entry is just being "cut off" as in, it's too long for the field, rather than the ) being missing?

 

How to fix it, I don't know though.. Sorry

Share this post


Link to post
Share on other sites

Best guess

 

Check Admin >> Localisation >> Order Status.

 

If that says Processed look at the name of ths page being displayed and edit it in

 

/admin/xxxxx.php as closing ) probably missed out.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

A couple of questions. How do I include more products in the "New Products for MONTH" box? Also, is there an easy way to make them show up with their price and description in a list like they do on the categories pages? Thanks for any help.

Share this post


Link to post
Share on other sites
How do I include more products in the "New Products for MONTH" box?
Log in to your osC admin panel --configuration>>maximum values
Also, is there an easy way to make them show up with their price and description in a list like they do on the categories pages?
Check the contribution section. --> osCommerce Addon

Share this post


Link to post
Share on other sites
Best guess

 

Check Admin >> Localisation >> Order Status.

 

If that says Processed look at the name of ths page being displayed and edit it in

 

/admin/xxxxx.php as closing ) probably missed out.

 

 

Couldn't find anything in there for the past 3 days...searched all day and night :) Finally figured out it was the length value. Changed it from 32 to 64 but that still wasn't enough so changed it to 128 and found out that it was supposed to say "CREDIT OR DEBIT CARD (PROCESSED SECURELY BY PAYPAL) and then has a logo of the credit card next to it. Hope this helps out anyone that had the same issue.

Share this post


Link to post
Share on other sites

Just a quick question...

 

I managed to change the OsCommerce logo to my own store logo, but now its aligned to the left... How do I center the logo so that its in the middle of the window?

Share this post


Link to post
Share on other sites

×