Jump to content

Archived

This topic is now archived and is closed to further replies.

hauruapai

How Do I ...? All the basic install questions regularly asked...

Recommended Posts

how do I reset the admin user name/password?

 

Andy - found this in my travels while checking out the contributions - might help you or not...

 

http://addons.oscommerce.com/info/5857


Dance as if No One were Watching ~ Sing as if No One were Listening ~ And Live Life everyday as if it were Your Last!

Share this post


Link to post
Share on other sites
Here's a few basics I could think of. Please don't post questions here, if you need to ask, start a new thread and reference this. Let's keep this clean!

 

20. How do I remove or change the osCommerce Account, Cart and Checkout clip art?

To remove them completely, find and delete this line from includes/header.php

 

	<td align="right" valign="bottom"><?php echo '<a href="' . tep_href_link(FILENAME_ACCOUNT, '', 'SSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_account.gif', HEADER_TITLE_MY_ACCOUNT) . '</a>  <a href="' . tep_href_link(FILENAME_SHOPPING_CART) . '">' . tep_image(DIR_WS_IMAGES . 'header_cart.gif', HEADER_TITLE_CART_CONTENTS) . '</a>  <a href="' . tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_checkout.gif', HEADER_TITLE_CHECKOUT) . '</a>'; ?>  </td>

 

 

Many thanks! I was looking for this. And it did the trick. It got rid of the clip art in the headers. But didn't seem to remove it for the shopping cart clip art (below header on right side). How do I get rid of it all?

 

Thanks in advance for any help!

Share this post


Link to post
Share on other sites
Bump, still cant find how to do this... =(

 

to change the "best way" text go to catalog/includes/language/yourlanguage/modules/shipping and there you will see the various default shipping options (flat-per item-table etc ) open the one you (are using) want changed and change the text best way to whatever you want!

Share this post


Link to post
Share on other sites

When i open my site and store in explorer it said os commerce at those tabs in explorer any way to change that?

Share this post


Link to post
Share on other sites

I don't beleive this has already been covered, but I am wondering how to have my breadcrumb "Top" link to hold the session id of a customer who is already logged in. The problem I am having is evertime I click on the "Top" breadcrumb my session ends and I am no longer logged in. I notice that the link does not have the session id.

 

Any help would be appreciated. This is only my second post and I hope to be of some help to others in the future.

 

Thank you again.

Share this post


Link to post
Share on other sites

Does the "Top" link point to the same place as your Catalog index.php page?

:unsure:

 

If the "Top" goes to the root folder, and you have osC installed in another folder (such as /catalog) you have a problem.

 

Both of those links get developed in /includes/application_top.php

 

  $breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER);
 $breadcrumb->add(HEADER_TITLE_CATALOG, tep_href_link(FILENAME_DEFAULT));


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites
Does the "Top" link point to the same place as your Catalog index.php page?

:unsure:

 

If the "Top" goes to the root folder, and you have osC installed in another folder (such as /catalog) you have a problem.

 

Both of those links get developed in /includes/application_top.php

 

  $breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER);
 $breadcrumb->add(HEADER_TITLE_CATALOG, tep_href_link(FILENAME_DEFAULT));

 

I have my osC installed in root directory not in catalog. I have changed the "Top" to a icon with and I don't recall checking the "Top" breadcrumb link before changing to an icon as to whether or not the session was attached before I made the change. I believe I know how to attach the session ID to the link but I would like to get someone elses (anyone other than myself) imput before waisting any more time going in circles.

 

Thanks again! I am really enjoying osC and appreciate the support group. :+)

Share this post


Link to post
Share on other sites

This code change should do it:

 

  $breadcrumb->add(HEADER_TITLE_TOP, tep_href_link(FILENAME_DEFAULT));
 $breadcrumb->add(HEADER_TITLE_CATALOG, tep_href_link(FILENAME_DEFAULT));

Although I think it might be redundant to have both when they go to the same place.

 

I suppose it's just a matter of preference on your part.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites
This code change should do it:

 

  $breadcrumb->add(HEADER_TITLE_TOP, tep_href_link(FILENAME_DEFAULT));
 $breadcrumb->add(HEADER_TITLE_CATALOG, tep_href_link(FILENAME_DEFAULT));

Although I think it might be redundant to have both when they go to the same place.

 

I suppose it's just a matter of preference on your part.

 

Excellent! Thank you Germ! This worked perfectly. I will probably just leave the other there as default since it's not affecting anything.

 

Another thing I have been curious of is the sessions. I know this may be a newbie question but I am going to ask it anyway. Am I mistaken to think that most people do not have cookies enabled due to vulnerabilities? How do I use the sessions without having to force cookies and show the session ID in the URL?

 

I have a SSL Cert. that I will be using when I go live, when I change to SSL enabled will the session ID change?

 

Thank you for any help you can provide. :rolleyes:

Share this post


Link to post
Share on other sites

You need to update your /includes/spiders.txt file:

 

Updated spiders.txt

 

In your /includes/configure.php file set this:

 

  define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

And the cookie settings in that configure file should be:

 

  define('HTTP_COOKIE_DOMAIN', '.domain.com');
 define('HTTPS_COOKIE_DOMAIN', '.domain.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');

(Replace domain.com with your domain name)

 

In your Admin under Sessions this is how I have mine set:

 

Force Cookie Use False

Check SSL Session ID False

Check User Agent True

Check IP Address False

Prevent Spider Sessions True

Recreate Session True

 

If anyone sees anything wrong with those settings don't be bashful!

 

I think the real important ones are set OK (Force Cookie Use false, Prevent Spider Sessions true, Recreate Session true).

 

The reason to not force cookie usage is some people have all cookies turned off.

 

When you go to install the SSL, this may prove handy:

 

How to install SSL on OSC: A Simple 1-2-3 Instruction, Simple, straighforward instructions

 

That should get you started off on the right foot, I believe.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

17. How do I change the font / colour / size?

Go to catalog/includes/stylesheet.css and make the changes in there for the main site.

Go to catalog/admin/includes/stylesheet.css and make the changes in there for the admin section.

 

Happy coding! :D

 

I do not have a catalog/includes/stylesheet.css I have a catalog/stylesheet.css what I am looking for is to change the font color

in the info boxes including categories

 

Email me at myshipper@gmail.com please asap

Share this post


Link to post
Share on other sites

In the admin pages I am getting the following error at the top of the screen:

Catalog images directory does not exist: /catalog/images/

 

I have looked in the admin configure file and even if I make changes to it it still reads what ever directory I set as not existing.

I have even created a brand new folder and set the permissions to 755 and 777

 

I do not use a /catalog/ directory, everything runs at the root level

 

any idea on how I can create a directory that OSC will write to so product images can be uploaded

 

cheers

nate

Share this post


Link to post
Share on other sites

admin/includes configure.php

define('DIR_WS_CATALOG', '/');

define('DIR_FS_CATALOG', '/some/path/like/this/public_html/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

 

includes/configure.php

 

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

Share this post


Link to post
Share on other sites

Thanks for the suggestion, but still no luck. Even though the directory is there and with permissions of 777 or 755 OSC just isn't registering it, nor with any other folders I create.

Share this post


Link to post
Share on other sites
You need to update your /includes/spiders.txt file:

 

Updated spiders.txt

 

In your /includes/configure.php file set this:

 

  define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

And the cookie settings in that configure file should be:

 

  define('HTTP_COOKIE_DOMAIN', '.domain.com');
 define('HTTPS_COOKIE_DOMAIN', '.domain.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');

(Replace domain.com with your domain name)

 

In your Admin under Sessions this is how I have mine set:

 

Force Cookie Use False

Check SSL Session ID False

Check User Agent True

Check IP Address False

Prevent Spider Sessions True

Recreate Session True

 

If anyone sees anything wrong with those settings don't be bashful!

 

I think the real important ones are set OK (Force Cookie Use false, Prevent Spider Sessions true, Recreate Session true).

 

The reason to not force cookie usage is some people have all cookies turned off.

 

When you go to install the SSL, this may prove handy:

 

How to install SSL on OSC: A Simple 1-2-3 Instruction, Simple, straighforward instructions

 

That should get you started off on the right foot, I believe.

 

Again thank you for you help Germ!

 

I am still seeing the session ID in the URL which I am hoping to get rid of. How would I do this without having to "Force Cookies"? I have updated the spiders.txt file and made the changes to my config file as recommended but it doesn't seem to have changed anything.

 

Something completely in another direction that I would like a workaround on is that I have added an image to the front of my subcategories links in my "categories" box under inlcludes. The issue I am having is that when you click on a category name to view the subcategories, my image shows up 2,3,4 times as you continue to go down the levels of subcategories.

 

How do I make it to only show the image once in front of each subcategory link name?

 

Thanks again and sorry for the jump in topic but I am trying to do my touch ups and would like to go live soon.

Share this post


Link to post
Share on other sites
I have added a script called content slider frm dhtml website

I need to put the following script in the head of I presume the index.php file ?????

 

<link rel="stylesheet" type="text/css" href="contentslider.css" />

<script type="text/javascript" src="contentslider.js">

/***********************************************

* Featured Content Slider- © Dynamic Drive DHTML code library (www.dynamicdrive.com)

* This notice MUST stay intact for legal use

* Visit Dynamic Drive at http://www.dynamicdrive.com/ for this script and 100s more

***********************************************/

</script>

 

but it is not picking it up. Is there some other files that I need to put it in or I need to embed the code differently?

 

go to their web page and you will see 3 files you need to upload to the root of your page.

 

1-contentslider.css

2-contentslider.js

3-loading.gif

By default, upload these files into the same directory as where your webpage resides.

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for the person who posted the below quotes.

 

32 .... change the default email message that is sent when someone signs up?

Go to catalog/inculdes/languages/YOURLANGUAGE/create_account.php and make the changes in there

Share this post


Link to post
Share on other sites
Please don't post questions here, if you need to ask, start a new thread and reference this. Let's keep this clean!

 

What a shame... <_<

 

Ruined a nice idea - A clean How-to thread...

 

... and only after 3 post! :o

 

 

:(


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
i can't get my header logo image to work please tell me what i can do!!

 

:angry:

 

How big is the file size? If it is too big it won't load.

Also you need to save as the same file type as the original and replace it. Store logo is in images/store_logo.png

So make sure you save you logo with the exact same name, and also as a .png of otherwise the php code will not know how to find it (unless you recode the php and this is much harder!)

Share this post


Link to post
Share on other sites
Warning: I am able to write to the configuration file: C:/xampp/htdocs/oscommerce-2.2rc2a/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

what do I set on file?


Signature must be here...

Share this post


Link to post
Share on other sites

And How do I remove "Powered by osCommerce"

And How do install new Payment Modules?


Signature must be here...

Share this post


Link to post
Share on other sites

3. … Change the Welcome Guest! Would you like to log yourself in? Or would you prefer to create an account on the front page?

Go to catalog/includes/languages/English/index.php

Find the following line and change it to what you want it to say

 

Is this for an older version than that currently released? 'TEXT_GREETING_GUEST is not found in my catalog/includes/languages/English/index.php file.

Share this post


Link to post
Share on other sites
Is this for an older version than that currently released? 'TEXT_GREETING_GUEST is not found in my catalog/includes/languages/English/index.php file.
You'll find it in catalog/includes/languages/English.php file

Share this post


Link to post
Share on other sites

×