Jump to content

Archived

This topic is now archived and is closed to further replies.

hauruapai

How Do I ...? All the basic install questions regularly asked...

Recommended Posts

@@oldcelt You can use paypal without an ssl, or with a shared one in your case. The problem you are having is most likely one, or more, of the following:

 

- you don't have the configure file in the shop side set up correctly. The admin configure file won't affect this in any way though it should use ssl too.

 

- the auto-return on paypal is returning you to your shops url, not the shared cert url. You have to change that in the paypal account settings.

 

- there is something on the page that is not secure. Can you go through an order (enable Check/Money Order) without getting a non-secure warning? If not, that needs to be fixed first.

 

You can turn off ssl in the configure file and then try an order to verify it works at all.  This thread may help setting up your configure file though I'm not sure how much it covers a shared ssl. I posted instructions for sitting up a shared ssl in some thread but I've no idea what the link is. A google search will probably find it though.

 

I've done masses of google searches without finding your instructions for shared SSL setup - no joy unfortunately.   I'll have a look at the link you've given.  Thanks very much.

Share this post


Link to post
Share on other sites

My problem is setting up PayPal (any module) to work faultlessly with osC 2.3.4.

 

If I set up PayPal Standard it all seems fine until reaching the point where PayPal returns to the website.   Then a warning box about passing data back to non secure web pages pops up.   It's ok if that is ignored and the client clicks on 'Submit' but many people will heed the warning and close the page!

 

If I set a shared SSL https address in configure.php and enable SSL (set to true), clients cannot login and new clients cannot register.

 

Alternatively, if I try PayPal Express, I set 'Client ID' and 'secret' to the keys supplied in the PayPal Sandbox setup but I get an error saying that the 'Client ID' cannot be identified when I try to login with Paypal!  The keys have been cut and pasted to avoid entry errors!

 

I'm tearing my hair out having tried every permutation I can think of for at least two weeks now.  Can somebody PLEASE tell me how to set up any connection to PayPal which works when using a shared SSL?

 

I'll be eternally grateful.   TIA,   Ken

going a bit off topic but paypal express does not have 'Client ID' and 'secret' to the keys only the log in with paypal CONTENT MODULE  has this ????

 

Have you installed the payment module paypal express ?  forget about the content module and log in with the secret id STUFF until you get the basic paypal payment set up set up.

 

Now payment data transfer IS SET TO OFF in your paypal account??  under ( IN YOUR PAYPAL ACCOUNT)  profile / my selling prefrences  /

 

then 8 lines from top (UK)

 

Website preferences  right hand side update link

 

Payment Data Transfer:   OFF

 

 

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Have you installed the payment module paypal express ?  forget about the content module and log in with the secret id STUFF until you get the basic paypal payment set up set up.

 

Now payment data transfer IS SET TO OFF in your paypal account??  under ( IN YOUR PAYPAL ACCOUNT)  profile / my selling prefrences  /

 

then 8 lines from top (UK)

 

Website preferences  right hand side update link

 

Payment Data Transfer:   OFF

 

 

I'm trying to set up two paypal modules: paypal express and paypal standard.

 

Yes, I installed the payment module paypal express: I did it before installing the paypal content module.   Was this wrong?   I don't understand what you mean by "log in with the secret id STUFF".   Log into what please?

 

I'll double-check the paypal account profile - have to be tomorrow now - visitors about to arrive!  :(

Share this post


Link to post
Share on other sites

well you said yourself in post #655

 

"Alternatively, if I try PayPal Express, I set 'Client ID' and 'secret' to the keys supplied in the PayPal Sandbox setup but I get an error saying that the 'Client ID' cannot be identified when I try to login with Paypal!  The keys have been cut and pasted to avoid entry errors!"

 

 

There is no client id or secret in paypal express or paypal standard  so trying to get rid of the confusion here  the log in with paypal which needs this is an extra content module  which should be forgotten at the minute

 

It does exactly what it says it lets customers log in to your shop using there paypal details so basically bells and whistles

 

this is not  needed for the basic  customer wants to pay =  ---> I get the money   paypal set up

 

Paypal standard is very simple just add your email address and you are ready to go make sure data transfer is set to off in your paypal account off

 

simple  really the same with express  if you later want to add the options do but I would suggest (you walk before you run ;) ) better you get the basic settings working first which is simply a payment email address in your admin payment module/s

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Thanks - I thought the Paypal login CONTENT module was needed for Paypal Express.   I somehow implied that from various messages.

 

So, that really takes me back to the beginning where, if I leave things as supplied and initially installed, I get the warning about returning to a non-secure page. Then, if I enable the shared SSL in configure.php, previously registered clients cannot login, neither can new clients register.   Maybe it's my configure.php settings which I listed in #674?   If so, could you please tell me what's wrong with the settings?

Share this post


Link to post
Share on other sites

@@oldcelt These 

define('HTTPS_SERVER', 'https://xi.securesslhost.net/~userid');
define('ENABLE_SSL', true);
define('HTTP_COOKIE_DOMAIN', 'userdomain.co.uk');
define('HTTPS_COOKIE_DOMAIN', 'xi.securesslhost.net');

should be

define('HTTPS_SERVER', 'https://xi.securesslhost.net/~userid');
define('ENABLE_SSL', true);
define('HTTP_COOKIE_DOMAIN', '.userdomain.co.uk');
define('HTTPS_COOKIE_DOMAIN', '.xi.securesslhost.net/~userid');

And there is an additional setting farther down that you don't show that should be the full path to the shop.

Share this post


Link to post
Share on other sites
  define('DIR_FS_CATALOG', '/home/userid/public_html/catalog/');

Is this the setting you mean?

 

Thanks very much for your help.

Share this post


Link to post
Share on other sites

Yes, that's the one and it is correct.

Thank you very much.   I'll do some more tests in the morning.   Into my cooking duties now  :) 

Share this post


Link to post
Share on other sites

Hi,

Didn't see this come up. How do I change the Oscommerce default template design to one of the free Oscommerce template design?

Angie

Share this post


Link to post
Share on other sites

Hi,

Didn't see this come up. How do I change the Oscommerce default template design to one of the free Oscommerce template design?

Angie

Installation instructions should come with each template.

 

Download the template, un-zip it and look for files called install or read_me.

 

HTH

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

×