Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

hauruapai

How Do I ...? All the basic install questions regularly asked...

686 posts in this topic

Good morning to everyone,

I am writing for you from perualpacayarn.com. We bought online mercant 3.0.2 trough one of the companys in US called XXX

We are struggling. We are just starting the company and our budget is limited, so many things we need to do by ourselves and waiting replay from XXX has been taken week so far(still waiting).

for example

1. Clicking "GREATE AN ACCOUNT" we are asking many questions from our clients in our registration form.

I would like to keep ONLY section "Your personal details" and "Your Password" and I would like to deactivate the rest.

Can I do this without making mess in the webpage config.

I do have admin page, but the company in us XXX told us not to change anything without them. So every time, when I need to change something, I need to contact with them. We need to change things ALL the time.

Thank You

Share this post


Link to post
Share on other sites

i have two languages on my oscommerce - English and Romanian. how do I configure to start by default in Romanian ? in localization --> languages the default is set by me to Romanian but still when i open my oscommerce page is in english ... can you tell me how to fix that ? I mention that the romanian language is installed properly because on the oscommerce page it changes manually. I just want to be default romanian.

 

thank you, expecting answer

Share this post


Link to post
Share on other sites

V 2.3.1:

 

Is there a simple way to modify the index so that it will check to see if a category has subcategory images, and if it doesn't, then output a custom text (or reference a new file that contains the text); otherwise display the subcategory images?

 

I have "Modular Front Page" installed and currently have my mission statement on the front page. Some of my categories have subcats that I don't want to use images or links for, so they show as a blank page in the main body. I would like the Modular Front Page content to continue to show until the customer reaches a category with subcategory images.

 

It seems like this could be handled easily by adding an if-else, but I don't have the know-how to make it work.

Share this post


Link to post
Share on other sites

Hi gals and pals.. smile.png

 

for the contentBoxHeading and infoBoxHeading, I would like to use the span -tag to avoid jagged headings.

My right corner image is not in perfect alignment...

 

Any help is appreciated, I'd love to avoid headaches as well :)

 

Linnea

Share this post


Link to post
Share on other sites

The place I'm stuck at is how to change the product text color, can anyone help me with this? I have no problem editing the site using catalog/stylsheet.css, header and footer pages and the jquery system but I can't seem to change the product text any ideas?

Share this post


Link to post
Share on other sites

Good Day can someone please tell me how to change my default currency i my oscommerce to SOuth African rand as its not listed in the currency tab

Share this post


Link to post
Share on other sites

Hi Folks, I'm failing at the first hurdle!

I'm trying to configure 'payment' and install a module for OKPay. I got the correct module and put it in the payment folder on the server.

Now, when I go to Install Module I get this message:

Fatal error: Cannot redeclare class okpay in /home/casc2366/public_html/shop2/includes/modules/payment/okpay.php

 

and I can't find anything on this forum which relates to it.

Can anyone help me with a resolve?

Thank you in anticipation, Steve

Fatal error: Cannot redeclare class okpay in /home/casc2366/public_html/shop2/includes/modules/payment/okpay.php on line 17

Share this post


Link to post
Share on other sites

Click the "Cannot redeclare ..." - How to find/fix it" link in my signature.

Share this post


Link to post
Share on other sites

I can't get any of these hacks to work. I,ve made some of changes but they are not taking effect when I refresh my browser.

 

e.g

 

I changed the privacy info code to show this.

 

<?php

/*

$Id$

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

Copyright © 2002 osCommerce

Released under the GNU General Public License

*/

define

(

 

'NAVBAR_TITLE', 'Privacy Notice');

define

(

 

'HEADING_TITLE', 'Privacy Notice');

define

(

 

'TEXT_INFORMATION', 'Privacy info this is the changed version');

?>

 

Then I uploaded it back to the includes\languages\english directory on my server.

 

When I refreshed the browser all I got was the same old message. I even cleared my browser cache to make sure I wasnt getting a stale record.

 

I thought PHP was dynamic so it should have been served right away.

 

Please can someone help.

Share this post


Link to post
Share on other sites

Is there any reason why you have all those extra line feeds in there?

 

Try

 

<?php
/*
 $Id$
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com
 Copyright (c) 2002 osCommerce
 Released under the GNU General Public License
*/
define('NAVBAR_TITLE', 'Privacy Notice');
define('HEADING_TITLE', 'Privacy Notice');
define('TEXT_INFORMATION', 'Privacy info changed');
?>

 

Cheers

 

G

Share this post


Link to post
Share on other sites

Is there any reason why you have all those extra line feeds in there?

 

Try

 

<?php
/*
 $Id$
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com
 Copyright (c) 2002 osCommerce
 Released under the GNU General Public License
*/
define('NAVBAR_TITLE', 'Privacy Notice');
define('HEADING_TITLE', 'Privacy Notice');
define('TEXT_INFORMATION', 'Privacy info changed');
?>

 

Cheers

 

G

 

I managed to get everything working today.

 

Yesterday must have been one of them days for me.

 

Thanks

Share this post


Link to post
Share on other sites

How do I edit the CSS?

I want the header where the logo is to ne taller?

Do I need to do this with an html editor (dreamweaver)? Can it be done from within the OScommerse site?

I looked everywhere on the site but could not find css editor.

Share this post


Link to post
Share on other sites

@@vapingxt

 

NEVER use Dreamweaver to edit files. Use Notepad++ or Editplus+

 

 

There is no editor in the admin area.

 

 

Chris

Share this post


Link to post
Share on other sites

Hi

 

I am using V2.3.1 and am struggling to make the background below the left column be the same colour (white) all down the page to the footer, I seem to have tried every option can anyone give me advice please.

 

Link here

Share this post


Link to post
Share on other sites

Ok, I got the site up and running, only took me 6 days. Thanks for everything people have posted in the past, as that has helped me out a lot.

 

There are just a few issues I am trying to figure out, and can't seem to find the answers yet.

 

1. Is there a description somewhere that explains what needs to be placed in the OpenSearch module in the Admin section of the site. Not all the code stuff, but something that explains each box in the Admin section for this module.

 

2. I'm trying to get the site out there and get customer's in, but to be honest, I do not know code, and all the talks of meta tags and such, has confused the heck out of me. Is there other options?

 

The web site is: www.RonisRingsNThings.com.

Share this post


Link to post
Share on other sites

Hi all,

 

i am a total noob to ecommerce, just need a bit of a jump start. I have :

changed the company logo

added stock and prices

changed currencies, all ok, really like it so far.

 

Now i would like to :

 

install a free template from the contributions that I have downloaded as a zip file. . Please give me steps..

 

and

 

increase the space in my header area for my company logo. probably a header.php edit?

 

and

 

is it possible to later add discount coupon codes to my site? How?

 

 

thanx in advance,

Wes

Share this post


Link to post
Share on other sites

Smee again

 

Managed to do all the things asked above, please disregard the post.

 

New Question

 

I the Header, there are "CART CONTENTS", "Checkout" and "my account" buttons. I would like to change the COLOUR of these buttons. Can anyone tell me where this is defined? (Oh and the BUY NOW button too)

 

Thanx

Wessie

Share this post


Link to post
Share on other sites

i have changed the root folder from www.crockerybazaar.com/shop to www.crockerybazaar.com, but i am unable it to point it to right directory.

Share this post


Link to post
Share on other sites

Hi Guys,

 

Just setting up my store using OSCommerce version 2.3.1 and need to remove the "Welcome to Company Name" from the top of the page above the login line.

 

Any help would be appreciated.

 

Website is www.thailandexportco.com

 

Thanks in advance

 

Thaiexportco (Bruce)

Share this post


Link to post
Share on other sites

Hi

Im trying to install oscommerce 2.2-MS2 .. when i put in the url to start installing it..i get to the install page but noticing the none of the images are loading..there all broken images. and after the install no images are showing. would anyone know why.

 

Thanks

Share this post


Link to post
Share on other sites

oscommerce 2.2-MS2 is very outdated, it requires an old version of php and MySQL on the server, I strongly advise you to use the latest version of osC.

 

If you have purchased a template based on MS2, go back for a refund. The latest is 2.3.1

 

Note MS2 has many security issues, so if you persist with it (and your host is happy keep their server degraded to support it) make sure you apply all the security measures detailed in the pinned thread in the 2.x security forum

Share this post


Link to post
Share on other sites

oscommerce 2.2-MS2 is very outdated, it requires an old version of php and MySQL on the server, I strongly advise you to use the latest version of osC.

 

If you have purchased a template based on MS2, go back for a refund. The latest is 2.3.1

 

Note MS2 has many security issues, so if you persist with it (and your host is happy keep their server degraded to support it) make sure you apply all the security measures detailed in the pinned thread in the 2.x security forum

 

ok Thank you

i installed the latest version..now when i go to the main page still no images are being loaded

Share this post


Link to post
Share on other sites

Hi Guys,

 

Just setting up my store using OSCommerce version 2.3.1 and need to remove the "Welcome to Company Name" from the top of the page above the login line.

 

Any help would be appreciated.

 

Website is www.thailandexportco.com

 

Thanks in advance

 

Thaiexportco (Bruce)

 

All fixed.

 

Thanks Bruce

Share this post


Link to post
Share on other sites