Jump to content

Archived

This topic is now archived and is closed to further replies.

hauruapai

How Do I ...? All the basic install questions regularly asked...

Recommended Posts

hiya guys, thanks for this info.

 

I am wondering. How do i get my logo to show the full width on the header?

 

This is my header.php file code...

 

<table border="0" width="624" height="114" cellspacing="0" cellpadding="0">

<tr class="header">

<td><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'store_logo.png', STORE_NAME) . '</a>'; ?></td>

 

 

I have removed the 3 side images. So i need the banner to go all the way 100%.

 

I have changed width to 100& but nothing happens.

Share this post


Link to post
Share on other sites
Hi,

 

Since I'm hosting the store on a different server than the informational website the link from the top lefthand logo and the "top" link in the breadcrumb don't go where they're supposed to.

 

I've already read through the questions in this thread and I see clearly how to change the text for the breadcrumb but is there any way for me to hard code the destination link for both of the aforementioned items?

 

Thanks in advance.

 

Can nobody help me with this?

Share this post


Link to post
Share on other sites

Top link in /catalog/includes/application_top.php

 

  $breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER);

Change to something like:

 

  $breadcrumb->add(HEADER_TITLE_TOP, 'http://www.otherdoamin.com/some_page.html');

The logo link in /catalog/includes/header.php

 

	<td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'oscommerce.gif', 'osCommerce') . '</a>'; ?></td>

Change to something like:

 

	<td valign="middle"><?php echo '<a href="http://www.otherdoamin.com/some_page.html">' . tep_image(DIR_WS_IMAGES . 'oscommerce.gif', 'osCommerce') . '</a>'; ?></td>

BACKUP THE FILES BEFORE EDITING.

 

You break it you bought it...

:blush:


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites
hiya guys, thanks for this info.

 

I am wondering. How do i get my logo to show the full width on the header?

 

This is my header.php file code...

 

<table border="0" width="624" height="114" cellspacing="0" cellpadding="0">

<tr class="header">

<td><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'store_logo.png', STORE_NAME) . '</a>'; ?></td>

 

 

I have removed the 3 side images. So i need the banner to go all the way 100%.

 

I have changed width to 100& but nothing happens.

 

the logo is only going to be as wide as the actual image is. this might be the problem.

Share this post


Link to post
Share on other sites
Top link in /catalog/includes/application_top.php

 

......

 

You break it you bought it...

:blush:

 

Well I managed not to break it :)

 

Thank you very much for lending a hand.

Share this post


Link to post
Share on other sites

Hi Lotti

 

It should just be a case of changing the color: attribute under the standard link buttons. Under catalog/stylesheet.css look for:

 

A {
 color: #000000;
 text-decoration: none;
}

A:hover {
 color: #AABBDD;
 text-decoration: underline;
}

 

From there you should be able to change the colour. If you wanted the link colour different on the footer compared to the rest of the site, you could add a different class, for example:

 

A.foot {
 color: #000000;
 text-decoration: none;
}

A.foot:hover {
 color: #AABBDD;
 text-decoration: underline;
}

 

And then add the class to the link in your footer, eg:

 

<a href="http://www.oscommerce.com" class="foot" target="_blank">Powered by osCommerce</a>

 

Hope this helps.


Debbie Harrison

 

Share this post


Link to post
Share on other sites
Hi Lotti

 

It should just be a case of changing the color: attribute under the standard link buttons. Under catalog/stylesheet.css look for:

 

A {
 color: #000000;
 text-decoration: none;
}

A:hover {
 color: #AABBDD;
 text-decoration: underline;
}

 

From there you should be able to change the colour. If you wanted the link colour different on the footer compared to the rest of the site, you could add a different class, for example:

 

A.foot {
 color: #000000;
 text-decoration: none;
}

A.foot:hover {
 color: #AABBDD;
 text-decoration: underline;
}

 

And then add the class to the link in your footer, eg:

 

<a href="http://www.oscommerce.com" class="foot" target="_blank">Powered by osCommerce</a>

 

Hope this helps.

 

Thank you so much for getting back to me, I tried that but it still doesn't work.

 

This is what I have added to you style.css page

 

A.foot:hover {
 color: #FFFFFF;
 text-decoration: none;
}

 

This is what I have added to my footer.php (you are right, I want the link text in the footer a different colour to other linked text)

 

 

<td align="center" class="foot"><?php echo FOOTER_TEXT_BODY; ?></td>

 

I'm sure I must be doing something really stupid, but can't figure it out.

 

I'd really appreciate any more help, I've been trying for days!

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites
Thank you so much for getting back to me, I tried that but it still doesn't work.

 

This is what I have added to you style.css page

 

A.foot:hover {
 color: #FFFFFF;
 text-decoration: none;
}

 

This is what I have added to my footer.php (you are right, I want the link text in the footer a different colour to other linked text)

 

 

<td align="center" class="foot"><?php echo FOOTER_TEXT_BODY; ?></td>

 

I'm sure I must be doing something really stupid, but can't figure it out.

 

I'd really appreciate any more help, I've been trying for days!

 

Thanks

 

Lotti

 

To be more precise, it's not the hover colour I want to change particularly - just the normal colour. I.e I have a black background.

 

I want the footer text to show in white when the page is loaded and stay white, when hovered over I'd like the underline added.

 

Thanks

Share this post


Link to post
Share on other sites

How do I remove the "Customers also purchased" area that appears below each product page.

 

In administration go to Configuration/Maximum Values

 

Select "Also Purchased"

 

Set to 0

Share this post


Link to post
Share on other sites
Thank you so much for getting back to me, I tried that but it still doesn't work.

 

This is what I have added to you style.css page

 

A.foot:hover {
 color: #FFFFFF;
 text-decoration: none;
}

 

This is what I have added to my footer.php (you are right, I want the link text in the footer a different colour to other linked text)

 

 

<td align="center" class="foot"><?php echo FOOTER_TEXT_BODY; ?></td>

 

I'm sure I must be doing something really stupid, but can't figure it out.

 

I'd really appreciate any more help, I've been trying for days!

 

Thanks

 

Lotti

Hi Lotti

 

Try adding an a.foot:link command. If its the same as the default link colours, try:

 

a, a.foot{
 color: #FFFFFF;
 text-decoration: none;
}

 

To include them both.


Debbie Harrison

 

Share this post


Link to post
Share on other sites

Lotti, I've just looked closer at your reply and the fact that your calling

<td class="foot">

explains why the link color won't work.

 

You need to assign it to the a tag

<a href="yourpage.php" class="foot">


Debbie Harrison

 

Share this post


Link to post
Share on other sites

Hi

 

I want to change the font size, text colour and underline 1 line only on my homepage.

 

I dont want to change the default text throughout the entire site, just one line.

 

How do I do this?

 

Thanks

Share this post


Link to post
Share on other sites
Hi

 

I want to change the font size, text colour and underline 1 line only on my homepage.

 

I dont want to change the default text throughout the entire site, just one line.

 

How do I do this?

 

Thanks

 

 

Use inline CSS in your language file: includes/languages/english/index.php. Update the definition value for the constant that contains the language block in question.

Share this post


Link to post
Share on other sites
Use inline CSS in your language file: includes/languages/english/index.php. Update the definition value for the constant that contains the language block in question.

 

I'm very inexperienced with code. How do I use inline CSS? And how do I update the definition value?

 

Thanks again

Share this post


Link to post
Share on other sites
I'm very inexperienced with code. How do I use inline CSS? And how do I update the definition value?

 

Thanks again

 

If you'll open the language file for the home page, you'll see a bunch of "constants" that contain various pieces of text content. For example:

 

define('TEXT_MAIN', 'Hello World! Welcome to my web site.');

 

Look for the particular text you want to format. In the part of the constant that contains the actual text, you can use HTML with inline CSS. Like this:

 

define('TEXT_MAIN', 'Hello World! Welcome to <span style=\"font-size: 20px; color: #f00; text-decoration: underline;\">my</span> web site.');

 

The above will change the size, color and underline the word "my". Just be sure to escape apostrophes, double and singe quote characters. (Place a back-slash before the apostrophe or quote chars.) This is done so that the quotes will be served as HTML and not read as part of the PHP statement.

 

Of course, backup the current copy of the language file you're editing so that you have a rollback if needed. Good luck! :)

Share this post


Link to post
Share on other sites

Actually when use HTML with inline CSS to make the change to that one line I get this error message:

 

 

Parse error: syntax error, unexpected '<' in /home/homeland/public_html/includes/languages/english/index.php on line 13

 

I know it's something simple but I cant figure it out. :unsure:

Share this post


Link to post
Share on other sites
Actually when use HTML with inline CSS to make the change to that one line I get this error message:

 

 

Parse error: syntax error, unexpected '<' in /home/homeland/public_html/includes/languages/english/index.php on line 13

 

I know it's something simple but I cant figure it out. :unsure:

 

Can you post here the code on line 13?

Share this post


Link to post
Share on other sites

Line 13:

 

define('TEXT_MAIN', <span style=\"font-size: 40px; color: #f00; text-decoration: underline;\">'FREE WORLD-WIDE SHIPPING ON ALL ORDERS</span>

Share this post


Link to post
Share on other sites
Line 13:

 

define('TEXT_MAIN', '<span style=\"font-size: 40px; color: #f00; text-decoration: underline;\">FREE WORLD-WIDE SHIPPING ON ALL ORDERS</span>');

 

I presume you have the corresponding call to TEXT_MAIN in the desired location in public_html/index.php, yes?

Share this post


Link to post
Share on other sites

when I add that code I get this error message:

 

Parse error: syntax error, unexpected '<' in /home/homeland/public_html/includes/languages/english/index.php on line 14

 

here is my line 14:

 

<br><br>

 

I'm not sure what you mean by the "corresponding call to TEXT_MAIN in the desired location but the only reference to TEXT_MAIN in that file is on line 402:

 

<td class="main"><?php echo TEXT_MAIN; ?></td>

Share this post


Link to post
Share on other sites
when I add that code I get this error message:

 

Parse error: syntax error, unexpected '<' in /home/homeland/public_html/includes/languages/english/index.php on line 14

 

here is my line 14:

 

<br><br>

 

I'm not sure what you mean by the "corresponding call to TEXT_MAIN in the desired location but the only reference to TEXT_MAIN in that file is on line 402:

 

<td class="main"><?php echo TEXT_MAIN; ?></td>

 

Ok, that's correct. Just wanted to make sure you had the echo statement for "TEXT_MAIN" in your home-page file. You do. :)

 

Did the parse error go away?

Share this post


Link to post
Share on other sites

Parse error still there:

 

Parse error: syntax error, unexpected '<' in /home/homeland/public_html/includes/languages/english/index.php on line 14

Share this post


Link to post
Share on other sites

×