Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
thewitt

Experience with "Attributes option type selection v.2.0

Recommended Posts

Does anyone have experience with the following contribution?

 

Attributes option type selection v.2.0

 

Here is the description:

 

I've modified osCommerce's option system so that it's now possible to select (in admin) the option type of a product (select, checkbox, radio, select multiple).

 

New features in version 2.0:

- use of attribute for:

special offer on product (3x2,4x2,...)

minimum order quantity

price levels: qty < n1 price1

n1 <= qty <n2 price2

...

- new text attribute option

- conditional option (option1 linked with option2, if you select option1, option2 is automatically selected)

- order of attribute

 

----------------

I've just installed AttributeSorterv4.0, and this contribution also appears to also have attribute sorting built into it. I've been waiting to put a store online until I had text attributes, and this looks like it adds those for me as well.

 

Anyone have experience with it they wish to share?

 

Thanks,

 

-t

Share this post


Link to post
Share on other sites

Your question is more than a little vague!

 

But if all you want is an answer then, yes I have experience with it.

 

If you want to let us in one exactly what you want to know I am sure more people will be helpful.

 

CC.

Share this post


Link to post
Share on other sites

Sorry, I didn't mean to be more than a little vague. It does happen sometimes though :).

 

I am not concerned about anything in particular, though I did mention I was interested if the attribute sorting and text attribute options worked as advertised.

 

I've installed and dumped a half a dozen contributions in the last few months, and was looking for general feedback on this one - that's all.

 

I guess I'll ask some more specific questions:

 

Has this one given you any problems?

 

Is there anything in the text attribute section that I should be concerned with during an implementation?

 

How does the order of attribute function compare to AttributeSorterv4.0 ?

 

Should I be concerned about integrating this with snapshot 20021111?

 

Thanks for any input, and sorry to have been so vague in my initial request.

 

-t

Share this post


Link to post
Share on other sites

I've installed it. I'm using radio selects for my attributes. I tried the text box option but it doesn't seem to work. I haven't looked at it to figure out what's wrong yet.

 

When adding a new product attribute on the admin/products attribute page, choosing the option type (select, radio, etc.) doesn't work - it applies the default, which is select. You have then to edit the attribute to choose the right option type. The best way to do it is to upload text files via phpMyadmin to bypass the time-consuming data entry in admin.

 

The contribution seems pretty good, although it has more than I need and my sales tax is now 76%. Not sure if this contribution is the problem.

The attribute sorting is good. I added another field to sort by 2 criteria.

 

- Dana

Share this post


Link to post
Share on other sites

Thanks for the reply Dana.

 

I installed it, but I have apparently foobared something in the process, as all my attributes are now gone, and none of the new features are working. There were a condsiderable number of changes in a few of the files between the version in the snapshot I am running (20021111) and the date 10/29 date of the contribution.

 

I have to go back and re-merge the changes I'm afraid.

 

-t

Share this post


Link to post
Share on other sites

Well I integrated this with the latest snapshot, and it appears that the TEXT option provides a STATIC text option that is displayed with the order. Not sure what's up with this - I may simply be using it incorrectly, or may have missed someting in the integration, but in looking through the contribution, I think I misunderstood the way that TEXT attributes are treated.

 

Shoot. I still need text attributes where the customer can enter his own text, AND sorted attribute values. I guess I'm back in the hunt.

 

-t

Share this post


Link to post
Share on other sites

There's another contribution for a text input field in attributes - maybe you could merge the text portion with the Option type feature you have installed. I looked for the other one but can't find it - it's by "Chandra" - if you search for her in the forum you might find her post announcing it.

 

Did you merge the checkout_confirmation pages on the Option Type Feature v2? my shipping amount doesn't get added to the shopping cart and I'm wondering if the option type feature is messing up things...

Share this post


Link to post
Share on other sites
Did you merge the checkout_confirmation pages on the Option Type Feature v2?  my shipping amount doesn't get added to the shopping cart and I'm wondering if the option type feature is messing up things...

Though I have not tested exhaustively, yes the shipping does seem to get added in correctly. I'd be happy to share my integrated files with you if you would like them. I've offered them to the module author as well with hopes that he'll actually do a formal update soon.

 

I've looked at the other contribution you mentioned, and I believe it requires a manual database update using phpMyAdmin to add text attributes to the store. I have a store administrator who is not technical so I really need to have all the features supported directly in the admin interface. Perhaps I'll learn how to add things to the admin interface and do this part as a contribution.

 

-t

Share this post


Link to post
Share on other sites
Guest

I have installed Chandra's contribution and the problem I have run into is that after an order is placed the product that was ordered with the text option is switched to inactive- don't know why. She has helped a bunch but I don't want to be a pain. The manual part of the database is not a big deal and no one knows less about this stuff than me. If someone could tell me why the product status is changing and how to fix it I would really be greatful. osCommerc rocks because of the people involved. Thanks to everyone that has helped me. Here is a link to see what I am talking about http://www.dfwo.com/catalog/product_info.p...2&products_id=2 Place a test order and watch the product dissapear when you go back to the default page. This is not a live site, yet.

Share this post


Link to post
Share on other sites
Guest
I have installed Chandra's contribution and the problem I have run into is that after an order is placed the product that was ordered with the text option is switched to inactive- don't know why. She has helped a bunch but I don't want to be a pain. The manual part of the database is not a big deal and no one knows less about this stuff than me. If someone could tell me why the product status is changing and how to fix it I would really be greatful. osCommerc rocks because of the people involved. Thanks to everyone that has helped me. Here is a link to see what I am talking about http://www.dfwo.com/catalog/product_info.p...2&products_id=2 Place a test order and watch the product dissapear when you go back to the default page. This is not a live site, yet.

 

My bad this was not a problem with just the text option. I added a product with no text and then placed an order and it was changed to inactive after the order was completed also. HELP!

Share this post


Link to post
Share on other sites
Guest
My bad this was not a problem with just the text option. I added a product with no text and then placed an order and it was changed to inactive after the order was completed also. HELP!

 

And what is the inventory level that you put in when you added the product?

Share this post


Link to post
Share on other sites
Guest

I was wondering if anyone had any idea why the text option doesn't work properly in this contribution. i.e. once you add a "text attribute" in admin and you view the product in the catalog - nothing.

 

i think i'm using a mid october snapshot on my semi live site, i've also tried this contribution on an early november snapshot.

 

any ideas??

 

cheers

barry

Share this post


Link to post
Share on other sites

I did not have any problem getting the contribution to install - though I had to modify a bunch of files for the 11/11/02 snapshot.

 

The problem I had was the text attribute is simply static text and not editable. I'm not sure what a static attribute is worth, but I'm sure there was a reason for it in the first place.

 

I'm going to play with making it an editable attribute...

 

-t

Share this post


Link to post
Share on other sites
Guest

in answer to one of your points the static uneditable text attribute isn't worth anything at all and i don't see the point in it having been added o the mod in the first place if it don't work.

 

if you get anywhere editing this mod i'll be glad to test it for you.

 

cheers

barry

Share this post


Link to post
Share on other sites
Guest

My bad this was not a problem with just the text option. I added a product with no text and then placed an order and it was changed to inactive after the order was completed also. HELP!

 

And what is the inventory level that you put in when you added the product?

 

:D I got it. These are custom items made when ordered so there is no inventory. You have to set it not to subract from inventory. Once it hits a negative number it makes the item inactive. It is working fine now. I'm not stupid I just don't know anything. Thanks to everyone for the help and to Chandra for making the contribution - it made osCommerce a product I can use for this site now. :D

Share this post


Link to post
Share on other sites

Yes, there are a number of problems regarding this contribution...tho we need SOMETHING more than the standard osC features, so I'm still using it.

 

The text field option in particular is messed up. I don't really need text fields, so I haven't messed with it much yet. However I did notice that:

 

tep_draw_hidden_field($name_text, $value_text)

 

should be

 

tep_draw_input_field($name_text, $value_text)

 

(but that alone doesn't fix it, cuz that way it doesn't pass the value to the shopping cart...start with this and I'm sure you can figure it out)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×