Jump to content
Silverado05

Offical Google Checkout module for osCommerce Support Thread

Recommended Posts

- Utilized the shipping_method_generator.php

- Results pasted in shipping_methods.php

 

Is this a required step for ALL shops? If so, i don't recall seeing it in the instructions. If not, then what does it attempt to fix?


John Skurka

Share this post


Link to post
Share on other sites

Dang how many shipping modules do you need geez...LoL That is why you are getting that error because your fedex, freeamount, and all those others are not generated and posted in your shipping_methods.php. I can help you with the freeammout array but you are going to need to tone down your shipping modules some. I did notice something though. You are using the Free shipping per product contribution correct? I noticed the item.php in the array. You might have to disable that then run the shipping generator to get all your shipping arrays for the shipping_methods.php then install it back.

 

As far as this error

 

Fatal error: Cannot redeclare class xmlparser in public_html/includes/classes/xmldocument.php on line 209

 

 

This is a patch for it but I will have to give it to you tomorrow. Ropu told me he got it patched for this error but he forgot to send it to me...LoL

 

 

You can go ahead and undo those changes I told you to do to get that array output. Also remove that shipping array from your googlecheckout.php you don't need that in there on 1.4

 

 

 

Greetings

Thank you for the reply. Yes - the module was uninstalled / re-installed after modifying shipping methods, still producing the same error.

 

Later....In addition to pasting the code in shipping methods.php - I placed it directly in googlecheckout.php, uninstalled / reinstalled the module.......and the error appeared to disappear.

 

However google checkout sandbox still did not populate ups shipping information, but instead defaulted to the hard-coded shipping values. Testing on responsehandler_test.php returns and error of

Fatal error: Cannot redeclare class xmlparser in public_html/includes/classes/xmldocument.php on line 209

 

Here is the below response after peforming your instructions in post #44 (after pasting shipping methods directly in googlecheckout.php)

 

Array ( [0] => fedex1.php [1] => flat.php [2] => freeamount.php [3] => item.php [4] => spu.php [5] => table.php [6] => upsxml.php [7] => usps.php [8] => zones.php ) Array ( [fedex1] => Array (

 => fedex1 [title] => Federal Express [description] => Federal Express

 

You will need to have registered an account with FEDEX to use this module. Please see the README.TXT file for other requirements. [status] => 1 ) [freeamount] => Array ( [code] => freeamount [title] => Free Shipping [description] => Free Shipping w/ Minimum Order Amount [status] => 1 ) [spu] => Array ( [code] => spu [title] => Store Pickup [description] => In-store pickup during regular business hours. [status] => 1 ) [upsxml] => Array ( [code] => upsxml [title] => United Parcel Service [description] => United Parcel Service [status] => 1 ) [usps] => Array ( [code] => usps [title] => United States Postal Service [description] => United States Postal Service

 

You will need to have registered an account with USPS.

 

USPS expects you to use pounds as weight measure for your products.

 

Click HERE for registration details and instructions for proper usage. [status] => 1 ) ) [/i]

 

Thank you in advance.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
Is this a required step for ALL shops? If so, i don't recall seeing it in the instructions. If not, then what does it attempt to fix?

 

 

Yes it is a required step. It will be added to the update install text. As of now it isn't because it was a fix after the release came out so the next release will have it included. 1.3 didn't even have this in the install package.

 

So yes you need to run it. It gets your shipping methods so you can copy and paste it into your shipping_methods.php otherwise no shipping methods will be passed to Google and the customer will get free shipping so it is a very important step.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
Dang how many shipping modules do you need geez...LoL That is why you are getting that error because your fedex, freeamount, and all those others are not generated and posted in your shipping_methods.php. I can help you with the freeammout array but you are going to need to tone down your shipping modules some. I did notice something though. You are using the Free shipping per product contribution correct? I noticed the item.php in the array. You might have to disable that then run the shipping generator to get all your shipping arrays for the shipping_methods.php then install it back.

 

As far as this error

 

Fatal error: Cannot redeclare class xmlparser in public_html/includes/classes/xmldocument.php on line 209

This is a patch for it but I will have to give it to you tomorrow. Ropu told me he got it patched for this error but he forgot to send it to me...LoL

You can go ahead and undo those changes I told you to do to get that array output. Also remove that shipping array from your googlecheckout.php you don't need that in there on 1.4

 

;) I am indeed using the Free Shipping Per Product contribuiton. Actually for Google Checkout, my end goal is to just utilize the UPS XML method. Is there a simply way to hide/supress the other modules, without re-writing the core design?

 

Thank you for the assistance. I will keep an eye out for the xmlparser redeclare patch.

Share this post


Link to post
Share on other sites
;) I am indeed using the Free Shipping Per Product contribuiton. Actually for Google Checkout, my end goal is to just utilize the UPS XML method. Is there a simply way to hide/supress the other modules, without re-writing the core design?

 

Thank you for the assistance. I will keep an eye out for the xmlparser redeclare patch.

 

 

To be honest with I wouldn't use the UPSXML it is a bit of overkill and through some research and testing I have found that UPS Choice is much easier to use and does the same thing has UPSXML but in a lighter verison. It is what I use and love it and never had a problem. Also another thing I have noticed is UPSXML will under quote your shipping cost thus making you spend money out of your pocket for shipping sometimes.

 

What I would do is disable the free shipping per product then run the shipping generator. Then after you get the generated arrays for pasted in the shipping_methods then you can enabled the free shipping per product. The Free shipping per product has been addressed and is being worked on but no patch as of yet. Shouldn't be to long for it. Once you get your other shipping methods configure I will give you the array for your freeamount. Then you should be set. as far as the XML parser redelcare, but of course if you use UPS Choice it will fix that issue unless you want to want for the patch.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

ok so i took silverado's advise and un installed the ups xml module, i installed ups choice, it was a much easier install thanks for that.

 

now the google checkout logo displays ups ignored in red bla bla, i know im supposed to go to http://www.feesha.com/googlecheckout/shipp...d_generator.php and generate the code. but it generates absolutly nothing. im dumbfounded. any advise?

Share this post


Link to post
Share on other sites

Please try what is in post #44 and post the results here that will display on the shopping cart page.

 

Are you sure the UPS Module is installed?

 

Did you uninstall and install the GC module after your installed the UPS Module if you did install it?


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

yes im sure the module is installed, it works correctly in the paypal pro site cart.

 

just to double check i uninstalled and re installed both, in the admin module page for google checkout it no longer allows me to set default values it says ups not configured.

 

i then followed the steps in post #44 and this is what i get

 

Array ( [0] => flat.php [1] => item.php [2] => table.php [3] => ups.php [4] => upsxml.php [5] => usps.php [6] => zones.php ) Array ( [ups] => Array (

 => ups [title] => United Parcel Service [description] => United Parcel Service [status] => 1 ) ) 

 

 

 

Please try what is in post #44 and post the results here that will display on the shopping cart page.

 

Are you sure the UPS Module is installed?

 

Did you uninstall and install the GC module after your installed the UPS Module if you did install it?

Share this post


Link to post
Share on other sites
also the generator works for zone, flat rate and table it does not work for ups if that helps any

 

Because you still have UPSXML enabled. You need to disable that shipping module.

 

Notice in the array it says this [3] => ups.php [4] => upsxml.php that means both are still installed, so disable UPSXML. Then uninstall and reinstall the GC module and set the default values after you run the shipping generator once you have disabled UPSXML and you should be good to go.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

i just checked the ups xml and it is not enabeled,

 

now im getting this error code from the generator

 

Warning: Invalid argument supplied for foreach() in /home/feeshaco/public_html/googlecheckout/shipping_generator/multigenerator.php on line 18

 

Warning: Invalid argument supplied for foreach() in /home/feeshaco/public_html/googlecheckout/shipping_generator/multigenerator.php on line 61

<?php

/**

* File: googlecheckout/shipping_methods.php file

*/

$mc_shipping_methods = array(

);

 

$mc_shipping_methods_names = array(

);

?>

 

ups choice now appears in google cart but value is 0.00

 

Because you still have UPSXML enabled. You need to disable that shipping module.

 

Notice in the array it says this [3] => ups.php [4] => upsxml.php that means both are still installed, so disable UPSXML. Then uninstall and reinstall the GC module and set the default values after you run the shipping generator once you have disabled UPSXML and you should be good to go.

Share this post


Link to post
Share on other sites

ok i manually created the code using anotherone as an example, all the values in os commerce are 0.00 is there a pahe i can manually add the default prices to?

 

 

i just checked the ups xml and it is not enabeled,

 

now im getting this error code from the generator

 

Warning: Invalid argument supplied for foreach() in /home/feeshaco/public_html/googlecheckout/shipping_generator/multigenerator.php on line 18

 

Warning: Invalid argument supplied for foreach() in /home/feeshaco/public_html/googlecheckout/shipping_generator/multigenerator.php on line 61

<?php

/**

* File: googlecheckout/shipping_methods.php file

*/

$mc_shipping_methods = array(

);

 

$mc_shipping_methods_names = array(

);

?>

 

ups choice now appears in google cart but value is 0.00

Share this post


Link to post
Share on other sites

You need to be running the shipping_method_generator.php not the multigenerator.php. Once you run the correct one and you get the shipping values then look at post #117 for an update code for the default values. Once you add the code from the shipping method generator to googlecheckout/shipping_methods.php file then you are going to need to uninstall and reinstall the GC module then set your default values.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

dude you are the man!!!

 

shipping generator doesnt work.

 

BUT i used the code from post #117

 

then un installed google checkout - re installed google checkout

 

closed IE

 

cleared cookies/history/cache

 

made sure i created an account with a different address than the store address

 

added an item

 

clicked on google checkout

 

shipping has been set to default value! thanks man

 

You need to be running the shipping_method_generator.php not the multigenerator.php. Once you run the correct one and you get the shipping values then look at post #117 for an update code for the default values. Once you add the code from the shipping method generator to googlecheckout/shipping_methods.php file then you are going to need to uninstall and reinstall the GC module then set your default values.

Share this post


Link to post
Share on other sites

I've got UPSXML and Google Checkout installed. Google Checkout keeps giving me $0 for all shipping values. PayPal shows up correct and the oscommerce cart shows up correct. So it seems like UPSXML is working fine. Google Merchant account gives me Integration error:

 

URL you are using for merchant calculations is not valid or is not https http://......./catalog/googlecheckout/responsehandler.php -- the error we got is: An HTTPS URL is required.

 

 

Any idea on how to fix this? I have a SSL which is approved by Google Checkout and I have entered the:

 

https://www........./catalog/google...onsehandler.php

 

into the API Callback URL (level 2 integrations only) in Google Merchant Integration

 

Seems like I'm missing something somewhere that it isn't looking in https like it should be during the callback process.

Share this post


Link to post
Share on other sites

Has there been any update on the parser error?

 

I would like to keep UPSXML at this time, given the heavy customization made to that shipping module to fit our requirements. Thank you.

Share this post


Link to post
Share on other sites

Here's another question. What is the file that the Google Callback is supposed to point to? Maybe I'm not setting the url correctly...

Share this post


Link to post
Share on other sites
Has there been any update on the parser error?

 

I would like to keep UPSXML at this time, given the heavy customization made to that shipping module to fit our requirements. Thank you.

 

I have patch files, but 1.4.1 will release this week if you can wait. Otherwise I can give you the patch files but you are going to have to sort it out yourself because their are no install documents yet, but here is the change log so far

 

Change log for the googlecheckout dir library is this one

Modified googlecheckout/library/googletax.php

Modified googlecheckout/library/googleitem.php

Modified googlecheckout/library/googleresponse.php

Modified googlecheckout/library/googleresult.php

Modified googlecheckout/library/googleshipping.php

Modified googlecheckout/library/googlemerchantcalculations.php

Modified googlecheckout/library/googlerequest.php

Modified googlecheckout/library/googlecart.php

Added googlecheckout/library/xml-processing/gc_xmlbuilder.php

Added googlecheckout/library/xml-processing/gc_xmlparser.php

Removed googlecheckout/library/xml-processing/xmlparser.php

Removed googlecheckout/library/xml-processing/xmlbuilder.php


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
Here's another question. What is the file that the Google Callback is supposed to point to? Maybe I'm not setting the url correctly...

 

You need to put the URL that points to your response_handler.php


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
I have patch files, but 1.4.1 will release this week if you can wait. Otherwise I can give you the patch files but you are going to have to sort it out yourself because their are no install documents yet, but here is the change log so far

 

Change log for the googlecheckout dir library is this one

Modified googlecheckout/library/googletax.php

Modified googlecheckout/library/googleitem.php

Modified googlecheckout/library/googleresponse.php

Modified googlecheckout/library/googleresult.php

Modified googlecheckout/library/googleshipping.php

Modified googlecheckout/library/googlemerchantcalculations.php

Modified googlecheckout/library/googlerequest.php

Modified googlecheckout/library/googlecart.php

Added googlecheckout/library/xml-processing/gc_xmlbuilder.php

Added googlecheckout/library/xml-processing/gc_xmlparser.php

Removed googlecheckout/library/xml-processing/xmlparser.php

Removed googlecheckout/library/xml-processing/xmlbuilder.php

 

Probably best to wait. ;)

Share this post


Link to post
Share on other sites
I've got UPSXML and Google Checkout installed. Google Checkout keeps giving me $0 for all shipping values. PayPal shows up correct and the oscommerce cart shows up correct. So it seems like UPSXML is working fine. Google Merchant account gives me Integration error:

 

URL you are using for merchant calculations is not valid or is not https http://......./catalog/googlecheckout/responsehandler.php -- the error we got is: An HTTPS URL is required.

Any idea on how to fix this? I have a SSL which is approved by Google Checkout and I have entered the:

 

https://www........./catalog/google...onsehandler.php

 

into the API Callback URL (level 2 integrations only) in Google Merchant Integration

 

Seems like I'm missing something somewhere that it isn't looking in https like it should be during the callback process.

 

Do you have your module set to accept https: and not http: on the OSC admin?

 

The fix for the $0.00 prices is on page like 6 post 117 I think. This has been discussed so just look back a couple of pages. It is also recommended to use UPS Choice instead of UPSXML unless you want to wait for 1.4.1


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
Do you have your module set to accept https: and not http: on the OSC admin?

 

The fix for the $0.00 prices is on page like 6 post 117 I think. This has been discussed so just look back a couple of pages. It is also recommended to use UPS Choice instead of UPSXML unless you want to wait for 1.4.1

 

 

Thanks for the reply. Yes OSC admin is set to https (I think it may have been that way by default) and my Google Merch. account API is pointing back to:

 

https://........./catalog/googlecheckout/responsehandler.php

 

I did read through the whole thread and I saw that post 117 and a reference back to it, but I didn't think it pertained to me for some reason. I'll read through it again and try it. Let me know if you have any other ideas on it, in the meantime I'll give that a shot also. Thanks!

Share this post


Link to post
Share on other sites
Do you have your module set to accept https: and not http: on the OSC admin?

 

The fix for the $0.00 prices is on page like 6 post 117 I think. This has been discussed so just look back a couple of pages. It is also recommended to use UPS Choice instead of UPSXML unless you want to wait for 1.4.1

 

 

No luck with that. Also reinstalled the Google Checkout module and tried it again and my account is giving me the same error:

 

URL you are using for merchant calculations is not valid or is not https http://......../catalog/googlecheckout/responsehandler.php -- the error we got is: An HTTPS URL is required.

 

Also if this helps, if I go directly to:

 

https://........./catalog/googlecheckout/responsehandler.php

 

It gives me this message in my browser:

 

"Failed to Get Basic Authentication Headers"

Edited by SVTour98

Share this post


Link to post
Share on other sites

I have a store up and running but still quite new to this. I need to install Google Checkout as a payment method on my site. What is the best, updated contribution that I should use for this. Please help!

Share this post


Link to post
Share on other sites
No luck with that. Also reinstalled the Google Checkout module and tried it again and my account is giving me the same error:

 

URL you are using for merchant calculations is not valid or is not https http://......../catalog/googlecheckout/responsehandler.php -- the error we got is: An HTTPS URL is required.

 

Also if this helps, if I go directly to:

 

https://........./catalog/googlecheckout/responsehandler.php

 

It gives me this message in my browser:

 

"Failed to Get Basic Authentication Headers"

 

 

Do you have a SSL that is dedicated and not shared. If you have a SSL make sure it is accepted by GC

 

http://checkout.google.com/support/sell/bi...py?answer=57856

 

Also what do you have set for .htaccess in your module on the OSC side?


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×