Jump to content
Silverado05

Offical Google Checkout module for osCommerce Support Thread

Recommended Posts

Hey guys,

 

I have had Google checkout installed for months now working well, today I installed more modules replicating the table.php....now, when more modules are running I get this written in red under the google checkout image in the cart page:

 

* THERE ARE MULTIPLE SHIPPING OPTIONS SELECTED AND THEY USE DIFFERENT SHIPPING TAX TABLES OR SOME DONT USE TAX TABLES

ERROR: SHIPPING METHODS NOT CONFIGURED

CANADA (IGNORED)

CANADA2 (IGNORED)

TABLE2 (IGNORED)

WORLD (IGNORED)

How do I fix this? Are customers able to check out? What am I doing wrong?

Share this post


Link to post
Share on other sites

Is Google Checkout dead? Support from Google on this matter is atrocious. No support whatsoever for 2.3?

Share this post


Link to post
Share on other sites

I would like to know if it can even be put in. Once i upload google checkout files, i can no longer access the admin side. I don't want to use PayPal, but I guess I have to.

Share this post


Link to post
Share on other sites

i got the google checkout ipn working...but using the sandbox it doesnt seem to return back to the store to actually approve or activate the order. once i goto the sandbox the order is placed as successful and is pending.

 

i remember years ago it worked fine, but i had to do some sort of modification to make it do what it was suppose to...but i dont remember ;(

Share this post


Link to post
Share on other sites

i just got the google checkout mod to work on 2.3...i dont know why no1 will support this mod and work on it being better. such a great addon.

Share this post


Link to post
Share on other sites

ndamico i installed this one http://addons.oscommerce.com/info/5157 did you try and install it and get it to work? i dont think i had any issues on the install part. the config was tricky because on the live production end or whatever, to actually process a payment, i figured out that i can use my shared ssl settings on my site to actually have google call back and activate the orders, record the google order number...works perfect now. but thats the mod i used. should just install fine for you same as for me.

Share this post


Link to post
Share on other sites

i got it working but it doesn't pull the correct discount from discount coupons. this is a killer for me. anyone know a solution to this?

Share this post


Link to post
Share on other sites

I just switched for Fedex Real Time Quotes (fedex1) to the FedEx Webservices (fedexwebservices) module. The module is working fine with normal store checkout and paypal express...

 

I am no longer getting merchant calculated ship quotes into google checkout. So I assume I need to update shipping_methods.php with the new module details.

So when I run shipping_generator I get an error:

Warning: Division by zero in /var/www/pti/includes/modules/shipping/fedexwebservices.php on line 240

Line 240: $shipping_weight = round($new_shipping_weight / $shipping_num_boxes, 2);

So I try setting temporarily setting $shipping_num_boxes = 1 as the default

The error goes away but I am not getting an output for the fedexwebservices

 

Does anyone have the fedexwebservices appropriate code to place into shipping_methods.php manually?

 

I tried a guees like this but its not working for me

				    'fedexwebservices' => array(						  /////// TESTING THIS ////////////
							    'domestic_types' =>
								  array(
									    'GROUND_HOME_DELIVERY' => 'Ground Home Delivery',
									    'FEDEX_GROUND' => 'FedEx Ground'
									   ),
							    'international_types' =>
								  array(
									    'INTERNATIONAL_ECONOMY' => 'International Economy',
									    'INTERNATIONAL_GROUND' => 'International Ground'
									   ),
								    ),


-Dave

Share this post


Link to post
Share on other sites

I am pretty sure this is accurate for the services I offer

				    'fedexwebservices' => array(						  /////// TESTING THIS ////////////
							    'domestic_types' =>
								  array(
									    'GROUND_HOME_DELIVERY' => 'Ground Home Delivery',
									    'FEDEX_GROUND' => 'FedEx Ground'
									   ),
							    'international_types' =>
								  array(
									    'INTERNATIONAL_ECONOMY' => 'International Economy',
									    'INTERNATIONAL_GROUND' => 'International Ground'
									   ),
								    ),

 

But I cannot seem to get the modules rates to send. What other steps am I missing for the new ship module to get recognized and tender rates? I've tried the removing and reinstalling of the module in admin. everything seems recognized and detected in admin. Any help appreciated.

 

Is there an especially good troubleshooting guide anywhere?


-Dave

Share this post


Link to post
Share on other sites

Unfortunately I don't have any solutions for anyone yet, but i do have a problem with installation of Google Checkout v1.5 rc1 ( v1.5_rc1.zip ) into an osCommerce 2.3.1 shop, which is driving me round the twist.

 

I don't often need to ask for help here, but i'm hoping with the information I am providing below, that some more people may be able to get Google Checkout v1.5 rc1 working with osCommerce 2.3.1 once I have a solution for this.

 

I have configured it with a fresh sandbox account i set up today, and have read all the notes on the Google Group for installing it, and i have got so far:

 

I have reached the point where I have the Google Checkout icon appearing on the following pages:

 

shopping_cart.php - when you mouse over the icon it points to http://example/shopping_cart.php?action=update_product

(If i click on the link, it goes straight back to shopping_cart.php)

 

and

 

login.php - whether i have anything in my shopping cart or not, and the link

 

It does NOT appear on checkout_shipping.php (i guess this is correct)

 

It does NOT appear on checkout_payment.php (again, i guess this is correct)

 

But at this point, with products in my shopping cart, clicking on the continue button results in:

 

checkout_payment.php?error_message=Please+select+a+payment+method+for+your+order.

(with a corresponding red banner)

 

I have added, removed, re added it from admin - modules - payment (where it shows up with the expected detail) but I have not so far been able to work out where I am going wrong.

 

I have the following files in the following places:

( NOTE, these are original 2.3.1 files modified with the code from v1.5_rc1.zip )

 

catalog/shopping_cart.php

 

Original 2.3.1 ( starting around line 133 when viewed in notepad++ ) was:

 

<div class="buttonSet">

<span class="buttonAction"><?php echo tep_draw_button(IMAGE_BUTTON_CHECKOUT, 'triangle-1-e', tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'), 'primary'); ?></span>

</div>

<?php

$initialize_checkout_methods = $payment_modules->checkout_initialization_method();

if (!empty($initialize_checkout_methods)) {

?>

 

 

Modified 2.3.1 is:

 

<div class="buttonSet">

<span class="buttonAction"><?php echo tep_draw_button(IMAGE_BUTTON_CHECKOUT, 'triangle-1-e', tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'), 'primary'); ?></span>

</div>

<?php

// *** BEGIN GOOGLE CHECKOUT ***

if (defined('MODULE_PAYMENT_GOOGLECHECKOUT_STATUS') && MODULE_PAYMENT_GOOGLECHECKOUT_STATUS == 'True') {

include_once('googlecheckout/gcheckout.php');

}

// *** END GOOGLE CHECKOUT ***

?>

<?php

$initialize_checkout_methods = $payment_modules->checkout_initialization_method();

if (!empty($initialize_checkout_methods)) {

?>

 

 

 

catalog/login.php

 

starting around line 130 of the original oscommerce 2.3.1 file, where it was:

 

</form>

</div>

</div>

<?php

require(DIR_WS_INCLUDES . 'template_bottom.php');

require(DIR_WS_INCLUDES . 'application_bottom.php');

?>

 

I now have modified it to:

 

</form>

<?php

// *** BEGIN GOOGLE CHECKOUT ***

if (defined('MODULE_PAYMENT_GOOGLECHECKOUT_STATUS') && MODULE_PAYMENT_GOOGLECHECKOUT_STATUS == 'True') {

include_once('googlecheckout/gcheckout.php');

}

// *** END GOOGLE CHECKOUT ***

?>

</div>

</div>

<?php

require(DIR_WS_INCLUDES . 'template_bottom.php');

require(DIR_WS_INCLUDES . 'application_bottom.php');

?>

 

 

 

catalog/admin/modules.php

 

starting at line 13 of the original osCommerce 2.3.1 code, what was:

 

require('includes/application_top.php');

$set = (isset($HTTP_GET_VARS['set']) ? $HTTP_GET_VARS['set'] : '');

$modules = $cfgModules->getAll();

if (empty($set) || !$cfgModules->exists($set)) {

$set = $modules[0]['code'];

}

 

 

has now been replaced with:

 

require('includes/application_top.php');

// *** BEGIN GOOGLE CHECKOUT ***

require_once(DIR_FS_CATALOG . 'googlecheckout/inserts/admin/modules1.php');

// *** END GOOGLE CHECKOUT ***

$set = (isset($HTTP_GET_VARS['set']) ? $HTTP_GET_VARS['set'] : '');

$modules = $cfgModules->getAll();

if (empty($set) || !$cfgModules->exists($set)) {

$set = $modules[0]['code'];

}

 

 

 

catalog/admin/orders.php

 

Starting at line 13 of the original osCommerce 2.3.1 code:

 

require('includes/application_top.php');

require(DIR_WS_CLASSES . 'currencies.php');

$currencies = new currencies();

 

has now become:

 

require('includes/application_top.php');

// *** BEGIN GOOGLE CHECKOUT ***

require_once(DIR_FS_CATALOG . 'googlecheckout/inserts/admin/orders1.php');

// *** END GOOGLE CHECKOUT ***

require(DIR_WS_CLASSES . 'currencies.php');

$currencies = new currencies();

 

 

starting at line 40, the osCommerce 2.3.1 code which was:

 

if ( ($check_status['orders_status'] != $status) || tep_not_null($comments)) {

tep_db_query("update " . TABLE_ORDERS . " set orders_status = '" . tep_db_input($status) . "', last_modified = now() where orders_id = '" . (int)$oID . "'");

$customer_notified = '0';

if (isset($HTTP_POST_VARS['notify']) && ($HTTP_POST_VARS['notify'] == 'on')) {

$notify_comments = '';

if (isset($HTTP_POST_VARS['notify_comments']) && ($HTTP_POST_VARS['notify_comments'] == 'on')) {

$notify_comments = sprintf(EMAIL_TEXT_COMMENTS_UPDATE, $comments) . "\n\n";

}

$email = STORE_NAME . "\n" . EMAIL_SEPARATOR . "\n" . EMAIL_TEXT_ORDER_NUMBER . ' ' . $oID . "\n" . EMAIL_TEXT_INVOICE_URL . ' ' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT_HISTORY_INFO, 'order_id=' . $oID, 'SSL') . "\n" . EMAIL_TEXT_DATE_ORDERED . ' ' . tep_date_long($check_status['date_purchased']) . "\n\n" . $notify_comments . sprintf(EMAIL_TEXT_STATUS_UPDATE, $orders_status_array[$status]);

tep_mail($check_status['customers_name'], $check_status['customers_email_address'], EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

$customer_notified = '1';

}

tep_db_query("insert into " . TABLE_ORDERS_STATUS_HISTORY . " (orders_id, orders_status_id, date_added, customer_notified, comments) values ('" . (int)$oID . "', '" . tep_db_input($status) . "', now(), '" . tep_db_input($customer_notified) . "', '" . tep_db_input($comments) . "')");

$order_updated = true;

 

has become:

 

if ( ($check_status['orders_status'] != $status) || tep_not_null($comments)) {

tep_db_query("update " . TABLE_ORDERS . " set orders_status = '" . tep_db_input($status) . "', last_modified = now() where orders_id = '" . (int)$oID . "'");

 

// *** BEGIN GOOGLE CHECKOUT ***

require_once(DIR_FS_CATALOG . 'googlecheckout/inserts/admin/orders2.php');

// *** END GOOGLE CHECKOUT ***

 

tep_db_query("insert into " . TABLE_ORDERS_STATUS_HISTORY . " (orders_id, orders_status_id, date_added, customer_notified, comments) values ('" . (int)$oID . "', '" . tep_db_input($status) . "', now(), '" . tep_db_input($customer_notified) . "', '" . tep_db_input($comments) . "')");

$order_updated = true;

 

(the code above is one part i suspect may be incorrect)

 

Also, starting around line 295, the original osCommerce 2.3.1 code that was:

 

<td class="smallText" valign="top"><?php echo tep_draw_button(IMAGE_UPDATE, 'disk', null, 'primary'); ?></td>

</tr>

</table></td>

</form></tr>

 

is now:

 

<td class="smallText" valign="top"><?php echo tep_draw_button(IMAGE_UPDATE, 'disk', null, 'primary'); ?></td>

<!-- *** BEGIN GOOGLE CHECKOUT *** -->

<?php

require_once(DIR_FS_CATALOG . 'googlecheckout/inserts/admin/orders3.php');

?>

<!-- *** END GOOGLE CHECKOUT *** -->

</tr>

</table></td>

</form></tr>

 

 

catalog/admin/includes/functions/general.php

 

Starting with the osCommerce 2.3.1 code around line 1010:

 

tep_db_query("delete from " . TABLE_ORDERS . " where orders_id = '" . (int)$order_id . "'");

tep_db_query("delete from " . TABLE_ORDERS_PRODUCTS . " where orders_id = '" . (int)$order_id . "'");

tep_db_query("delete from " . TABLE_ORDERS_PRODUCTS_ATTRIBUTES . " where orders_id = '" . (int)$order_id . "'");

tep_db_query("delete from " . TABLE_ORDERS_STATUS_HISTORY . " where orders_id = '" . (int)$order_id . "'");

tep_db_query("delete from " . TABLE_ORDERS_TOTAL . " where orders_id = '" . (int)$order_id . "'");

}

 

has become:

 

tep_db_query("delete from " . TABLE_ORDERS . " where orders_id = '" . (int)$order_id . "'");

tep_db_query("delete from " . TABLE_ORDERS_PRODUCTS . " where orders_id = '" . (int)$order_id . "'");

tep_db_query("delete from " . TABLE_ORDERS_PRODUCTS_ATTRIBUTES . " where orders_id = '" . (int)$order_id . "'");

tep_db_query("delete from " . TABLE_ORDERS_STATUS_HISTORY . " where orders_id = '" . (int)$order_id . "'");

tep_db_query("delete from " . TABLE_ORDERS_TOTAL . " where orders_id = '" . (int)$order_id . "'");

// *** BEGIN GOOGLE CHECKOUT ***

require_once(DIR_FS_CATALOG . 'googlecheckout/inserts/admin/includes/functions/general.php');

// *** END GOOGLE CHECKOUT ***

}

 

 

 

I also have the following original folders and / or files from the v1.5_rc1.zip

 

catalog/gc_return.php

 

catalog/includes/languages/response_error.log

 

catalog/includes/languages/english/modules/payment/googlecheckout.php

 

catalog/includes/modules/payment/googlecheckout.php

 

catalog/googlecheckout/

(entire folder)

 

Anyone got any advice they could offer? I figure i can't be that far away from cracking it, but i'm stumped!

 

Thanks in advance!

Share this post


Link to post
Share on other sites

I'm using GCO 1.50 for osCommerce.

 

I have recently swithced from the older Fedex Real time Quotes (fedex1) to the newer FedEx Webservices API (fedexwebservices) and have not been able to determine the correct code to place in merchant_calculated_methods.php. For whatever reason my ship generator will not generate.

 

fedex1 array was like this:

 

'fedex1' => array(

'domestic_types' => array(

'01' => 'Priority (by 10:30AM, later for rural)',

'03' => '2 Day Air',

'05' => 'Standard Overnight (by 3PM, later for rural)',

'06' => 'First Overnight',

'20' => 'Express Saver (3 Day)',

'90' => 'Home Delivery',

'92' => 'Ground Service'

),

'international_types' => array(

'01' => 'International Priority (1-3 Days)',

'03' => 'International Economy (4-5 Days)',

'06' => 'International First',

'90' => 'International Home Delivery',

'92' => 'International Ground Service'

),

),

 

What would be the proper array for the FedEx Webservices API?

 

Here is the fedex webservices module if it is helpful

http://addons.oscommerce.com/info/7977

 

Any input appreciated


-Dave

Share this post


Link to post
Share on other sites

hello,

 

i have had GC on osc2.3 working now for about 2 months.

 

Now I have noticed that it does not subtract inventory level, has anyone seen anything on this

struckout googling the problem.

 

thanks,

craig

Share this post


Link to post
Share on other sites

Here is the response I received from Google today when I asked if they had any plans of supporting GC on 2.3.1:

 

 

Thanks for your email.

 

Google Payments currently doesn’t provide support for OSCommerce 2.3.1, though we may introduce this feature in the future. We’ll take your feedback into account and relay it to our engineering team as we move forward with product development.

 

We always welcome suggestions for how we can improve Google Payments, so please continue to send us your comments in the future.

 

If you have additional questions, please visit our Help Center at http://checkout.google.com/support/sell/

 

Sincerely,

 

Caden

The Google Checkout Team

 

 

It would probably help if everyone could also email Google about supporting it so they know it is worth their time to do so. You can write them here:

 

http://support.google.com/checkout/sell/bin/request.py?contact_type=more_nomid&from=avl

Edited by sammedit

Share this post


Link to post
Share on other sites

Here is the response I received from Google today when I asked if they had any plans of supporting GC on 2.3.1:

 

 

Thanks for your email.

 

Google Payments currently doesn’t provide support for OSCommerce 2.3.1, though we may introduce this feature in the future. We’ll take your feedback into account and relay it to our engineering team as we move forward with product development.

 

We always welcome suggestions for how we can improve Google Payments, so please continue to send us your comments in the future.

 

If you have additional questions, please visit our Help Center at http://checkout.google.com/support/sell/

 

Sincerely,

 

Caden

The Google Checkout Team

 

 

It would probably help if everyone could also email Google about supporting it so they know it is worth their time to do so. You can write them here:

 

http://support.google.com/checkout/sell/bin/request.py?contact_type=more_nomid&from=avl

 

Great suggestion! - Message sent to Google.

Share this post


Link to post
Share on other sites

hello,

 

i have had GC on osc2.3 working now for about 2 months.

 

Now I have noticed that it does not subtract inventory level, has anyone seen anything on this

struckout googling the problem.

 

thanks,

craig

 

Craig,

I'm sure the inventory level issue is easily resolved as well, but would need to see the checkout code that you are using - and as I'm stuck on the checkout phase and can't even get past that it would also benefit me....

Share this post


Link to post
Share on other sites

hello,

 

i have had GC on osc2.3 working now for about 2 months.

 

Now I have noticed that it does not subtract inventory level, has anyone seen anything on this

struckout googling the problem.

 

thanks,

craig

 

I might be able to help if you'll upload the code you are using so I can test it. Like @@WallaceNetworks.co.uk I'm stuck on checkout and don't have a lot of spare time to debug it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

oscommerce 2.2rc2a + GCO 1.50 + fedexwebservices v9

 

Please anyone - could you confirm this code to be correct, or post a correct example.

I've got GCO installed and tests perfectly except for merchant calculated shipping is not making it to the transaction. I am pretty sure this is not working. from merchant_calculated_methods.php:

 

$mc_shipping_methods = array(
  'fedexwebservices' => array(			  
   'domestic_types' => array(
 'STANDARD_OVERNIGHT' => 'Standard Overnight (by 3PM, later for rural)',
 'FIRST_OVERNIGHT' => 'First Overnight',
 'PRIORITY_OVERNIGHT' => 'Priority (by 10:30AM, later for rural)',
 'FEDEX_2_DAY' => '2 Day Air',
 'FEDEX_GROUND' => 'FedEx Ground',
 'GROUND_HOME_DELIVERY' => 'Ground Home Delivery'
 'FEDEX_EXPRESS_SAVER' => 'Express Saver (3 Day)',
 'FEDEX_FREIGHT' => 'FedEx Freight',
 'FEDEX_NATIONAL_FREIGHT' => 'FedEx National Freight',
 'FEDEX_1_DAY_FREIGHT' => 'Overnight Day Freight',
 'FEDEX_2_DAY_FREIGHT' => '2 Day Freight',
 'FEDEX_3_DAY_FREIGHT' => '3 Day Freight'
  ),
   'international_types' => array(
 'INTERNATIONAL_PRIORITY' => 'International Priority (1-3 Days)',
 'EUROPE_FIRST_INTERNATIONAL_PRIORITY' => 'International Priority (1-3 Days)',
 'INTERNATIONAL_ECONOMY' => 'International Economy',
 'INTERNATIONAL_GROUND' => 'International Ground'
 'INTERNATIONAL_ECONOMY_FREIGHT' => 'International Economy Freight',
 'INTERNATIONAL_PRIORITY_FREIGHT' => 'International Priority Freight'
  ),
 ),
);
Edited by Roaddoctor

-Dave

Share this post


Link to post
Share on other sites

ok I take the above post back... I think the above might be correct.... Using response handler test - when I manually add fedexwebservices to the xml request, I receive the following:

 

xml sent

 

<shipping>

<method name="fedexwebservices: FedEx" />

 

xml response

 

<result shipping-name="fedexwebservices: FedEx" address-id="xxxxxxeditedxxxx">

<shipping-rate currency="USD">9999.09</shipping-rate>

<shippable>false</shippable>

</result>

 

so the merchant calculated array is probably correct, but the fedex wsdl module isnt playing nice with google checkout... first the fedexwebservices module is not being sent, and when manually added to the sent xml, the response is obciously broken.

Any help is appreciated - I have no idea how to sort this


-Dave

Share this post


Link to post
Share on other sites

Well, i received a response from Google via email, unfortunately it doesn't offer anything new.

 

I would be willing to donate to a bounty in order for someone to resolve it and publish the code - would anyone else be willing to contribute?

 

is there a mechanism on this forum for bountys, or do we have to set them up elsewhere?

Share this post


Link to post
Share on other sites

Hi folks,

 

I've just completed a level 1 integration of Google Checkout in a 2.3 store. Thought I'd throw in my 2 cents in case it is of any use to anyone.

 

I used the same package as Alan, but on a modified store so can't provide line numbers.

 

Unfortunately I don't have any solutions for anyone yet, but i do have a problem with installation of Google Checkout v1.5 rc1 ( v1.5_rc1.zip ) into an osCommerce 2.3.1 shop, which is driving me round the twist.

 

 

The problem some people are getting with the shopping cart button is that it's placed within the update cart form if you follow the instructions. It needs to be outside this form, so I placed it here.

 

catalog/shopping_cart.php

 

 

 <p align="right"><?php echo $value; ?></p>

<?php
  }
}

?>

</div>

</form>

<?php
	 // *** BEGIN GOOGLE CHECKOUT ***
	  if (defined('MODULE_PAYMENT_GOOGLECHECKOUT_STATUS') && MODULE_PAYMENT_GOOGLECHECKOUT_STATUS == 'True') {
		include_once('googlecheckout/gcheckout.php');
	  }
	  // *** END GOOGLE CHECKOUT ***
 } else {
?>

<div class="contentContainer">
 <div class="contentText">
<?php echo TEXT_CART_EMPTY; ?>

 

I placed the addition in the login script before the closing require calls;

 

catalog/login.php

 

 

</form>
 </div>
</div>

<?php

	  // *** BEGIN GOOGLE CHECKOUT ***
	  if (defined('MODULE_PAYMENT_GOOGLECHECKOUT_STATUS') && MODULE_PAYMENT_GOOGLECHECKOUT_STATUS == 'True') {
		include_once('googlecheckout/gcheckout.php');
	  }
	  // *** END GOOGLE CHECKOUT ***
 require(DIR_WS_INCLUDES . 'template_bottom.php');
 require(DIR_WS_INCLUDES . 'application_bottom.php');
?>

 

The additions to admin/orders.php and /admin/includes/functions/general.phpare the same as Alan's. The admin/modules.php script has an additional edit;

 

catalog/admin/modules.php

 

 

 if (tep_not_null($action)) {
switch ($action) {
  case 'save':
	// *** BEGIN GOOGLE CHECKOUT ***
	require(DIR_FS_CATALOG . 'googlecheckout/inserts/admin/modules2.php');
	// *** END GOOGLE CHECKOUT ***
	reset($HTTP_POST_VARS['configuration']);

 

I would suggest not using the gc_return.php script as it's using the 2.2 layout. I just created a replacement script for 2.3 that displays a message and empties the cart. You may wish to include the text content in a language definition.

 

 

<?php
 require('includes/application_top.php');
 require(DIR_WS_INCLUDES . 'template_top.php');
?>

<h1><?php echo "Thankyou for your order through Google Checkout." ?></h1>
<div class="contentContainer">
 <div class="contentText">
<p>Thank you for buying with <img src="http://checkout.google.com/seller/images/google_checkout.gif" /></p>
<p>Please <a href='contact_us.php'>contact us</a> if you have any queries, we will process your order shortly.</p>
 </div>
 <div class="buttonSet">
<span class="buttonAction"><?php echo tep_draw_button(IMAGE_BUTTON_CONTINUE, 'triangle-1-e', tep_href_link(FILENAME_DEFAULT)); ?></span>
 </div>
</div>
<?php
$cart->reset(true);
 require(DIR_WS_INCLUDES . 'template_bottom.php');
 require(DIR_WS_INCLUDES . 'application_bottom.php');
?>

 

For the config of the payment module, don't forget to actually install it. There's a few posts scattered around the web that seem to have missed this step. Once you have your ID and key populated for the sandbox/live checkout, open the advanced settings for the module. If, like me, you rename your admin directory, the API callback URL listed may be incorrect (although this didn't affect me as I'm not using a level 2 integration).

 

If you have created another page instead of gc_return.php, enter the name of that script in the "continue shopping URL" at the end of the advanced settings page.

 

You may also want to add a class to the additional text for the Google checkout button so you can style it. This is in the catalog/googlecheckout/gcheckout.php script.

 

 

$google_analytics_id = gc_get_configuration_value($config->googleAnalyticsId());
if ($google_analytics_id != $config->nullValue()) {  
 $Gcart->AddGoogleAnalyticsTracking($google_analytics_id);
}

?>
<div align="right">
<?php
 echo '<div class='gcAddTxt' style="width: 180px; text-align: center;"><b>' . MODULE_PAYMENT_GOOGLECHECKOUT_TEXT_OPTION . '</b></div>';
?>

 

Hopefully someone will find this of some use, it's a messy "plugin".

 

Baps.

Share this post


Link to post
Share on other sites

Baps, sorry for taking a while to get back to you.

 

Many thanks for your assistance, i'm considerably further ahead now - to the extent that the only issues i now have outstanding are:

 

 

1.> If the purchaser does not click on the return to "webshop" link, the item remains in the cart.

 

2.> Stock levels are not adjusted at all, regardless of point 1.

 

3.> Orders & Customers are not generated when purchasing by Google Checkout - i've tried this with both the original gc_return.php, and the replacement gc_return.php

 

4.> google_orders table does not get any changes made to it.

 

5.> There are errors shown at https://sandbox.google.com/checkout/sell/settings?section=IntegrationConsole

 

These are as follows:

 

We encountered an error trying to access your server at http://shop.example.com/googlecheckout/responsehandler.php -- the error we got is Send failed with code: 400. Response body was: Invalid or not supported Message

 

We encountered an error trying to access your server at http://shop.example.com/googlecheckout/responsehandler.php -- the error we got is java.io.IOException: Error 'TIMEOUT' connecting to url http://shop.example.com/googlecheckout/responsehandler.php

 

I will give this some more thought and investigation, but I am sure many other people will now be able to get much closer to solving getting the google checkout v1.5 rc1 add-on to work fully with osCommerce 2.3.1

Share this post


Link to post
Share on other sites

For the moment I deactivated my GC. The orders where processed and I did fulfill them in a backwards way.

 

But I am tired of getting 5-10 emails every day: 'Attention required: order notification failing'.

 

None of the orders or the client info ever arrived in oscommerce. Thanks for all the work you doing on this. The google help sites are utterly useless.

 

I will keep an eye on this forum, now that my shipping season slowed down a little.

 

Thanks again.

 

Wolfgang

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×