Jump to content
Silverado05

Offical Google Checkout module for osCommerce Support Thread

Recommended Posts

Updated install of 1.4 beta worked like a charm and I believe I have my two table rates working too!

 

Thank you so much Silverado05 (Nick?) for tolerating my dumb questions :)

 

Now to try to install a coupon contrib!!

 

Your Welcome, Glad you got everything sorted.

 

Discount Coupon Code works well with GC.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

Silverado05,

 

How did you get your Discount Coupon codes to work with google checkout? I have it installed and working properly with my onsite checkout (authorize.net and moneyorder) but it is adding the coupon in google checkout rather than subtracting it. It also looks as though it is automatically adding the coupon, the customer doesnt even need to enter the coupon.

 

I've installed Discount Coupons 3.3.

 

I pm'd you the same question.

 

Thanks for your help!

Share this post


Link to post
Share on other sites
Silverado05,

 

How did you get your Discount Coupon codes to work with google checkout? I have it installed and working properly with my onsite checkout (authorize.net and moneyorder) but it is adding the coupon in google checkout rather than subtracting it. It also looks as though it is automatically adding the coupon, the customer doesnt even need to enter the coupon.

 

I've installed Discount Coupons 3.3.

 

I pm'd you the same question.

 

Thanks for your help!

 

 

Here's what I've found. I had logged into the onsite checkout, added the coupon and prceeded through but didnt confirm the order. I then went back to the shopping cart and clicked google checkout. This is where it added the coupon to the list of items in the cart as a product and showed the 10% as an addition.

 

I logged out of the site, added an item to the cart and clicked google checkout, there was no coupon option box nor did the coupon show anywhere in the google checkout screen.

 

Do I need to setup the same coupons in google checkout in addition to the coupon created on the site in order to allow a coupon to be used in google? Should I be concerned that someone who logs into the site, proceeds through checkout to the confirmation page, decides to go back to the cart and use google checkout will see the coupon as an addition to the order?

Share this post


Link to post
Share on other sites

"Turn Google coupons off in your Google checkout settings."

 

Perhaps I am just overlooking it. I do not see a google coupons setting anywhere. Where might I find this setting??

Share this post


Link to post
Share on other sites

What do you have your settings for your discount coupons in OSC?

 

Google coupons are under settings then on the left at the bottom.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

Google Coupons are on your Google Checkout Settings not your OSC settings. If you have Google Coupons set up it then it will cancel out your discount coupon codes. Also what are your settings to your Discount coupon Codes in your OSC admin?


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
Google Coupons are on your Google Checkout Settings not your OSC settings. If you have Google Coupons set up it then it will cancel out your discount coupon codes. Also what are your settings to your Discount coupon Codes in your OSC admin?

 

I dont have any coupons in my google checkout (checkout.google.com) only one to test with set up in the osc coupons area.

 

 

These are my coupon settings:

Enable discount coupon?
true

Sort Order
0

Display discount with minus (-) sign?
true

Display subtotal with applied discount?
true

Display tax in discount line?
None

Exclude product specials?
true

Random Code Length
6

Display discount total lines for each tax group?
false

Allow negative order total?
false

Use the language file to format display string?
false

Display Format for Order Total Line
Discount Coupon [code] applied

Debug Mode
false

 

Thank you so much for your help!

Share this post


Link to post
Share on other sites

set "Allow negative order total?" True


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

Hello, Silverado05,

 

I am so eager to let you know there is nothing wrong with the google checkout model. After I manually reinstall a fresh osCOMMERCE at the root folder. Everything works fine.

 

So I guess the problem is from the I tried at least 10 times of the os Commerce Pro in the netfirms.

 

If anyone has the same problem form netfirms, I would like to recommend them to do the manual installation.

 

Thanks again for your answers.

 

WM

 

If you are just getting Array ( ) Array ( ) then you need to run your shipping generator. If you have run that then post your includes/configure.php here minus the database info at the bottom.

Share this post


Link to post
Share on other sites

I'm using a TemplateMonster template from 5/25/06. I installed the module manually. I backed up the changed files. Ran the site and received this error:

 

Fatal error: Cannot redeclare tep_set_banner_status() (previously declared in /home/cedarsho/public_html/shop/includes/functions/general.php:694) in /home/cedarsho/public_html/shop/includes/functions/banner.php on line 15

 

I've since removed the files. Restored the backup and I still receive the error above. I've tried in 3 different browsers and the same thing comes up. How do I fix this without losing my other modules and format changes?


End of line.

Share this post


Link to post
Share on other sites

Cannot redeclare tep_set_banner_status() that error you are receiving is not related to Google Checkout. It looks like you didn't edit the general.php file correctly or you removed something that wasn't supposed to be removed.

 

Are you sure your back up file restored properly?


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
Cannot redeclare tep_set_banner_status() that error you are receiving is not related to Google Checkout. It looks like you didn't edit the general.php file correctly or you removed something that wasn't supposed to be removed.

 

Are you sure your back up file restored properly?

 

I renamed the files on the server. Then uploaded the new files. When things went wrong I deleted the new files and renamed the old files. When that didn't work I uploaded the original files from the original downloaded zip file.

 

The problem persists as you can see. I'm not sure what to do.


End of line.

Share this post


Link to post
Share on other sites

So then the answer would be no your files didn't restore properly. When you back up files you need to save them on your hard drive that way if you need it you can FTP them back. All you did is rename the edited files no matter if you deleted them or not. The server will revert back to the original edits. So all you did was delete and extra file with the same name.

 

Next time save it to your hard drive, don't rename it on your server.

 

You need to call your host and see if they can run a back up of your site from a day before this happened.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
So then the answer would be no your files didn't restore properly. When you back up files you need to save them on your hard drive that way if you need it you can FTP them back. All you did is rename the edited files no matter if you deleted them or not. The server will revert back to the original edits. So all you did was delete and extra file with the same name.

 

Next time save it to your hard drive, don't rename it on your server.

 

You need to call your host and see if they can run a back up of your site from a day before this happened.

I restored the backup and reinstalled the module. It works! Not without errors though.

1. When I run shipping_method_generator.php it comes up with the methods for UPS (I only use UPS) just fine. It generates no code and gives me an error: * ups WXS has an empty "Method Fancy Name"

2. I activated it and began a test order (with the live system) and the button said "Error: Shipping Methods not configured ups (ignored)" I'm not sure what this is. I looked throught the thread and found references to using UPSXML. So I downloaded it and began to install it, but the code it wants me to enter into modules.php looks like it will conflict with the Google Checkout code. I'm not sure what to do.


End of line.

Share this post


Link to post
Share on other sites

What UPS module are you using?

 

Also after you ran the shipping method generator did you take that code and past it in your shipping_methods.php?

 

If you did then post the code of the file, if not run the shipping generator and post that code into your shipping_methods.php?


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

shipping it's on zero. I'm using Zones rates, but I'm wondering if I set everything correctly. I inserted ISO for country, so Great Britain GB but still nothing, maybe there is a problem, because I can't find any zone settings in google account...

Edited by ErollorD

Share this post


Link to post
Share on other sites
shipping it's on zero. I'm using Zones rates, but I'm wondering if I set everything correctly. I inserted ISO for country, so Great Britain GB but still nothing, maybe there is a problem, because I can't find any zone settings in google account...

 

 

Do you have your zones set up correctly on OSC? Google Checkout does not have a zone settings. You have to properly configure your zones in OSC then run the shipping generator. Then past that code into shipping_methods.php in the proper place. The module will then pass all that information to Google during Checkout. Have you done all of this?


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

I don't think your problem is Google Related.

 

Do you not have any products in your catalog yet?


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

Well I am not sure what you are asking?

 

This:

 

Cart Description

Weight:

Quantity:

Total Price:

 

Is not part of Google Checkout. You need to be a little more informative with your explanation and question.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

so with shipping generator I'm getting

 

<?php
/**
 * File: googlecheckout/shipping_methods.php file
 */ 
$mc_shipping_methods = array(
							  );

$mc_shipping_methods_names = array(

				   );
?>

can somebody else gives me what u get?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×