Jump to content
Sign in to follow this  
adammde

Problem with STS 4.5.2 and category list mods

Recommended Posts

Hi all,

 

I have been using STS and it works great... up until I tried using the Show Sub-Categories mod (latest version as shown here). After integration, all boxes stretch to 100% of the screen width, although functionally it's fine.

 

screenie.jpg

 

Is this a problem of STS trying to parse the already-modded category list layout into a table, or did I mess up?

 

Any help much appreciated!

 

Adam

Share this post


Link to post
Share on other sites

Fixed:

 

I loaded the page and read through the HTML output, and found a closing /table tag that shouldn't have been there. Unfortunately it wasn't clear which part of the PHP was writing it, so I simply inserted an opening table tag before the category menu in the STS template.

 

Layout is now fine again.

 

However a better solution would be to find the conflict between STS and the menu contrib to figure out where the closing /table tag is coming from...

 

Adam

Share this post


Link to post
Share on other sites
Fixed:

 

I loaded the page and read through the HTML output, and found a closing /table tag that shouldn't have been there. Unfortunately it wasn't clear which part of the PHP was writing it, so I simply inserted an opening table tag before the category menu in the STS template.

 

Layout is now fine again.

 

However a better solution would be to find the conflict between STS and the menu contrib to figure out where the closing /table tag is coming from...

 

Adam

Adam, first of all, thanks for posting back with your fix. What contribution are you trying to get to work with STS? Did you take a look at the STS4 Power Pack site to see if a fix was already available? Also, since you posted this outside of the STSv4 Forum, did you take a look at the forum to see if anyone else had the same issue?

 

Please post a response in the STSv4 Forum (link in my signature below). This appears to be an issue with the other contribution but other STS users would be interested since you used STS to come up with a fix.

 

Thanks,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×