Jump to content
Sign in to follow this  
dreaming spires oxford

Ultimate SEO Url 2.1d Installation Problem

Recommended Posts

I have installed this contribution with the following result. Visit My Website.

I am now not getting my page displayed but part of this contribution.

I would appreciate it if anyone who has successfully made this instalation please offer advice as to what has gone wrong and how to rectify.

Thanks for your help.


Best regards

 

Peter

Share this post


Link to post
Share on other sites

My guess is that you uploaded the install.html file from the contribution. There is also a mistake in one of the changes you made which you can see here. You need to read back through the instructions and doublecheck everything.

 

Jack

Share this post


Link to post
Share on other sites

Jack

Many many thanks for taking the time to look at my problem.

I have reinstated from a previous back up but still do not get my pages when logging in at www.janitorman.net.

Visit My Website.

However if I click the error message link you provided in your reply to me I do.

Can you perhaps advise what is happening and what I can do to restore correctly.

Thanking you in anticipation.


Best regards

 

Peter

Share this post


Link to post
Share on other sites
Jack

Many many thanks for taking the time to look at my problem.

I have reinstated from a previous back up but still do not get my pages when logging in at www.janitorman.net.

Visit My Website.

However if I click the error message link you provided in your reply to me I do.

Can you perhaps advise what is happening and what I can do to restore correctly.

Thanking you in anticipation.

 

Wierd, i click on your link and i go to a version of ur page that has the install instructions on, but jacks link shows ur actual site... but both directed to http://janitorman.net

 

Im having problems with this contribution as well, sorted out the problem not being able to access my catalog from admin section... added this to SQLdatabase.

 

ALTER TABLE `categories_description` ADD `categories_seo_url` VARCHAR( 100 ) NOT NULL ;

ALTER TABLE `products_description` ADD `products_seo_url` VARCHAR( 100 ) NOT NULL ;

 

Any wayz my problem is when i have enable SEOs set to true i get 404 errors for all my products... Ive followed all the installation instructions and the additional instructions, but with no success. Where should i start with solving this problem?

 

Adam

Share this post


Link to post
Share on other sites
Jack

Many many thanks for taking the time to look at my problem.

I have reinstated from a previous back up but still do not get my pages when logging in at www.janitorman.net.

Visit My Website.

However if I click the error message link you provided in your reply to me I do.

Can you perhaps advise what is happening and what I can do to restore correctly.

Thanking you in anticipation.

Did you check what I already suggested?

 

Jack

Share this post


Link to post
Share on other sites
Wierd, i click on your link and i go to a version of ur page that has the install instructions on, but jacks link shows ur actual site... but both directed to http://janitorman.net

 

Im having problems with this contribution as well, sorted out the problem not being able to access my catalog from admin section... added this to SQLdatabase.

 

ALTER TABLE `categories_description` ADD `categories_seo_url` VARCHAR( 100 ) NOT NULL ;

ALTER TABLE `products_description` ADD `products_seo_url` VARCHAR( 100 ) NOT NULL ;

 

Any wayz my problem is when i have enable SEOs set to true i get 404 errors for all my products... Ive followed all the installation instructions and the additional instructions, but with no success. Where should i start with solving this problem?

 

Adam

That is usually due to having the wrong path set in the .htaccess file.

 

Jack

Share this post


Link to post
Share on other sites
That is usually due to having the wrong path set in the .htaccess file.

 

Jack

 

Hi, ive got 2 htaccess files one before the catalog directory and one in the catalog dir... Ive added this file to the one in the /catalog

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

Is it somethign in this bit, or in the rest of my file thats wrong, because i think the rest is the stock stuff.

Share this post


Link to post
Share on other sites

Hi, been busy last few days so not had a good chance to look at this. What is the correct path??? and roughly where should it be placed in my htaccess file. Thanks for any help. I got those HTC working with the super help from this fourm so thanks to all (jack especially).

 

Adam

Share this post


Link to post
Share on other sites

It should be

RewriteBase /catalog/

And there should only be one file with the rewrite code in it and that should be in the catalog directory, assuming that is where your shop is located.

 

Jack

Share this post


Link to post
Share on other sites
It should be
RewriteBase /catalog/

And there should only be one file with the rewrite code in it and that should be in the catalog directory, assuming that is where your shop is located.

 

Jack

Hi jack my .htaccess file is set to my root catagory, but its under a different name /*****/store, does this matter at all? Is there any other files from the Seo contribution that require me to change it from /catalog to /*****/store????

 

Ive checked and it is the only htaccess file with the rewrite rule in and its in my catalog route. Should i try changing it to the /***** bit???

 

Adam

Share this post


Link to post
Share on other sites
Hi jack my .htaccess file is set to my root catagory, but its under a different name /*****/store, does this matter at all? Is there any other files from the Seo contribution that require me to change it from /catalog to /*****/store????

 

Ive checked and it is the only htaccess file with the rewrite rule in and its in my catalog route. Should i try changing it to the /***** bit???

 

Adam

I'm not sure I follow that but try this. Loacated the index.php file for your shop (not the one in the english directory). Edit the .htaccess file that is in the same directory as your index.php. Whatever directory that is should be in the .htacces file. If it is nested, then the full path needs to be entered.

 

Jack

Share this post


Link to post
Share on other sites
I'm not sure I follow that but try this. Loacated the index.php file for your shop (not the one in the english directory). Edit the .htaccess file that is in the same directory as your index.php. Whatever directory that is should be in the .htacces file. If it is nested, then the full path needs to be entered.

 

Jack

 

Hi, yeah i did i dodgy explaination last time, but basically my htaccess file where my index.php is... is set with the full path of my nested shop entered. :( . What other places could cause a 404 error... When the Seo contribution is turned on my new urls look like this.

 

http://www.mystore.co.uk/Store/war-elemental-p-86.html

 

Is there something wrong in this maybe???

 

Thanks for any and all help.

 

Adam

Share this post


Link to post
Share on other sites

If you are on a non-Windows server and the name of the directory is store, then that will fail since it is case-sensitive. If you have other .htaccess files with redirects, which I think you said you did, then that might cause it to fail.

 

Jack

Share this post


Link to post
Share on other sites
If you are on a non-Windows server and the name of the directory is store, then that will fail since it is case-sensitive. If you have other .htaccess files with redirects, which I think you said you did, then that might cause it to fail.

 

Jack

 

WoooooooooOOOOooooooooooooooooooooooW, they working they working... THanks alot Jack Mc, its the smallest things that cause the biggest problems. Thanks a billion...

 

Regards

 

Adam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×