Jump to content
Jack_mcs

Links Manager II

Recommended Posts

According to your posts and the errors, your shop is located in the catalog directory. So instead of it should be

 

Jack

 

Sorry for all the trouble, Im completly lost now and don't know what to try next. I had to remove the changes in column left, column right and catalog/includes/boxes/information because it made my boxes too wide and gave me other errors.

on my home page as seen below. I'm working with a live shop so I can't leave the errors on site.

 

Walt

 

Warning: main(includes/boxes/links.php) [function.main]: failed to open stream: No such file or directory in /usr/local/www/virtual1/66/175/33/157/html/catalog/includes/column_right.php on line 42

 

Warning: main() [function.include]: Failed opening 'includes/boxes/links.php' for inclusion (include_path='.:/usr/local/share/pear') in /usr/local/www/virtual1/66/175/33/157/html/catalog/includes/column_right.php on line 42

Share this post


Link to post
Share on other sites

I think you are probably uploading to the wrong place on the server. You need to make sure the files are where they should be.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

 

i just installed linkmanager II, in the Admin everything works fine, but when i click on link sin teh site the links.php page go blank.

 

what went wrong, i didnt make any changes to links.php

 

Mitch

Share this post


Link to post
Share on other sites

If you mean the whole page goes blank, then that is usually caused by uploading the links.php file that belongs in the english directory to the root directory.

 

Jack

Share this post


Link to post
Share on other sites
If you mean the whole page goes blank, then that is usually caused by uploading the links.php file that belongs in the english directory to the root directory.

 

Jack

 

 

Thanks Jack,

 

 

there was a file missing in the dutch directory, the problem is solved, a new problem arived. I tranlate everything to dutch but there are 3 things i cant find.

1. in colum_left of the shop in the information box "Links" i want it to be Linken but i cant find it in the language files.

2. HEADING_TITLE is displayd in stead of the title i gave it.

3. HEADING_TITLE_SEARCH is displayd, i cant find where to change it.

 

Mitch

Share this post


Link to post
Share on other sites

You have to add the links manager files in the languages directories to any language you want to use.

 

Jack

Share this post


Link to post
Share on other sites
You have to add the links manager files in the languages directories to any language you want to use.

 

Jack

I have 3 files uploaded in the language directory's:

links.php

links_submit.php

links_submit_succes.php

 

i cant find any more

 

Mitch

Share this post


Link to post
Share on other sites

Try setting the option in admin->Configuration->Links to load for all languages.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack, this is a great contibution I am trying to set up the link info for simplicity

you recommend

 

define('LINK_NAME', 'Link Name');

define('LINK_DESCRIPTION', 'My home page sells the best products you can imagine.');

define('LINK_URL', 'http://www.myhomepage.com');

 

I have modified this to read

define('LINK_NAME', '' . STORE_NAME . '');

 

this works a treat and places the storename as a title

however what do I call to pull the stores description from HTC and what do i call for the stores URL

 

Thanks in advance

Share this post


Link to post
Share on other sites

define('LINK_URL', ''. HTTP_SERVER .''); sorts out the website address, now just to figure out the description

Share this post


Link to post
Share on other sites

Hi Jack

 

Thanks for LINK MANAGER II.

 

I am new to LM and have just installed it. I get the LINKS link on my home page and I can add a link. I also get the email notifications.

 

I am unable to approve the links. As far as I can tell, there should be a Links Manager section in the Admin page but I have nothing there. Where should I be looking to fix this?

 

cheers,


Patrick Markham

Share this post


Link to post
Share on other sites
Hi Jack, this is a great contibution I am trying to set up the link info for simplicity

you recommend

I have modified this to read

define('LINK_NAME', '' . STORE_NAME . '');

 

this works a treat and places the storename as a title

however what do I call to pull the stores description from HTC and what do i call for the stores URL

 

Thanks in advance

The keyword for the page should be the named used, in some fashion. That is almost never the store name so making that change would be a mistake, from an SEO point of view.

 

Jack

Share this post


Link to post
Share on other sites
Hi Jack

 

Thanks for LINK MANAGER II.

 

I am new to LM and have just installed it. I get the LINKS link on my home page and I can add a link. I also get the email notifications.

 

I am unable to approve the links. As far as I can tell, there should be a Links Manager section in the Admin page but I have nothing there. Where should I be looking to fix this?

 

cheers,

If you are not seeing a Links Manager link in admin, then you didn't complete the installation. You will need to go over the instructions again. Look for the change to the admin/includes/column_left.php file to start.

 

Jack

Share this post


Link to post
Share on other sites
If you are not seeing a Links Manager link in admin, then you didn't complete the installation. You will need to go over the instructions again. Look for the change to the admin/includes/column_left.php file to start.

 

Jack

 

Jack,

 

Thanks for the rapid response. Is see my error(s)! I have confused the 'catalogue/admin/includes' and 'catalogue/includes' directories from time to time!

 

arrrghhhh!


Patrick Markham

Share this post


Link to post
Share on other sites

Okay, all files in the right places now!

 

I stall have an

 

Admin -> Configuration -> Links

 

but not an

 

Admin -> Links Manager II

 

Do I need to re-run setup? I have tried but got the message: Looks like Links Manager is already installed. Aborting...

 

cheers


Patrick Markham

Share this post


Link to post
Share on other sites
Okay, all files in the right places now!

 

I stall have an

 

Admin -> Configuration -> Links

 

but not an

 

Admin -> Links Manager II

 

Do I need to re-run setup? I have tried but got the message: Looks like Links Manager is already installed. Aborting...

 

cheers

If you have done the installation correctly, it may be that you have the admin access contribution installed. In that case, you have to enable the file before it display.

 

Jack

Share this post


Link to post
Share on other sites
If you have done the installation correctly, it may be that you have the admin access contribution installed. In that case, you have to enable the file before it display.

 

Jack

 

"admin access contribution"?? What's that? And how do I enable it?


Patrick Markham

Share this post


Link to post
Share on other sites
"admin access contribution"?? What's that? And how do I enable it?
You don't enable it. It is a contribution that controls how your admin is viewed by various members. If you don't have it installed, it is not the problem and needn't be concerned about. If you do, then you need to ask in its support thread as to how to use it. If you have it installed, there will be a administration section in your admin.

 

Jack

Share this post


Link to post
Share on other sites

Oh, I see. I don't have it installed then. It's a new installation of OSCommerce.

 

I'm not even sure what else I'm supposed to see! I have a 'Links' link below 'Sessions' in the Admin > Configuration section but this just does config settings. I'm looking for the bit where I can manage my link requests.

 

I also have a 'Links' link on my shop page for requesting a link (that works okay)

 

Any other suggestions?

 

Patrick

Edited by patrick101

Patrick Markham

Share this post


Link to post
Share on other sites

You've missed a step in the installation. See my text regarding the left column.

 

Jack

Share this post


Link to post
Share on other sites
You've missed a step in the installation. See my text regarding the left column.

 

Jack

 

Hi Jack,

 

Thanks for your patience.

 

I have the line

require(DIR_WS_BOXES . 'links.php');

in admin/includes/column_left.php

 

Will I need to rerun setup following my initial errors?


Patrick Markham

Share this post


Link to post
Share on other sites
QUOTE(Brian-Bear @ Nov 12 2007, 09:31 AM)

Hi Jack, this is a great contibution I am trying to set up the link info for simplicity

you recommend

I have modified this to read

define('LINK_NAME', '' . STORE_NAME . '');

 

this works a treat and places the storename as a title

however what do I call to pull the stores description from HTC and what do i call for the stores URL

 

Thanks in advance

The keyword for the page should be the named used, in some fashion. That is almost never the store name so making that change would be a mistake, from an SEO point of view.

 

Jack

 

Hi Jack, an inbound link is still what is achieved and yes it would be better with a keyword but this is like a default setting that can be fine tuned later, Do you know what pulls the default description from Header Tags Controller.

 

Can I make a suggetion, that you could enter your websites custom link details from admin in any updates of link manager 11

Share this post


Link to post
Share on other sites
Hi Jack,

 

Thanks for your patience.

 

I have the line

require(DIR_WS_BOXES . 'links.php');

in admin/includes/column_left.php

 

Will I need to rerun setup following my initial errors?

Change the line
require(DIR_WS_BOXES . 'links.php');

to

require(DIR_WS_BOXES . 'customers.php');

Does it show up?

 

Jack

Share this post


Link to post
Share on other sites
Hi Jack, an inbound link is still what is achieved and yes it would be better with a keyword but this is like a default setting that can be fine tuned later, Do you know what pulls the default description from Header Tags Controller.

 

Can I make a suggetion, that you could enter your websites custom link details from admin in any updates of link manager 11

An inbound link is of little use if not setup correctly. If you have header tags code installed in the head section of the page, then HEAD_DESC_TAG_DEFAULT will hold the default description. I didn't add the code for the site information in admin because it can't be added as an option in the links settings section. A new page would have to be created to handle it and I ran out of time for working on the project on this go-around.

 

Jack

Share this post


Link to post
Share on other sites
Change the line
require(DIR_WS_BOXES . 'links.php');

to

require(DIR_WS_BOXES . 'customers.php');

Does it show up?

 

Jack

 

No, it's made no difference, although customers.php is of course already there.


Patrick Markham

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×