Jump to content
Jack_mcs

Links Manager II

Recommended Posts

That works for the Links Status page only and for one of those links:

link05.jpg

 

However it doesn't seem to work for the Links page (same link after refresh), clicking check link button shows Link Check Result: Not Found

link06.jpg

Edited by mr_absinthe

Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

That works for the Links Status page only and for one of those links:

 

However it doesn't seem to work for the Links page (same link after refresh), clicking check link button shows Link Check Result: Not Found

 

As mentioned, it works fine here and the links are found. Perhaps it is related to the php version and/or server settings, though I doubt it since the other links work.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

As mentioned, it works fine here and the links are found. Perhaps it is related to the php version and/or server settings, though I doubt it since the other links work.

I understand that the link might not be found due to server settings, php version or bad weather and I accept that. But why the link that IS correctly found on the Links Status page as shown above (the webtender) is being shown as Not Found with "disable" button on the Links page? Are those pages not using the very same script from admin/includes/functions/links.php file?


Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

Hello all,

 

I've installede the contrib. I've follewed the instructions as mentioned but when I login I get the following:

 

1146 - Table 'born22_osco1.TABLE_ACTION_RECORDER' doesn't exist

 

select id from TABLE_ACTION_RECORDER where module = 'ar_admin_login' and (user_name = 'admin' or identifier = '94.208.223.123') and date_added >= date_sub(now(), interval 5 minute) and success = 0 order by date_added desc limit 3

 

[TEP STOP]

 

What's wrong?

Share this post


Link to post
Share on other sites

Hello all,

 

I've installede the contrib. I've follewed the instructions as mentioned but when I login I get the following:

 

 

 

What's wrong?

That error means there is a missing definition in your files and it is a default one for 2.3. So either you used the wrong set of files to install for your oscommerce version or there was a problem with the shop in the first place.

Share this post


Link to post
Share on other sites

Actually, now that you mention it, I think someone reported this problem in the Header Tags SEO thread and it was spcific to IE. If you know the fix, or the contribution, you are referring to, please let me know since it will save me the work of having to find the solution myself. :)

 

Jack, I am sure you have a handle on this issue, but I just downloaded Firefox tonight and took a look at that page I reported to you. In Firefox it's fine.

 

So for Admin>>Links Manager II>>Links

 

In IE8 the page display is distorted (meaning the content is pushed downward)

In Firefox/3.6.13 the page displays correctly.

 

Just feedback is all....thanks


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Hi Jack,

 

installed 1.29 by uploading the files appeared okayt, but I dont want people to upload there images to the site, so prefer just to have the the old image url option only.

 

would i need to modify much to keep the new functionality and still use the image url in submit links and in admin?

 

maybe useful tohave as option selected in admin or to haev the option for the link submitter, if they want to upload or use the url?

 

Thanks, I did note that previously submitted image urls worked fine.


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Hello Jack,

 

Installed your contribution but of course I'm getting a error :rolleyes:

 

When clicking on Link Categories following error message shows up?

 

Not Found

The requested URL /catalog/addy/FILENAME_LINKS_CATEGORIES was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at www.koolkatjazz.com Port 80

 

All other links are working?

 

Please advise

 

Cheers


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

installed 1.29 by uploading the files appeared okayt, but I dont want people to upload there images to the site, so prefer just to have the the old image url option only.

 

would i need to modify much to keep the new functionality and still use the image url in submit links and in admin?

 

maybe useful tohave as option selected in admin or to haev the option for the link submitter, if they want to upload or use the url?

 

Thanks, I did note that previously submitted image urls worked fine.

No, it's not possible. It's not a simple change to add that code back in but it can be done.

Share this post


Link to post
Share on other sites

When clicking on Link Categories following error message shows up?

 

The requested URL /catalog/addy/FILENAME_LINKS_CATEGORIES was not found on this server.

Whenever you see capital letters in an error like that, it almost always means a step was missed in the installation. Search the install instructions for FILENAME_LINKS_CATEGORIES and you should be able to find the mistake.

Share this post


Link to post
Share on other sites

Whenever you see capital letters in an error like that, it almost always means a step was missed in the installation. Search the install instructions for FILENAME_LINKS_CATEGORIES and you should be able to find the mistake.

 

Do I have to re-run links_setup.php?

 

I have re-uploaded everything else?

 

Cheers


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Do I have to re-run links_setup.php?

 

I have re-uploaded everything else?

 

Cheers

No, that is for the database changes. It should only be done once.

Share this post


Link to post
Share on other sites

Still the same error?

 

What I'm I missing?


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Still the same error?

 

What I'm I missing?

If you are still seeing the capital letters, it is for the reason I stated. You will have to find the part you missed in the installation.

Share this post


Link to post
Share on other sites

If you are still seeing the capital letters, it is for the reason I stated. You will have to find the part you missed in the installation.

Jack, I have re-done it 3 times and nothing changes, it is still the same. I also noticed that it make no difference if I enable or disable Links Manager II in module/boxes, it is still showes up on the site?

 

Placement is also stuck on the right side and will not move to the left either?

 

Please help me


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Jack, I have re-done it 3 times and nothing changes, it is still the same. I also noticed that it make no difference if I enable or disable Links Manager II in module/boxes, it is still showes up on the site?

 

Placement is also stuck on the right side and will not move to the left either?

 

Please help me

Please post the filenames.php file from the catalog/addy/ section of your shop.

Share this post


Link to post
Share on other sites

Here you go

 

<?php
/*
 $Id$

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2007 osCommerce

 Released under the GNU General Public License
*/

// define the filenames used in the project
 define('FILENAME_ACTION_RECORDER', 'action_recorder.php');
 define('FILENAME_ADMINISTRATORS', 'administrators.php');
 define('FILENAME_BACKUP', 'backup.php');
 define('FILENAME_BANNER_MANAGER', 'banner_manager.php');
 define('FILENAME_BANNER_STATISTICS', 'banner_statistics.php');
 define('FILENAME_CACHE', 'cache.php');
 define('FILENAME_CATALOG_ACCOUNT_HISTORY_INFO', 'account_history_info.php');
 define('FILENAME_CATEGORIES', 'categories.php');
 define('FILENAME_CONFIGURATION', 'configuration.php');
 define('FILENAME_COUNTRIES', 'countries.php');
 define('FILENAME_CURRENCIES', 'currencies.php');
 define('FILENAME_CUSTOMERS', 'customers.php');
 define('FILENAME_DEFAULT', 'index.php');
 define('FILENAME_DEFINE_LANGUAGE', 'define_language.php');
 define('FILENAME_FEEDERS', 'feeders.php');
 define('FILENAME_GEO_ZONES', 'geo_zones.php');
 define('FILENAME_LANGUAGES', 'languages.php');
 define('FILENAME_LOGIN', 'login.php');
 define('FILENAME_MAIL', 'mail.php');
 define('FILENAME_MANUFACTURERS', 'manufacturers.php');
 define('FILENAME_MODULES', 'modules.php');
 define('FILENAME_NEWSLETTERS', 'newsletters.php');
 define('FILENAME_ORDERS', 'orders.php');
 define('FILENAME_ORDERS_INVOICE', 'invoice.php');
 define('FILENAME_ORDERS_PACKINGSLIP', 'packingslip.php');
 define('FILENAME_ORDERS_STATUS', 'orders_status.php');
 define('FILENAME_POPUP_IMAGE', 'popup_image.php');
 define('FILENAME_PRODUCTS_ATTRIBUTES', 'products_attributes.php');
 define('FILENAME_PRODUCTS_EXPECTED', 'products_expected.php');
 define('FILENAME_REVIEWS', 'reviews.php');
 define('FILENAME_SEC_DIR_PERMISSIONS', 'sec_dir_permissions.php');
 define('FILENAME_SERVER_INFO', 'server_info.php');
 define('FILENAME_SHIPPING_MODULES', 'shipping_modules.php');
 define('FILENAME_SPECIALS', 'specials.php');
 define('FILENAME_STATS_CUSTOMERS', 'stats_customers.php');
 define('FILENAME_STATS_PRODUCTS_PURCHASED', 'stats_products_purchased.php');
 define('FILENAME_STATS_PRODUCTS_VIEWED', 'stats_products_viewed.php');
 define('FILENAME_STORE_LOGO', 'store_logo.php');
 define('FILENAME_TAX_CLASSES', 'tax_classes.php');
 define('FILENAME_TAX_RATES', 'tax_rates.php');
 define('FILENAME_VERSION_CHECK', 'version_check.php');
 define('FILENAME_WHOS_ONLINE', 'whos_online.php');
 define('FILENAME_ZONES', 'zones.php');
 define('FILENAME_DATABASE_OPTIMIZER', 'database_optimizer.php');
 // Links Manager II v1.29 begin
 define('FILENAME_LINKS', 'links.php');
 define('FILENAME_LINK_CATEGORIES', 'link_categories.php');
 define('FILENAME_LINKS_CONTACT', 'links_contact.php');
 define('FILENAME_LINKS_CHECK', 'links_check.php');
 define('FILENAME_LINKS_EXCHANGE', 'links_exchange.php');
 define('FILENAME_LINKS_FEATURED', 'links_featured.php');
 define('FILENAME_LINKS_STATUS', 'links_status.php');
// Links Manager II v1.29 end
?>

 

Cheers


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Here you go

Yes, that is correct. It is a 2.3 file. Are you sure you used the 2.3 install section in the contribution?

Share this post


Link to post
Share on other sites

Yes, that is correct. It is a 2.3 file. Are you sure you used the 2.3 install section in the contribution?

 

Hi Jack,

 

Yes I'm sure, I even deleted the 2.2 folder so I would not mix them up.

 

Cheers


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Yes I'm sure, I even deleted the 2.2 folder so I would not mix them up.

Then, sorry, but I don't have any other suggestions.

Share this post


Link to post
Share on other sites

Then, sorry, but I don't have any other suggestions.

 

Could there have been any errors while running links_setup.php?

 

Also what is the links_db_update.php for?

 

Cheers


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Could there have been any errors while running links_setup.php?

 

Also what is the links_db_update.php for?

There could have been errors with that but it wouldn't cause a problem like you are seeing. The update script is for updating the configuration options without destroying the ones that are already set. It is not needed unless the update instructions says to use it.

Share this post


Link to post
Share on other sites

Could there be another contribution that conflicts with yours?

 

Cheers

Edited by pederb

-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Could there be another contribution that conflicts with yours?

 

Cheers

I don't recall any but it is possible but that wouldn't cause that problem.

Share this post


Link to post
Share on other sites

Jack, if I type in manually the correct url, http://www.koolkatjazz.com/catalog/*******/link_categories.php then it works and the page "Link Categories" shows up.

 

But if I click on the link in the program I get following url, http://www.koolkatjazz.com/catalog/********/FILENAME_LINKS_CATEGORIES and 404 Not Found

 

Hope this is of help

 

Cheers


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×