Jump to content
Jack_mcs

Links Manager II

Recommended Posts

The link has to be marked Approved in order for it to show on the site. The language setting has to be set to All in order for it to show on the site. Other than that, the links should show up. At least, I can't think of anything else that would stop them.

 

Jack

 

I have nothing showing up on my sites link page. I've spent 3 hours now searching what to do. I have english clicked at my language. I made sure that each catagory is turned on. I've made sure that the language in each link is clicked to all. I saw something about turning off search engine friendly, but can't find that...i did find search engine safe. I've tried quit a few things and it's just not showing up. Any other thing i need to try?

 

Thanks,

Denise

Share this post


Link to post
Share on other sites

I have nothing showing up on my sites link page. I've spent 3 hours now searching what to do. I have english clicked at my language. I made sure that each catagory is turned on. I've made sure that the language in each link is clicked to all. I saw something about turning off search engine friendly, but can't find that...i did find search engine safe. I've tried quit a few things and it's just not showing up. Any other thing i need to try?

 

Thanks,

Denise

The option to turn off is in admin->Configuration->My Store and is named "Use Search-Engine Safe URLs (still in development)."

 

In admin, be sure the link you added is assigned to a category, not Top. Also make sure it is still set to enabled and try setting the language to All.

Share this post


Link to post
Share on other sites

The option to turn off is in admin->Configuration->My Store and is named "Use Search-Engine Safe URLs (still in development)."

 

In admin, be sure the link you added is assigned to a category, not Top. Also make sure it is still set to enabled and try setting the language to All.

Yes, I had presumed the seacrch engine safe was what I needed to turn off. I also had already asigned new categories, as well as double checked to make sure they were enabled. I even went in and reclicked enabled just in case, even though it was set. As I said, they are all set to all in language.

Share this post


Link to post
Share on other sites

Yes, I had presumed the seacrch engine safe was what I needed to turn off. I also had already asigned new categories, as well as double checked to make sure they were enabled. I even went in and reclicked enabled just in case, even though it was set. As I said, they are all set to all in language.

Assuming you have the latest version of Links Manager instaled and the links are active, I can't think of anything else to try. But since you said nothing is showing up on the links page, I have to assume something is wrong with your caegories since they should show up, unless you don't have the option to show them set in the settings.

Share this post


Link to post
Share on other sites

Assuming you have the latest version of Links Manager instaled and the links are active, I can't think of anything else to try. But since you said nothing is showing up on the links page, I have to assume something is wrong with your caegories since they should show up, unless you don't have the option to show them set in the settings.

Yes, I have the latest version. I had an older one, but found the new one, tried to update but had some trouble, so took out both the old and the new completely. Then installed the new one. I had trouble, but got that all figured out. The only thing not working is the site page not work (that I can tell of coarse). There is one thing this time that i didn't have the first time (or when i tried to update)....in administration-configuration, there are 2 "links" available. One is smaller, but what is listed there is listed on the one with more options. I made sure they were both set to the same things, but maybe that's my problem....i shouldn't have 2. Maybe i need to take it off again.

Share this post


Link to post
Share on other sites

I did a fresh install, and my links page from the catalog directory retrieves this error: 404 not found for catalog/FILENAME_LINKS

 

i checked my error logs and got this:

[22-Feb-2010 02:48:37] PHP Warning:  require(includes/boxes/links.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in root/admin/includes/column_left.php on line 23
[22-Feb-2010 02:48:37] PHP Fatal error:  require() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/boxes/links.php' (include_path='.:/usr/services/vux/lib/php') in root/admin/includes/column_left.php on line 23

 

this is my column left:

<?php
/*
 $Id: column_left.php 1739 2007-12-20 00:52:16Z hpdl $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2002 osCommerce

 Released under the GNU General Public License
*/

 require(DIR_WS_BOXES . 'configuration.php');
 require(DIR_WS_BOXES . 'catalog.php');
 require(DIR_WS_BOXES . 'modules.php');
 require(DIR_WS_BOXES . 'customers.php');
 require(DIR_WS_BOXES . 'taxes.php');
 require(DIR_WS_BOXES . 'localization.php');
 require(DIR_WS_BOXES . 'reports.php');
 require(DIR_WS_BOXES . 'tools.php');

// Links Manager II v1.24 begin
 require(DIR_WS_BOXES . 'links.php');
// Links Manager II v1.24 end
?>

 

the admin shows everything, just nothing for the catalog links page.

ANY IDEAS? thanks :)

Edited by Tim Romero

Share this post


Link to post
Share on other sites

I installed the contribution v.1.25. It gave me no error in my installation, but when I create the categories, the link does not work. (www.labotigadelvi.com/catalog/links.php/lPath/0_1)

 

Any ideas?

 

This is the address of my website.

http://www.labotigadelvi.com/catalog/links.php

 

I tried to test also try creating some link, but not on the initial category.

 

I installed header tags Seo 3.0

Thank you very much

Edited by mega01

Share this post


Link to post
Share on other sites

I installed the contribution v.1.25. It gave me no error in my installation, but when I create the categories, the link does not work. (www.labotigadelvi.com/catalog/links.php/lPath/0_1)

That's not a valid link. If you are using Ultimate SEO V2.2d (recommended), then you don't have the latest version installed or it is not installed correctly. If you are using some other url rewriter contribution, you will need to ask in the support thread for it for a fix.

Share this post


Link to post
Share on other sites

ok, I am using the contribution "Ultimate SEO URLs" might also have something to do?

 

I have installed the version "Ultimate SEO URLs v2.8 - FullPackage" I recommend for example, Ultimate SEO 2-2.2d-7? Is it compatible?

 

Thanks

Share this post


Link to post
Share on other sites

ok, I am using the contribution "Ultimate SEO URLs" might also have something to do?

 

I have installed the version "Ultimate SEO URLs v2.8 - FullPackage" I recommend for example, Ultimate SEO 2-2.2d-7? Is it compatible?

 

Thanks

 

 

I turned off the tax so that the link is normal oscommerce, and still not working.

 

I also downloaded the files replacing Ultimate_SEO_URLSv22d_7 contained

admin \ includes \ reset_seo_cache.php and includes \ classes \ seo.class.php

 

and I get this error when you click on the categories of "Link Manager II" "Fatal error: Call to undefined function: mb_convert_case () in c: \ program files (x86) \ easyphp1-8 \ www \ catalog \ includes \ classes \ seo.class.php on line 1809 "

 

 

Any ideas?

Edited by mega01

Share this post


Link to post
Share on other sites

I turned off the tax so that the link is normal oscommerce, and still not working.

 

I also downloaded the files replacing Ultimate_SEO_URLSv22d_7 contained

admin \ includes \ reset_seo_cache.php and includes \ classes \ seo.class.php

 

and I get this error when you click on the categories of "Link Manager II" "Fatal error: Call to undefined function: mb_convert_case () in c: \ program files (x86) \ easyphp1-8 \ www \ catalog \ includes \ classes \ seo.class.php on line 1809 "

 

 

Any ideas?

 

 

ok, everything works perfectly now with the latest version of seo, thank you very much for this great contribution.

Share this post


Link to post
Share on other sites

ok, everything works perfectly now with the latest version of seo, thank you very much for this great contribution.

 

Now I have the following problem. When I'm in the admin and entered into LINK I get this error: (taking a long time to appear)

 

Warning: feof (): supplied argument is not a valid stream resource in: catalog / admin / includes / functions / links.php on line 176

 

Warning: fgets (): supplied argument is not a valid stream resource in: catalog / admin / includes / functions / links.php on line 178

 

Any ideas?

Share this post


Link to post
Share on other sites

It looks like there's something wrong with the path in your admin. To see what that is, find this line in admin/includes/functions/links.php

    $fd = fopen ($path, "r");

and add this above it

echo 'Path '.$path;

Then try looking at the link again and see what is displayed at the top of the page.

Share this post


Link to post
Share on other sites

It looks like there's something wrong with the path in your admin. To see what that is, find this line in admin/includes/functions/links.php

    $fd = fopen ($path, "r");

and add this above it

echo 'Path '.$path;

Then try looking at the link again and see what is displayed at the top of the page.

 

I tried to do what you've told me, but not working. I only see "Path" without any path.

 

I have not commented before that it usually takes 3 or 4 minutes to appear errors and although there are repeated at least 1000. The last error that occurs is this: "Fatal error: Maximum execution time of 30 seconds exceeded in: admin / includes / functions line 179 ($ buffer = fgets ($ fd, 4096);)

 

The computer is very slow and internet explorer crashes.

 

Any ideas?

Share this post


Link to post
Share on other sites

I tried to do what you've told me, but not working. I only see "Path" without any path.

That code is trying to check the other site(s). Since there isn't anything printed out, it appears there isn't a reciprocal url entered, or maybe it is invalid. You can turn off reciprocal checking in the links settings to see if it will work so you can verify the reciprocal url for the link(s) causing the problem.

Share this post


Link to post
Share on other sites

Hi,

 

Having this fatal error

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/yourmob/public_html/includes/header.php:178) in /home/yourmob/public_html/includes/boxes/categories.php on line 60

 

Any help appreciated

 

Thanks

Share this post


Link to post
Share on other sites

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/yourmob/public_html/includes/header.php:178) in /home/yourmob/public_html/includes/boxes/categories.php on line 60

It's a common problem usually due to the template being used. See this thread on how to fix it.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Hi

 

Having problems approving the link.

 

I created a category and after submitting a link request successfully I go to Admin -> Links Manager II -> Links but nothing is displayed. Where do I approve the link?

 

I have Ultimate SEO URLs v2.2d-8 which I have disabled to make sure nothing is interefering and I reset the SEO cache.

 

Also when I click Links Manager II -> Links Status - nothing is displayed.

 

I have created links with and without Reciprocal Link Required.

 

Cheers,

T

Share this post


Link to post
Share on other sites

I created a category and after submitting a link request successfully I go to Admin -> Links Manager II -> Links but nothing is displayed. Where do I approve the link?

What happens if you create a link in admin? Does it show up, both in admin and on the site?

Share this post


Link to post
Share on other sites

What happens if you create a link in admin? Does it show up, both in admin and on the site?

 

I assume you create links in Link Manager II -> Links?

 

Because there is no option in there - it is just a heading with some text on the right TEXT_MISSING_VERSION_CHECKER.

 

No options/buttons for creating links ...

Share this post


Link to post
Share on other sites

I assume you create links in Link Manager II -> Links?

 

Because there is no option in there - it is just a heading with some text on the right TEXT_MISSING_VERSION_CHECKER.

 

No options/buttons for creating links ...

Then you don't have it installed correctly since you should see a number of sections there. Until that is fixed, there's no need trying to work on other problems so you'll need to go back through the installation instructions and see what was missed.

Share this post


Link to post
Share on other sites

Then you don't have it installed correctly since you should see a number of sections there. Until that is fixed, there's no need trying to work on other problems so you'll need to go back through the installation instructions and see what was missed.

 

Did a complete re-install again:

 

1. Deleted references to link manager in CONFIGURATIONS AND CONFIGURATIONS_GROUP

2. Copied files over again

3. Did the steps again and then ran links_setup

 

All done successfully with no problems. Then ..

 

4. Set up Links Check Phrase

5. Set up Links Exchange

6. Created a category TEMP

 

Then I successfully submitted a link.

 

But still nothing displayed in ADMIN or on the links page itself.

 

As before in Links Manager II -> Links - no table headings, buttons either. Checked files and they are all in correct place.

 

 

HOWEVER .. on the store I am working on they used to use linkshare contribution:

 

http://www.oscommerce.com/community/contributions,2122

 

But this did not update database and these files were different names anyway and have been removed.

Share this post


Link to post
Share on other sites

But still nothing displayed in ADMIN or on the links page itself.

 

As before in Links Manager II -> Links - no table headings, buttons either. Checked files and they are all in correct place.

 

HOWEVER .. on the store I am working on they used to use linkshare contribution:

 

http://www.oscommerce.com/community/contributions,2122

 

But this did not update database and these files were different names anyway and have been removed.

I once installed this into a shop that had used a links exchange package (not oscommerce based) and it had put data in the database that was preventing it from working. Perhaps that is what your problem is. You said you deleted the entries from the configuration tables but didn't mention the tables this contribution uses. I suggest deleting all of the links tables as well as deleting the entries from the configuration tables and and trying again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×