Jump to content
Jack_mcs

Links Manager II

Recommended Posts

There can only be one instance of a function. You will need to delete one them, assuming the code is the same. If not, you will need to rename one of them and anywhere where the function is called.

 

Jack

Share this post


Link to post
Share on other sites
Did you replace all of your files with the ones in the new version and make the database changes? The link information is just standard oscommerce code. There shouldn't be any reason it is not showing except for an installation error, at least none I can think of. For the category problem, it may be related to the php and/or mysql version you are using. But I can't fix it if I can't see the problem, which I can't. If I find a solution, I will post it but there is no telling when that might be.

 

Jack

 

 

Ok, it is the fact that allow seo urls still in development is says. I shut that off and they go into categories. Click the category link and everything works like normal. I would rather use the seo links. Anyway that you can give me a code or something to fix this to make it work?

Share this post


Link to post
Share on other sites

The SEO Url option is admin does not work for many servers and is not recommended, even for the ones it does work, since the generated url's are not properly optimized. You are better advised to install the Ultimate SEO contribution.

 

Jack

Share this post


Link to post
Share on other sites
The SEO Url option is admin does not work for many servers and is not recommended, even for the ones it does work, since the generated url's are not properly optimized. You are better advised to install the Ultimate SEO contribution.

 

Jack

 

 

Thank you very much. Your help and updated mod have been very much appreciated.

Share this post


Link to post
Share on other sites

back on track with dispaly error ON ..

 

so .. when i try tu submit link via links_submit.php it resides on normal server .. when hitting Continue script goes to secure server where it says

 

Warning: main(includes/functions/links.php) [function.main]: failed to open stream: No such file or directory in /home/web/secure.domain/www/links_submit.php on line 17

 

Warning: main(includes/functions/links.php) [function.main]: failed to open stream: No such file or directory in /home/web/secure.domain/www/links_submit.php on line 17

 

Fatal error: main() [function.require]: Failed opening required 'includes/functions/links.php' (include_path='.:/usr/pkg/include/php:/usr/pkg/lib/php:/usr/pkg/share/php-jpgraph') in /home/web/secure.domain/www/links_submit.php on line 17

 

all files are uploaded also to secure server

 

!?

Share this post


Link to post
Share on other sites

I'm sorry but I don't have any suggestions. Servers running dual directories like that can present problems. All I can suggest s to ensure all of the files are uploaded to both, which it sounds like you have done.

 

Jack

Share this post


Link to post
Share on other sites

there are several lines in links_submit.php where SSL is mentioned. Can i remove those SSLs?

Share this post


Link to post
Share on other sites

You can't remove them but you can change the SSL to NONSSL. That will tell it not to use SSL on those pages.

 

Jack

Share this post


Link to post
Share on other sites
yes .. the only fix was this one at #19

 

i still receive

at admin/links.php

 

hmm .. could it be, cause i'm on mysql3?

 

The error 1064 occurs due to Mysql version mismatch,because differnt

versions have differnt

reserved words,which if used by a previous version causes the error to

occur.

Share this post


Link to post
Share on other sites
hmm .. could it be, cause i'm on mysql3?
Could be. That is an extremely old version. Most code for oscommerce, where it makes a difference, generally requires V 4.1 or higher.

 

Jack

Share this post


Link to post
Share on other sites

can i see this in operation on someone website please, i just want to check it's what i want before installing it.

 

Thanks

 

Daz

Share this post


Link to post
Share on other sites

I'm having a problem with the admin side of the Links Manager II contribution.

 

I managed to add a couple of categories and when I navigate to the Links page in the Admin panel I get the following error:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

select l.links_id, l.links_url, l.links_image_url, l.links_date_added, l.links_last_modified, l.links_status, l.links_clicked, ld.links_title, ld.links_description, l.links_contact_name, l.links_contact_email, l.links_reciprocal_url, l.links_reciprocal_disable, l.links_status from links l left join ( links_description ld ) on ( l.links_id = ld.links_id ) order by ld.links_title limit -20, 20

[TEP STOP]

 

I copied the SQL right from here and dropped it into a SQL box in phpMyAdmin and the query failed until I changes the -20 to 0 in the limit clause of the query. Could this be due to an improper use of the splitPageResults class?

 

Thanks,

Andy

Share this post


Link to post
Share on other sites

It's due a mysql compatibility problem. You need to apply the fix for the includes/classes/split_page_results.php file from the oscommerce updates.

 

Jack

Share this post


Link to post
Share on other sites

Hi,

 

I have Links Manager V 1.14 installed. Everything was fine until I received an email from a link partner in which she said that she was expecting a direct link to her site not a redirect! I asked her to explain as I didn't understand what exactly she was talking about. She said that when she pointed the mouse to her link on our site, it reads:

www.OUR_SITE.com/redirect.php?action=links&goto=5

while it is supposed to read:

www.HER_SITE.com/

 

I got the point when I checked my link on her site as it reads:

www.OUR_SITE.com/

and no redirect.

 

Please let me know how to replace the redirect link with a direct one.

 

Thank You.

Share this post


Link to post
Share on other sites

Hi

I wanted to know If this contribution is a solutions to my problem.

I have to link two of the categories to an external site(which is another osc site dedicated to that category)

Will I be able to do that in this mod and How?(just a little primer).

For e.g. My categories are

 

Categories

Laptop

Monitors

Software( I want this to link to an external site that is exclusively for software)

Services

 

Thank You

Share this post


Link to post
Share on other sites
No, it won't even come close.

 

Jack

 

Thanks. Do you know any contributions that comes to your knowledge that will do what I need.

Thanks

Share this post


Link to post
Share on other sites

I doubt there is a contribution for it. You should ask in the general forum for how to change the code.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

I looked at the new version and i look awesome. The only other thing that I can see that would make it better for the end user is to make a text box for our sites info that is a one click highlight so they could quickly copy and paste it to there site. Its not a big deal I just thought that would be pretty cool. Ive seen a lot of asp cgi and html sites that have. Im not one for writing to extensive code or I could help.

 

Hope I didnt throw a loop in here.

 

Thanks for all your help, and hard work,

 

Eric


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

Thanks for the suggesstion Eric. I've seen that too and it is a good idea. I will put it on the list for the next update.

 

Jack

Share this post


Link to post
Share on other sites

hi jack, im not sure what exact version of links manager i installed, it was few years ago, but the coding is marked as // VJ Links Manager v1.00 begin

 

so far what i tried was replace the older files with your links manager files and also followed the instructions in the read me file. but for sql i tried to follow the update_bocs but kept getting different errors.

 

i was wondering if its possible to do a clean install of your version and somehow keep my current links??

 

your help is very much apprecaited

 

thankyou

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×