Jump to content
Jack_mcs

Links Manager II

Recommended Posts

Started from scratch updated the links_setup file as suggested worked.

 

What happened previously is I had to change the permissions from 644 to 777 to edit the file, once edited and saved changed the permissions back to 644.

 

So when I thought I had changed it previously, I hadn't actuall changed it at all.


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Great contribution!

 

It literally only took minutes to do the installation. The only "bug" I ran into had already been discussed in the forum (which naturally I did not read until after I added the ,'1'). Did a couple tweaks to suit my preferences (try that with proprietary software). Great job folks.


Doug

 

My newest friends are simvastatin, lispinopril, metoprolol, asprin, plavix, and my good buddy nitroquick (I take him everywhere!).

 

Most Frequent Criticism from English Teachers: "Awkward Sentence Construction"

 

Business was good until the start of 2009

Share this post


Link to post
Share on other sites

With templates like the one you are using, you won't be able to use the files supplied for the shop side without editing them so that they match your site. Typically, the files will at least load though. But they try to load the left column, which you don't use and that is probably causing the problem.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

 

I wonder if someone might be able to shed some light on a problem I am having.

 

I have upgraded from version v 1.07 to the lastest v 1.21. I have done something daft though as I get this problem

 

 

0 -

select lc.link_categories_id, lcd.link_categories_name, lcd.link_categories_description, lc.link_categories_image, lc.parent_id from link_categories lc left join link_categories_description lcd on lc.link_categories_id = lcd.link_categories_id where lc.link_categories_status = '1' and lc.parent_id = '' and lcd.language_id = '1' order by lc.link_categories_sort_order, lcd.link_categories_name

[TEP STOP]

 

http://www.prettyposhpets.co.uk/links.php

 

If anyone knows what might be wrong I would appreciate any advice!

 

Thank you

 

Dave

Share this post


Link to post
Share on other sites

Do you get the same error if you upload the links.php file included with the package? If not, then there was a mistake made in editing.

 

Jack

Share this post


Link to post
Share on other sites

Hello Jack,

 

I uploaded the latest files and i have used the links_db_update.php but i get that error. Was that not the the correct way to do the upgrade?

 

Thank you

 

Dave

 

Do you get the same error if you upload the links.php file included with the package? If not, then there was a mistake made in editing.

 

Jack

Share this post


Link to post
Share on other sites

V 1.07 was released in May of 2005. There have been many, many changes since then. I don't know what would be needed to upgrade from there. It would be best to treat this as a new install since there are several new file changes that have to be made. All of your existing Links Manager files will have to be replaced with those from the latest version. The db_update file just updates the Links Manager settings section in admin->Configuration. There will be other database changes needed. If you know how to manually edit a database, then you can do that to get it upgraded. Otherwise, you can go through each upgrade file since your version and make the changes detailed there.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack

 

Thank you for replying. I simply made the chages t othe DB listed in the Update_Docs folders and this fixed it. I wrongly assumed the upgrade DB file did it all for me.

 

Thank you I have a fully functioning links manager!

 

Cheers

 

 

 

V 1.07 was released in May of 2005. There have been many, many changes since then. I don't know what would be needed to upgrade from there. It would be best to treat this as a new install since there are several new file changes that have to be made. All of your existing Links Manager files will have to be replaced with those from the latest version. The db_update file just updates the Links Manager settings section in admin->Configuration. There will be other database changes needed. If you know how to manually edit a database, then you can do that to get it upgraded. Otherwise, you can go through each upgrade file since your version and make the changes detailed there.

 

Jack

Share this post


Link to post
Share on other sites

Hello I'm wondering if someone might know how about this error and how to fix it.

 

I'm getting /links.php//lPath/0_2 in my url double / is messing things all up. how to get rid of it.

Share this post


Link to post
Share on other sites

It's most likely your configure file is setup incorrectly. That's not a subject for here though. You will need to post that problem along with your configure file, minue the login parts, in the general forum.

 

Jack

Share this post


Link to post
Share on other sites

I just upgraded from Links Manager 1.18 to 1.20 & get the following errors.

 

Fatal error: Call to undefined function tep_hide_session_id() in C:\htdocs\mystorename\myadminfoldername\links.php on line 722

[/color]

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr><?php echo tep_draw_form('search', FILENAME_LINKS, '', 'get') . tep_hide_session_id(); ?> [color=#0000FF]// line 722[/color]

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

 

Links Status = Fatal error: Call to undefined function tep_hide_session_id() in C:\htdocs\mystorename\myadminfoldername\links_status.php on line 111

[color=#FF0000][code][/color]

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr><?php echo tep_draw_form('search', FILENAME_LINKS_STATUS, '', 'get') . tep_hide_session_id(); ?> [color=#0000FF]// line 111[/color]

<td class="pageHeading"><?php echo HEADING_TITLE_LINKS_STATUS; ?></td>

 

Link Categories = ok

Links Contact = ok

Links Exchange = ok

Links Featured =ok

 

Ideas as to what went wrong?

Thanks

Share this post


Link to post
Share on other sites

Just installed this on the test server and all went well, but I am wondering a couple things:

 

1) Is there a way to display links without having categories? Right now we don't have many links to display, so it seems silly to have to click "Links" and then click a category in order to see the links.

 

2) Is there a way to have more than one "Featured Link" in the Featured Links box (includes/boxes/links.php). It would be nice if it would scroll through however many links you want to have marked as featured. Right now it seems to only display one link in the box (even though the title of the box is plural).

 

BTW- This looks like a great contribution!

 

Oh - I did have one error (installed v1.21 Nov 30 2008 upload) and it was a clean install. The links_setup.php file is apparently missing a spot for language_id in one of the "insert" tags. I don't remember the exact error, but I found the line of code and added a , ' ' in front of the ending ) and then it seemed to work. If this sounds familiar to anyone, and I've done this incorrectly, please let me know. I figured I'd research through this board tomorrow when I have more time ;)


~Tracy
 

Share this post


Link to post
Share on other sites
I just upgraded from Links Manager 1.18 to 1.20 & get the following errors.

 

Fatal error: Call to undefined function tep_hide_session_id() in C:\htdocs\mystorename\myadminfoldername\links.php on line 722

See the update_changes_v_1.16_to_1.19.txt file. The note referencing this problem should be in the main readme but I forgot to copy it there.

 

Jack

Share this post


Link to post
Share on other sites
Just installed this on the test server and all went well, but I am wondering a couple things:

 

1) Is there a way to display links without having categories? Right now we don't have many links to display, so it seems silly to have to click "Links" and then click a category in order to see the links.

Change the setting in admin->Configuration->Links for that option.

2) Is there a way to have more than one "Featured Link" in the Featured Links box (includes/boxes/links.php). It would be nice if it would scroll through however many links you want to have marked as featured. Right now it seems to only display one link in the box (even though the title of the box is plural).

The featured box randomply displays the links. It can't show more than one with the current code. I will look into changing that though.

 

Oh - I did have one error (installed v1.21 Nov 30 2008 upload) and it was a clean install. The links_setup.php file is apparently missing a spot for language_id in one of the "insert" tags. I don't remember the exact error, but I found the line of code and added a , ' ' in front of the ending ) and then it seemed to work. If this sounds familiar to anyone, and I've done this incorrectly, please let me know. I figured I'd research through this board tomorrow when I have more time ;)
This was go over many times in the last few pages. I will upload a fixed version to stop this from happening though.

 

Jack

Share this post


Link to post
Share on other sites

I thought it might apply here since it only happens to this mod.

 

It's most likely your configure file is setup incorrectly. That's not a subject for here though. You will need to post that problem along with your configure file, minue the login parts, in the general forum.

 

Jack

Share this post


Link to post
Share on other sites

I have a new problem. When I click on Links in admin the page displays but at the bottem I get, Done but with errors on the page.

 

Line: 33

Char: 57

Error: Syntax Error

Code: 0

URL: [url="https://mystore.com/myadminfoldername/links.php?page=0&action=new"[/url]

 

for ($i = 0, $n = sizeof($languages); $i < $n; $i++) {

$languages_array[] = array('id' => $languages[$i]['id'],

'text' => $languages[$i]['name']);

} [color=#0000FF]// This is line 33[/color]

 

$showLinkStatus = 'All';

$links_statuses = array();

 

I also have this at the very to of the page above my header.

[color=#0000FF]dis[/color]

The site is currently set Down for maintenance to the public. Remember to bring it up when you are done!

 

When I search the file for dis, I find this at line 283

[code]

$lInfo_array = array_merge((array)$links, (array)$category);

$lInfo = new objectInfo($lInfo_array);

 

echo 'dis '.$lInfo->links_reciprocal_check_count; [color=#0000FF]// this line 283[/color]

}

}

 

Thanks

Edited by newtest

Share this post


Link to post
Share on other sites

The "Down for maintenance" message is due to another contribution you have installed. It might be causing the other problem. I don't think the Links Manager code is causing it, but I could be wrong. You should fix the obvious first though.

 

Jack

Share this post


Link to post
Share on other sites
The "Down for maintenance" message is due to another contribution you have installed. It might be causing the other problem. I don't think the Links Manager code is causing it, but I could be wrong. You should fix the obvious first though.

 

Jack

 

I just put that as a reference to show the dis is above my header.

I do have the site down for maint at this time.

Share this post


Link to post
Share on other sites

Either way, it appears to be a problem related to your installation. You should install it into a clean shop to make sure it works on your server and proceed from there.

 

Jack

Share this post


Link to post
Share on other sites
Change the setting in admin->Configuration->Links for that option.

 

The featured box randomply displays the links. It can't show more than one with the current code. I will look into changing that though.

 

This was go over many times in the last few pages. I will upload a fixed version to stop this from happening though.

 

Jack

 

Hi Jack,

 

Thank you for the quick answers! I did change my settings in admin->Configuration->Links to "False" for "Display Links in Categories". I double checked my database and ensured that the change had been correctly made to the configuration table. But when I try to add a link I get an error message at the top of the page in admin stating that I must have a category before I can add a link. If I add a category and then put links into that category - the catalog/links.php page does not show the categories or the links.

 

Normally I am not completely inept - but I'm wondering if I missed something simple here - LOL :blush:

 

I have my includes/boxes/specials.php set to scroll through multiple items rather than displaying just one - so I'll check and see if I can utilize some of that code in includes/boxes/links.php so Special Features can show more than one link.

 

I will read through the board here throughout the day as well to catch up on the already posted fixes - was too late when I got things up and running last night to do that ;)


~Tracy
 

Share this post


Link to post
Share on other sites
Yes, you have to assign the link to a category.

 

Jack

 

Ok - but with them assigned to a category they don't show up on the catalog/links.php page with show categories set to false in the admin. I can find the

<?php if (LINKS_SHOW_CATEGORIES == 'True') { ?>

in catalog/links.php but I cannot find any else statement for this, or an if (LINKS_SHOW_CATEGORIES == 'False') { statement - am I missing something?


~Tracy
 

Share this post


Link to post
Share on other sites
Either way, it appears to be a problem related to your installation. You should install it into a clean shop to make sure it works on your server and proceed from there.

 

Jack

 

I reinstalled the contribution and got same errors, I then reinstalled 1.20 this removed the dis at page top above header. reinstalling files from 1.21 and the dis returns.

 

both 1.20 & 1.21 produce the error at page bottem:

Done but with errors on the page.

 

Line: 33

Char: 57

Error: Syntax Error

Code: 0

URL: [url="https://mystore.com/myadminfoldername/links.php?page=0&action=new"[/url]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×