Latest News: (loading..)
sgostelow

[contribution] Social Bookmarks - Del.icio.us, Digg, Etc

81 posts in this topic

Social Bookmarks v1.0 - del.icio.us, digg, etc

 

Date: 29th June 2007

Author: Shaun Gostelow

Support Thread: This thread!

 

If you find this contribution useful please DONATE WITH PAYPAL (see the INSTALL.html) to encourage future development.

 

What is the Social Bookmarks OSCommerce contribution?

 

This small contribution to OScommerce adds links at the bottom of product pages so that users on your site can bookmark the page with a social bookmarking service such as del.icio.us or digg. This is a great way to help with SEO efforts as your product pages should get lots of inbound links.

 

If you have additional services (Google Bookmarks, etc) you would like to add to this contribution please feel free to add more, or donate to encourage further development.

 

Have fun...

Share this post


Link to post
Share on other sites

Doh! Thanks for spotting that jamez. Glad to hear it worked for you.

 

I've uploaded a new version (v1.1) with the del.icio.us and digg icon images. I've also added a missing space before the del.icio.us text. You can download this from:

 

http://www.oscommerce.com/community/contributions,5261

 

Note: There is a duplicate of the contribution in the credit modules section. Please ignore this. I've let the mods know and asked for it to be removed.

 

Cheers

 

Shaun

Share this post


Link to post
Share on other sites

Great addition thanks.

 

I use CRE LOADED so had to make a few quick changes:

1. /catalog/product_info.php is /catalog/templates/content/product_info.tpl.php

2. Had to remove leading / in front of images in social_bookmarks.php file

ie <img src=\"images/yahoomyweb-small.png\" alt=\"Add to Yahoo myWeb\" title=\"Add to Yahoo myWeb\" border=\"0\"> Add to Yahoo myWeb</a>

 

Incidentally, I notice that del.icio.us still opens window instead of new tab.

Share this post


Link to post
Share on other sites

Made the tags such as title and alt show the product name to make it SEO friendly, and hopefully help keep pages out of supplemental results and make each ad more relevant even if it's just a slight increase. ;)

Share this post


Link to post
Share on other sites

Hi folks thanks for making this contrib, i have actually started with a slightly different one and wondered if anyone would mind helping me convert this google link here:

 

<a rel=\"nofollow\" target=\"_blank\" href=\"http://www.google.com/bookmarks/mark?op=edit&bkmk=" . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . "&title=" . $product_info['products_name'] . "\">

<img src=\"/images/google-bookmarks-small.gif\" alt=\"Google Bookmark " . $product_info['products_name'] . "\" title=\"Google Bookmark " . $product_info['products_name'] . "\" border=\"0\"> Google Bookmark this</a>

 

 

to a version like this one:

 

'YahooMyWeb' => Array(

'favicon' => 'yahoomyweb.png',

'url' => 'http://myweb2.search.yahoo.com/myresults/bookmarklet?u=$url&title=$title',

),

 

if you could there are a ton more that you guys could reverse and include in your contrib also , if you guys could do one i might could reverse the others for you with a little practice. Thanks if you could help :)

 

the main part im having trouble with is at the end of the url... just need it to be a little less cryptic, im not super keen on php syntax yet...

 

CYA!

Edited by ggbig

Share this post


Link to post
Share on other sites

after installing version 1.3, an error came up.

"social_bookmarks.php on line 18"

 

after removing second <?php it worked.

 

should be

 

* @copyright Copyright 2007, Shaun Gostelow

* @author Shaun Gostelow

* @filesource

*/

echo "

Share this post


Link to post
Share on other sites

Just installed this contribution. I changed it slightly by putting the icons in column_right. Everything works fine except the google bookmark link, the page loads to 92% and then jams, with a blank page. When I click refresh it loads perfectly. It’s strange it requires a refresh every time. Any ideas? code below is my google bookmark code:

 

<a rel=\"nofollow\" target=\"_blank\" href=\"http://www.google.com/bookmarks/mark?op=edit&bkmk=" . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . "&title=" . $product_info['products_name'] . "\">
<img src=\"/images/google-bookmarks-small.gif\" alt=\"Google Bookmark " . $product_info['products_name'] . "\" </a>

 

 

Also is it possible to add an internet explorer icon that adds to user's browser favourites? Internet-explorer.gif

 

Thanks. :)

Share this post


Link to post
Share on other sites

Just tested it with Firefox, works perfectly (no refresh needed). Tested with Internet Explorer 6, works perfectly (no refresh needed). The browser I use, Avant, doesn't work correctly (refresh is required to load google bookmark page). Not as big a problem I as first thought just strange. maybe I'll try updating Avant to latest version.

 

Would still love to know how to code in a IE icon with add to favourites.

 

David.

Share this post


Link to post
Share on other sites
Just tested it with Firefox, works perfectly (no refresh needed). Tested with Internet Explorer 6, works perfectly (no refresh needed). The browser I use, Avant, doesn't work correctly (refresh is required to load google bookmark page). Not as big a problem I as first thought just strange. maybe I'll try updating Avant to latest version.

 

Would still love to know how to code in a IE icon with add to favourites.

 

David.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title></title>
<script language="JavaScript1.2" type="text/javascript">
function CreateBookmarkLink() {

title = "XXWebsite TitleXX"; 
url = "http://www.site.com/";

if (window.sidebar) { // Mozilla Firefox Bookmark
	window.sidebar.addPanel(title, url,"");
	window.location = 'http://www.site.com'
} else if( window.external ) { // IE Favorite
	window.location = 'http://www.site.com';
	window.external.AddFavorite( url, title); 
	}
else if(window.opera && window.print) { // Opera Hotlist
	window.location = 'http://www.site.com'
	return true; 
	}

}
</script>
</head>
<body onLoad="CreateBookmarkLink();">
</body>
</html>

 

put that in a page say, addtofav.html and bring it up in any browser. dunno if thats what you were looking for, but thats one way i do it. works from emails or whatever... as long as the link points to the page on your site.

Share this post


Link to post
Share on other sites

This is a very cool contribution!!! I only have one small problem. Does anyone know how I can fix this? I've already uploaded the pix in the images folder.

 

Picture-1.gif

 

Thanks for your help!

 

Jason

Share this post


Link to post
Share on other sites

Hi Everyone! Can anyone tell me where this file should go?

 

Thumbs.db

 

I just put it in the images folder. Is this why it's not working for me?

 

Thanks for your help!!

 

jason

Share this post


Link to post
Share on other sites

Thanks for that Roaddoctor!

 

Any idea why my icons aren't showing up?

 

Thanks,

Jason

Share this post


Link to post
Share on other sites

I finally figured it out why I wasn't getting the images. I deleted the forward slash before "images" and had to change "catalog" to my actual url.

 

Hope this helps a newbie like me!

 

Jason

Share this post


Link to post
Share on other sites
I finally figured it out why I wasn't getting the images. I deleted the forward slash before "images" and had to change "catalog" to my actual url.

 

Hope this helps a newbie like me!

 

Jason

Hi Jason

 

I am still having a problem with this? :huh:

I cannot see my images either. I have tried removing the / before images in the /includes/modules/social_bookmarks.php but it made no difference. The image is pointing to catalog but shouldn't, so where did you amend the "catalog" to your actual url please because I cannot find catalog in any of thefiles?

 

Thanks

Julie

Share this post


Link to post
Share on other sites
Hi Jason

 

I am still having a problem with this? :huh:

I cannot see my images either. I have tried removing the / before images in the /includes/modules/social_bookmarks.php but it made no difference. The image is pointing to catalog but shouldn't, so where did you amend the "catalog" to your actual url please because I cannot find catalog in any of thefiles?

 

Thanks

Julie

Problem solved!

The newest upload solved an error & introduced one as well!! That file has catalog which I must have uploaded, but the original which I must have looked at didn't. It didn't say it was adding catalog too...but just proves you have to check & then double check!!

Share this post


Link to post
Share on other sites

I respect this contribution quite a bit as I would be lying through my teeth if I were to tell you that Google doesn't factor in social networks in their rankings. And its intensifying.

 

Quick question about this contribution; hopefully someone will indulge me here.

 

If I just wanted to install social bookmarking features on one or 2 pages of a 30 page commerce site, and these are custom php pages (not product pages), is this contribution worthwhile for me too look at?

Share this post


Link to post
Share on other sites

Great contrib and really easy to install!!

 

Not looked in detail at the code as I'm trying to do loads of other stuff as well but has anyone got this working with other social sites - facebook etc?

Share this post


Link to post
Share on other sites

I use OSCMax and had to do the same thing. Has anyone added other sites like Reddit? What's the best way to do that?

 

Great addition thanks.

 

I use CRE LOADED so had to make a few quick changes:

1. /catalog/product_info.php is /catalog/templates/content/product_info.tpl.php

2. Had to remove leading / in front of images in social_bookmarks.php file

ie <img src=\"images/yahoomyweb-small.png\" alt=\"Add to Yahoo myWeb\" title=\"Add to Yahoo myWeb\" border=\"0\"> Add to Yahoo myWeb</a>

 

Incidentally, I notice that del.icio.us still opens window instead of new tab.

Edited by finjay

Share this post


Link to post
Share on other sites

Added a version 1.3a - Great contribution btw - was about to start writing one myself when I came across it!

 

Added some more links, and modified the code to remove the need for all those escape characters.

 

Contains:

 

del.icio.us

Digg

Google Bookmark

Yahoo myWeb

Furl

Squidoo

StumbleUpon

 

Additional images included.

 

Paul

Share this post


Link to post
Share on other sites

Hi,

 

great contribution, is it possible to add msn.nl and ekudos.nl to the list?

 

Thanks.

 

kind regards,

Jan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now