Jump to content

Recommended Posts

i have applied all the code fixes and all the patches listed in the documentation for this contribution, and I have still got a division by zero error appearing on my admin page.

 

 

 

the part in the support forum that tells you to change code in the split pages.php was doable for the catalog/includes/classes/splitpages.php however, this code that the author says to change was not even in the admin/includes/classes/split_pages.php file.

 

Anyone run across this yet?

 

i got it working, as i had replaced only one instance of the max display search results code, and there were three instances in the admin/faq.php file. I still have a javascript error when trying to preview the answer, i can only preview the question.

 

I must say, I have been dealing with oscommerce for about 4 years now, and this is by far the worst coded contribution I have ever dealt with. Why release a cont. if you know if has "multiple issues" and if you discover the issues, update the contribution for goodness sakes. I have had to modify twice as many files as the documentation recommends just to get the thing working, not to mention the image calls are all wrong, the javascript has issues with the preview, the install documentation has typos, and incorrectly referenced files to edit, and the functionality, is at best, mediocre.

 

Folks, if you have a contribution that you feel needs sharing, make sure it works and you will be here to support it. This should be removed from the library all together in my opinion.

Share this post


Link to post
Share on other sites

Warning: Cannot modify header information - headers already sent by (output started at /usr/local/psa/home/vhosts/domain.com/httpdocs/admin/faq.php:27) in /usr/local/psa/home/vhosts/domain.com/httpdocs/admin/includes/functions/general.php on line 31

can anyone tell me why I would get this error when I add a new question/answer in the admin section.

 

The faq shows up on the catalog side, no problem, i just get this error each time i enter a new question/answer


Remember what the Bible says: He who is without sin, cast the first rock. And I shall smoketh it.

Share this post


Link to post
Share on other sites

Also is it possible to add subject headers for different FAQ sections.

 

i.e.

 

SHIPPING TIME

Q

A

 

Q

A

 

BILLING ISSUES

Q

A

 

Q

A

 

Kinda get my drift?


Remember what the Bible says: He who is without sin, cast the first rock. And I shall smoketh it.

Share this post


Link to post
Share on other sites
Warning: Cannot modify header information - headers already sent by (output started at /usr/local/psa/home/vhosts/domain.com/httpdocs/admin/faq.php:27) in /usr/local/psa/home/vhosts/domain.com/httpdocs/admin/includes/functions/general.php on line 31

can anyone tell me why I would get this error when I add a new question/answer in the admin section.

 

The faq shows up on the catalog side, no problem, i just get this error each time i enter a new question/answer

 

Fixed, in line 27 of /admin/faq.php

 

change that line to

 

$sort_order = (int)$HTTP_POST_VARS['sort_order']; // echo $sort_order .'<br>';

 

FYI ... I like rock.


Remember what the Bible says: He who is without sin, cast the first rock. And I shall smoketh it.

Share this post


Link to post
Share on other sites

Can any one point me in the right direction?

I installed FAQdesk 2.1, I had a few Errors and warnings.

I solved al but 1 of them.

I'am no php coder.

I gat the following warning on my site.

"Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/testter/public_html/includes/database_tables.php:66) in /home/testter/public_html/includes/functions/sessions.php on line 102"

Any idea where I can find the fault?

Share this post


Link to post
Share on other sites

I found the solution.

There where spaces aded in the file /includes/database_table.php after modifying it.

It al works now.

Share this post


Link to post
Share on other sites

any idea on why a clean install would spit this out? When trying to add a new faq from the admin side? if i click back it does write the insert, but i am not sure why it errors.

 

There are no blank spaces before the <?php tags on any of the files.

 

thanks

 

0

 

Warning: Cannot modify header information - headers already sent by (output started at /home/contentsite/html/admin/faq.php:26) in /home/content/html/admin/includes/functions/general.php on line 22

Share this post


Link to post
Share on other sites

If the /admin/faq.php code has this on line 26:

 

		$sort_order = (int)$HTTP_POST_VARS['sort_order']; echo $sort_order .'<br>';

Change it to:

 

		$sort_order = (int)$HTTP_POST_VARS['sort_order'];


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites
Also is it possible to add subject headers for different FAQ sections.

 

i.e.

 

SHIPPING TIME

Q

A

 

Q

A

 

BILLING ISSUES

Q

A

 

Q

A

 

Kinda get my drift?

 

is there any FAQ system that does this or someone code this fantastic faq system to do that please :-)

Share this post


Link to post
Share on other sites

Hi,

 

I just add faq in my web, but it doesn't show faq.php page properly. the faq content is displayed outside of the template

 

see: http://www.bxjie.com/faq.php Can anyone help solve this problem?

 

Another quesiton: Do anyone know where to change the style and content of ' Frequently Asked Questions

Click on question to reveal the answer'

 

Thanks for andvance

Share this post


Link to post
Share on other sites

I have installed FAQDesk 2.2. but there is a slight issue on admin side. Of all the mod I have installed this is the only mod is a bit weird looking. First of all I have Sexy Admin RC2a installed. All categories in left column and the center text is centered. Even looked into faq.php code to see what would cause this, but nothing.

 

Here is a admin_faq.jpgimage.

 

So if someone has an idea where I can look or this an Sexy Admin RC2a issue?

 

Thank you.

Share this post


Link to post
Share on other sites
I have installed FAQDesk 2.2. but there is a slight issue on admin side. Of all the mod I have installed this is the only mod is a bit weird looking. First of all I have Sexy Admin RC2a installed. All categories in left column and the center text is centered. Even looked into faq.php code to see what would cause this, but nothing.

 

Here is a admin_faq.jpgimage.

 

So if someone has an idea where I can look or this an Sexy Admin RC2a issue?

 

Thank you.

 

Let me try to attach image again. admin_faq.jpg

Share this post


Link to post
Share on other sites

okay, the install was cake, but where do the actual questions and answers go? I edited "faq.php" in the define languages in admin but when I saved it I got an error. also, since it says "click on question to reveal answer" I'm guessing that I need to add the questions and answers in one of the "english.php" files....??? can someone help me out please?

***edit-duh, nevermind.

Edited by broadstreetbully

Share this post


Link to post
Share on other sites

Hi,

 

I installed FAQ2.2 and I have one problem.

 

I can't EDIT the question/answer ! when I push the EDIT button, I don't see any text in the languages text boxes !

 

Any help please?

 

Thanks a lot,

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites

Did u double check your install, did you run the sql?


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
Did u double check your install, did you run the sql?

 

Hi spook !

 

Thank you for helping me again..

 

When I go to admin. panel to faq manager.. I see all of them, and I can select them, so they have to be saved correctly in the database with the right ID's numbers.

The problem is when I select a question and press the EDIT button then I see the edit page without the TEXT inside !

I have OSC 2.2ms and tinymce installed and here is my admin/faq.php file:

 

I really appreciate you help.. Thank you !

 

Nathali

 

<?php

/*

$Id: FAQDesk 2.1

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

 

$fID = (!empty($HTTP_GET_VARS['fID']) ? (int)$HTTP_GET_VARS['fID'] : 0 );

$action = (!empty($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : '' );

$languages = tep_get_languages();

switch($action){

case 'setflag':

if( !empty($fID) && isset($HTTP_GET_VARS['flag']) && ( $HTTP_GET_VARS['flag'] == '1' || $HTTP_GET_VARS['flag'] == '0' ) ){

tep_db_query('update '.TABLE_FAQ.' set faq_status='.$HTTP_GET_VARS['flag'].' where faq_id='.$fID.'');

}

tep_redirect(tep_href_link(FILENAME_FAQ, (isset($HTTP_GET_VARS['page']) ? 'page='.$HTTP_GET_VARS['page'].'&' : '' ).'iID='.$fID));

break;

case 'insert':

case 'update':

$sort_order = (int)$HTTP_POST_VARS['sort_order'];

//echo $sort_order .'<br>';

$faq_status = !empty($HTTP_POST_VARS['faq_status']) ? '1' : '0';

 

$sql_data_array = array('sort_order' => $sort_order,

'last_modified' => 'now()',

'faq_status' => $faq_status);

 

if ($action == 'insert') {

tep_db_perform(TABLE_FAQ, $sql_data_array);

$fID = tep_db_insert_id();

} elseif ($action == 'update') {

tep_db_perform(TABLE_FAQ, $sql_data_array, 'update', "faq_id = '".(int)$fID."'");

}

 

for ($i=0,$n=sizeof($languages);$i<$n;$i++) {

$faq_question_array = $HTTP_POST_VARS['faq_question'];

$faq_answer_array = $HTTP_POST_VARS['faq_answer'];

$language_id = $languages[$i]['id'];

 

$sql_data_array = array('faq_question' => tep_db_prepare_input($faq_question_array[$language_id]),

'faq_answer' => tep_db_prepare_input($faq_answer_array[$language_id]),

);

 

if ($action == 'insert') {

$insert_sql_data = array('faq_id' => (int)$fID,

'language_id' => (int)$language_id);

$sql_data_array = array_merge($sql_data_array, $insert_sql_data);

 

tep_db_perform(TABLE_FAQ_DESCRIPTION, $sql_data_array);

} elseif ($action == 'update') {

tep_db_perform(TABLE_FAQ_DESCRIPTION, $sql_data_array, 'update', "faq_id = '".(int)$fID."' and language_id = '".(int)$language_id . "'");

}

}

 

tep_redirect(tep_href_link(FILENAME_FAQ, (isset($HTTP_GET_VARS['page']) ? 'page='.$HTTP_GET_VARS['page'].'&' : '') . 'fID=' . $fID));

break;

case 'deleteconfirm':

$faq_id = tep_db_prepare_input($HTTP_GET_VARS['fID']);

 

tep_db_query("delete from " . TABLE_FAQ . " where faq_id = '".(int)$fID."'");

tep_db_query("delete from " . TABLE_FAQ_DESCRIPTION . " where faq_id = '".(int)$fID."'");

 

tep_redirect(tep_href_link(FILENAME_FAQ, 'page=' . $HTTP_GET_VARS['page']));

break;

 

}

 

 

?>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

<link rel="stylesheet" type="text/css" href="includes/stylesheet.css">

<script language="javascript" src="includes/general.js"></script>

<script language="JavaScript">

function showItem(id){

var item = document.getElementById(id);

if (item){

if (!item.style.display || item.style.display == '' )

item.style.display = 'none';

else

item.style.display = '';

}

}

</script>

</head>

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0" bgcolor="#FFFFFF" onload="SetFocus();">

<!-- header //-->

<?php require(DIR_WS_INCLUDES . 'header.php'); ?>

<!-- header_eof //-->

 

<!-- body //-->

<table border="0" width="100%" height="80%" cellspacing="2" cellpadding="2">

<tr>

<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="1" cellpadding="1" class="columnLeft">

<!-- left_navigation //-->

<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>

<!-- left_navigation_eof //-->

</table></td>

<!-- body_text //-->

<td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td width="100%"><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10')?></td>

</tr>

<?php

if ( $action == 'new_faq' || $action == 'edit_faq' ){

 

$faq_info_query = tep_db_query('select f.faq_id, fd.language_id, fd.faq_question, fd.faq_answer, f.last_modified, f.sort_order, f.faq_status from '.TABLE_FAQ.' f, '.TABLE_FAQ_DESCRIPTION.' fd where f.faq_id=fd.faq_id and f.faq_id='.(int)$fID);

$faq_info = array();

$faq_info['faq_question'] = array();

$faq_info['faq_answer'] = array();

 

while($faq = tep_db_fetch_array($faq_info_query)){

$faq_info['status'] = $faq['faq_status'];

$faq_info['question'][$faq['language_id']] = $faq['faq_question'];

$faq_info['answer'][$faq['language_id']] = $faq['faq_answer'];

$faq_info['sort_order'] = $faq['sort_order'];

 

}

$submit = ($action == 'edit_faq' ? tep_image_submit('button_update.gif', IMAGE_UPDATE) : tep_image_submit('button_insert.gif', IMAGE_INSERT));

?>

<tr>

<td>

<?php echo tep_draw_form('new_faq', FILENAME_FAQ, ( empty($fID) ? 'action=insert' : 'action=update&fID='.$fID) );?>

<table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td class="main" align="right" colspan="2"><?php echo $submit . ' <a href="'.tep_href_link(FILENAME_FAQ, tep_get_all_get_params(array('action'))).'">'.tep_image_button('button_cancel.gif', IMAGE_CANCEL).'</a>' ;?></td>

</tr>

<tr>

<td class="main" valign="top"><?php echo TITLE_STATUS;?></td>

<td class="main" valign="top"><?php echo TEXT_ON.tep_draw_radio_field('faq_status', '1', ($faq_info['status'] ? true : false) ).'   '.TEXT_OFF.tep_draw_radio_field('faq_status', '0', ($faq_info['status'] ? false : true) );?></td>

</tr>

<tr>

<td class="main" valign="top"><?php echo TITLE_SORT;?></td>

<td class="main" valign="top"><?php echo tep_draw_input_field('sort_order', ( !empty($faq_info['sort_order']) ? $faq_info['sort_order'] : 0 ), ' size="4" ');?></td>

</tr>

<tr>

<td class="main" valign="top"><?php echo TITLE_ADD_QUESTION;?></td>

<td class="main" valign="top"><table border="0" cellspacing="0" cellpadding="2"><?php

for($i=0,$x=count($languages);$i<$x;$i++){

if ( !empty($faq_info['question'][$languages[$i]['id']]) ){

$faq_question = $faq_info['question'][$languages[$i]['id']];

} else {

$faq_question = '';

}

 

echo '<tr>

<td class="main" valign="top">' . tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name'], '', '', '', false).'</td>

<td class="main" valign="top">' . tep_draw_textarea_field('faq_question['.$languages[$i]['id'].']','soft','70','3',$faq_question) . '</td>

</tr>';

}

?></table></td>

</tr>

<tr>

<td class="main" valign="top"><?php echo TITLE_ADD_ANSWER;?></td>

<td class="main" valign="top"><table border="0" cellspacing="0" cellpadding="2"><?php

for($i=0,$x=count($languages);$i<$x;$i++){

if ( !empty($faq_info['answer'][$languages[$i]['id']]) ){

$faq_answer = $faq_info['answer'][$languages[$i]['id']];

} else {

$faq_answer = '';

}

 

echo '<tr>

<td class="main" valign="top">'.tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name'], '', '', '', false).'</td>

<td class="main" valign="top">'.tep_draw_textarea_field('faq_answer['.$languages[$i]['id'].']','soft','70','10',$faq_answer).'</td>

</tr>';

}

?></table></td>

</tr>

<tr>

<td class="main" align="right" colspan="2"><?php echo $submit . ' <a href="'.tep_href_link(FILENAME_FAQ, tep_get_all_get_params(array('action'))).'">'.tep_image_button('button_cancel.gif', IMAGE_CANCEL).'</a>' ;?></td>

</tr>

</table>

</form>

</td>

</tr>

<?php

 

} elseif ($action == 'preview_faq'){

$plid = (isset($HTTP_GET_VARS['prevlang']) ? $HTTP_GET_VARS['prevlang'] : $languages_id);

$faq_query = tep_db_query('select f.faq_id, fd.faq_question, fd.faq_answer, f.last_modified, f.sort_order, f.faq_status from '.TABLE_FAQ.' f, '.TABLE_FAQ_DESCRIPTION.' fd where f.faq_id=fd.faq_id and f.faq_status and fd.language_id=' . (int)$plid . ' order by f.sort_order, fd.faq_id');

?>

<tr>

<td class="main"><?php echo TEXT_CLICK_REVEAL; ?></td>

<td class="main" align="right"><?php echo '<a href="'.tep_href_link(FILENAME_FAQ, tep_get_all_get_params(array('action'))).'">'.tep_image_button('button_back.gif', IMAGE_BACK).'</a>';?></td>

</tr>

<tr>

<td style="padding-left:20px;"><table border="0" cellspacing="0" cellpadding="0">

<?php

while($faq = tep_db_fetch_array($faq_query)){

?>

<tr>

<td colspan="2" class="main"><b style="cursor:pointer;" onclick="showItem('faq_answer_<?php echo $faq['faq_id'];?>')"><?php echo $faq['faq_question'];?></b><br><small><?php echo TEXT_LAST_UPDATED.$faq['last_modified'];?></small></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '5')?></td>

</tr>

<tr>

<td colspan="2" class="main" style="display:none;" id="faq_answer_<?php echo $faq['faq_id'];?>"><?php echo $faq['faq_answer'];?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10')?></td>

</tr>

<?php

}

?>

</td></table>

</tr>

 

 

<?php

} else {

?>

 

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr class="dataTableHeadingRow">

<td class="dataTableHeadingContent" align="center"><?php echo TABLE_HEADING_FAQ_ID; ?></td>

<td class="dataTableHeadingContent"><?php echo TABLE_HEADING_FAQ_QUESTION; ?></td>

<td class="dataTableHeadingContent" align="center"><?php echo TABLE_HEADING_FAQ_STATUS; ?></td>

<td class="dataTableHeadingContent" align="center"><?php echo TABLE_HEADING_FAQ_LAST_MODIFIED; ?></td>

</tr>

<?php

$faq_query_numrows = 0;

$faq_query_raw = 'select f.faq_id, fd.faq_question, fd.faq_answer, f.last_modified, f.sort_order, f.faq_status from '.TABLE_FAQ.' f, '.TABLE_FAQ_DESCRIPTION.' fd where f.faq_id=fd.faq_id and fd.language_id=' . (int)$languages_id . ' order by f.sort_order, fd.faq_id';

$faq_split = new splitPageResults($HTTP_GET_VARS['page'], MAX_DISPLAY_SEARCH_RESULTS, $faq_query_raw, $faq_query_numrows);

$faq_query = tep_db_query($faq_query_raw);

while ($faq = tep_db_fetch_array($faq_query)) {

if ((!isset($HTTP_GET_VARS['fID']) || (isset($HTTP_GET_VARS['fID']) && ($HTTP_GET_VARS['fID'] == $faq['faq_id']))) && !isset($fInfo)) {

$fInfo = new objectInfo($faq);

}

 

if (isset($fInfo) && is_object($fInfo) && ($faq['faq_id'] == $fInfo->faq_id)) {

echo ' <tr id="defaultSelected" class="dataTableRowSelected" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)" onclick="document.location.href=\'' . tep_href_link(FILENAME_FAQ, 'page=' . $HTTP_GET_VARS['page'] . '&fID=' . $faq['faq_id'] . '&action=edit_faq') . '\'">' . "\n";

} else {

echo ' <tr class="dataTableRow" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)" onclick="document.location.href=\'' . tep_href_link(FILENAME_FAQ, 'page=' . $HTTP_GET_VARS['page'] . '&fID=' . $faq['faq_id']) . '\'">' . "\n";

}

?>

<td class="dataTableContent" align="center"><?php echo $faq['faq_id']; ?></td>

<td class="dataTableContent" width="70%"><?php echo $faq['faq_question']; ?></td>

<td class="dataTableContent" align="center"><?php

if ($faq['faq_status'] == '1') {

echo tep_image( DIR_WS_IMAGES . 'icon_status_green.gif', IMAGE_ICON_STATUS_GREEN, 10, 10) . '  <a href="' . tep_href_link(FILENAME_FAQ, 'action=setflag&flag=0&fID=' . $faq['faq_id'] ) . '">' . tep_image( DIR_WS_IMAGES . 'icon_status_red_light.gif', IMAGE_ICON_STATUS_RED_LIGHT, 10, 10) . '</a>';

} else {

echo '<a href="' . tep_href_link(FILENAME_FAQ, 'action=setflag&flag=1&fID=' . $faq['faq_id']) . '">' . tep_image( DIR_WS_IMAGES . 'icon_status_green_light.gif', IMAGE_ICON_STATUS_GREEN_LIGHT, 10, 10) . '</a>  ' . tep_image( DIR_WS_IMAGES . 'icon_status_red.gif', IMAGE_ICON_STATUS_RED, 10, 10);

}

?></td>

<td class="dataTableContent" align="center"><?php echo $faq['last_modified']; ?></td>

</tr>

<?php

}

?>

<tr>

<td colspan="4"><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td class="smallText" valign="top"><?php echo $faq_split->display_count($faq_query_numrows, MAX_DISPLAY_SEARCH_RESULTS, $HTTP_GET_VARS['page'], TEXT_DISPLAY_NUMBER_OF_QUESTIONS); ?></td>

<td class="smallText" align="right"><?php echo $faq_split->display_links($faq_query_numrows, MAX_DISPLAY_SEARCH_RESULTS, MAX_DISPLAY_PAGE_LINKS, $HTTP_GET_VARS['page']); ?></td>

</tr>

</table></td>

</tr>

<tr>

<td align="right" colspan="4" class="smallText"><?php echo '<a href="' . tep_href_link(FILENAME_FAQ, 'page='.$HTTP_GET_VARS['page'].'&action=new_faq') . '">' . tep_image_button('button_insert.gif', IMAGE_INSERT) . '</a><br>';

for($i=0,$x=count($languages);$i<$x;$i++){

echo '<a href="' . tep_href_link(FILENAME_FAQ, 'page='.$HTTP_GET_VARS['page'].'&action=preview_faq&prevlang=' . $languages[$i]['id']) . '">' . tep_image_button('button_preview.gif', IMAGE_PREVIEW) . ' ' . tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name'], '', '', '', false) . '</a><br>';

}

?>

</td>

</tr>

</table></td>

<?php

$heading = array();

$contents = array();

 

switch ($action) {

case 'delete':

$heading[] = array('text' => '<b>' . sprintf(TEXT_HEADING_DELETE_INTRO, $fInfo->faq_id) . '</b>');

 

$contents = array('form' => tep_draw_form('faq', FILENAME_FAQ, 'page=' . $HTTP_GET_VARS['page'] . '&fID=' . $fInfo->faq_id . '&action=deleteconfirm'));

$contents[] = array('text' => '<br /><b>'.TEXT_QUESTION.'</b><br />' . $fInfo->faq_question );

$contents[] = array('text' => '<br /><b>'.TEXT_ANSWER.'</b><br>' . $fInfo->faq_answer );

 

if ($fInfo->products_count > 0) {

$contents[] = array('text' => '<br>' . tep_draw_checkbox_field('delete_products') . ' ' . TEXT_DELETE_PRODUCTS);

$contents[] = array('text' => '<br>' . sprintf(TEXT_DELETE_WARNING_PRODUCTS, $fInfo->products_count));

}

 

$contents[] = array('align' => 'center', 'text' => '<br>' . tep_image_submit('button_delete.gif', IMAGE_DELETE) . ' <a href="' . tep_href_link(FILENAME_FAQ, 'page=' . $HTTP_GET_VARS['page'] . '&fID=' . $fInfo->faq_id) . '">' . tep_image_button('button_cancel.gif', IMAGE_CANCEL) . '</a>');

break;

default:

if (isset($fInfo) && is_object($fInfo)) {

$heading[] = array('text' => '<b> #' . $fInfo->faq_id . '</b>');

 

$contents[] = array('align' => 'center', 'text' => '<a href="' . tep_href_link(FILENAME_FAQ, 'page=' . $HTTP_GET_VARS['page'] . '&fID=' . $fInfo->faq_id . '&action=edit_faq') . '">' . tep_image_button('button_edit.gif', IMAGE_EDIT) . '</a> <a href="' . tep_href_link(FILENAME_FAQ, 'page=' . $HTTP_GET_VARS['page'] . '&fID=' . $fInfo->faq_id . '&action=delete') . '">' . tep_image_button('button_delete.gif', IMAGE_DELETE) . '</a>');

 

$contents[] = array('text' => '<br /><b>'.TEXT_QUESTION.'</b><br />' . $fInfo->faq_question );

$contents[] = array('text' => '<br /><b>'.TEXT_ANSWER.'</b><br>' . $fInfo->faq_answer );

}

break;

}

 

if ( (tep_not_null($heading)) && (tep_not_null($contents)) ) {

echo ' <td width="25%" valign="top">' . "\n";

 

$box = new box;

echo $box->infoBox($heading, $contents);

 

echo ' </td>' . "\n";

}

?>

</tr>

 

<?php

}

?>

</table></td>

<!-- body_text_eof //-->

</tr>

</table>

<!-- body_eof //-->

 

<!-- footer //-->

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

<!-- footer_eof //-->

<br>

</body>

</html>

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>


Best Regards,

Nathali

Share this post


Link to post
Share on other sites
Hi,

 

Could someone help please,

 

When I go to admin. panel to faq manager.. I see all of them, and I can select them, so they have to be saved correctly in the database with the right ID's numbers.

The problem is when I select a question and press the EDIT button then I see the edit page without the TEXT inside !

I have OSC 2.2ms and tinymce installed and my admin/faq.php file I posted above..

 

Any advises ? thanks

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites

MAX_DISPLAY_ADMIN_SEARCH_RESULT probably a value associated (in configuration table) is missing from that table.

 

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites
MAX_DISPLAY_ADMIN_SEARCH_RESULT probably a value associated (in configuration table) is missing from that table.

 

 

Satish

 

Thanks Satish !

 

Where did this value MAX_DISPLAY_ADMIN_SEARCH_RESULT should be?

If in should be in the database, then the sql in the contribution does not enter it.

 

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites
Thanks Satish !

 

Where did this value MAX_DISPLAY_ADMIN_SEARCH_RESULT should be?

If in should be in the database, then the sql in the contribution does not enter it.

 

Nathali

 

I think it connected to the javascript function.. since I have tinymce installed!

 

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites
Thanks Satish !

 

Where did this value MAX_DISPLAY_ADMIN_SEARCH_RESULT should be?

If in should be in the database, then the sql in the contribution does not enter it.

 

Nathali

 

 

Don't know where that one is from, but the likely query to add it would be:

 

INSERT INTO `configuration` (`configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) 
VALUES ('Display Results In Admin', 'MAX_DISPLAY_ADMIN_SEARCH_RESULT' , '20', 'Maximum Display Results In Admin', 3, 2, NULL, now(), '', '');


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
Don't know where that one is from, but the likely query to add it would be:

 

INSERT INTO `configuration` (`configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) 
VALUES ('Display Results In Admin', 'MAX_DISPLAY_ADMIN_SEARCH_RESULT' , '20', 'Maximum Display Results In Admin', 3, 2, NULL, now(), '', '');

 

Thanks for your reply Sam!

 

Before I do this, Please let me understand.. I installed the contribution:

http://addons.oscommerce.com/info/1106 that posted by Fimble 7 feb 2009 (FAQ desk 2.2)

Now, This is a complete distribution so in the SQL query I didn't had this value 'MAX_DISPLAY_ADMIN_SEARCH_RESULT' and I do not have any problem with that OR any page Errors !!

 

When I enter to admin>tools>faq manager I see 20 lines of results very clear and I can move to the other 20 pages without any problem !!

 

The problem is when I choose a question/answer and try to edit it, I don't see the question/answer TEXT in side their langauges BOXES so I can't edit the text ! All the rest is functioning very good !

 

So please let me understand why I need this? Is it relevant to my problem?

 

Please reply..

 

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites

I mearly responded after I saw the posts for 'MAX_DISPLAY_ADMIN_SEARCH_RESULT'

 

Looking back it appears this is an admin value that the contributer did'nt, or could'nt create the sql for, so advised replaceing it with a static value.

 

It just happens I have created a programme that looks in depth at the configure items & is able to create 'on the fly' a sql for any item displayed

 

PS Without examining the contrib I could.nt say what your error is without further info, try looking at your error log in cpanel

Edited by spooks

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hello,

 

I have FAQ Desk installed on my site, and everything is working fine for Eng, Ger, and Spanish. However, when adding new languages to the site, and when adding faq text via admin to new language sites, nothing comes visible after saving the page?

 

Is anyone seeing the same thing?

 

Does anyone have a solution for this?

 

- J -

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×