Jump to content
Sign in to follow this  
Elazar

[contribution] Send_order_html_email

Recommended Posts

You are right coopco,

 

but only with the missing ; and the <tr> tag - the db_query is correct as described in the txt file

 

Thanks for checking.

OK, mine needed the extra )

 

My installation is in between the original and the image display. I have not used the rows feature.

 

The email really does look fantastic now. Just have to work out why CCGV is preventing the payment method from showing. I might have to do away with CCGV until the next osc release.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

OK,

 

because of the fact that some users doesnt have installed the full contribution BEFORE making the rowmod mod, i ve uploaded the last full

package (original from Untitled No 4) including the row mod instructions today.

 

Hope that this might help ;)

 

@ Coopco - hm i´m wondering why you have to use a second ) at the end of the line..

Share this post


Link to post
Share on other sites
OK,

 

because of the fact that some users doesnt have installed the full contribution BEFORE making the rowmod mod, i ve uploaded the last full

package (original from Untitled No 4) including the row mod instructions today.

 

Hope that this might help ;)

 

@ Coopco - hm i´m wondering why you have to use a second ) at the end of the line..

 

I got an error without it. I have no idea why, so I made it the same as line 30 in the instructions.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Ok, as i know yet elazars problem is solved and the contribition rwo mod should worked as described

 

No doubt about it, you have done a fantastic job with this.

Edited by Coopco

The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hi Shetani !

 

I have a little problem :huh:

 

When I update the status of the order in the admin section, the email for the updated status is not being send to the customer!

 

Could you help please to see what's messed up ??

 

Thanks again,

 

Elazar

Share this post


Link to post
Share on other sites
Hi Shetani !

 

I have a little problem :huh:

 

When I update the status of the order in the admin section, the email for the updated status is not being send to the customer!

 

Could you help please to see what's messed up ??

 

Thanks again,

 

Elazar

 

Dear Elazar,

 

have you made the modifications in the admin/orders.php also as in the admin/languages/YOURLANGUAGE/orders.php and

uploaded all necessary files like admin/modules/email/html_order.php ?!

 

If yes, please check the modifications as described in the V2.html file which is included in the full package again.

 

I´ve tested it on 2 different shops also as with an external software package which i´m using as cms and it workes perfect.

 

In the orders.php in catalog/admin folder you have to replace

 

$email = STORE_NAME . "\n" . EMAIL_SEPARATOR . "\n" . EMAIL_TEXT_ORDER_NUMBER . ' ' . $oID . "\n" . EMAIL_TEXT_INVOICE_URL . ' ' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT_HISTORY_INFO, 'order_id=' . $oID, 'SSL') . "\n" . EMAIL_TEXT_DATE_ORDERED . ' ' . tep_date_long($check_status['date_purchased']) . "\n\n" . $notify_comments . sprintf(EMAIL_TEXT_STATUS_UPDATE, $orders_status_array[$status]);

 

with

 

 //BEGIN SEND HTML MAIL//

//Prepare variables for html email//
$Varlogo = ''.VARLOGO.'' ;
$Vartable1 = ''.VARTABLE1.'' ;
$Vartable2 = ''.VARTABLE2.'' ;

$Vartext1 = ' <b>' . EMAIL_TEXT_DEAR . ' ' . $check_status['customers_name'] .' </b><br>' . EMAIL_MESSAGE_GREETING ;
$Vartext2 = '    ' . EMAIL_TEXT_ORDER_NUMBER . ' <STRONG> ' . $oID . '</STRONG><br>' . EMAIL_TEXT_DATE_ORDERED . ': <strong>' . strftime(DATE_FORMAT_LONG) . '</strong><br><a href="' . HTTP_SERVER . DIR_WS_CATALOG . 'account_history_info.php?order_id=' . $insert_id .'">' . EMAIL_TEXT_INVOICE_URL . '</a>' ; 

$Varbody = EMAIL_TEXT_COMMENTS_UPDATE . ' ' . $comments . "\n\n" . sprintf(EMAIL_TEXT_STATUS_UPDATE, $orders_status_array[$status]);

$Varmailfooter = ''.VARMAILFOOTER.'' ;

$Varhttp = ''.VARHTTP.'';
$Varstyle = ''.VARSTYLE.'';

//Check if HTML emails is set to true
if (EMAIL_USE_HTML == 'true') {	

//Prepare HTML email
require(DIR_WS_MODULES . 'email/html_orders.php');
$email = $html_email_orders;
} else {		

//Send text email
           $email = STORE_NAME . "\n" . EMAIL_SEPARATOR . "\n" . EMAIL_TEXT_ORDER_NUMBER . ' ' . $oID . "\n" . EMAIL_TEXT_INVOICE_URL . ' ' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT_HISTORY_INFO, 'order_id=' . $oID, 'SSL') . "\n" . EMAIL_TEXT_DATE_ORDERED . ' ' . tep_date_long($check_status['date_purchased']) . "\n\n" . EMAIL_TEXT_COMMENTS_UPDATE . ' ' . $comments . "\n\n" . sprintf(EMAIL_TEXT_STATUS_UPDATE, $orders_status_array[$status]);
}

//END SEND HTML MAIL//

 

please check

 

Greets Frank

Edited by shetani

Share this post


Link to post
Share on other sites

its the same for me - our shops are all installed in the root without catalog dir

 

Im not able to find any mistake in the file so the reason maybe another one.

 

I´m sorry

Share this post


Link to post
Share on other sites
Have you checked your email options within the admin panel

 

 

Dear Shetany!

 

Thanks for your reply,

 

Yes sure. It's set ok.

 

Hope you will help me to solve it..

 

Best Regards,

Elazar

Share this post


Link to post
Share on other sites
Dear Shetany!

 

Thanks for your reply,

 

Yes sure. It's set ok.

 

Hope you will help me to solve it..

 

Best Regards,

Elazar

 

Dear Elazar,

 

today i´ve tested your original files on my own installation (ok i have to made 2 modifications because you have modified the tep_db_querys with an

own mod ?!)

and it works perfect. Their were no problems so you may have another issue or could it be possible that your customer - who doesnt received the email

have a antispam tool working ?

 

Could you please post an picture of your orders status screen from the admin panel

Share this post


Link to post
Share on other sites
Dear Elazar,

 

today i´ve tested your original files on my own installation (ok i have to made 2 modifications because you have modified the tep_db_querys with an

own mod ?!)

and it works perfect. Their were no problems so you may have another issue or could it be possible that your customer - who doesnt received the email

have a antispam tool working ?

 

Could you please post an picture of your orders status screen from the admin panel

 

Dear shetani !

 

Thanks for reply!

 

First I would move out the contribution that I installed named: Email Subject with Order Number and Order Status 1.0

Then I will check if my problem still appears, then I will let you know as soon as I do it..

 

Thanks again,

 

Elazar

Share this post


Link to post
Share on other sites
Dear shetani !

 

Thanks for reply!

 

First I would move out the contribution that I installed named: Email Subject with Order Number and Order Status 1.0

Then I will check if my problem still appears, then I will let you know as soon as I do it..

 

Thanks again,

 

Elazar

It works with that contrib.

I am having problems under wamp. On the web, it works fine..


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
It works with that contrib.

I am having problems under wamp. On the web, it works fine..

 

Yes you right!

 

I post here picture of my orders status & order status update page so maybe shetani or you :rolleyes: could help me to solve my problem..

 

orders_status.gif

 

order.gif

 

Thanks a lot !

 

Great day,

 

Elazar

Share this post


Link to post
Share on other sites
Yes you right!

 

I post here picture of my orders status & order status update page so maybe shetani or you :rolleyes: could help me to solve my problem..

 

orders_status.gif

 

order.gif

 

Thanks a lot !

 

Great day,

 

Elazar

 

Hi, why am I not able to insert image links for my pictures? I saved them on gif format.

Share this post


Link to post
Share on other sites
Hi, why am I not able to insert image links for my pictures? I saved them on gif format.

Permissions on directory prevent access.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Permissions on directory prevent access.

 

I changed the chmod to 777

 

in that case I need to save it in the root directory..

 

thanks I do it

Share this post


Link to post
Share on other sites

Ok, what i can see on the pictures, especially the order.gif, is that the customer where notified correctly.

 

What happens if you send the customer the same notifictaion again ?

 

Normally you got an info statement on the top of the admin panel which shows you the status of the

email - which means send correct or failure.

Share this post


Link to post
Share on other sites
Ok, what i can see on the pictures, especially the order.gif, is that the customer where notified correctly.

 

What happens if you send the customer the same notifictaion again ?

 

Normally you got an info statement on the top of the admin panel which shows you the status of the

email - which means send correct or failure.

 

Shetani thanks!

 

When I update an order I get a message: Success: Order has been successfully updated.

Share this post


Link to post
Share on other sites
Shetani thanks!

 

When I update an order I get a message: Success: Order has been successfully updated.

 

and when I send the customer the same notifictaion again I get Warning: Nothing to change. The order was not updated.

Share this post


Link to post
Share on other sites
and when I send the customer the same notifictaion again I get Warning: Nothing to change. The order was not updated.

Change the comments or the status.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Change the comments or the status.

 

and when I enter comments in the same status it updated. I get Success: Order has been successfully updated.

Share this post


Link to post
Share on other sites
and when I enter comments in the same status it updated. I get Success: Order has been successfully updated.

And you had notify customer ticked?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×