Jump to content
Sign in to follow this  
Elazar

[contribution] Send_order_html_email

Recommended Posts

Probably can be, but I don't know how.

 

Thats a great shame! If that did work I would go ahead and install this, although at the moment I wont. If its not possible to replace the current 'Invoice' button would it be any easier to just create another button that would do the same thing, but for this contribution?

Share this post


Link to post
Share on other sites
Thats a great shame! If that did work I would go ahead and install this, although at the moment I wont. If its not possible to replace the current 'Invoice' button would it be any easier to just create another button that would do the same thing, but for this contribution?

This contribution sends a html order email. The email does not have to be the same as you see when you click on invoice in admin, in the same way that the customer order email is not the same as is seen on the order confirmation page.

 

If you want to print the invoice, there is a contribution for that.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hello all, thanks for this great contrib, but I need to know how is it possible to add customer details, such as email address and phone number in the same order email?

 

THanks,

Share this post


Link to post
Share on other sites

Hello all, thanks for this great contrib, but I need to know how is it possible to add customer details, such as email address and phone number in the same order email?

 

THanks,

Share this post


Link to post
Share on other sites

I believe there are some serious problems with the UPDATE ORDER part to this contribution and i would love for someone to be able to fix it.

 

When i update an order i get the customer gets the correct email but my store logo is not showing up in the email with my selected background colour. This is working for the create account and checkout process emails --

 

So i am wondering where the problem is. It's most likely either the language/english/orders.php file or the html_orders.php file that came with the contribution. Is anyone else seeing this problem???

 

some direction would be a huge help....thanks :blush:

Share this post


Link to post
Share on other sites

Great contribution.

I installed the row_mod, but have no luck. I also changed colours in stylesheetmail.css, but 'no changes at all.

Please help!!!

 

not_work.jpg

Share this post


Link to post
Share on other sites

I also installed this mod on clean oscommerse, but same result- NO COLUMNS- NO COLOURS!!!

somebody know, maybe mistake with css file?

Share this post


Link to post
Share on other sites

Having one problem with this mod. I receive a html email of customers order. But customer does not receive an email of his order.

 

Thanks.

Share this post


Link to post
Share on other sites
I also installed this mod on clean oscommerse, but same result- NO COLUMNS- NO COLOURS!!!

somebody know, maybe mistake with css file?

 

 

Color and columns work. In my situation, I do not see this info untill I click link at top of email to display imagges.

Share this post


Link to post
Share on other sites

Well I read this thread from start to finish and with many thanks to the original authors and the help that Lesley in particular has offered to others in this thread I have it all working like a charm all bar the email after adding additional items to an order. I doubt that will happen much so I am not so fussed but will keep an eye out for a solution ;) I have all the info I need included in the emails plus my header images, product images, comments etc :D Even got rid of pesky little extra %s LOL!

 

I am no expert but by gosh I am glad I can read :lol: NOw I belileve I have lovely professional looking emails :D

 

Most grateful THANK YOU

 

P.S I also had the 'stylesheet challenge' first time around I tried this contribution a few weeks back so took it down and re tried this morning and Da daaaaaa, much better!


Heather...

 

icon_baby_crawl-1.gifCrawling my way through pages of code with my fingers crossed and one eye on here. Grateful to many at the osCommerce Community. Thank YOU

 

Coding successes: GV & Coupons, UltraPics, FCK Editor, Product Listings Enhancement, Short Descriptions, Define Main Page, Text Box, Attribute Sets Plus, . PayPal WPP. UL Catagories. Dynamenu. Featured Products. Mailist Report 1.2. Easy Meta Tags (Now even I could have screwed that up) Sold Out but Displayed 0.3. Club osc Specials on Front Page. Order Editor. HTML Emails V2

Working on: SEO

 

 

Proud member of the Code Breakers Club

Share this post


Link to post
Share on other sites
Well I read this thread from start to finish and with many thanks to the original authors and the help that Lesley in particular has offered to others in this thread I have it all working like a charm all bar the email after adding additional items to an order. I doubt that will happen much so I am not so fussed but will keep an eye out for a solution ;) I have all the info I need included in the emails plus my header images, product images, comments etc :D Even got rid of pesky little extra %s LOL!

 

I am no expert but by gosh I am glad I can read :lol: NOw I belileve I have lovely professional looking emails :D

 

Most grateful THANK YOU

 

P.S I also had the 'stylesheet challenge' first time around I tried this contribution a few weeks back so took it down and re tried this morning and Da daaaaaa, much better!

Heather, you can't still be in the code breakers club after that effort.

 

How do you add additional items to the order?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Heather, you can't still be in the code breakers club after that effort.

 

oh yes I can LOL! I can still cause a disaster at any moment :lol:

 

How do you add additional items to the order?

 

I added Order Edit Contribution the other day, well I think that is how I can do it though I have not had to yet. I tested it properly during this modification LOL!


Heather...

 

icon_baby_crawl-1.gifCrawling my way through pages of code with my fingers crossed and one eye on here. Grateful to many at the osCommerce Community. Thank YOU

 

Coding successes: GV & Coupons, UltraPics, FCK Editor, Product Listings Enhancement, Short Descriptions, Define Main Page, Text Box, Attribute Sets Plus, . PayPal WPP. UL Catagories. Dynamenu. Featured Products. Mailist Report 1.2. Easy Meta Tags (Now even I could have screwed that up) Sold Out but Displayed 0.3. Club osc Specials on Front Page. Order Editor. HTML Emails V2

Working on: SEO

 

 

Proud member of the Code Breakers Club

Share this post


Link to post
Share on other sites

See see I told you would break sommat soon LOL!

 

I had a 'real' case of needing to add to an order today and could I do it? NAH!! I got a white blank page every time :lol: :rolleyes: It was fine yesterday during testing......*sigh*


Heather...

 

icon_baby_crawl-1.gifCrawling my way through pages of code with my fingers crossed and one eye on here. Grateful to many at the osCommerce Community. Thank YOU

 

Coding successes: GV & Coupons, UltraPics, FCK Editor, Product Listings Enhancement, Short Descriptions, Define Main Page, Text Box, Attribute Sets Plus, . PayPal WPP. UL Catagories. Dynamenu. Featured Products. Mailist Report 1.2. Easy Meta Tags (Now even I could have screwed that up) Sold Out but Displayed 0.3. Club osc Specials on Front Page. Order Editor. HTML Emails V2

Working on: SEO

 

 

Proud member of the Code Breakers Club

Share this post


Link to post
Share on other sites

I am back LOL!

 

Ok I found a wee problem and I have been trying fixes for hours :blink:

 

email_layout.jpg

 

I have a gap issue when products attributes are used. The attribute information pushes my table out and now nothing lines up and no matter what I have tired I can't close the gap. I am missing something obvious I know but I have really tried, in fact the sun has come up during the time I have been fiddling with this silly thing lol!

 

Anyone have any words of wisdom to help solve. Most appreciated


Heather...

 

icon_baby_crawl-1.gifCrawling my way through pages of code with my fingers crossed and one eye on here. Grateful to many at the osCommerce Community. Thank YOU

 

Coding successes: GV & Coupons, UltraPics, FCK Editor, Product Listings Enhancement, Short Descriptions, Define Main Page, Text Box, Attribute Sets Plus, . PayPal WPP. UL Catagories. Dynamenu. Featured Products. Mailist Report 1.2. Easy Meta Tags (Now even I could have screwed that up) Sold Out but Displayed 0.3. Club osc Specials on Front Page. Order Editor. HTML Emails V2

Working on: SEO

 

 

Proud member of the Code Breakers Club

Share this post


Link to post
Share on other sites
I am back LOL!

 

Ok I found a wee problem and I have been trying fixes for hours :blink:

 

email_layout.jpg

 

I have a gap issue when products attributes are used. The attribute information pushes my table out and now nothing lines up and no matter what I have tired I can't close the gap. I am missing something obvious I know but I have really tried, in fact the sun has come up during the time I have been fiddling with this silly thing lol!

 

Anyone have any words of wisdom to help solve. Most appreciated

stretching the memory banks, did you do the row mod?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

I didn't Leslie as I got it to look ok without, do you think I need to to fix this?

 

Thanks :)

Edited by Design Recollections

Heather...

 

icon_baby_crawl-1.gifCrawling my way through pages of code with my fingers crossed and one eye on here. Grateful to many at the osCommerce Community. Thank YOU

 

Coding successes: GV & Coupons, UltraPics, FCK Editor, Product Listings Enhancement, Short Descriptions, Define Main Page, Text Box, Attribute Sets Plus, . PayPal WPP. UL Catagories. Dynamenu. Featured Products. Mailist Report 1.2. Easy Meta Tags (Now even I could have screwed that up) Sold Out but Displayed 0.3. Club osc Specials on Front Page. Order Editor. HTML Emails V2

Working on: SEO

 

 

Proud member of the Code Breakers Club

Share this post


Link to post
Share on other sites
I didn't Leslie as I got it to look ok without, do you think I need to to fix this?

 

Thanks :)

Been a while since I installed this, but I did the row mod when I installed it. If you install it, backup first.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

OK Will try that later and see of it fixes this, thank you :D


Heather...

 

icon_baby_crawl-1.gifCrawling my way through pages of code with my fingers crossed and one eye on here. Grateful to many at the osCommerce Community. Thank YOU

 

Coding successes: GV & Coupons, UltraPics, FCK Editor, Product Listings Enhancement, Short Descriptions, Define Main Page, Text Box, Attribute Sets Plus, . PayPal WPP. UL Catagories. Dynamenu. Featured Products. Mailist Report 1.2. Easy Meta Tags (Now even I could have screwed that up) Sold Out but Displayed 0.3. Club osc Specials on Front Page. Order Editor. HTML Emails V2

Working on: SEO

 

 

Proud member of the Code Breakers Club

Share this post


Link to post
Share on other sites

Hello,

I have two questions:

1. I want to know haw I can add telephone number in customers details

2. I want $Vartaxe to display only Total price I want only one row.

 

Thank you

 

P.S.

Sorry for my bad English I hope you understand me.

Share this post


Link to post
Share on other sites
stretching the memory banks, did you do the row mod?

 

I have now and its fine now LOL! See I think I have something sussed but alas there is always more ;)

 

Paradisebg do you want that info in the customers email? I am sure there is a way to add tel no's but I do not know how but I do know that all the information that I want included in my customer emails such as images, model, totals etc is 'called for' in checkout_process.php

This morning I missed the called for model number and it was missing for test emails and I found all the 'calls' in that file around line 270-280 ish.

Being the dunce I am that is all I can offer you at this time, someone else will no doubt do better soon ;)

 

Thanks again Leslie :)

 

H x


Heather...

 

icon_baby_crawl-1.gifCrawling my way through pages of code with my fingers crossed and one eye on here. Grateful to many at the osCommerce Community. Thank YOU

 

Coding successes: GV & Coupons, UltraPics, FCK Editor, Product Listings Enhancement, Short Descriptions, Define Main Page, Text Box, Attribute Sets Plus, . PayPal WPP. UL Catagories. Dynamenu. Featured Products. Mailist Report 1.2. Easy Meta Tags (Now even I could have screwed that up) Sold Out but Displayed 0.3. Club osc Specials on Front Page. Order Editor. HTML Emails V2

Working on: SEO

 

 

Proud member of the Code Breakers Club

Share this post


Link to post
Share on other sites

Any idea why comments are not coming through in the email?

They were before modifications.

 

Also, my tax line, in the emails, reads "Tax Low-end:"

"Tax Low" comes from the database (I have two tax categories "Tax Low" and "Tax High")

Where is the "-end" coming from?

My english checkout_process.php reads: define('EMAIL_TEXT_TAX', 'Tax:');

Would love to have the email tax line simply read "Tax:"

 

This is a way sweet add-on, thank you.

Share this post


Link to post
Share on other sites
Also, my tax line, in the emails, reads "Tax Low-end:"

"Tax Low" comes from the database (I have two tax categories "Tax Low" and "Tax High")

Where is the "-end" coming from?

My english checkout_process.php reads: define('EMAIL_TEXT_TAX', 'Tax:');

Would love to have the email tax line simply read "Tax:"

 

 

The answer: The text that shows up on the tax line in the confirmation email can be found in the database. Go to your phpAdmin (or whaterver you use to access the mySQL). The tax_rates table has a tax_description field which can be edit via the browse tab.

Share this post


Link to post
Share on other sites

Hello,

 

I installed the contrib. The welcome message is looking ok.

But the order confirmation is showing like :

 

VARHTTP VARSTYLE VARTABLE1

VARLOGO

 

VARTABLE2

EMAIL_TEXT_DEAR H.W. Bartels

EMAIL_MESSAGE_GREETING

 

Order Number: 15

Date Ordered:: Wednesday 05 November, 2008

Detailed Invoice:

 

EMAIL_TEXT_PRODUCTS_ARTICLES EMAIL_TEXT_PRODUCTS_MODELE EMAIL_TEXT_PRODUCTS_QTY Total:

Post T Simulatie Arnhem

 

 

Download Yes

 

 

Post T Arnhe

 

 

1

 

 

€21.00EUR

 

 

 

DETAIL Sub-Total: €24.99EUR

 

Incl. BTW 19,00 %: €3.99EUR

 

Total: €24.99EUR

 

 

Delivery Address Billing Address

 

 

 

 

,

 

 

Payment Method

Check/Money Order

 

Make Payable To:

 

 

 

Send To:

 

 

Can someone telling me what is going wrong and how i can correct this

 

Thank you


Greetings,

 

Henk Bartels

Share this post


Link to post
Share on other sites
Hello,

 

I installed the contrib. The welcome message is looking ok.

But the order confirmation is showing like :

 

VARHTTP VARSTYLE VARTABLE1

VARLOGO

 

VARTABLE2

EMAIL_TEXT_DEAR H.W. Bartels

EMAIL_MESSAGE_GREETING

 

Order Number: 15

Date Ordered:: Wednesday 05 November, 2008

Detailed Invoice:

 

EMAIL_TEXT_PRODUCTS_ARTICLES EMAIL_TEXT_PRODUCTS_MODELE EMAIL_TEXT_PRODUCTS_QTY Total:

Post T Simulatie Arnhem

 

 

Download Yes

 

 

Post T Arnhe

 

 

1

 

 

€21.00EUR

 

 

 

DETAIL Sub-Total: €24.99EUR

 

Incl. BTW 19,00 %: €3.99EUR

 

Total: €24.99EUR

 

 

Delivery Address Billing Address

 

 

 

 

,

 

 

Payment Method

Check/Money Order

 

Make Payable To:

 

 

 

Send To:

 

 

Can someone telling me what is going wrong and how i can correct this

 

Thank you

 

Hello

 

Already solved.

 

Forgotten to upload some files......

 

Thanks


Greetings,

 

Henk Bartels

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×