Jump to content
Sign in to follow this  
JeremyM

Product Listings Header, Css Class Problem

Recommended Posts

Hey all, this image should explain my problem:

 

product.gif

 

How do I change the class for Product Name and Price?

 

I tried throwing in a <font> tag in the language file, but that's a no-go.

Share this post


Link to post
Share on other sites
.productListing-heading in stylesheet

 

That's what I edited, hence the background image.

 

The problem is that those links have a background and its just taking that gradient and putting it behind them. Here's a closer picture.

 

gradient.JPG

 

How do I just make it be a transparent bg?

 

Here's what's in my stylesheet:

.productListing-heading {
 font-family: Verdana, Arial, sans-serif;
 font-size: 10px;
 color: #000000;
 font-weight: bold;
 background-image: url(images/infobox/bg_grad_cont.gif);
 background-repeat: repeat-x;
}

A.productListing-heading:link {
 font-family: Verdana, Arial, sans-serif;
 font-size: 10px;
 color: #000000;
 font-weight: bold;
}

A.productListing-heading:hover {
 font-family: Verdana, Arial, sans-serif;
 font-size: 10px;
 color: #000000;
 font-weight: bold;
}

I added the last two classes and they work as far as text-decoration and color and size. However, even if I throw the background: transparent; line in there, it does nothing, it just keeps that gradient background and resizes it.

Share this post


Link to post
Share on other sites

.productListing-heading a{

font-family: Verdana, Arial, sans-serif;

font-size: 10px;

color: #000000;

background-color: #DFFFDF;

font-weight: bold;

}

 

just a stab in the dark , but my css for a links work as above - so try that with the background url, also when i am testing new css styles - say as above, i would make the a link text colour bright red so i can see that they are actually being taken from the changes i have made and i havent inherited them from somewhere else

Share this post


Link to post
Share on other sites
.productListing-heading a{

font-family: Verdana, Arial, sans-serif;

font-size: 10px;

color: #000000;

background-color: #DFFFDF;

font-weight: bold;

}

 

just a stab in the dark , but my css for a links work as above - so try that with the background url, also when i am testing new css styles - say as above, i would make the a link text colour bright red so i can see that they are actually being taken from the changes i have made and i havent inherited them from somewhere else

 

I did have them changed to white and I know my css was working because they were changing when I'd change the text decoration, etc.

 

 

I just need to know how to NOT apply the background image to the links and only apply it to the table background. I've never ever had this happen to me though so I have no idea where to start.

Edited by JeremyM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×