Jump to content
Sign in to follow this  
tx08152

After installing STS Error register_globals is disabled in your PHP configuration.

Recommended Posts

Hi to all

 

after i installed the STS Template file i get the error "register_globals is disabled in your PHP configuration." what can i do because i have no access to the php.ini file on the server because it's ashared Server (Strato)

 

help will be welcome very urgent

Share this post


Link to post
Share on other sites
Hi to all

 

after i installed the STS Template file i get the error "register_globals is disabled in your PHP configuration." what can i do because i have no access to the php.ini file on the server because it's ashared Server (Strato)

 

help will be welcome very urgent

What version of STS did you try to install? STSv4.5.2 should not have any issues with Register Globals

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
What version of STS did you try to install? STSv4.5.2 should not have any issues with Register Globals

 

 

Hi

 

i try STS4.5.2 to install

Share this post


Link to post
Share on other sites

just chek all $HTTP_*********** and replace with $_Post or $_get or $_SERVER 0r $_SESSION.

 

else place a php.ini or place htaccess and set register globals as true.

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites
just chek all $HTTP_*********** and replace with $_Post or $_get or $_SERVER 0r $_SESSION.

 

else place a php.ini or place htaccess and set register globals as true.

 

Satish

 

 

in which Folder or where can i find this files

Share this post


Link to post
Share on other sites
in which Folder or where can i find this files

Tim, before you make any additional modifications, did your shop work without Register Globals before you installed STS? If so, then you do not need to make any of the edits mentioned above since STS does not require Registre Globals. You need to reinstall STS.

 

IF your shop did not work prior to installing STS, and you also got the Register Globals error message, then you need to install one of the Register Global contribution fixes or search these forums for a step by step on how to configure your site's php.ini and .htaccess files.

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Tim, before you make any additional modifications, did your shop work without Register Globals before you installed STS? If so, then you do not need to make any of the edits mentioned above since STS does not require Registre Globals. You need to reinstall STS.

 

IF your shop did not work prior to installing STS, and you also got the Register Globals error message, then you need to install one of the Register Global contribution fixes or search these forums for a step by step on how to configure your site's php.ini and .htaccess files.

 

Hope this helped,

 

 

Hello

 

before i installed sts4.5.2 the os commerce was running with the update patch for Register Globals but after i installed sts 4.5.2 again but no change on the error message

 

as notice : i can't write to php.ini because shared server

Share this post


Link to post
Share on other sites
Hello

 

before i installed sts4.5.2 the os commerce was running with the update patch for Register Globals but after i installed sts 4.5.2 again but no change on the error message

 

as notice : i can't write to php.ini because shared server

You may have overwritten some of the Register Globals code when you installed STS. Try installing the Register Globals patch again.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
You may have overwritten some of the Register Globals code when you installed STS. Try installing the Register Globals patch again.

 

i have installed the globals patch again and the error was still on, i installed osc new and leave it now without STS because i'm tired of all the Problems and wasting time for such a solution i allway come to the resolution that the oscommerce system contibutions and all other things are only works correct if the user hase full access to the server settings like php.ini and so on.

 

but thanks for trying to help

Share this post


Link to post
Share on other sites
i have installed the globals patch again and the error was still on, i installed osc new and leave it now without STS because i'm tired of all the Problems and wasting time for such a solution i allway come to the resolution that the oscommerce system contibutions and all other things are only works correct if the user hase full access to the server settings like php.ini and so on.

 

but thanks for trying to help

Tim, that's too bad.

Just so you know...I have never had to edit my host's server settings just to use osCommerce or any of the other add-on contributions such as STS. :rolleyes:

 

I have come to the resolution that not all hosts are created equal. I would suggest that you find a stable host. Don't let a bad host keep you from benefiting from all of the added features that the add-on contributions bring to osCommerce. :thumbsup:


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×