Jump to content
Sign in to follow this  
ski2bbad

GOOGLE CHECKOUT IPN

Recommended Posts

Sorry if this has been mentioned before, I am a novice with this add-on. If the customer gets to the google payment page and then cancels the process, the order is still raised. What can I do about this? Thanks.

Share this post


Link to post
Share on other sites
Sorry if this has been mentioned before, I am a novice with this add-on. If the customer gets to the google payment page and then cancels the process, the order is still raised. What can I do about this? Thanks.

 

roclobsta,

 

The module works pretty much like PayPal in the sense that if you look in your ADMIN side after 48 hours and the status of your order has not changed (ie. from Preparing IPN to Processing) than you can pretty much delete the order and re-stock the items into your inventory. OR you can just login into your Google Merchant account and look at the status of the order in there and if it has not been paid, then just go ahead and cancel it.

 

Again, this module is simple and it requires a bit more work from the merchant to keep tabs on what is going on with their orders and to make sure that payment is being made. Don't assume that if the order is there, that payment has been made. Always check your account prior to shipping any merchandise in order to avoid or minimize losses.

 

Hope this helps.

 

ski

Share this post


Link to post
Share on other sites

Please can anybody tell me why I get integrations errors in my google seller account, I have tried BOTH google checkout contribs and I get the following:

 

 

 

We encountered an error trying to access your server at https://www.secret-desire.co<WBR>.uk/google_ipn.php; the error we got is: java.net.MalformedURLException: no protocol:

 

I have no idea where the <WBR> comes from, I did not type it as part of the api path ?

 

This means using this contrib it returns the buyer to checkout_success.php, using the other google checkout contrib it returns them to my index.php

 

I suspect it's a server side thing, something not supported or turned on, the order is created correctly and the checkout process works, it just wont return to google_ipn.php

Share this post


Link to post
Share on other sites
Hi valerif.

 

I may be able to help you out. Please let me know which countries you do business with (if the entire world, let me know that too). Today is a pretty busy day for me, but I will do my best to get you going.

 

regards,

 

ski

hi ski

thanks for your replay

it is the entire world

cheers

valeri

Share this post


Link to post
Share on other sites
Valerif.

 

Please check a few posts back, as I have addressed this issue for WORLDWIDE shipping (post #85). If you want shipping only available to specific countries (i.e. Switzerland) please let me know which countries and I will work on it.

 

regards,

 

ski

dear ski

thanks for your help

Share this post


Link to post
Share on other sites
Please can anybody tell me why I get integrations errors in my google seller account, I have tried BOTH google checkout contribs and I get the following:

I have no idea where the <WBR> comes from, I did not type it as part of the api path ?

 

Hi ihatedeskjets.

 

This is something I have not seen before. . . . quite interesting. <_<

 

Perhaps the wbr may be a way of your browser telling you that there is a "word break" on your path. I'd suggest that you check your API call back path in the Merchant Google account side and make sure that the path you typed in there has no spaces. If that doesn't work, it may be something that was introduced when you downloaded the files into the server. Just go through the file transfer process again and see if that fixes the problem.

 

Good luck!

 

ski

Edited by ski2bbad

Share this post


Link to post
Share on other sites

I'm gonna introduce an error into my google_ipn.php file to see if the integration reports a different error,, at least we will know if its looking at the file then.

Share this post


Link to post
Share on other sites
Ski,

 

I've re-installed it 3 times, and tried the other google checkout as well, same result ! My API for the ipn version is https://www.secret-desire.co.uk/google_ipn.php

 

and for the other version it's https://www.secret-desire.co.uk/googlecheck...onsehandler.php

 

Same results from google for BOTH

 

Hi ihatedeskjets.

 

I don't know what to tell you, except perhaps that google is preventing your website from using their services as your site may be considered "too strong" for their views. I'm not sure here, so you might have to check with google as they may prevent access to sites like yours. Sorry I can't help you further, but I really have never experience this issue before. Try to do a google seach and see if anything comes up.

 

Good luck.

 

ski

Edited by ski2bbad

Share this post


Link to post
Share on other sites
I'm gonna introduce an error into my google_ipn.php file to see if the integration reports a different error,, at least we will know if its looking at the file then.

 

 

Ihatedeskjets,

 

I'm sure you probably have alredy checked this, but not to state the obvious here . . . . do you have your files inside the "catalog" or whatever named folder or are all your files in root? If you have your files in a "catalog" type folder you need to disclose it in your path (i.e. ..yourURL/catalog/google_ipn.php).

 

That is the only other thing I can think of.

 

Regards,

 

ski

Share this post


Link to post
Share on other sites

Thnx ski,

 

I'll try and see what they say, after googleing for a few hours i've only found 2 other instances of this, (both unresolved) just a thought but as it doesn't seem to matter what goes in the API address as long as it's to a https addy I might try pointing it to a sub domain and see what happens.

 

Introducing the error in the google_ipn.php file did not change the error btw. Perhaps my shop is sending something bad to google ? is there anyway to trap the stuff sent to google to have a look at it ?

Share this post


Link to post
Share on other sites
Thnx ski,

 

I'll try and see what they say, after googleing for a few hours i've only found 2 other instances of this, (both unresolved) just a thought but as it doesn't seem to matter what goes in the API address as long as it's to a https addy I might try pointing it to a sub domain and see what happens.

 

Introducing the error in the google_ipn.php file did not change the error btw. Perhaps my shop is sending something bad to google ? is there anyway to trap the stuff sent to google to have a look at it ?

 

Ishatedeskjets,

 

Check your log file in the GCLOG folder and or XML error page in your Google Merchant account. If anything is being reported, that is where you will find it.

 

Regards,

 

ski

Share this post


Link to post
Share on other sites

Ski,

Here's an update from google techies:

 

Hi Ken,

 

Thank you for your email.

 

I understand that you're receiving a MalformedURLException error. I've

tried to determine exactly what has caused this issue to occur. I believe

that when the Google Checkout servers are trying to send information, your

server redirects the connection to "/" instead of google_ipn.php. Please

double check your server setting to ensure that we can connect to your API

callback handler.

 

If this is the case then I have a problem with my server rejecting the google connection, possibly mistaking it for a bot or something ? i'll investigate but this is a bit beyond me tbh.

Share this post


Link to post
Share on other sites

If I go to https://www.secret-desire.co.uk/google_ipn.php and look at the html / source all I see is an empty header ?

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
<BODY></BODY></HTML>

 

can this be correct ?

Share this post


Link to post
Share on other sites
If I go to https://www.secret-desire.co.uk/google_ipn.php and look at the html / source all I see is an empty header ?

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
<BODY></BODY></HTML>

 

can this be correct ?

 

Hi ihatedeskjets.

 

I tried the same using your URL above and my own URL and at least on my browsers (Firefox and Safari) all I get is a BLANK page for both URLs and both shows no source code at all.

 

After reading your posts, my first impression, based on google's email response and your source code above, was that you are having a charset problem. Google only accepts UTF-8 and if during the conversion between your charset (windows-1252) to UTF-8 the "/" is not being translated correctly. However you have other "/" in your API URL, so that does not make any sense. A few posts back, a character set problem was observed when the "pound" £ sign was used and that has been a known problem in the UK during UTF-8 conversion.

 

Did you read my previous post where I asked if your files are in root or if you have a "catalog" folder?

 

I'll try to see if I can find out anything on my side . . . If I do I will post it here.

 

Good luck.

 

ski

Share this post


Link to post
Share on other sites

All of my files are in root ,

 

I've removed every .htaccess and double checked i'm not redirecting in any way but i'm still stumped. If you try the other google checkout at my address https://www.secret-desire.co.uk/googlecheck...onsehandler.php then we get an error about raw data, so the script runs, but still the API complains it cannot get there ? confused ? i am.

Share this post


Link to post
Share on other sites

ski,

 

I'm gonna do a clean install, then restore my DB and images, and just install 1 google checkout to see if any of my other mods could be causing this.

I'll let you know in a day or 2,

 

Thanks for your efforts so far, really appreciated.

 

Ken

Share this post


Link to post
Share on other sites
ski,

 

I'm gonna do a clean install, then restore my DB and images, and just install 1 google checkout to see if any of my other mods could be causing this.

I'll let you know in a day or 2,

 

Thanks for your efforts so far, really appreciated.

 

Ken

 

Hey ihatedeskjets.

 

Before you go though all of this trouble, check to see if your "register globals" are on or off. This may not solve the problem, but try to switch it from whatever status you currently have. Just a thought . . . and it is simpler than re-installing everything. :rolleyes:

 

ski

Share this post


Link to post
Share on other sites

I did a clean install but left my DB intact, didnt take very long and with only the google checkout mod installed, it did not work :( same error, so now i've got to look at php settings etc, i've e-mailed my host to see if they can spot anything i've missed.

 

My oscommerce doesnt run with register_globals off ! so I have the lines in my .htaccess:

 

<IfModule mod_php5.c>
 php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

 

sorry to hijack this entire thread everybody but I have paying customers wanting to use this checkout

Share this post


Link to post
Share on other sites

This morning I received this from my hosting company.

Hello,

 

Its seems to be issue with SSL authority from where the ssl was issued.

Google Checkout currently accepts a SSL certificate whose root certificate is

from any of the following Certificate Authorities. You can check the list at

http://checkout.google.com/support/sell/bi...py?answer=57856

 

I am escalating this issue concern dept for further investigation.

Share this post


Link to post
Share on other sites

hello, i just installed this google ipn contrib, and everything seems to be working up to the point of checkout. after i select google as my payment type it takes me to the order confirmation screen, then when i hit the confirm order button, i get this next page:

 

Not Found

The requested URL /catalog/FILENAME_GOOGLE_CHECKOUT_PROCESS was not found on this server. even though the google_checkout_process.php is in the catalog directory..

 

any thoughts on how i can correct this?

Share this post


Link to post
Share on other sites
hello, i just installed this google ipn contrib, and everything seems to be working up to the point of checkout. after i select google as my payment type it takes me to the order confirmation screen, then when i hit the confirm order button, i get this next page:

 

Not Found

The requested URL /catalog/FILENAME_GOOGLE_CHECKOUT_PROCESS was not found on this server. even though the google_checkout_process.php is in the catalog directory..

 

any thoughts on how i can correct this?

 

Hi trancechannel,

 

Try checking step 6 of the README file and make sure that your "define" is correct. Other than that, go through it again and make sure that you have carefully followed each step in the installation process.

 

Good luck!

 

ski

Share this post


Link to post
Share on other sites

Hi

 

Just installed this and it works fine - ie the order goes through and is seen on Google Account.

 

But it doesn't update the status of the order on my shop like the Paypal IPN does, it is surpose to? If it is what am i doing wrong? Or do i have to update that manually?

 

I do have a SSL Cert but it is only a shared one (https://sslrelay.com/myshop.co.uk/catalog/google_ipn.php) could that be the problem?

 

Any help appreciated.

 

Cheers Richard

Share this post


Link to post
Share on other sites

Unfortunately, it doesn't appear that the Google Checkout IPN supports inbound data updates to osCommerce Admin. When changing status within Google Checkout's admin interface (ie to CHARGE, CANCEL, etc), this does not update within the osC admin side.

 

Also, the EXTRAS included by ski2bbad within version 1.2.2 don't appear to successfully import the Google Checkout order ID into osC.

 

Any thoughts or success on these so far?


Carpe Carp: Seize the Fish.

Share this post


Link to post
Share on other sites
Unfortunately, it doesn't appear that the Google Checkout IPN supports inbound data updates to osCommerce Admin. When changing status within Google Checkout's admin interface (ie to CHARGE, CANCEL, etc), this does not update within the osC admin side.

Also, the EXTRAS included by ski2bbad within version 1.2.2 don't appear to successfully import the Google Checkout order ID into osC.

Hello moonlitsun.

 

The status interface (cancel, charge, etc) and the GC order ID should update your osC without any problems as it does update mine and others here in the forum. Someone else here had a similar problem with the GC order ID (please check previous posts on page 4, I think) but those problem seemed to be caused by other modifications made to their osC or they were using other modules (i.e. STS) that affected how GC works. Since I don't know how heavily your osC has been modified I cannot pin-point a possible solution for you. Again, this module is very simple and there is very little that can go wrong. If you haven't already, please read the back posts as they may offer you some insight. Otherwise, let us know where you are (US or UK), if you are using STS (which version if so), if you have made significant changes to your checkout_process.php file (significant changes should be merged with google_checkout_process.php). A bit more info will help us help you.

 

Regards,

 

ski

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×