Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

stevi1983

500 Internal Server Error

16 posts in this topic

I am having serious problems getting the admin panel to work after successfully installing oscommerce. Th etemplae works fine but it is when you get to the administration tool that nothing happens only this error screen. I added an .htaccess file to teh admin panel that allowed the osccommerce to get past register globals. Is it this that is causing it and what should I do about it? Many thanks in advance.

Share this post


Link to post
Share on other sites

That error can be caused by a number of things, some beyond your control. You should contact your host and ask them to find the reason for it since it might be on their side.

 

Jack

Share this post


Link to post
Share on other sites

I have emailed my webhost and if it is not anything to do with them what options are available?

 

Cheers

Share this post


Link to post
Share on other sites

You will need to isolate the file causing the problem and try to fix it or change to a host that offers such support.

 

Jack

Share this post


Link to post
Share on other sites

Can You paste what errors getting displayed.

 

 

Satish

Share this post


Link to post
Share on other sites

Look through your FTP folders and your web hosting control panel to see if you have access to an error log.

 

Vger

Share this post


Link to post
Share on other sites

I am also having this error which is

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, webmaster@gamait.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

I have emailed my host but they have asked me to remove this 2 lines from the .htaccess

# php_value session.use_trans_sid 0

# php_value register_globals 1

 

I did but still the same error please help

I looked in your forum and added this 2 lines

php_flag display_errors on

php_value error_reporting 7

in the .htaccess in the admin folder, because befor I had only a blank page now the error is displayed which i put at the top.

any body please faced this problem or might have an idea on how to fix it

Share this post


Link to post
Share on other sites

Many server configurations no longer permit PHP settings to be put in the .htaccess file (php_value, php_flag commands). These cause a 500 error, and need to be moved to a "php.ini" file. That's probably what your host was telling you. Ask them how to set up a php.ini file to do PHP settings.

 

You also should define a set of "error documents" ("error pages") for 400, 401, 403, 404, and 500, to avoid getting these silly "404" errors. Again, your host will be able to tell you how.

 

More information:

http://www.catskilltech.com/freeSW/SMF/faqs > "500 (Internal Server) Errors", "Missing Support Files", "Querying/Setting my PHP settings".

Share this post


Link to post
Share on other sites

Also, from the sublime to the ridiculous, if this is a new installation in the root folder, make sure that you don't have an index.html file in the same folder as your index.php file. Sometimes people do an install on a new hosting account w/o deleting the placeholder page. Since a 500 error is due to server configuration, usually your hosting company can help you figure it out. Good luck.

Share this post


Link to post
Share on other sites

I solved this 500 internal server error (in 2.3)

 

Just renamed .htaccess to .htaccess.BAK in admin's(root)

 

I hope this help someone ;)

 

I working for me but not in admin's folder just in catalog. Thank you! ;)

Share this post


Link to post
Share on other sites

I had the same error. I had a missing .htpasswd_oscommerce from the admin directory, I just uploaded the file from my computer to the web server and all is good. I hope this helps someone.

Share this post


Link to post
Share on other sites

I solved this 500 internal server error (in 2.3)

 

Just renamed .htaccess to .htaccess.BAK in admin's(root)

That's hardly a fix. You merely showed that there is something wrong with your .htaccess file. .htaccess files exist for a reason (they're highly functional), and you'd be better off really fixing the problem with it. Your store may be highly vulnerable now to a hack. Ten to one there is a php_flag or php_value statement in there that should be moved to a php.ini file.

Share this post


Link to post
Share on other sites

Hello Friends,

 

I have moved my oscommerce from catalog directory to root directory and its giving me 500 error. I had done changes in both configuration files.

 

"HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request."

 

Can anyone help me please? I also checked by removing .htaccess files but still not got working.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Really, you should always leave a major subsystem (like a store) in its own subdirectory, but if you insist...

 

What files did you change? Just configure.php files? Most likely when you edited them you left a blank line at the beginning or end of a file. That's just one of many ways to get a 500 error. You didn't change servers, and your host didn't update anything (PHP level, etc.) at the same time? Any changes to any .htaccess or php.ini files? It could also be something that broke on the server and it's just coincidence that it happened at this time.

Share this post


Link to post
Share on other sites

I had the same error. I had a missing .htpasswd_oscommerce from the admin directory, I just uploaded the file from my computer to the web server and all is good. I hope this helps someone.

 

I do not see that file in my admin directory. Am I suppose to have it if I'm running the following (from the top of my index.php page):

 

$Id: index.php,v 1.19 2003/06/27 09:38:31 dgw_ Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

 

If I'm suppose to have the file, is there a way that I can get the file from you?

 

Thanks

Share this post


Link to post
Share on other sites