Jump to content
Latest News: (loading..)
Sign in to follow this  
Salvo

ref: AJAX Search Suggest

Recommended Posts

in the includes/boxes/search.php there is this code

<script language="JavaScript" type="text/javascript" src="includes/class.OSCFieldSuggest.js"></script>

<script language="JavaScript" type="text/javascript">

/*<![CDATA[*/

//Attention!!! put always this code above the HTML code of your field!!!

var oscSearchSuggest = new OSCFieldSuggest('txtSearch', 'includes/search_suggest.xsl', 'searchsuggest.php');

/*]]>*/

</script>

 

Can someone tell me what it is ment for //Attention!!! put always this code above the HTML code of your field!!!

 

Should I place in different place that it is now?

 

<!-- search //-->

<tr>

<td>

<?php

$info_box_contents = array();

$info_box_contents[] = array('text' => BOX_HEADING_SEARCH);

 

new infoBoxHeading($info_box_contents, false, false);

 

$info_box_contents = array();

$info_box_contents[] = array('form' => tep_draw_form('quick_find', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get'),

'align' => 'center',

'text' => tep_draw_input_field('keywords', '', 'id="txtSearch" size="10" maxlength="30" style="width: ' . (BOX_WIDTH-30) . 'px"') . ' ' . tep_hide_session_id() . tep_image_submit('v.gif', BOX_HEADING_SEARCH) . '<br>' . BOX_SEARCH_TEXT . '<br><a href="' . tep_href_link(FILENAME_ADVANCED_SEARCH) . '"></a>');

 

new infoBox($info_box_contents);

?>

 

<script language="JavaScript" type="text/javascript" src="includes/class.OSCFieldSuggest.js"></script>

<script language="JavaScript" type="text/javascript">

/*<![CDATA[*/

//Attention!!! put always this code above the HTML code of your field!!!

var oscSearchSuggest = new OSCFieldSuggest('txtSearch', 'includes/search_suggest.xsl', 'searchsuggest.php');

/*]]>*/

</script>

 

</td>

</tr>

<!-- search_eof //-->

 

 

Thanks

Share this post


Link to post
Share on other sites

Hi again

 

has anybody installed this contribution?

 

Can anybody tell me if it is working?

 

Thanks

 

Salvo

Share this post


Link to post
Share on other sites

Hi, I have also problems with contrib.

Practically in local he works perfectly while if loaded on the server he not work with no browser.

 

IE 6 and 7 show this error:

The stylesheet does not contain a document element. The stylesheet may be empty, or it may not be a well-formed XML document.

Share this post


Link to post
Share on other sites

HI, i have the same .

In Firefox searchsuggest works fine but in IE i have the error:

 

Row: 67

Column: 9

The sylesheet contain no element, Maybe the styleshhet is empty or no correct XML-Document

Code: 0

 

Is there a solution for this problem?

 

Regards Brass

Share this post


Link to post
Share on other sites

Sorry, after delete the cache-files in firefox i have the error-message like in Internet-Explorer too:

 

"The stylesheet does not contain a document element. The stylesheet may be empty, or it may not be a well-formed XML document."

 

This error i have since upgrading to PHP5. With PHP4 the same contribution works fine.

Maybe sombody has some informations about this problem? I need some help.

Thank You

Brassmann

 

 

HI, i have the same .

In Firefox searchsuggest works fine but in IE i have the error:

 

Row: 67

Column: 9

The sylesheet contain no element, Maybe the styleshhet is empty or no correct XML-Document

Code: 0

 

Is there a solution for this problem?

 

Regards Brass

Share this post


Link to post
Share on other sites
Hi just posted a fix to the buggy javascript code on the contribution page, I still encounter some display issues with IE7 : Smartoys Jeux video if someone could fix this problem I'll appreciate.

 

Wow but yours at least works. Hey which version did you install?

Thanks Ed

Share this post


Link to post
Share on other sites
Wow but yours at least works. Hey which version did you install?

Thanks Ed

 

I installed your version and it still doesn't work for. I'll explain.. i type into my search box and in seconds i see a box pop up but this box is completely transparent i only see the border and nothing in it. Nothing appears. I do have the css info that is supposed to work with it but it doesn't do anything :<

Share this post


Link to post
Share on other sites
I installed your version and it still doesn't work for. I'll explain.. i type into my search box and in seconds i see a box pop up but this box is completely transparent i only see the border and nothing in it. Nothing appears. I do have the css info that is supposed to work with it but it doesn't do anything :<

Bump! No idea. I see a lot a couple of stores with AJAX Suggest installed and they are working fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×